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When you contact us for help, we'll need to know which version of the RAMM 
Street Lights software you are using. 

TIP: Problems are sometimes fixed simply by upgrading your software to a 
later Build. To find out which problems are fixed in later Builds than the 
one you're using, see our website Upgrades page 
(http://www.cjntech.co.nz/upgrades.htm). If you have any questions 
about upgrading, feel free to contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

4 To Find the Software Build Number 

Go to the menu at the top of the main RAMM Street Lights window, then choose 
Help > About. A small window shows details about the software. You'll find the Build 
Number at the top- in the example below it is 95.0013. 

 

 

Software Version 
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C H A P T E R  1  

This guide is specifically intended to help you use and understand the functions of 
the RAMM Street Lights software from CJN Technologies. We've structured it to 
progress from basic tasks like getting to know RAMM Street Lights concepts and 
setting up to more complex tasks like Maintenance and Mapping. 

Since RAMM Street Lights is both an independent, standalone application as well 
as part of the RAMM (Road Assessment and Maintenance Management) suite of 
applications, you may also need to refer the Using RAMM Guide. If you're not sure 
whether you're reading the right guide, see RAMM Guides (on page 21). 

This section tells you how to get the most out of using the rest of the document- if 
you're familiar with RAMM Street Lights you can use the links to go directly to 
the section you need. If you're new to RAMM Street Lights, we recommend that 
you read the entire guide. 

Understanding RAMM Street Lights 
Understanding RAMM Street Lights (on page 33) is an overview of what RAMM 
Street Lights is, what it does, and other basic RAMM Street Lights concepts like 
the components of a Street Light and its location on the road. 

Getting Started with RAMM Street Lights 
Getting Started with RAMM Street Lights (on page 39) describes how to 
configure it and get to know the RAMM Street Lights Workspace. We've included 
extensive descriptions of Toolbar buttons (on page 45). If you need help setting up 
RAMM Street Lights, including setting up Contracts (see "Contract Details" on 
page 55), this is where you should look. 

RAMM Street Lights Tasks 
Most of the common tasks you will perform in RAMM Street Lights are described 
briefly here (see "RAMM Street Lights Tasks" on page 67). Use this section if 
you're in a hurry and you want a quick start to working with RAMM Street Lights. 
This is where you'll read about entering Dispatches, printing them for your 
maintenance crew and completing them. We also have brief descriptions of other 
regular tasks such as Patrols, Claims and Data Transfer. All the topics in this 
section are dealt with in more detail in separate sections - use the links in the 
descriptions below to go directly to them. 

About This Guide 



 

1 4  R A M M  S t r e e t  L i g h t s  
 

Filters 
Though Filters are not exclusive to RAMM Street Lights, using filters is crucial to 
be able to see the information you want quickly instead of having to sort through 
unnecessary information. This section describes using Filters (on page 139). 

Dispatches 
This section examines the Dispatch entry process in detail and describes each tab 
of the Dispatch Entry window (on page 84). It also includes a section on 
Automatic Dispatches (dispatches received by email) and related options (see 
"Automatic Dispatches" on page 100). 

Street Lights 
This is where you'll find a detailed description of the Street Lights window (on 
page 112), with individual descriptions of each tab. We also look at the distinction 
between Updating and Replacing Street Light assets (on page 125), and also Rapid 
Entry Profiles (on page 128) to set up Street Light assets in your network quickly. 

Maintenance 
Use the Maintenance sections of this guide to work through setting up and 
configuring Patrols (on page 153), Claims (on page 157), Maintenance Crew 
Payments and all other Maintenance screens. You can refer to RAMM Street 
Lights Options (on page 165) for global options governing what you see in 
RAMM Street Lights, like screens for Rating, Electricity Charges and Optional 
Groups and to set options for Tolerances and Enforcement. 

Working with Databases 
This section focuses on Data Transfer functions (see "Data Transfer" on page 204) 
between the Network Owner, Consultant and Contractor copies of the database. 
Data transfer is something you should do on a regular basis to keep all versions of 
your database up to date. If you're a Contractor, this may be specified in your 
contract. 

Reporting 
This is where we describe how RAMM Street Lights can help you analyse your 
data and generate reports (see "Reporting" on page 215). They are either in 
QuickReport format or the Decision Cube format (see "Decision Cube" on page 
217). Both are powerful tools for viewing and analysing your Street Light data and 
generating printed or soft-copy reports or charts and/or exporting to popular 
spreadsheet formats like Excel. 
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Mapping 
Mapping (on page 245) is stand-alone function that can be linked to RAMM or 
RAMM Street Lights, and requires a separate licence - for more information, 
please contact us (see "Contacting CJN Technologies Ltd" on page 23). Mapping is 
a key element of RAMM Street Lights because it allows you to visualise your 
Street Light data and even select Street Light assets on a map. You also have access 
to a number of mapping query tools. 

Administrative tasks 
Status Check (on page 285) and Security (on page 287) functions have their own 
sections in the guide. The Status Check function is to ensure that all the processes 
and tables in RAMM Street Lights are up to date, and Security sets different access 
levels for various users of RAMM Street Lights. 
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This section describes the many ways you can get help when you have problems or 
questions about using our software. 

IN  THIS  CHAPTER 
Finding the Answers You Need Quickly....................................18 
What You Should Already Know ................................................19 
Conventions We Have Used.......................................................19 
Help Yourself ..............................................................................20 
Help from Other Users ..............................................................21 
Help from CJN Technologies ....................................................21 
RAMM Guides............................................................................21 
RAMM Database Details ............................................................22 
Comments and Suggestions........................................................23 
Contacting CJN Technologies Ltd.............................................23 

 
 

Getting Help 
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Finding the Answers You Need Quickly 

To Find Out How to Use Help 
For descriptions of the different types of help we have, formatting conventions 
and contact information - that's right here in the section you're reading now. 

To Find Out How to Work with a Particular Function 
Go directly to the section about that particular function - refer to the Contents. 

Answers Elsewhere 
If the task is not listed in the Contents, you may find it in another of the RAMM 
Guides. Check our list of RAMM Guides (on page 21) to make sure you've got the 
right one. 

To Find Out what a Particular Term Means 
Read the Glossary at the end of this Guide. 

To Find where a Particular Term Appears in this Guide 
Read the Index at the end of this Guide. 

Talk to Us 
Feel free to contact us (see "Contacting CJN Technologies Ltd" on page 23) 
directly. 
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What You Should Already Know 

The Microsoft Windows Environment 
Before you read this guide, you need to be comfortable working with the 
Windows environment and its applications. We assume you already know how to 
use standard Microsoft Windows applications. For more information about using 
Windows applications, please refer to the Windows user documentation - 
including the online Help which you can open by clicking on a blank part of your 
Windows desktop, then pressing the F1 key at the top of your keyboard. 

Security and Passwords 
Safeguarding passwords and security information is important. It's best never to 
write down a password, but if you must, keep it under lock and key. 

Data Backup 
Back up your data regularly. At the very least, you should back up your database in 
a location other than the computer you usually work on. Ideally, your entire 
computer's hard disk will be mirrored in another location such as a server or a 
network drive. Another cost-effective and secure backup solution is to use the 
RAMM Hosting Service. For more information, see our website 
(http://www.cjntech.co.nz). 
 

Conventions We Have Used 
This document uses certain ways of formatting text to identify special information.  

Formatting Convention Type of Information 
 (printed document) or 

Brown heading (online/web) 
Step-by-step procedures. Follow these instructions 
to complete a specific task. 

Bold Items you must select, such as buttons, menu 
options or items in a list. Menu options are 
separated by the > symbol. For example: View > 
Refresh. 

KEYS Keys on the keyboard. For example: SHIFT or 
CTRL. 

KEY+KEY Key combinations where you must hold down one 
key while you press another. For example: 
CTRL+P, or ALT+F4.  
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[Implied] Field Name Part of a field name not actually shown on the 
screen. 

> Menu Path > [Variable] A menu option that can have several values - usually 
Asset Types. 

Throughout this guide, when we refer to RAMM or a related application like 
RAMM Asset Valuation, RAMM Assessment, RAMM Street Lights, Signs, or RAMM 
Traffic Signals we mean the Windows versions of our software. 
 

Help Yourself 
You can help yourself with integrated help, your printed help guide, or with web help. 

Many people like to be able to find their own answers. It's often quicker than other 
ways, and it's usually more satisfying. If you can't find the answer quickly, don't 
hesitate to ask us for help directly (see "Contacting CJN Technologies Ltd" on 
page 23). 

Using Integrated Help 
Press F1 on your keyboard in any window to access context sensitive help 

-OR- 

Click on the Help menu at the top of the window you're in and choose a relevant 
topic 

-OR- 

If you choose any of the Help > CJN Website options, your browser will be activated 
and take you to a page on our website (see Using Web Help below). 

Using the Printed Help Guide 
Printed help is useful especially when you don't have access to a computer. 

Using Web Help 
Our website (http://www.cjntech.co.nz) has number of resources that you'll find 
useful. Our Support page (http://www.cjntech.co.nz/support/index.htm) has links 
to documentation, reference, training and troubleshooting pages. If you're using an 
installed version of the application you can also download the latest version of the 
software from our website Upgrades page 
(http://www.cjntech.co.nz/upgrades.htm). 
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Help from Other Users 

Contacting Other Users 
When you have a problem or question about different ways of doing something, or 
you'd like to share ideas with those who have hands-on experience, you can ask 
other users. We'll be happy to put you in touch with them - just contact us (see 
"Contacting CJN Technologies Ltd" on page 23). 

CJN Forum 
You can also ask questions and participate in ongoing discussions in the CJN 
Forum (http://forums.cjntech.co.nz). 
 

Help from CJN Technologies 
We pride ourselves on our friendly, responsive support. If you need a helping 
hand, feel free to contact us (see "Contacting CJN Technologies Ltd" on page 23). 
 

RAMM Guides 
We publish a number of guides. Here's a brief overview of them and what they 
cover. 

With every major release of RAMM, we publish a brief description of what's new 
in the release: 

§ What's New in RAMM. 

Main functions and basic tasks in RAMM are described in: 

§ Using RAMM. 

Advanced functions in RAMM are in a separate guide: 

§ Working with RAMM, including: 

§ RAMM Network Manager. 

§ Transaction Logging. 

§ Surfaces. 
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§ RAMM SQL. 

§ Bridges. 

§ Maintenance Activity. 

§ Pavement Structure. 

§ Pavement Strength. 

§ RAMM Security. 

We have some other specific RAMM guides: 

§ Managing RAMM. 

§ RAMM Street Lights. 

§ RAMM Asset Valuation. 

§ RAMM Assessment. 

§ RAMM Forward Work Planning. 

§ RAMM Traffic Signals. 

We have two reference guides for advanced database details: 

§ Working with Treatment Lengths. 

§ RAMM Database Reference. 
 

RAMM Database Details 
Occasionally you'll need to know where specific details are stored in the RAMM 
database for more complex tasks. There are a number of ways to find out which 
tables and columns contain the information you need: 

§ Read the separate RAMM Database Reference guide. 

§ For the most up-to-date listing of the details you require, go to the RAMM 
Manager main menu and choose Reports > Database Structure. Choose the tables 
you wish to view and then Preview or Print them. 

§ For a general overview, read Understanding RAMM Toolbar Controls in the Using 
RAMM Guide. 

§ Ask workmates and associates who have used RAMM for longer. 

§ Contact CJN (see "Contacting CJN Technologies Ltd" on page 23). 
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Comments and Suggestions 
If you have any feedback about this document or about the software itself, please 
contact us (see below). We welcome your observations and suggestions, as they 
help us to improve what we offer you. 
 

Contacting CJN Technologies Ltd 

Web 
www.cjntech.co.nz 

Email 
support@cjntech.co.nz 

Phone 
+ 64 9 415 4790 

0800 CJNTECH (256 8324) within New Zealand only 

Fax 
+ 64 9 415 4791 

Post 
PO Box 302-278 
North Harbour 
Auckland 1330 
New Zealand 

Address 
12 Piermark Drive 
North Harbour 
Auckland 1311 
New Zealand 
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When you're using RAMM, some of your actions will be common to more than 
one task or window. This section describes those common actions. 

IN  THIS  CHAPTER 
Moving to the Next or Previous Record ....................................25 
Adding a New Record.................................................................26 
Cancelling Changes.....................................................................26 
Saving Your Changes ..................................................................27 
Updating a Record ......................................................................28 
Deleting a Record........................................................................28 
Using Collapsible Panels ............................................................29 
Resetting 'Don't Show This Again' Warning Dialogs .................30 
Setting Editing and Viewing Preferences....................................31 

 
 

Moving to the Next or Previous Record 
When you're working with details in a Detail window, you can only see one record 
at a time. You can easily move to the next and previous record. If you have made 
changes to the current record, you will be prompted to save them before the next 
record is shown. 

4 To Show the Next Record's Details 

§ From the toolbar at the top of the Detail window, click the Next button . 

-OR- 

§ From the menu at the top of the Detail window, choose View > Next. 

-OR- 

§ Press ALT + N. 

Common Actions 
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4 To Show the Previous Record's Details 

§ From the toolbar at the top of the Detail window, click the Previous button . 

-OR- 

§ From the menu at the top of the Detail window, choose View > Previous. 

-OR- 

§ Press ALT + P. 
 

Adding a New Record 
When you want to add a new item to a window, you usually have to tell RAMM to 
create a new record (unless Auto Insert mode is switched on). 

4 To Add a New Record 

To add a blank new record, ready for you to add details: 

§ From the standard toolbar, click the Add Record button . 

-OR- 

§ From the menu, choose Edit > Add. 
 

Cancelling Changes 
When you have made changes that you do not want to keep, and you have not 
already saved them (see "Saving Your Changes" on page 27), you can tell RAMM 
to cancel the changes. 

4 To Cancel Changes 

To cancel changes, without closing the window you're working in: 

§ From the standard toolbar, click the Cancel button . 

-OR- 

§ From the menu, choose Edit > Cancel. 
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-OR- 

§ Press ESC on the keyboard. 

To avoid saving changes, you can also close the window and click the No button 
when you are prompted to save changes.  
 

Saving Your Changes 
When you make changes in a window you have to save those changes to the 
RAMM database. Until you do this, changes you have made to that record usually 
exist only on the screen and may be lost when you close that window (or if 
RAMM fails for whatever reason, while you are working). Read more about how 
the information shown on your screen relates to the database. 

4 To Save Changes 

To save changes you have made to the details in a window, either: 

§ From the toolbar, click the  button. 

-OR- 

§ From the menu, choose Edit > Save. 

-OR- 

§ Press CTRL + S. 

To Avoid Saving Changes 
To avoid saving your changes, either: 

§ Cancel them if you want to keep working in that window. 

-OR- 

§ Close the window and click on the No button when you are prompted to save 
changes. 

Using Auto Insert Mode 
Auto Insert mode is especially useful when you are entering many records at once. 
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Updating a Record 
Some Detail and Grid windows in RAMM open as read-only by default (for 
example, most asset windows that open inside the RAMM main window). If you 
have the correct permissions, you can edit or update the data in these windows. 

4 To Update a Record 

To edit or update a record in any Detail or Grid window: 

§ From the window toolbar, click the Update button . 

-OR- 

§ From the menu, choose Edit > Update. 

Save your changes  when you are done. 
 

Deleting a Record 
If you have the correct permissions, you can delete records in RAMM Detail and 
Grid windows. Some windows (for example, the SLIM windows launched from 
RAMM) do not allow deleting. 

4 To Delete a Record 

§ From the window toolbar, click the Delete button . 

-OR- 

§ From the menu, choose Edit > Delete. 
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Using Collapsible Panels 
Some windows in RAMM have collapsible panels, so you can get certain features 
out of the way when you're not using them. The most obvious examples are the 
Grid Layout panel and the Road Selection panel, which you'll often collapse to free 
up space to show more road assets. 

4 To Expand or Collapse a Panel 

Go to the panel you want to expand or collapse. Point to the panel sizer, the blue 
marked area on the dividing bar between the panel and the rest of the window 
with tiny triangles: 

 

Sometimes (in Grid windows and reports) the bar will be horizontal: 

 

The triangles show you the direction in which the panel will move. Click the sizer 
to expand or collapse it. 

TIP: To expand or collapse the Grid Layout panel, you can also go to the 
menu at the top of the Grid window and choose View > Show Layout. 
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Resetting 'Don't Show This Again' Warning Dialogs 
Several message windows in RAMM give you the option of not being shown again 
- usually in the same day or until the next upgrade is installed. You can easily reset 
this option to show all warning dialogs again, if you change your mind. 

4 To Reset 'Don't Show This Again' Warning Dialogs 

1 From the window menu, choose Options > Reset All Warning Dialogs. The Reset All 
Warning Dialogs window appears. 

 

2 Click OK to apply the change. From now on, warning dialogs which were 
hidden will be shown again whenever they are appropriate. 
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Setting Editing and Viewing Preferences 
There are some options you can set that control how RAMM works when you're 
viewing and editing data. The default settings should be adequate for most 
purposes, but this is where you change them if you need to. The settings apply 
only to you, and to the specific RAMM program you're working with. 

To open the Options window, go to the menu at the top of the main window and 
choose Options > Preferences. 

Editing Options 
You can tell RAMM how to behave when you're editing data, specify what 
happens when the Enter or Tab keys are pressed, and whether or not to use Auto 
Insert mode for all editable windows. You can instead specify Auto Insert for one 
window at a time, as you use them. 
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The Replacement Reminder option will activate a reminder on the Replace Asset 
dialog prompting you to replace all attached assets in addition to the asset itself. 

 

Viewing Options 
When you're editing or entering data, all fields where you must enter a value can 
be highlighted in a different colour. You can set that colour here. 

 

Make your changes and click Save to return to the RAMM main window. 
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This section introduces you to the basic concepts of RAMM Street Lights. 

IN  THIS  CHAPTER 
What is RAMM Street Lights? ....................................................33 
Background Information.............................................................34 
How Does RAMM Street Lights Work? ....................................34 
Street Light Location Diagram....................................................34 
Components of a Street Light.....................................................36 

 
 

What is RAMM Street Lights? 
The RAMM Street Lights software enables you to build an inventory and maintain 
street lighting assets. 

It's also a register of calls and information about asset faults and the Dispatches that 
relate to those faults. 

Once the faults have been seen to, the Contractor can also generate Claims for the 
work that has been done. 

RAMM Street Lights can also generate reports that will analyse the Street Light 
network in a number of different ways and help with the maintenance. 
 

Understanding RAMM Street Lights 
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Background Information 
Street lighting contracts are awarded by Network Owners on a regular basis. 

RAMM Street Lights enables the transfer of street lighting data between 
Contractors while maintaining a history of asset replacements. It also ensures 
privacy between Contractors. 

With the current trend to move power cabling underground and remove power 
poles, an increasing number of Network Owners are finding it necessary to install 
specific street lighting poles. This naturally leads to an increase in the overall value 
of the street lighting assets. 

RAMM Street Lights helps to locate street lighting assets and look into the history 
of a particular asset's performance, thereby giving Network Owners and their 
Contractors a more accurate picture of the Street Light network and its estimated 
value. 
 

How Does RAMM Street Lights Work? 
RAMM Street Lights is an extension of another product called RAMM (Road 
Assessment and Maintenance Management). RAMM is used by Network Owners 
to help them maintain their roading network and record other network assets. 

RAMM Street Lights uses the RAMM Roadnames and Carriageway core tables. 
These tables are maintained by the Network Owner's roading engineers and 
reflect the current road network. For more information on RAMM, see the Using 
RAMM guide. 
 

Street Light Location Diagram 
The RAMM Street Lights information is linked to specific terms describing parts 
of the road network. Here are some of the most important terms: 

§ Road. A road in RAMM Street Lights is the unique name given to a length of 
the network, for example Queen Street or Tamaki Drive. 

§ Carriageway. A road can be divided into logical sections in a number of ways- 
for example, where an intersection with another road occurs, the start of a 
bridge, or where an extra lane starts. These divisions are called carriageway 
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sections. The start and end of a carriageway section is measured in metres 
from the start of the road. To assist in visually locating these boundaries, start 
and end names can also be used. 

§ Location. This is the location of the Street Light in metres from the start of the 
road. The location of the Pole will place it in a carriageway section. 

§ Offset. The offset is the distance from the left hand side kerb (the edge of the 
seal) to the Pole. The left hand side always in relation to the increasing 
direction of the road or carriageway, so in the example below the left hand side 
is the same side the Street Light is on.  

 

 

NOTE: If the Street Light data is available in the database, it has already been 
collected and needs updating only. If you haven't been supplied with the 
data, you will need to build a Street Light inventory (see "Building a 
Street Light Inventory" on page 297). 
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Components of a Street Light 
A Street Light has five basic components. 

 

§ Pole. A Pole or column in RAMM Street Lights can refer to any fixture to 
which the Bracket and Light are attached. This may also be a building, bridge 
or a power pole. 

§ Bracket. This is sometimes referred to as the arm or outreach, and is the section 
that links the Pole to the Light. 

§ Light. This is the housing of the Gear and the Lamp. It is also referred to as the 
lantern. 

§ Gear. The group of components that ignite, control and regulate the operation 
of the Lamp. 

§ Lamp. The bulbs, filaments or tubes that generate illumination from the Light. 
These are the assets that are most often replaced. 
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The reason for breaking the Street Light down into these separate components is 
to leave room for every possible configuration. This may include multiple Brackets 
on a single Pole, as in the image below, or multiple Lights on a single Bracket. 
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This section tells you how to launch RAMM Street Lights and set it up to suit 
your needs. 

IN  THIS  CHAPTER 
Launching RAMM Street Lights ................................................40 
RAMM Street Lights Workspace ................................................43 
Toolbar Buttons ..........................................................................45 
Setting Up RAMM Street Lights................................................48 
Setting Up a Contract .................................................................55 

 
 

Getting Started with RAMM Street 
Lights 
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Launching RAMM Street Lights 
How you start RAMM Street Lights on your computer depends on whether you're 
running it from an installed copy on your computer or via the RAMM Hosting 
Service. If you need help with setting up RAMM Street Lights on your computer, 
see Setting Up RAMM Street Lights (on page 48). 

Launching Installed Versions of RAMM Street Lights 
On computers running Windows 95 and later, use your Start menu to launch 
RAMM Street Lights from the relevant program group. RAMM Street Lights may 
be in its own program group or in the RAMM program group, depending on how 
it has been installed. 

~i 

You will next connect to your database. If your database has not been set up for 
you, see Setting Up RAMM Street Lights (on page 48). 

You'll see the database login screen: 
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The database name should be visible in the Database field - if you have more than 
one database installed click the  to select the one you want from the drop-down 
menu. 

Enter your User Name and Password and click OK, and you will connect to the 
RAMM Street Lights main window. 

Launching RAMM Street Lights Via Hosting 
Use a standard web browser (for example Internet Explorer) to connect to our 
website (http://www.cjntech.co.nz). 

Click on the links to RAMM Hosting and Login Here. Enter your Hosting Username and 
Password in the window below and click Login. This will have been supplied to you 
by CJN Technologies earlier. Contact us (see "Contacting CJN Technologies Ltd" 
on page 23) if you can't remember them! 

If you haven't installed the Citrix ICA client you will need to do so first - see 
RAMM Hosting Service (on page 49). 



 

4 2  R A M M  S t r e e t  L i g h t s  
 

     

 

You will then see a number of icons to launch programs. Launch RAMM Street 
Lights from the icon below by choosing either the Full Screen or Seamless (windowed) 
option. 

   ~i 

On the Hosting service RAMM Street Lights is usually configured to connect 
automatically to your database. If you have multiple databases this will be the last 
database you accessed. 
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RAMM Street Lights Workspace 
Here are some of the terms we use for different areas of the RAMM Street Lights 
workspace. We describe the buttons and controls in more detail in Toolbar 
buttons (on page 45). 

Pop-up help 
All buttons and fields in RAMM Street Lights have pop-up help. Just hover your 
mouse over a control, button or field and a little pop-up will describe what that 
control or field is supposed to do. 

RAMM Street Lights Main Window 
This is the main window you see after starting RAMM Street Lights and 
connecting to your database. 

The database you're connected to is always shown in the title bar of the window at 
the top. 

NOTE: If you're connected to an Informix DS database, you can view a list of all 
users currently connected to the database by selecting Database > Users 
currently logged on. 

  

The RAMM Street Lights main window has three buttons on the toolbar to 
launch its main function windows. 

§  Dispatch Entry window (on page 84). 

§  Street Lights window (on page 112). 

§  Claims window (see "Claims" on page 157). 
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You can also launch these windows from the Actions menu. 

RAMM Street Lights Working Windows 
The working windows are broadly divided into two areas, the List panel and the 
Detail panel. The Detail panel is itself sometimes divided into an upper and lower 
section, depending on which function of RAMM Street Lights you're currently 
using. 

 

When you're working in RAMM Street Lights, you'll select either Dispatches, 
Street Lights or Claims in the List panel on the left. In some cases you can view 
further details of the item in the List panel by clicking the + to expand the tree. In 
the Street Lights window List panel the currently selected Pole, Bracket and Light 
are highlighted in red. 

The Detail panel is where you enter the various details for the functions or assets 
you have chosen in the List panel. Some fields require you to select something 
from a drop-down list. These lists are set up beforehand in Maintenance (on page 
171). 

The coloured fields are mandatory. Sometimes the Detail panel will have more 
than one tab, as above, and you can activate each tab by clicking on the tab header. 

The toolbar at the top is where you will find buttons to quickly perform important 
actions- the buttons you see will change according to the window you are 
currently in. These actions can also be selected from the Menu bar. If a control for 
an action is unavailable, it is "dimmed" as above. See Toolbar buttons (on page 45). 
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Toolbar Buttons 
Every RAMM Street Lights window has a toolbar at the top that contains buttons 
for quick access to its functions. We've described them all here for you as a toolbar 
"quick reference". 

The exact buttons you see on each window toolbar vary according to the task at 
hand. If you'd like to know more about a control, hover your mouse over any 
button and a pop-up description will appear (see "RAMM Street Lights 
Workspace" on page 43). This description will also give you the HOTKEY 
combination for that respective action. If disabled, use the ALT key to make them 
visible. 

NOTE: Mapping (on page 245) and Decision Cube (on page 217) have separate 
sections describing their toolbar controls. 

 

Common Toolbar Controls 
§  Add Record. Adds a new record relevant to the window you're in. 

§  Delete Item. Deletes the selected item. 

§  Save Item. Save the current window. 

§  List View. This toggle reveals or hides the List panel (see "RAMM Street Lights 
Workspace" on page 43). 

§  Detail View. This toggle reveals or hides the Detail panel. 

§  Previous Item. In a window with a number of records, clicking this button will 
take you to the previous record. 

§  Next Item. In a window with a number of records, clicking this button will 
take you to the next record. 

§  Undo action. Undo the last action you performed. 

§  Filter. This control is to perform actions in the Filter window (on page 142). 
Both the Street Lights window and the Dispatch Entry window are filtered by 
default, so if you don't see anything when you open them you may need to 
adjust the filter. 

§  Decision Cube. You can generate analyses of RAMM Street Lights information 
in various ways with the Decision Cube (on page 217). 
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§  Multimedia. This button is to load multimedia objects into your database- for 
example, digital camera images of Street Light assets. 

§  Help. Click this button to access context sensitive help from any screen 

-OR- 

Press F1 on your keyboard. 
 

Dispatch Entry Toolbar Controls 
§  Dispatch Update. When you are in the Dispatch Entry window, if 

this button shows Refresh Dispatches instead of No Dispatch Updates as above, you have 
new Dispatches via email from your Network Owner (see "Receiving Loaded 
Dispatches" on page 107). Click the button to refresh the Dispatch list in the 
List panel. 

§  Assign Dispatch. This button assigns the selected Dispatch to Anyone or a 
name in the drop-down list. The list is maintained in Contract Specific Staff 
Permissions (on page 295).~a 

For a full description of the controls and menus that apply to the Dispatch 
management process, see Dispatch Entry (on page 68). 
 

Street Lights Toolbar Controls 
§  Add Street Light Item. This button is used for adding new items to the network 

quickly. It will show the type of Street Light asset currently selected to add, as 
well as giving you the choice of another asset from the drop-down list as 
below: 

 

§  Replace. Replace an asset. 

§  Add to Map. Add asset to the map. For more information, see Mapping (on page 
245). 

§  Load Map. Load a map. 

For a full description of the controls and menus that apply to the Street Light 
management process, see Street Lights (on page 111). 
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Status Check Controls 
§  Tick All. Select all the options available for the Status Check. 

§  Tick None. Clear all selections. 

§  Required only. Select options based on the availability of data. 

For more information, see Status Check (on page 285). 
 

Patrols Window Controls 
§  Show Patrol Area. This control is available only in Patrols (on page 153). It shows 

the area that the Patrol is responsible for. 
 

Preview Toolbar Controls (for Reports) 
§  Zoom to Fit. Fits the entire page to the preview window. 

§  Zoom to 100%. Actual size. 

§  Fit Width. Fits the width of the page only to the preview window. 

§  Zoom In. Enlarge the text by zooming in each time you click the button. 

§  Zoom Out. Reduce the text by zooming out each time you click the button. 

§  Go to First Page. Displays the first page of the preview. 

§  Go to Previous Page. Displays the previous page. 

§  Go to Next Page. Displays the next page. 

§  Go to Last Page. Displays the last page. 

§  Print Report. Brings up the Print dialog for your default printer to enable you 
to print the report. 

§  Open Report. Brings up the Open File dialog to enable you to select a 
previously saved report file and open it. 

§  Save Report. Brings up the Save File dialog box to enable you to select a 
location and Save As Type and save the report as a file. 

For more information, see Viewing and Saving Previews and Reports (on page 
215). 
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Setting Up RAMM Street Lights 
This guide is aimed at the RAMM Street Lights Contractor / Consultant. 

If purchased RAMM Street Lights as Network Owner, it will be made available as 
part of the RAMM install. The RAMM Street Lights tables are incorporated in 
your existing RAMM database, and once the software is loaded you'll be able to 
access them. 

As the new Contractor / Consultant you need to start by setting up your database 
and your Contract Details. 

If you'd like a quick guide to those actions you need to do most often, such as 
entering Dispatches, completing them, updating the network and claiming for 
work done, see Daily Tasks (on page 67). 

Once the work is done, you can generate and keep track of Claims for the work. 

Two Ways of Setting Up RAMM Street Lights 
There are two methods of setting up RAMM Street Lights- you either install it on 
your computer from a CDROM, or contact us to set up RAMM Street Lights on 
the RAMM Hosting Service. 

These depend on whether you have been supplied with Street Light data or not, 
and whether you are using the RAMM Hosting Service or an installed version of 
RAMM Street Lights. 

NOTE: If you do not have Street Light data, you will need to go out into the 
field, record information about the Street Light assets and build the 
Street Light inventory (see "Building a Street Light Inventory" on page 
297). 

 



 

 C h a p t e r  5   –   G e t t i n g  S t a r t e d  w i t h  R A M M  S t r e e t  L i g h t s  4 9   

RAMM Hosting Service 
This section deals with setting up RAMM Street Lights on the RAMM Hosting 
service. If you're not using the RAMM Hosting Service, go the next step (see 
"Installing RAMM Street Lights" on page 50). 

To use RAMM Street Lights on the RAMM Hosting Service, all you need is a 
connection to the Internet and a standard web browser like Internet Explorer. For 
more information on Hosting- click on the link to RAMM Hosting on our website 
(http://www.cjntech.co.nz). 

Before You Log In to the Hosting Service 
§ You need a login Username and Password. The process of setting up the 

Hosting Service generally includes setting up permissions and access levels to 
RAMM Street Lights databases, so you should already have your username 
and password by this time. If you need help with this contact your 
administrator or contact us (see "Contacting CJN Technologies Ltd" on page 
23). 

§ You also need to install the Citrix ICA Client. This is a small programme that 
facilitates the connection to RAMM Street Lights. If it's not already installed, 
RAMM Street Lights will prompt you to download and install it. Our Hosting 
page on the website has a link for this purpose. 

You're now ready to start working with RAMM Street Lights (see "Launching 
RAMM Street Lights" on page 40). 
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Installing RAMM Street Lights 
This section describes how to install the RAMM Street Lights application on your 
computer. We assume that you already have Street Light data supplied to you in 
the form of a .slm file. 

Before You Begin Installing RAMM Street Lights 
You should have received the RAMM Street Lights software on CDROM. 

It's designed to work with either a Microsoft Access (MS Access) or Informix 
database that it will create from a .slm file. If you do not have MS Access installed 
on the computer you are using contact us (see "Contacting CJN Technologies 
Ltd" on page 23) and we will supply you with a runtime version of MS Access on 
the RAMM Street Lights installation CD. Feel free to contact us if you have any 
questions about the install process. 

Installing RAMM Street Lights 
To install the RAMM Street Lights software just place the CD in the drive and 
follow the prompts. By default the software will be installed in the directory  

C:\PROGRAM FILES\CJN TECHNOLOGIES\SLIM 

Creating a RAMM Street Lights Database 
To create the RAMM Street Lights database you will need a .slm file. This will be 
supplied either by the Network Owner (the Council) or the Consultant. This will 
contain the roadnames and carriageway information for the network and may also 
include an inventory of the Poles, Brackets and Lights. For more information, see 
Data Transfer (on page 204). 

4 To Create the RAMM Street Lights Database 

1 Start up the RAMM Street Lights software. 

2 Select Actions > Data Transfer. 



 

 C h a p t e r  5   –   G e t t i n g  S t a r t e d  w i t h  R A M M  S t r e e t  L i g h t s  5 1   

3 Select the option to Load Data from Council, and then navigate to the location of the 
.slm file. 

 

-OR- 

Simply double-click the .slm file wherever it may be on your computer. 

4 RAMM Street Lights will prompt you to confirm that the file you have loaded 
is the correct one. 

5 RAMM Street Lights now takes you to the database setup window. Here you 
specify the Database Type as either Microsoft Access or Informix from the drop-down 
list, and set a Directory location for the database. Choose MS Access if you're not 
sure. 

 

NOTE: The directory location is up to you, but please ensure it is placed on 
a drive that is regularly backed up. 
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6 When you click OK RAMM Street Lights will go through the process of 
loading all the tables and setting up the database. You'll see a series of progress 
windows like this one. Please be patient, this step of the process takes some 
time. 

 

7 When the database setup is finished, click OK. RAMM Street Lights is now up 
and running. 

 

Call Types 
Call Types describe the source of a fault report - for example a Consultant, staff, 
Patrol, or a member of the public. Call Types are required on the Dispatch Entry 
window, where you will select them from a drop-down list. 

In the main RAMM Street Lights window, select Maintenance > Dispatch Definitions > Call 
Types to begin setting them up. 
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4 To Set Up Call Types 

1 Click Add Record  

-OR- 

CTRL+N on your keyboard. 

2 Give your call type a Code and a Description. 

3 Select either Caller, Patrol or Other to define the category for this call type. Your 
selection will be reflected at the bottom of the Detail panel of the Dispatch 
Entry window, and will govern how you record details about how the fault 
was reported. 

4 Save  each entry, and repeat the process for each item. 

5 Close the window to exit when you are done. 

NOTE: Categorising call types and faults into groups allow you to get a better 
picture of how the faults are reported. For example, if the greater 
percentage of faults should be reported from Patrols rather than from 
public calls. 
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Fault Categories 
Fault Categories describe the actual faults. Like Call Types, Fault Categories are 
required when you're working in the Dispatch Entry window. 

In the main RAMM Street Lights window, select Maintenance > Dispatch Definitions > Fault 
Categories to begin setting them up. 

 

4 To Set Up Fault Categories 

1 Click Add Record  

-OR- 

CTRL+N on your keyboard. 

2 Enter a Code and a Fault description. 

3 Set the list order. Use the Promote  and Demote  buttons on the toolbar to 
change the position of the item in the list as required. 

4 Save  each entry, and repeat the process for each item. 

5 Close the window to exit when you are done. 
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Setting Up a Contract 
If you've successfully set up RAMM Street Lights and connected to your database 
you're now ready to set up your Contract Details, Contract Item Activities and 
Schedule Items. If you haven't, see Setting Up RAMM Street Lights (on page 48). 

This is a very important step, as it will establish a number of settings for other 
areas of RAMM Street Lights. 

You can always return here to make changes, but entering the details as accurately 
and comprehensively as you can at the beginning of the contract is crucial. 

Doing so will help you perform your contract duties efficiently and quickly. 
 

Contract Details 
From the main RAMM Street Lights window, click Maintenance > Contract Details to 
view and work with your Contract Details. 

If Your Contract Is Already Loaded 
If your database was created from a .slm file, the contract would also have been 
created and you will see the Contract Details when you open this window. If you 
see a contract already loaded in the Contract field, go straight on to Contract 
Groups (on page 58) or Contract Item Activities (on page 60). 

Adding a New Contract 
If you need to set up a contract from scratch, however, the fields above will be 
blank. To add a contract, click the Add Record button  on the toolbar of your 
window or simply start typing in a blank field. A dialog box will ask you to allocate 
a Contract ID, after which you can proceed to enter Contract Details as below. 
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4 To Enter Contract Details 

 

You'll notice that while you are doing the initial input of Contract Details, the 
words Setting Up are visible on the window. You'll now enter Contract Details and 
Contract Item Activities (on page 60). When that's done to make the contract 
available you'll need to open the contract (see "Opening the Contract" on page 66). 

NOTE: All coloured fields are mandatory (you must enter the information). 
Piecemeal Rate payments for specific Crew members is no longer available 
in RAMM Street Lights. 

1 Enter the Contract name and a unique (user defined) ID number. This may be 
supplied to you by the Network Owner. 

2 Enter the start and end dates of the contract in the From and To fields. 

3 Enter the names of the organisations involved in the Parties section and the 
individual Contact for each organisation. 

4 The Update Asset option should not be changed unless you are specifically 
instructed to do so. For more information on updating assets, see Updating 
Assets (on page 124). 

5 The Mark Dispatched When Assigned option (default) marks all Dispatches that are 
assigned to someone or printed as Dispatched. However, if your maintenance 
crew is using Pocket SLIM, for example, you would wish to untick the option 
so that you could assign it to someone (see "Dispatch Entry Window" on page 
84) without it being marked as Dispatched in the desktop application. It will 
be marked Dispatched when the crew accepts the job for processing.~a 
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6 You can record any general comments relating to the contract on the Notes tab. 

7 The Priority tab allows you to set options for prioritising Dispatches within the 
job list. You can allocate a response time in hours, and choose whether the 
priority level will be printed on the relevant Dispatch.~a 

8 The Maintenance Note Actions tab is where you can enter the actions you can 
quickly select for entering into the Dispatch Entry window Maintenance 
Notes tab (see "Maintenance Notes" on page 87). 

9 The Dispatch Group and Claim Group tabs are to configure the contract specific 
Optional Groups (see "Contract Groups" on page 58) and control how they 
are used on the Dispatch Entry and Claims windows. 

10 Save  the Contract Details into RAMM Street Lights. 

For more information on the Reports menu, see Reporting (on page 215). 

NOTE: The Staff Permissions button  on the toolbar allows you to set contract 
specific staff permissions (on page 295). General RAMM Street Lights 
Staff Permissions are maintained in RAMM Manager (see "Security" on 
page 287). 
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Contract Groups 
Contract Groups are to customise, record or group information in a way that's 
pertinent to the specific needs of a Network Owner.~a 

For example, the Network Owner may require a breakdown of their Schedule 
Items in such a way that they know how much a Ward is costing them to maintain 
(Claim group) or they may wish to find out how many faults are been reported on 
weekends (Dispatch group).  These groups can be configured to reflect this 
information and then made available on the Dispatch Entry window (see "General 
Information" on page 86) and Claim Line Detail window (see "Claim Lines" on 
page 79). 

NOTE: Contract Groups are distinct from the Optional Claim Group and Dispatch 
Group, which are not linked to contracts, and are managed via the 
Maintenance menu of the main RAMM Street Lights window. See Optional 
Grouping (on page 192) for more information. 

4 To Maintain Contract Groups 

1 View Contract Details (on page 55), and select the relevant tab for the 
Contract Group (either Dispatch Group or Claim Group). 

2 Enter a Name if required. This name will be included on the tab heading and 
wherever the Group appears. 

3 Set the Status of the Group as required: 

§ Optional. The group is available, but the field can be left blank. Use this 
status option if the group needs to be selected only for certain items. 

§ Required. The user must select a value before the entry can be saved. This 
status option is a good way of ensuring that data is entered in all cases. 
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§ Not in use. This is the default value. If this status option is selected the group 
will not be visible, even if other details have been set up within it. 

 

4 Add a new record  and a  Description for each item that will be available for 
selection from the drop down lists for the respective Groups. Each item can be 
ticked to be made Active as required. 

These groups will also be available for generating reports and analyses with the 
Decision Cube (on page 217), which is available by clicking  from the 
Dispatch Entry window, or from the Claims window. 

NOTE: Optional Dispatch groups can also be set up for email entries.  If you 
have these groups flagged as Required then ensure that default entries 
are selected under Email Options (on page 101). 
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Contract Item Activities 
These are the activity categories for the Schedule Items you will be entering. 
Contract Item Activities are set up at the beginning of the contract. 

TIP: For example, within the contract there may be a number of different 
items for replacing lanterns. The breakdown of these items will reflect 
the differing costs for each wattage and type. If you set up "Replacing 
Lanterns" as a Contract Item Activity this enables you to enter all related 
Schedule Items under the one activity. This allows grouping later on the 
overall cost to replace Lamps. 

It's advisable to set these up first before setting up Schedule Items. 

Close the Contract Details window and select Maintenance > Contract Item Activities from 
the main RAMM Street Lights menu. 

 

4 To Enter Contract Item Activities 

1 Enter the activity categories you need by clicking the Add Record button . 

2 Enter a Code, an Activity name, and descriptive Notes in the respective fields. 

3 Save  the entry. 

4 Repeat steps 1 through 3 as needed. 

5 Close the window when you are done. 
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These activities will become available to you from a drop-down list when you're 
entering the Schedule Items. 
 

Schedule Items 
If you've finished entering the general Contract Details (on page 55) and the 
Contract Item Activities (on page 60), you're now ready to enter Schedule Items. 

Select Maintenance > Contract Details from the main RAMM Street Lights window and 
click the Schedule Items button on the menu. 

~i 

NOTE: The Schedule Items reflected in this window must reflect the Schedule 
Items on your contract. You'll need a copy of the contract before you 
proceed any further. 

4 To Enter Schedule Items 

1 Click the Add Record button  on the toolbar of your window to begin entering 
Schedule Items. 
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2 Item Number. The numbering system you use here should reflect the system in 
the contract itself. This column allows both alphabetical and numeric 
characters. 

3 Set the Item order. You don't need to add spaces or 0s before the number to create 
a sort order as in previous SLIM versions. Use the Promote  and Demote  
buttons on the toolbar to change the position of the item in the list as 
required. 

4 Item Description. When entering Schedule Items, it's important to enter a 
meaningful description to make working with Schedule Items easy and 
efficient not just in this window but in RAMM Street Lights generally. 

TIP: A long description like Replacement of Gough GL 500 50w Gear Tray is likely to 
have you searching through a long list of Schedule Items to get to 
the one you want. Entering the same item as 50w GGL 500 GT will make 
things much easier for you. Especially when it comes to replacing 
assets in the Street Lights window, simply start typing 50w ..... and the 
software will jump to the 50w items, refining the list as you keep 
typing the description. 

5 Activity. Choose the appropriate contract item activity for the Schedule Item. If 
you don't have any activities in the drop-down list they need to be set up 
beforehand from main RAMM Street Lights window, from the Maintenance > 
Contract Item Activities menu (see "Contract Item Activities" on page 60). 

6 Rate. The rate is optional but the unit indication is mandatory. The rate 
entered here will be used as the default rate when claiming for this item. 

7 Totals. This section requires you to enter an amount as an Allocation for the 
specified Schedule Item that covers replacement as well as overheads. This can 
be an Agreed amount or an Indicative number only. You can also enter the Hardware 
Cost for comparison if you wish. The Item Count is an estimation of how often 
within the contract you expect to claim for that Schedule Item. 

8 You can also allocate a Maintenance Cost Group, Activity, Fault or Failure (see "Costs" 
on page 194) to the item so that this data can be exported to RAMM for the 
use of the Network Owner. 

9 Notes. This space is for any notes you wish to attach to a specific Schedule Item. 

10 Save  each item. Repeat the steps above until all items are entered. 

11 Close this window to return to the Contract Details window, which you can 
also close if you are done. 

NOTE: You may need to return to this option throughout the life of the 
contract to enter any variations, additional items or to alter rates. 
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Automatic Claims 
You can automate the process of claiming for replaced assets and work done with 
Automatic Claims. 

This option is available once you've finished setting up Schedule Items (on page 
61). From the RAMM Street Lights main window, select Maintenance > Contract Details 
> Schedule Items. You'll enter Automatic Claims on the Automatic Claims tab. 

NOTE: The Automatic Claims function is currently available only in Pocket 
SLIM, though the rules described below are set up in RAMM Street 
Lights. Contact us (see "Contacting CJN Technologies Ltd" on page 23) 
for more information. 

Having automatic Claim generation in place saves time by having Claim lines for 
common types of maintenance work automatically generated, and there's less 
chance of getting asset data and costs incorrect when generating Claim lines. 

Once the Schedule Item has been highlighted in the selection panel on the left, 
click the Automatic Claims tab. The rules for automatic claiming can be defined in two 
ways: 

§ Non Asset-related Charges - for when the Schedule Item is for an activity rather 
than a physical asset, like data entry or monthly administrative tasks. 

§ Asset Related Charges - when the Claim is linked to a physical asset, like data 
entry or monthly administrative tasks. 
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These two options are mutually exclusive - for example, you cannot enter asset 
related charges and other charges for the same Schedule Item. 

4 Setting Up Automatic Claim Rules for Non Asset-related Charges 

1 Select the relevant Schedule Item. 

 

2 In the Non Asset-related Charges section, select the appropriate rules from the 
drop-down lists. 
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3 Save  the Automatic Claim rules. 
     

4 Setting Up Automatic Claim Rules for Asset Related Charges 

1 Select the relevant Schedule Item. 

2 In the Asset Related Charges panel, click the Add Record button  in the Detail 
window as indicated below to insert a new record. 

 

3 Select the rules controlling Claim line generation from the drop-down lists in 
the Detail window columns. 

In the example above, the Claim line will be automatically generated 
whenever the asset is replaced, or when a new asset is installed. 

4 The Add Claim column selects the enforcement conditions for the Automatic 
Claim - not applicable, mandatory or optional. If adding the Claim is optional, you 
can also choose to set whether it is ticked or unticked by default. 

5 The Asset Make and Asset Model columns are similar to other RAMM Street 
Lights maintenance screens and are to identify the asset Make and Model 
being replaced or installed. Model is applicable to Light, Gear and Lamp assets 
only. 

6 Repeat steps 1 through 5 as required for as many Claim lines are required for 
the Schedule Item. 

7 Save  the Automatic Claim rules. 
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Approval of the Automatic Claims generated by this process can be managed in the 
Dispatch Claim Approval window (see "Dispatch Claim Approval" on page 164). 
 

Opening the Contract 
When you've finished entering Contract Details, Contract Item Activities and 
Schedule Items, you're ready to open the contract and begin work on it. 

If not, see Setting Up a Contract (on page 55). 

In the Contract Details window, click Actions > Open Contract. Depending on the 
permissions that have been set up for you in the Security section, you're now able 
to enter Dispatches, carry out replacements, and generate Claims on this contract. 
For more information on permissions see Security (on page 287). 
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This section outlines the tasks involved in maintaining your Street Light network. 

IN  THIS  CHAPTER 
Daily Tasks ..................................................................................67 
Other Regular Tasks ...................................................................81 
Concluding the Contract ............................................................82 

 
 

Daily Tasks 
You're now ready to get started with the regular tasks involved in working with 
RAMM Street Lights. 

We've categorised them as follows: 

§ Daily tasks (in this section). 

§ Other regular tasks (on page 81). 

NOTE: The exact frequency of these tasks is up to you, and naturally dependent 
on the stipulations of your contract. Our recommendations are a guide 
only. 

For more information on setting up a new contract, see Setting Up a Contract (on 
page 55). 
 

RAMM Street Lights Tasks 
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Dispatch Entry 
Dispatch handling is a key area of RAMM Street Lights. This is where you'll 
record all the faults that are found or reported on your Street Light network as a 
Dispatch. Entering as much detail as possible is an important aid to locating the 
faulty asset. These Dispatches can then be printed and passed on to the 
maintenance crews. 

This section of the RAMM Street Lights guide gives you a quick introduction to 
entering a new Dispatch. For more detailed instructions, see Dispatches (on page 
83). 

TIP: For more information on RAMM Street Lights windows and controls, 
see RAMM Street Lights Workspace (on page 43). 

4 To Enter a Dispatch 

1 From the main RAMM Street Lights window, click the Dispatch Entry window 
launch button indicated by the mouse arrow: 
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-OR- 

Select Actions > Dispatch Entry. 

NOTE: When you open the Dispatch Entry window, RAMM Street Lights 
filters the Dispatches you see to display only current or outstanding 
Dispatches. See Filters (on page 139). These include Dispatches that 
may have been emailed from your Network Owner, which will be 
highlighted in the List panel. For more information see Email 
Options (on page 101). Completed Dispatches are still in the system, 
just not visible. 
 
To show the Dispatch address in the list select Options > Show Address In 
List. 

2 Click the Add Record button  

-OR- 

CTRL+N on your keyboard. 
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RAMM Street Lights now adds a new Dispatch to the List panel with a Call 
Status of Entered and records the date and time in the Entered field on the Detail 
panel. 

3 Select a contract by clicking on the  in the Contract field. If you don't see a 
contract, you need to close this window and set it up (see "Setting Up a 
Contract" on page 55). If the List panel already has Dispatches, the contract 
and other details will default to those of the last highlighted Dispatch. 

NOTE: Coloured fields are mandatory. 

4 Select the Type of Dispatch from the drop down list, and enter corresponding 
Details in the panel below the Location section. If you do not have a list of 
Dispatch Call Types, you need to set them up (see "Call Types" on page 52). 

5 Select the Fault. This can either be a Standard fault you can select from the 
drop-down list, or you can select Other and enter your own. If you have no 
faults in your drop-down list, you need to set them up (see "Fault Categories" 
on page 54). 

6 Set Priority. The default is Non-emergency. If you select Emergency, the 
Dispatch will be marked with Emergency icons as above and the word 
EMERGENCY will be printed on the Dispatch (see "Printing Dispatches" on 
page 71). 

7 In the lower section of the detail panel, enter a Location. It's crucial to enter the 
location information as accurately as possible. Select the Feature Side (the side 
that the asset is located on). 

NOTE: All other fields in the Location section (Address, Feature, Notes) are 
optional, but remember that the more information you include, the 
easier it will be for your crew to find and fix the fault. The 
information you enter here also depends on how you identify 
features on your Street Light network. For example, if you prefer to 
identify Street Lights by Pole ID, you can configure this section to 
show Likely Pole ID instead. For more information on the other 
fields in the Detail window and on the other tabs, see Dispatches (on 
page 83). It's advisable that you enter at least a possible house 
number or Pole ID - if you don't enter any location information at 
all, your Dispatch won't show any Poles. 

8 Save  the Dispatch into RAMM Street Lights. 

9 Once you've entered the Dispatches, you need to print them (see "Printing 
Dispatches" on page 71). 
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NOTE: A Dispatch doesn't have to be printed before you complete it. 

 

Printing Dispatches 
Once you've entered your Dispatches into RAMM Street Lights, you need to print 
them out for your crew so that they can find and fix the faults. 

This section gives you basic instructions on printing a Dispatch for your 
maintenance crew. For more advanced printing options related to Dispatches, see 
Dispatch Printing Options (on page 97). 

TIP: For more information on RAMM Street Lights windows and controls, 
see RAMM Street Lights Workspace (on page 43). 

4 To Print Dispatches 

1 In the Dispatch Entry window, select Actions > Print Dispatches 

-OR- 

CTRL+P on your keyboard. 

TIP: If you want to print a specific Dispatch, in the Dispatch Entry 
window, select the Dispatch you want to print in the List panel and 
select Actions > Print Selected Dispatch from the menu 
-OR- 
CTRL + B on your keyboard. 
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2 By default this window is set up to print only the newly Entered Dispatches. 
Once the Entered Dispatches have been printed they will show as Dispatched in 
the List Panel of the Dispatch Entry window. The Dispatches will also be 
updated with the date and time the Print Dispatches process was run. 
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3 Report Selection. What you see on your report is governed by the selections in 
this section. With Full Report selected, you will see a single Dispatch per page. 
The number of pages will correspond with the number of Dispatches Entered. 
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NOTE: With Full Report selected, the report will show a number of Poles in the 
vicinity of the location details entered. If there is a direct match 
between the location entered and the data Most Likely will be printed 
alongside the Pole. 

The Summary selection lists the same Dispatches but with just the Dispatch 
information. 

 

Once you've made your selection, click Preview to see what the report will look 
like or Print to print it directly. Click Close when you are done. Either or both 
types of reports can be printed at the same time. 

4 When you return to the Dispatch Entry window, you'll see the Dispatches that 
had a status of Entered have now changed to Dispatched, and the date and time 
they were dispatched also recorded. 

For the other printing options available on this window, see Dispatch Printing 
Options (on page 97). 
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Completing Dispatches 
A Dispatch is completed when the required maintenance is done and the asset is 
working. If your crew have seen to the problem, you need to complete the 
Dispatch in RAMM Street Lights, update the asset/s repaired or replaced, and link 
the work done to a Claim line. 

4 To Complete a Dispatch 

1 Open the Dispatch Entry window and select the Dispatch you wish to 
complete. 

2 Select Actions > Complete Dispatch from the menu 

-OR- 

Use the key combination CTRL + O. 

3 RAMM Street Lights asks you to confirm your action. Click OK to proceed. It 
may also warn you if the Dispatch is still flagged as Entered. 

NOTE: Dispatches do not have to be printed before they are completed. 

4 The Call Status in the List Panel will change to Complete and you'll be taken to 
the Maintenance Notes tab to add notes. These maintenance notes will show on the 
Dispatch Summary Report for completed Dispatches- see Dispatch Summary 
Report (on page 238). 

NOTE: The Completed date of the Dispatch will default to the current date, 
but should be changed to reflect the actual date of completion. Click 
the drop-down arrow  on the Completed field to bring up a Date 
Picker to do this. It's important to have the correct Completed date 
as this date is used to calculate response times. The Completed date 
is used as the replaced date / install date on the new asset(s). 
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5 Click the Save button  to complete the Dispatch and proceed to the Street 
Lights window to update the assets that have been repaired or replaced as part 
of this Dispatch. 
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Replace Asset 
You may need to update the asset register to reflect the actual repairs made by the 
crew. 

The Street Lights window will be opened and a filter applied, using the road and 
house number information from the completed Dispatch. See Filters (on page 
139) for more information. 

NOTE: The Update Asset option on the Contract Details window (see "Contract 
Details" on page 55) must be ticked to enable you to replace an asset as 
part of the Dispatch completion process. See Updating Assets (on page 
124). 
 
You can also specify that asset replacement is mandatory or optional for 
the Light, Gear and Lamp - see Enforcement (on page 170). 
 
You also have control over which combinations of assets are available 
when going through the replacement process - see Allowed Items (on 
page 174). 

4 To Replace the Asset 

1 Select the Pole that the work was carried out on in the List panel. You need to 
be absolutely sure to select the correct Pole, or you'll replace the wrong asset. 
This is where details like the Pole number and Pole ID will be crucial. See 
Database Options (on page 166). 

2 Click the tab for the asset you wish to replace. 

3 Click the Replace Asset  button on the toolbar. 

4 Choose a replacement reason from the drop-down list and click OK. 
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If you don't have Replacement Reasons to choose from, you can click the  
button to set them up. 

The date will default to the Completed date. 

For more information, see Replacement Reasons (on page 183). 

5 Choose the replacement Make and Model from the relevant list on the asset 
tab. 

 

If you don't have Makes and Models to choose from, see Maintenance (on 
page 171). 

6 Save  the replaced asset. The Date, Dispatch and Reason fields in the Replaced 
row will be updated. 

7 Repeat steps 3 through 6 as needed. 

8 Close the window. When you have finished replacing the assets RAMM Street 
Lights will automatically take you to Claims to claim for the repairs that were 
carried out in order to get the asset working. See Claims (on page 157). 

Your replacement has now been recorded in history, and will be available for the 
relevant reports and analyses. See Replacing Street Light Assets (on page 125) for 
more information. 
 



 

 C h a p t e r  6   –   R A M M  S t r e e t  L i g h t s  T a s k s  7 9   

Claim Lines 
RAMM Street Lights takes you into the Claims module as part of the Dispatch 
completion process. If you choose not to continue, you can always manually enter 
the Claims window by selecting Actions > Claim Lines from the Dispatch Entry 
window menu. 

Claim lines represent each part of the work done to repair the asset and are created 
based on the list of Schedule Items set up for the contract. This is equivalent to the 
amount the Network Owner will be charged for the work. Claim lines are 
grouped together under a Claim header. Each Claim header reflects a claim 
period, for example monthly, or fortnightly. See Claims (on page 157). 

Claim lines can only be created for completed Dispatches. As many Claim lines as 
required can be entered during this process. Each Claim line is linked to a 
scheduled item in the contract. 

By default, the Claim Lines window shows you only the Detail panel. If you wish 
to view multiple Claims, click the List panel button  on the toolbar- see Toolbar 
Buttons (on page 45). 

~a 

A Claim line must be linked to a Claim header so that the amount can be 
presented to the Network Owner. By default the new Claim line will be added to 
the currently open header. 

If there is no Claim open, you will be prompted to create one. 
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On the other hand, if there is more than one Claim open, you will be prompted to 
select it from a list. 

 

In both cases, all lines being entered for this Dispatch will be linked to this Claim. 
For more information, see Claims (on page 157).  

4 To Enter a Claim Line 

1 Item. Select the Schedule Item that corresponds to the fault that has been fixed. 
This is the reference for the Claim line. By default, the Quantity, Units and 
Rate/Unit are carried across from the item definition. The Claim Amount = 
Quantity x Rate. If one of these values is altered, the other values will be 
updated. 

NOTE: To view all Dispatches with more than a specific number of Claims 
per Dispatch, see Auditing (on page 240). 

2 Where there is some problem about a specific Claim, the Claim line can be 
flagged Held from Payment on the Claim tab, and the Claim line will not appear in 
a Claim. The Claim line can be reinstated at a later date and then presented for 
payment. 

3 Claim group codes can be selected on the Claim tab. These will be available to 
you if you have set Claim Groups 1 and 2 to Optional or Required in RAMM 
Street Lights Options (on page 165). 

NOTE: The Owner details will automatically come through from the asset 
that is being replaced. 

4 You can also enter Notes if necessary. 
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5 Dispatch Details. This tab shows details from the Dispatch, which are useful when 
viewing the Claim line from the Claims window (see "Claims" on page 157). 

6 Save  each item. You can continue to enter Claim lines, and close the 
window when you're finished. 

NOTE: You can enter as many Claim lines as you need - in this window 
you're in auto-insert mode, so you can keep adding Claim lines. 

When all lines have been entered, close this window. You will be returned to the 
Dispatch Entry window, and you will see that the Dispatch Call Status in the List 
panel will now show as Complete. 

This Dispatch is now complete, and you can move on to the next one. 
 

Other Regular Tasks 
There are other tasks in RAMM Street Lights that you need to perform at regular 
intervals in addition to daily tasks (on page 67). These can be weekly, monthly, 
quarterly, or at predefined intervals. 

Below are some regular tasks and an indication of how often they are performed. 

§ Patrols (on page 153). Your Patrols are your "eyes and ears" on the street, and 
you need to ensure that Patrols are being conducted regularly and efficiently. 
If they are, the Dispatches you enter will mainly originate from Patrols rather 
than from other sources (the public, staff etc). The frequency of Patrols will 
be stated in the contract. 

§ Claims (on page 157). Claims need to be presented to the Network Owner 
regularly to ensure that the work flows smoothly and that you make and 
receive payments on time. Presenting and completing Claims are covered in a 
separate section, and are generally done every month. 

§ Data Transfer (on page 204). The Street Light database is the master list of the 
Street Lighting assets. At regular intervals the data should be returned to the 
Network Owner / Council (unless you're using the live database on the 
RAMM Hosting Service). This is done using the Data Transfer module. 
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Concluding the Contract 

Unloading Data - Installed Versions of RAMM Street Lights only 
At the end of your Contract, once all Dispatches have been concluded and 
payments collected, you need to transfer your database to that of the Network 
Owner / Council or Consultant so that their records are complete. This should be 
done even if you know that the next contract will also be awarded to you. 

Closing the Contract in RAMM Street Lights 
On completion of the contract, select Maintenance > Contract Details from the main 
RAMM Street Lights window to close the contract. Choose the appropriate option 
below. 

§ RAMM Hosting customers: select Actions > Close Contract from the menu. After this 
has been done, no new Dispatches or Claims can be entered. 

§ Installed Versions of RAMM Street Lights: select Actions > Complete and Unload from the 
menu. This will take you to the Data Transfer window, where you can then 
proceed to unload the database for the Network Owner / Council and close 
the contract as well. See Data Transfer (on page 204) for more information. 
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This section describes actions related to Dispatches. 

A Dispatch is created for each call taken or problem raised with regard to a fault on 
the Street Light network. Each Dispatch is entered under a contract name and 
allocated a unique system generated number. Details of the person reporting the 
problem, the date and time of the call, and a description of the problem are all 
logged. 
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Progress .......................................................................................88 
Audit Info ....................................................................................89 
Map..............................................................................................91 
Actions Menu..............................................................................92 
Options Menu.............................................................................96 
Dispatch Printing Options ..........................................................97 
Automatic Dispatches................................................................100 

 
 

Dispatches 
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Dispatch Entry Window 
You can access the Dispatch Entry window directly by clicking the button highlighted 
by the mouse arrow below, or by selecting Actions > Dispatch Entry from the main 
RAMM Street Lights window. 

 

The Dispatch Entry window opens. 

 

If you are at the beginning of a contract and haven't entered any Dispatches, you 
won't see any Dispatch information. For an introduction to entering new 
Dispatches, see Dispatch Entry (on page 68). By default it shows you only the 
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Dispatches with a Call Status of Entered, Dispatched or Loaded Data, though you can 
use the Filter button  to change what you see here. See Filters (on page 139) for 
more information. 

§  Dispatch Update. When you are in the Dispatch Entry window, if 
this button shows Refresh Dispatches instead of No Dispatch Updates as above, you have 
new Dispatches via email from your Network Owner (see "Receiving Loaded 
Dispatches" on page 107). Click the button to refresh the Dispatch list in the 
List panel. 

§  Assign Dispatch. This button assigns the selected Dispatch to Anyone or a 
name in the drop-down list. The list is maintained in Contract Specific Staff 
Permissions (on page 295). 

§ Contract ID. Since every Dispatch is linked to a contract, that's what you see at the 
upper right hand of the Detail panel. If you have more than one contract active 
you'll be able to select a different contract to associate the Dispatch with from 
the drop-down list. For more information, go to Setting Up a Contract (on 
page 55). 

§ Dispatch ID. The Dispatch ID is generated by RAMM Street Lights, and is the 
unique identifier of a job within a contract once it has been entered into 
RAMM Street Lights. 

§ External ID. This field allows you to enter a reference to another system, such as 
the system of origin. Some Network Owners have their own fault logging 
systems, dealing with problems not necessarily confined to Street Lights. 
References to these faults can be any combination of numbers or letters up to 
a maximum of 10 characters - for example, 267025A106. You can then use the 
Filter to search for an External ID or ID range, return to this Dispatch, view 
what work was done and how much was claimed on it. 

The external ID will be automatically entered if received via email. 

§ Call Type. This field is related to the Panel 4 - Caller Details field below, and refers to 
the person who reported the problem- for example a Routine Patrol, a 
member of the Public, or a Staff member. See Call Types (on page 52) for 
more information. 

§ Fault. This can be selected from a Standard list, or by clicking Other, a unique 
fault entry can be made. See Fault Categories (on page 54) for more 
information. 

NOTE: All coloured fields are mandatory. 

 



 

8 6  R A M M  S t r e e t  L i g h t s  
 

General Information 
This section describes the panels on the Dispatch Entry window General tab. Except 
for the Location Panel all other panels are optional. They will be visible depending 
on the Options you've selected, the Dispatch Groups you've set up, and the Call 
type. 

 

§ Panel 1 - Location. You can enter details about the physical location of the fault in 
this field. The Address field can include a house number and road name, where 
the road name can be entered or selected from the list. Feature relates to an 
obvious landmark in the vicinity, and you can also specify a Feature Side. Use 
Notes for any extra comments e.g. "the dog bites" or "pole believed to be live". 
All of this information is printed on the Dispatch Form (see "Dispatch 
Printing Options" on page 97). 

§ Panel 2 - Likely Pole ID. This panel enables a direct reference to a Pole to be entered 
and will be visible if you've made any selection other than Not Applicable on the 
Pole Link field of the Options window (see "Database Options" on page 166). If a 
road has been entered in the location panel, a check will be made to ensure 
that the referenced Pole exists on the road and if not return an error. If a road 
hasn't been specified, the road that corresponds with the Pole ID will be 
shown. 

§ Panel 3 - Dispatch Groups. This panel will be available to you if you have set up any 
Dispatch Groups and made them active. To configure the drop-down lists, see 
Contract Groups (on page 58) and Optional Grouping (on page 192). 

§ Panel 4 - [Caller/Patrol/Other] Details. This panel corresponds to and expands on the 
Call Type which has been selected in the Dispatch Entry window (on page 84). 
For example, if Patrols is selected as the call type, this panel will contain 
further options to enter Patrol details, and you will be able to select a Patrol 
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from the list available. Alternatively, the call type may be classified as Caller or 
Other, in which case this panel will be labelled Caller Details or Other Details. If 
so, enter details about the caller or company representative responsible for the 
call. A caller might call back, and if the contact name(s) are entered correctly 
then this information can be filtered on. See Call Types (on page 52) for more 
information. 

NOTE: Be consistent with the use of upper and lower case when entering 
names. 

 

Maintenance Notes 
The Maintenance Notes tab of the Dispatch Entry window allows you attach notes 
related to completing a Dispatch. 

These notes can either be free-form, entered by simply typing in the window as 
below, or selected from the Maintenance Note Actions entered into the Contract 
Details window (see "Contract Details" on page 55). 

 

Click the Select Actions button to bring up a dialog that will allow you to select a 
Maintenance Note Action to append to any notes already in the window. 

These notes can then be included on the Dispatch Summary Report (on page 
238). 
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Progress 
Progress details about a job are displayed on the Progress tab of the Dispatch Entry 
window. In the example below we've also shown you the full window to 
demonstrate how the List panel indicates the presence of progress records. 

~q 

They consist of an optional user-defined Event Code, Event ID, and Logname 
(which is available if this Dispatch was sent from a Network Owner / Council Call 
Centre). The message itself is the only field which is mandatory. 

There are two ways in which progress records can be created. Both apply only to 
Contractors. 

1 A progress record may be created during the automatic creation of a Dispatch 
from data included in the email from the Network Owner or their Call 
Centre - see Automatic Dispatches (on page 100). 

The existence and status of the record will be indicated by an icon in the List 
panel. 

§  Unread progress record 

§  Read progress record 
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§  Unread emergency progress record 

§  Read emergency progress record 

Tick the Mark as Read box when you have read the progress information, and the 
icon will change accordingly. 

2 You may enter progress records yourself on this tab by clicking the New button 
at the bottom right of the tab. These records may be for your own information 
(as a 'progress note'), or for sending progress messages back to the Network 
Owner. (The latter option is only possible for Dispatches that were originally 
created automatically from emails). 

If you wish to send progress information, you must click the Send Email box 
after entering the message (see below). This way the Network Owner can be 
informed that the problem has been passed on to the electricity supplier or 
that you're waiting for repair / replacement parts. 

 
 

Audit Info 
The Audit Info tab of the Dispatch Entry window Detail panel will be shown only if 
you have enabled sending and receiving by email. 
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The information you see is generated from automatic emails, and enabled by the 
following selections on the Email tab in Email Options window: 

 

See Email Options (on page 101). 

Any or either of these options can be selected. 

In each case, the relevant date (of entry, dispatch and/or completion) will be 
shown on the Audit Info tab. 
 



 

 C h a p t e r  7   –   D i s p a t c h e s  9 1   

Map 
The Map tab of the Dispatch Entry window shows you the location of the job 
related to the selected Dispatch. 

NOTE: To use Mapping (on page 245) you need to purchase the appropriate 
licences - for more information, contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

 

The location is indicated by the blue dot. If no Pole ID or address is linked to the 
Dispatch, the Map will zoom to the relevant road. 

If you've purchased the relevant Staff Tracker and Pocket SLIM licenses, you will 
also be able to see the location and movements of the maintenance crew 
responsible for attending to the job.~a 

Below are brief descriptions of the Map tab toolbar controls. For more details, see 
Mapping (on page 245). 

§  Query. 

§  Pan. 
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§  Zoom in. 

§  Zoom out. 

§  Go to Road. 

§  Locate Selected Dispatch. This control is to locate the selected Dispatch on the 
map, after you've changed the view by zooming or panning so that the 
Dispatch is no longer visible. 

 

Actions Menu 
Select Actions from the Dispatch Entry window menu to access a number of 
Dispatch related tasks. 

Actions for Dispatches that have a Call Status of Entered or Dispatched: 

§ Complete Dispatch (see "Completing Dispatches" on page 75). You'll use this 
option to complete the Dispatch and enter a Claim line when all required 
maintenance work has been done. 

§ Transfer Dispatch (on page 93). This option is used if more than one call is logged 
for the same fault. 

§ No Further Action (on page 95). Occasionally, you may wish to select this option to 
manually close a Dispatch if no further action on it is required. 

Claim and Street Light related actions: 

§ Claim Lines (on page 79). This option enables you to manually enter a Claim line 
if there are existing Claim lines for the Dispatch- these will be shown when 
this window opens. 

NOTE: Claim lines that have appeared on a Claim cannot be pre-dated or 
closed. 

§ Street Lights (on page 111). This option takes you into the Street Lights window. 
It applies a filter to the Dispatch data, using the house number and roadnames 
from the currently selected Dispatch, and generates a list for all the assets in 
the vicinity. This option is available for all Dispatches except those with a 
status of Loaded Data. 
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The Email, Email Options, Load Dispatches / Events, Dispatch Auto Process and Enter Loaded Dispatch 
options are available only to Contractors, and are described in Automatic 
Dispatches (on page 100). 

Other actions on this menu are reporting and analysis related. 

§ Dispatch Analysis. This brings up the Decision Cube (on page 217) where 
standard groupings (for example Call Type, Fault) are available for obtaining 
performance statistics. An overview Dispatch analysis is also available by 
selecting Reporting > Contract Management > Dispatch Analysis from the main RAMM 
Street Lights window. 

§ Printing Dispatches (see "Dispatch Printing Options" on page 97). 

§ Work Performed Report. This shows details of the work carried out in the process of 
completing a Dispatch. 

 

Transfer Dispatch 
When two calls are received about the same fault, this option allows the calls to be 
linked so that only one Dispatch printout is produced. 

It's important that all calls are logged in the database - it takes the same time to 
handle a call even if it is about a known problem.  This option is designed to allow 
for this and avoid confusing crews with duplicate Dispatch forms. 

CAUTION: Don't transfer a Dispatch that already has work recorded against it. 
Always transfer a blank Dispatch to the main Dispatch. Also, 
completed Dispatches should not be transferred - link the new 
Dispatch to the completed one. 

4 To Transfer a Dispatch 

1 In the Dispatch Entry window, select the Dispatch you wish to transfer. 
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2 Select Actions > Transfer Dispatch to bring up a list of all Dispatches. 

 

NOTE: If the list is too large, you can limit it to 30 days by selecting Options >  
Limit Transfer List (30 days) from the Dispatch Entry window menu. 

3 You can now select the Dispatch to transfer to (the Dispatch that duplicates 
the one you've currently selected in the Dispatch Entry window List panel). 
Click OK. 

4 RAMM Street Lights will show you a confirmation screen identifying the two 
respective Dispatch numbers. Click OK to continue. 

5 The Dispatch that was transferred will now show Transferred in the List 
panel. (If you do not see it, you need to select Options > Clear Filter to clear the 
default filter and view all Dispatches). When viewing the Dispatch that has 
been transferred, you can view the other Dispatch by clicking the Transferred To 
button in the upper right of the Detail panel. 
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No Further Action 
Occasionally situations arise where even though a problem has been reported and 
a Dispatch entered, no further action is required. 

In the Dispatch Entry window, select Actions > No Further Action. 

The user is prompted to confirm this selection:  

 

The call will remain logged in the system, but as no work was carried out and no 
Claims were made, no action was taken. The status will be shown as No Action 
Required, and the Completed date will be set to the current date. 
 

Change Contract 
You can change the contract for a particular Dispatch if necessary. This is only 
applicable if there is more than one open contract in the database and the Dispatch 
is not complete. 

The Dispatch will be given a new Dispatch ID. 

4 To Change the Contract 

1 Select the Dispatch. 

2 Select Actions > Change Contract from the Dispatch Entry window menu. 
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3 Choose the contract to switch to from the drop-down list. 

4 RAMM Street Lights will ask for confirmation for this action, and return you 
to the Dispatch Entry window once it is completed. 

     

Options Menu 
Select Options on the Dispatch Entry window menu for a number of options for 
sorting and viewing Dispatches. The Dispatch Entry window is filtered by default 
- see Filters (on page 139) for more information and advanced options for filters. 

§ Show Unread Progress. Selecting this option includes Dispatches which have 
unread progress records, in addition to the filtered items, in the List panel. See 
Progress (on page 88) for more information. 

§ Show Contract No. in List. This allows you to see the contract number alongside the 
Dispatch number in the List panel. This is useful if the Dispatches in the list 
belong to more than one contract. It's shown in the List panel in the format 
Contract ID/Dispatch ID. 

§ Show Address in List. This option, if selected, will show the house number and 
road name in the List panel. 

§ Show Claim Total Message. Selecting this option will bring up a message box 
showing the Claim total at the end of the asset replacement and Claim 
generation process. 

§ Limit Transfer List (30 days). This option is to limit the list of Dispatches shown 
when choosing to transfer a Dispatch. Selecting it will restrict the list to those 
that were entered within the last 30 days. 

§ Limit Patrol List (3 months). This option limits the list of Patrols available on the 
Detail panel when Patrol has been selected as the call type. It shows only those 
Patrols that were begun within the last three months. 

These options allow you to personalise the way RAMM Street Lights works for 
you. When you leave the Dispatch window, your current settings are saved so they 
can be reapplied when you next open the Dispatch Entry window. This saves you 
having to set up everything again. 
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Dispatch Printing Options 
This section discusses the various options on the Print Dispatches window. For a 
quick introduction to printing Dispatches for your maintenance crew, see Printing 
Dispatches (on page 71). 

 

§ New. Prints all those Dispatches which have been entered into the system, and 
have a status of Entered. If the Update printed/exported dispatch status to 'Dispatched' 
option is ticked (default), the call status of these Dispatches, once printed, will 
show as Dispatched. The Dispatch forms can now be handed to the crew so that 
the repairs can be done. 

§ Completed. Prints those Dispatches with a status of Completed between the dates 
selected. By default RAMM Street Lights will show a date range for a 
complete month. 
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You can also further specify a response time (in days) taken to complete a 
Dispatch, or all completed but unclaimed Dispatches. 

 

§ Outstanding. Prints those Dispatches that have previously been printed but have 
not been completed. This option also brings up a date range, as above. 

Outstanding Dispatches will be printed with the word COPY on them to 
indicate that they have been printed more than once. 

§ All. Prints all Dispatches for the chosen contract within an entered period (date 
range shows as above). 

§ List. Prints those Dispatches that are shown on the left hand display panel as a 
result of the chosen filter. 

§ Selected. Prints only the current Dispatch. While in the Display Entry window 
CTRL + B has the same result. 

§ Claims. Prints those Dispatches associated with a specific Claim number. Claim 
lines can only be printed for a completed Dispatches. Selecting this option 
brings up a drop-down list from which you can select a Claim Header. 

 

§ Loaded Data. Prints those Dispatches which have been created automatically from 
emails, and still have a status of Loaded Data. A date range is available for this 
options also. 

NOTE: When entering a date range, ensure that the start date is prior to the end 
date. 

Report Formats 
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Two report formats are available : 

§ Full Report - one Dispatch per page, giving asset specifications, giving Poles 
located up to 10 house numbers away on either side of the entered location, 
depending on the range specified in Tolerances (on page 169). 

§ Summary - multiple Dispatches per page, giving a brief description only. Further 
options here include the printing of Claim Lines and any Notes pertaining to 
the Dispatch. 

Either or both may be selected, depending on which initial selections have been 
made. 

Order By 

 

This box allows you to select the printing order according to the options listed. 
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Automatic Dispatches 

Receiving Emails and Converting Them Into Dispatches 
RAMM Street Lights can interface directly with a service call centre, and Dispatch 
information can be sent via e-mail between the two systems in a predetermined 
format (see "Email Layout Types" on page 104). This section covers the process of 
setting up the software for this purpose, and the options available (see "Email 
Options" on page 101). 

Once the e-mail has been successfully received and converted a Dispatch is 
created. It is then added to the list of Dispatches in the Dispatch Entry window list 
panel with the status Loaded Data (see "Receiving Loaded Dispatches" on page 107) 
to distinguish it from manually entered Dispatches. 

Error Correction 
In the event of incorrect or incomplete data being sent in the e-mail, you can set 
up defaults to override these errors. In the case of more serious errors, however, 
the email data will not be converted. You'll be able to save and / or print out the 
email containing the errors and process them manually. 

Flexibility of Operation 
You have a certain amount of flexibility with regard to how the system is used. For 
example, once the basic options have been set up, it can be set to be completely 
automatic (you don't need to initiate email connections or be involved in 
converting the data if it is valid). Alternatively, you may prefer to view the 
Dispatch after the initial processing has been done to edit or add data before the 
Dispatch is added to the database. You can also choose if and when the email 
connection is established to retrieve the emails. 

Creating Dispatches from Other Sources 
A further option enables you to read a file into the RAMM Street Lights system 
even if it may have come from another source (for example from a Patrol), as long 
as it matches one of the specified email layout types. 

Dispatch Related Events 
You can enter information about the progress of a job in the relevant window on 
the Dispatch, and have this automatically emailed to the Network Owner. 
Communications of this nature are named events, and can have unique IDs. See 
Progress (on page 88). The Network Owner can also send additional information 
about the job to you via events- you'll be notified on the Dispatch Entry window 
that there are new events to view. Events cannot change the status of a Dispatch 
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(for example, re-open a completed Dispatch). All events are stored in the progress 
table. 
 

Email Options 
This section describes how to set up RAMM Street Lights to receive emails, and 
what defaults apply to the Dispatches generated from those emails. 

 

4 To Send and Receive Files via Email 

1 From the main RAMM Street Lights window, select Actions > Email Options 

-OR- 

In the Dispatch Entry window, select Actions > Email Options. 

2 Set the layout Type. The Standard layout is the default. The RFS layout was 
designed specifically to meet the needs of Waitakere City Council. For details 
of how the emails should report the information, see Email Layout Types below. 

3 Tick Receive files via Email to activate this facility. If you don't tick this option, you 
will only be able to load Dispatches and progress records from text files which 
have been saved on your computer. See Automatic Dispatches (on page 100) 
for a full description of both of these options. 

4 In the Description field, enter a descriptive name for the Email Options 
record, followed by an optional three character code identifying the 
Contractor who will be using this facility. 

5 Select the Contract that the emails will be linked with from the drop-down list. 

6 When the emails are processed into Dispatches, there are some fields that are 
required information. The fields in the panels below the Contract panel are to 
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set the defaults for this information, and under which conditions they will 
apply. 

You can select the Call Type and Fault. Ticking If Blank will enter the information 
only if the corresponding field in the email is blank, and ticking If In Error will 
enter the information only if the corresponding field in the email is incorrect. 

If the relevant Required switches have been set in Contract Groups (on page 58), 
the panels below these fields will also be activated to enable you to set If Blank 
and If In Error defaults for them. 

7 Connection Settings. The Email tab contains the settings for the type of connection 
you have to email and the Internet, and allow you to enter information such as 
passwords, mail server addresses etc. You may need to talk to your Network 
Administrator (if you're using a Local Area Network or LAN) or your Internet 
Service Provider (if you're using a stand-alone computer that you connect to 
the Internet for email and web services using a modem). You can also contact 
us (see "Contacting CJN Technologies Ltd" on page 23) if you need help on 
these settings. 

 

Here's a brief description of the sections you see on the Email tab in the image 
above: 

The Connection section is where you choose how you connect to the Internet. 

§ Use Local Area Network (LAN). Select this option if your computer is on an office 
network. 

§ Use Dialup Networking (DUN). Select this option if you use a modem to connect to 
email and the Internet via an Internet Service Provider (ISP). You should 
already have a connection available for selection from the drop-down list - 
if not, you will need to get the relevant information below from your ISP 
and set it up by clicking the Add Dialup Networking Connection  button. 
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The following sections contain settings that you need if you selected Use 
Dialup Networking (DUN). 

§ Receive (POP3) and Send (SMTP) Server settings. Typically they are 
pop3.yourisp.net.nz and smtp.yourisp.net.nz - sometimes both receive and 
send servers have the same address, such as mail.yourisp.net.nz. 

§ Port. It's very rarely that the port settings change from 110 to receive and 25 
to send - don't change these unless specifically instructed. 

§ User. You will definitely need a username to receive email - in rare cases 
you also require a username to send email. Enter the username/s here, and 
remember they are usually case sensitive. 

§ Password. Enter your password - it should also be case sensitive. 

§ Receive Address. This is your email address for receiving email Dispatches 
from the Network Owner / Council. 

§ Send Address. This is optional, and is simply an alternative email address for 
replies to the automatic emails you send (see below). The Send to field is 
very important - here you'll enter the email address at the Network 
Owner that the automatic emails (see below) will go to. 

§ The option to Send using UU Encoding is a specific email format. Don't select 
this unless specifically instructed. 

The panel at the bottom chooses which functions in RAMM Street Lights will 
Send an automatic Email when they are selected. You should consult the 
Network Owner on when they would like to receive automatic emails from 
your system. 
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Email Layout Types 
This topic describes the fields needed for the Standard and RFS layout types to be 
able to receive emailed Dispatches. 

You can use any pipe ( | ) delimited text file. 

Standard Layout 
Most Network Owners use the standard layout for email Dispatches. The fields 
you can include are listed below- the only mandatory fields are Road Name and 
Notes. 

Field Remarks / Instructions 
Contract ID  

Call Type  

Fault Type  

External ID  

Priority  

House No.  

Road Name Mandatory Field 

Caller first name  

Caller surname  

Caller phone no.  

Feature side  

Feature description  

Likely Pole ID  

Dispatch Group 1  

Dispatch Group 2  

Notes Mandatory Field 
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RFS Layout 
The RFS layout is much more detailed. It is currently used only by the Waitakere 
Council, and has the ability to interface directly with their Call Centre. Fields are 
as below: 

Field Remarks / Instructions 
RFS Number Prefixed number with "RFS " 

Transmitted Date and Time, format- dd/mm/yyyy 99:99 

RFS Type For example- L01 

RFS Type 
Description 

 

RFS Received Date and Time, format- dd/mm/yyyy 99:99 

Action required by Officer Code 

Action required by Officer Name 

Priority Normal or Emergency only 

Property code  

Property Owner's 
name 

 

Property address1 For example- House number 

Property address2 For example- Street name 

Property address3 For example- Suburb 

Property address4 For example- City 

Complainant code  

Complainant's first 
name 

 

Complainant's 
surname 

 

Complainants 
address1 

For example- House number 

Complainants 
address2 

For example- Street name 
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Complainants 
address3 

For example- Suburb 

Complainants 
address4 

For example- City 

Complainants ph nos: 
pvt 

 

Complainants ph nos: 
bus 

 

Complainants ph nos: 
mobile 

 

Enquiry details RFS details, 1 - 80 Char 

Enquiry details RFS details, 1 - 80 Char 

Enquiry details RFS details, 1 - 80 Char 

Response by Date and Time, format- dd/mm/yyyy 99:99 

Completion by Date and Time, format- dd/mm/yyyy 99:99 

Latest event number  

Latest event code  For example- RP, CC 

Latest event 
description: line 1 

Max 80 Characters 

Latest event 
description: line 2 

Max 80 Characters 

Latest event 
description: line 3 

Max 80 Characters 

Latest event 
description: line 4 

Max 80 Characters 

Latest event 
description: line 5 

Max 80 Characters 

Latest event 
description: line 6 

Max 80 Characters 

Latest event 
description: line 7 

Max 80 Characters 



 

 C h a p t e r  7   –   D i s p a t c h e s  1 0 7   

Latest event 
description: line 8 

Max 80 Characters 

Handling Officer 
Code 

For example- CC7 

 
 

Receiving Loaded Dispatches 
This section describes the process of receiving emailed Dispatches in the Dispatch 
Entry window. 

NOTE: For information on setting up and activating the receiving of emailed 
Dispatches see Email Options (on page 101). For information on the 
formats you should use to create Dispatches from emails, see Email 
Layout types (on page 104). 

The frequency of the emails and options for automatic sending and receiving can 
be configured from the Actions > Email menu. 

 

§ Auto Send/Receive. In the image above this is currently inactive - clicking on this 
option will show a tick next to the option to indicate its status. When this is 
ticked, sending and receiving email will occur automatically at preselected 
intervals. 

§ Change Interval. The interval for automatic sending and receiving is originally set 
at 10 minutes, but can be changed. 
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§ Send/Receive now. The email check can also be initiated manually as required by 
selecting Send/Receive Now. This option is available only if Auto Send/Receive is 
turned off. 

§ View Import Errors. If the format of the email is incorrect or data corruption occurs 
for any reason, the resulting errors can be viewed here. If any errors are found 
in the incoming data, an error message will explain that errors have been 
found. You can correct the errors using the correction screen. 

 

Once they are corrected, the emails will be reprocessed. 

NOTE: If errors are found in incoming data, a Dispatch will not be created 
for this data until it has been corrected and successfully input. 

When the email check is finished and new Dispatches have been received, the 
Dispatch Update button  on the Dispatch Entry window toolbar 
will alert the user by showing the caption Refresh Dispatches in red. When this button 
is pressed, the window will be updated to show the new Dispatches which have 
been received. See Toolbar Buttons (on page 45) for more information. 

Other Actions 
§ Load Dispatches / Events. This option allows you to manually load a Dispatch or 

Event from a .emd file. 

§ Dispatch Auto Process. If selected (ticked), this option will automatically change the 
status of the Dispatch from Loaded Data to Entered. The Enter Loaded Dispatch 
option is to manually change the status of a Dispatch from Loaded Data to 
Entered. See Changing Call Status on Loaded Dispatches (on page 109). 
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Confirming the Road Name on Loaded Dispatches 
When an email or text file has been successfully received and processed, a Dispatch 
will be produced and will appear in the Dispatch Entry window List panel. 

This type of Dispatch is entered into RAMM Street Lights with a status of Loaded 
Data, to distinguish it from a manually entered Dispatch. 

When RAMM Street Lights receives a Loaded Dispatch it will attempt to populate 
the house number and road name from the emailed description. Where it is 
successful, this information will show in the Dispatch. 

If the road name is blank, however, this means that a corresponding road name 
could not be determined. This could be because the road name was spelt wrong, is 
a road that is not yet in the database or that there were too many road names to 
choose from. 

For example, the emailed location details may read 10 West Coast. Possible 
selections in the roadnames table are West Coast Road, West Coast Street, and West 
Coast Place. The software cannot determine which road is the correct one, and so 
will not assign a road name automatically. 

At this point, therefore, it's very important that you select the correct road from 
the list manually. Select the correct road and save the Dispatch. Choosing the 
correct road will help when it comes to completing the Dispatch, and is also 
crucial for filtering by road names. 
 

Changing Call Status on Loaded Dispatches 
Once you've viewed the data entered into RAMM Street Lights via the automatic 
process, and you're satisfied that everything is correct, you should change the 
status of the Dispatch from Loaded Data to Entered. 

To do this select the Dispatch in the List panel and then select Actions > Enter Loaded 
Dispatch from the menu 

-OR- 

CTRL+E on your keyboard. 

You can also configure RAMM Street Lights to do this automatically by selecting 
Actions > Dispatch Auto Process, in which case all Automatic Dispatches will be created 
with a status of Entered directly. 

 





 

  

C H A P T E R  8  

This section describes the Street Lights window and the many actions you can 
perform within it for Street Light asset maintenance. 

IN  THIS  CHAPTER 
Street Lights Window................................................................112 
Viewing and Filtering Options for Street Lights ......................113 
Summary Information ..............................................................114 
Location .....................................................................................115 
Pole General ..............................................................................116 
Power Supply Points .................................................................117 
Cabling ......................................................................................118 
Pole Identifier............................................................................119 
Bracket.......................................................................................120 
Light...........................................................................................121 
Gear ...........................................................................................122 
Lamp..........................................................................................123 
Updating Assets.........................................................................124 
Replacing Street Light Assets ....................................................125 
Bulk Replacement of Assets ......................................................126 
Rapid Entry Profiles ..................................................................128 
Rating in RAMM Street Lights.................................................133 
Asset Valuation in RAMM Street Lights...................................134 
Street Light Report ....................................................................135 
Map Auto Update Options .......................................................137 

 
 

Street Lights 
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Street Lights Window 
On the main RAMM Street Lights window, click the Street Lights window launch 
button indicated by the mouse arrow below for direct entry into the Street Lights 
module. 

 

At this point no information has been asked for, so the window will open empty. 

 

You'll need to manually define a filter to bring up the roads you need and begin 
working with Street Lights. 

The same window will show different information if launched from the Dispatch 
Entry window Actions menu. When you do so, a filter relevant to the Dispatch 
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you're processing will be applied automatically- this is to help you locate the road 
for the assets described in your Dispatch and work with them. 
 

Viewing and Filtering Options for Street Lights 
Click the Filter  button on the toolbar, define and apply your filter. See Filters 
(on page 139) for more information. 

Once you've done so, the Street Lights window will show you the individual 
Street Lights in the List panel on the left, and the details for the selected Street 
Light on the various tabs of the Detail panel. Each Street Light also shows the 
assets attached to it in tree format. The location of the Street Light is generally 
shown as a combination of house number and road name, but if these are not 
available, the side of the road and the displacement will be used. 

The View menu contains a number of options to find the asset you want as quickly 
as possible. Auto Expand is a key function - it will automatically expand the assets in 
the List panel. Auto Collapse is similar - as you select a different street, it will 
automatically collapse the previously expanded items. 

Each tab contains information about the assets at the current location.  You can 
navigate through the assets either by using the List panel to the left or the Next Record 

 and Previous Record  buttons on the toolbar (see "Toolbar Buttons" on page 45). 

The tab that you select in the Detail panel will remain active as you move up and 
down the assets in the List panel. Selecting Options > Show Data for Selected Node will 
automatically switch tabs in the Detail panel to correspond with the asset selected 
in the List panel. 

NOTE: Only current assets will be shown in the List panel.To see all replaced 
assets as well, select Actions > Show Replaced Items from the menu -OR- 
CTRL + R. 
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Summary Information 
The Summary tab shows summary information for the current asset. You can't 
change any of this information - to update these values, go to the tab for the 
relevant asset and change it there. 

It contains a summary of all the information in the separate asset tabs, presenting it 
in a readable but abbreviated format. As assets are replaced, history is generated. By 
default, this history is not shown- you can select Options > Show Replaced Items if you'd 
like the history to be visible. The tabs of the Detail panel correspond with the  
components of a Street Light. See Components of a Street Light (on page 36). 
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Location 
The Location tab describes the Street Light location. Since all other assets are 
attached to the Pole, this is what you see in the List panel. You can view the other 
assets by clicking the  next to each Pole. 

 

You should enter as many details as possible. These details are reflected on the 
Dispatch, and the more comprehensive they are, the easier it will be for a 
maintenance crew to locate the Pole and carry out their work. 
     

Street Lights on Intersections 
A Street Light may be located at an intersection. Where it is located on the corner 
of two roads it may be viewed from either road. To allow for this, details of the 
intersecting road should be entered in the Intersects with Road panel on the Location 
tab. 
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Pole General 
This tab defines descriptive features - for example, the Material, Shape, Purpose and Make 
of the Pole (see "Components of a Street Light" on page 36). 

 

For information on setting up the information available from the drop-down lists, 
see Pole Details (on page 179). You can also enter your own Notes or LUX, Model and 
Colour information. 

To configure the Coating field, see Miscellaneous Definitions (on page 180). 

NOTE: The Dispatch and Reason fields on the Installed and Replaced rows are 
dimmed. They will show details if a replacement has occurred. This 
information is updated automatically when completing a Dispatch. 
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Power Supply Points 
To cater for situations where the power supply point may be remote to the Pole it 
serves, you can launch a separate, Pole specific, Power Supply Point maintenance 
window. 

It can be accessed directly from the main RAMM Street Lights window Actions 
menu. Select Actions > Power Supply Points. It will open blank since it's filtered by 
default to show points for a specific Pole and at this stage no Pole is selected. 

It can also be accessed from the Street Lights window (on page 112), by selecting a 
Pole and clicking the  button from the Power Supply Points section. This will 
show the power supply point for the selected Pole. 

 

The Pole Location information shows on the window title bar. 

You can now Add  a Power Supply Point record, and select other necessary 
details such as the Photocell, Owner, Road ID and Side. You can use the History tab to record 
an installation and replacement history. 

You can also use the window toolbar to define whether the selected supply point is 
Primary  or Secondary  by clicking the relevant button. ~a 
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Cabling 
The cabling connecting a remote power supply point (see "Power Supply Points" 
on page 117) and the Pole it serves is regarded as a separate asset, and has its own 
maintenance window. This is launched from Actions > Cabling in the main RAMM 
Street Lights main window. 

 

You'll be required to select the power supply point relevant to the cabling, and you 
can enter other details such as the Make, Model, Length, number of Cores and where it is 
Sited. 

The History tab records Installation and Replacement information. The Miscellaneous tab 
records Risk, Condition and Data Collection information, and the Valuation tab is for 
Asset Valuation purposes. 

~q info for Make and Model 
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Pole Identifier 
This tab on the Street Lights window records details that identify the Pole. 

 

For more information on configuring the drop-down fields, see Miscellaneous 
Definitions (on page 180). 

It is these identifying columns that can be used when entering the Likely Pole ID 
information (see "General Information" on page 86). 
 



 

1 2 0  R A M M  S t r e e t  L i g h t s  
 

Bracket 
The Bracket is the device that connects the supporting structure (Pole, building, 
etc) and the Light. 

 

The height at which the Bracket is mounted can be entered, as well as the angle of 
the Bracket, which is measured in degrees clockwise from road forward direction. 

When viewing a Bracket in the List view, the Bracket Type is shown. 

The Type of Bracket can also be viewed in the List panel at left by expanding the 
details for each Pole. 

For a Pole that has two Brackets, the first Bracket/Light combination will show in 
the list, and the next Bracket/Light combination will be listed next. 

To configure the selections in the drop-down lists, see Miscellaneous Definitions 
(on page 180). 
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Light 
This tab allows you to select Light Make and Model combinations. 

 

To configure the Make, Model, Owner and Type fields, see Light Models (on page 176). 

To configure the Coating field, see Miscellaneous Definitions (on page 180). 

You can also enter details about the owner of the Light here. 

NOTE: The owner of the Pole is not always the owner of the Light. 

The Supply Point Type is also required. 

The entry in the list view is the Lamp manufacturer's code and the Model 
description. 
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Gear 
This tab allows you to select Make, Model, Ballast, Ignitor, Capacitor and other 
information for the Gear of the Street Light. 

 

To configure the options available to you from the drop-down fields, and other 
details like the Gear Wattage (below the Model field) see Gear Models (on page 
177). 
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Lamp 
This tab contains information specific to the Lamp. 

 

To configure the selections available in the drop-down lists, see Lamp Models (on 
page 178). 

The wattage shown below the Model field is taken from the Lamp Make/Model 
combination entered in that window. 
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Updating Assets 
The decision whether to update Street Light assets is made at the point of setting 
up the contract (see "Contract Details" on page 55). 

 

In the Contract Details window (Maintenance > Contract Details from the main RAMM 
Street Lights menu) select the Update Asset option (see above) to enable the 
replacement of Street Light assets. 

If this is unticked, when completing a Dispatch (see "Completing Dispatches" on 
page 75) you'll go straight on to the Claims window (see "Claim Lines" on page 79) 
without being prompted to replace assets. 

This auto-skip facility cuts down on keying time and would only be applicable if as 
a Contractor you have won another contract which you are running on the 
database without updating asset data. 

For example, you may have a Street Light maintenance contract and also a power 
company maintenance contract. On checking a reported fault, you may have also 
found and fixed a related wiring fault. Back at base, you would transfer the 
supposed Street Light from the Network Owner contract to the power company 
contract and complete the Dispatch without updating the data. 
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Replacing Street Light Assets 
Street Light assets are replaced in the Street Lights window (on page 112) by 
clicking the Replace Asset  button on the toolbar. 

NOTE: Replacing an asset is quite different from simply changing its details to 
correct an error. Replacing an asset has an impact on Claims and 
maintenance schedules, and should be done only when necessary. 
 
When replacing assets,  you need to be absolutely sure that you're 
replacing the correct asset in the database. This is where details like the 
Pole number and Pole ID will be crucial. See Database Options (on page 
166). 

Replacement History 
Rather than simply replacing one asset with another, replacing assets in RAMM 
Street Lights involves 2 simultaneous actions: archiving the old asset, and adding 
the new asset. 

When the asset is replaced, the replaced date defaults to the completed date on the 
relevant Dispatch. This is primarily to create a replacement history over time- a 
record of how often different assets and asset types are replaced and why. When 
analysed (see "Reporting" on page 215), this becomes a good indication of the 
failure of a particular asset, or an external factor such as a poorly positioned Pole. 

For the same reason, it's also important to enter a reason for the replacement- for 
example vandalism, poor condition. These are set up in Replacement Reasons (on 
page 183). 

Linked Replacements 
The replacement dialog box has a context sensitive option to replace linked assets. 
For example, if you've selected the Pole to be replaced, you have the option to 
replace the Bracket and the Light as well since that's probably what you will need 
to do. 
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If you choose not to, the existing Bracket, Light, Gear and Lamp combination are 
transferred to the new Pole. RAMM Street Lights will also warn you if the change 
will have an impact on multiple assets, as in the screen above. For a detailed 
description of the replacement procedure, see Replace Asset (on page 77). 
 

Bulk Replacement of Assets 
The Bulk Replace option is useful, for example, when you want to replace all the 
Lamps on a given street.  

You can select a number of assets and then update them with the same details. 

 

4 To Bulk Replace Assets 

1 In the Street Lights window select Replace > Bulk Replace  to access this option. 
The Bulk Replace screen is populated from the current list of assets so it's 
important to apply the correct filter. 

2 Enable updating in the respective Light, Gear and Lamp panels, and specify the 
replacement items from the drop-down lists. 

3 Enter a replacement date (the current date is default) and a replacement 
reason. 
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4 Select the Street Lights on the network that will be updated in the Select 
Lights to Replace panel. 

Either click the Tick All button  and then deselect each asset you don't want 
replaced 

-OR- 

Click the Tick None button  and then select each asset you want replaced. 

5 Click Apply to replace the assets. 

6 RAMM Street Lights will ask you to confirm your selection. Click OK. 

7 RAMM Street Lights will inform you when the replacement is complete and 
return you to the Street Lights window. 

NOTE: Once an asset has been replaced, its details cannot be updated. 

A replaced item shows in the List panel of the Street Lights window as greyed 
(dimmed), to indicate that it is non-operational as below. To view replaced items, 
you may need to select Options > Show Replaced Items from the menu bar. 
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Rapid Entry Profiles 
Entering Street Light assets into RAMM Street Lights is made quick and easy with 
the help of Rapid Entry Profiles. 

Before commencing work in this window you need to define and set them up. 
This can be done two ways: 

§ You can set them up from the relevant Maintenance window. See Maintaining 
Rapid Entry Profiles below. 

§ Profiles can also be created from the Street Lights window, using the Create 
Profile option under the Actions menu item. This profile will be created using the 
current values, but where multiple Lights are attached to a Bracket, only the 
definition of the first Light will be stored. 

Numerous profiles can be created, each with a unique description which can then 
be selected from the list and linked with a road. The majority of the data will come 
from the selected profile, but you will be required to key in unique data such as 
Road name, Location, Side and House numbers. 

NOTE: Coloured fields are mandatory. 

 

Maintaining Rapid Entry Profiles 
A Rapid Entry Profile is a template consisting of default values for Poles, Brackets 
and Lights.  Each profile defines a unique arrangement of Pole, Bracket(s) and 
Light(s), and is known by a unique description.   

Since this requires that the asset properties be available for selection, you may need 
to set them up in Maintenance (on page 171) before they can be included in 
profiles here. 
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4 To Set Up Rapid Entry Profiles 

TIP: You can also select Edit > Duplicate  from the menu to duplicate an 
existing profile, edit the asset settings and then save the profile under a 
new name. See Duplicating Entries (on page 172) for more information. 

1 Enter the relevant information on the Pole tab. 

 

2 Enter the relevant information on the Bracket tab. 

 

NOTE: The Count field on the Bracket tab should reflect the total number of 
Brackets on the Pole. 
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3 Enter the relevant information on the Light tab. 

 

NOTE: The Count field on the Light tab should reflect the total number of 
lights on a Bracket. 

4 Save  each profile, and close the window when you are done. 
 

Creating a Rapid Entry Profile from the Selected Asset 
Rapid Entry Profiles can also be set up from an existing asset. 

4 To Create a Rapid Entry Profile from the Selected Asset 

1 In the Street Lights window (on page 112), select the Pole or asset from which 
you wish to create the profile. 
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2 Select Actions > Create Profile from the menu. 

 

NOTE: The profile created in this instance will use the current values for the 
Pole, Bracket and Light, but where multiple Lights are attached to a 
Bracket, only the definition of the first Light will be stored. 

3 Make any changes you wish to the profile on either of the three tabs (Pole, 
Bracket or Light). 

4 Give the profile a name.  

5 Save  the profile and close the window when you are done. It will now be 
available from in Street Light Rapid Entry Profiles window. 
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Entering Street Lights with Rapid Entry Profiles 
Once you've set up your Rapid Entry Profiles, it's easy to enter your Street Lights. 
This is particularly important when Building a Street Light Inventory (on page 
297). 

4 To Use Rapid Entry Profiles to Enter Street Lights 

1 In the main RAMM Street Lights window, select Actions > Street Light Rapid Entry 
from the menu. 

 

2 Click the Add Record button . 

3 Select the Profile you want to use. 

4 Enter the Road ID or select it from the list. 

5 Enter the Location- this must exist within the dimensions of the road. 

6 Enter the Side. The Offset will default to 0, unless another value is entered.  

7 Pole-specific information can also be entered (Pole no, Map Pole ID etc). You will 
be able to modify some of the data specified in the profile, if you wish to.  
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8 The Bracket and Light data will default to the number of Brackets and Lights 
specified in the relevant profile.  

9 Clicking the Street Light button in the Location section will take you to the 
Street Lights window, and show the current asset. 

 

If required, further changes can be made on the Street Lights window. On 
closing it, you will return to the Street Light Rapid Entry window.  

NOTE: If Rating has been selected in the RAMM Street Lights Options window 
(see "Database Options" on page 166), a Rating tab will also be visible on 
which you will be able to select asset ratings. See Rating Categories (on 
page 187) for more information. 

 

Rating in RAMM Street Lights 
The rating of assets is optional. 

If you wish to use rating categories, select Actions > Options from the main RAMM 
Street Lights menu and tick Rating on the Database tab (see "Database Options" on 
page 166). 
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You will then need to set up rating categories (on page 187). 

The Rating tab will then be made available in the Street Lights window: 

 

The rating information will also be printed at the bottom of the Dispatch form. 

NOTE: You can turn off the Rating Notes fields for each rating category under 
Options > Show Rating Notes from the Street Lights window menu. 

 

Asset Valuation in RAMM Street Lights 
Asset Valuation in RAMM Street Lights helps you compare the expected 
performance of a Street Light asset with its actual performance. 

The Asset Valuation tabs are only available for Consultants and Network Owners. 
The information on them is view-only. For all main Asset Valuation processing, see 
the RAMM Asset Valuation guide. 

NOTE: If Asset Valuation is enabled when a Data Transfer takes place, RAMM 
Street Lights is smart enough to sense this and tries to preserve these 
values on existing assets. 
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Street Light Report 
The Street Light report shows you an inventory of your Street Lights, with options 
to include different levels of detail. 

4 To Generate the Street Lights Report 

1 In the Street Lights window, select Actions > Street Light Report from the menu. 

2 Select your Street Light Report Options. 

 

If you choose Detailed, a number of other options will be activated. 

§ From the Selection panel if you choose Current Pole Only, the report will 
print only the current Pole/Bracket/Light combination that is currently 
selected in the Street Light list. 

§ If you choose All Poles in the List, this will print details for all of the 
Pole/Bracket/Light combinations currently showing in the Street Lights 
window. 

NOTE: If you have activated the option Street Lights > Options > Show Replaced Items, 
the replaced items will also be printed. 
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If you choose Summary as the Report Type, the Detail Options will be 
deactivated. 

3 Click Preview or Print, or Close to return to the Street Lights window. 
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Map Auto Update Options 
Select Options > Map Auto Update Options in the Street Lights window to configure these 
options. They allow you to choose whether RAMM road IDs and displacements 
will be updated automatically when you change Eastings and Northings, and vice 
versa. 

When you're using Mapping (on page 245), you'll naturally want to view your 
Street Light assets on the map. Whenever the map information gets out of date 
(for example, you may replace a Pole and move its location, or you may put in new 
Poles as a result of a subdivision) you would wish to update the map as well. 

You can update the map manually or automatically. These options configure how 
the updating happens, if you choose to allow RAMM Street Lights to update the 
map automatically. 

For more information, see Map Auto Update Options (see "Updating RAMM 
from the Map, and the Map from RAMM" on page 282). 
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This section describes working with filters. 

Filters help you find the data you're looking for quickly. You'll use a database filter 
to narrow down the amount of information that is retrieved from the database and 
sent from the server to your computer. You're only sending the information you 
need across your network, which increases speed and reduces network traffic. This 
is especially important if you're using the RAMM Hosting service. 

IN  THIS  CHAPTER 
Filters in RAMM and RAMM Street Lights ............................139 
Filter Window ...........................................................................142 
Defining Filters .........................................................................143 
Filtering Poles (Example)..........................................................147 
Saving Filters .............................................................................149 
Loading Saved Filters ................................................................150 
Clearing Filters ..........................................................................151 
Deleting Saved Filters ...............................................................151 

 
 

Filters in RAMM and RAMM Street Lights 
Filters are common to RAMM and RAMM Street Lights. RAMM uses two types 
of filters - database filters and grid filters. RAMM Street Lights uses only database 
filters.  

Filters in RAMM Street Lights 
In RAMM Street Lights, database filters are used for a number of purposes. 

§ They are automatically applied to the Dispatch Entry and Street Lights 
windows to show you relevant information only, though you can change the 
filtering conditions if you wish. 

Filters 
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NOTE: If you've set the Street Lights window to Show Replaced Items, the 
filters will do so also (see "Viewing and Filtering Options for Street 
Lights" on page 113). For example, filtering for Type A items will in 
this case also show all Type B items that have replaced former Type A 
items. 

§ You can define complex combinations of conditions that involve many 
different database tables and columns- for example, all wooden Poles with 250w 
Lights, or all ground planted Poles with an outreach greater than or equal to 2m and 
70w HPS Lamps. 

§ You can save database filters (see "Saving Filters" on page 149). The saved 
filters are specific to the window they're being used in. 

§ A specific type of Filter is available within the Decision Cube to help cut down 
unnecessary Cube clutter and save your Cube layout. See Decision Cube 
Filter (on page 221) for more information. 

Filters in RAMM 
RAMM uses filters for similar purposes to RAMM Street Lights, and most 
RAMM detail windows are also filtered by default to show you the Latest data. 

You can also launch RAMM Street Lights from the RAMM main window toolbar, 
but the window you see is filtered by default using a database filter to ensure that 
you see only those Street Lights where the Light, Gear and Lamp have not been 
replaced. 

CAUTION: Don't edit the filter criteria to clear the default filtered fields (see 
image below) unless you specifically wish to view all historical 
replacements in RAMM Street Lights. 

As the image shows, the way RAMM reports Street Light assets in the standard 
Grid window is different. RAMM shows the assets in numbered rows, whereas 
the Street Lights window (on page 112) arranges the assets in a tree format to show 
how the assets are linked. 
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For more information on grid filters, see the Using RAMM manual. 
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Filter Window 
To launch the filter, click the Filter button  on the toolbar of the Dispatch Entry 
or Street Lights window 

-OR- 

Selecting Options > Edit Filter from the menu 

-OR- 

Use the key combination CTRL+F. 

The screen below is what you see when launching filtering from the Dispatch 
Entry window (on page 84). 

 

If you have saved any filters, they will be available from a drop-down list next to 
the Filter button. 
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Defining Filters 
Defining a database filter is simply a matter of selecting the appropriate Field for 
the information you wish to see, defining criteria for filtering in the middle panel, 
ensuring that the Filtered Fields panel reflects the correct criteria you've defined. 

 

The example above shows only a single tab containing criteria for filtering by In 
List (see "Filtering By List" on page 143). Depending on which Field you select, 
you may also choose By Value (see "Filtering By Value" on page 145), and By Range 
(see "Filtering By Range" on page 144). 

NOTE: The filter fields are sorted in Logical Order by default. You can change 
this to Alphabetic Order by selecting Options > Alphabetic Order from the filter 
window menu. 

 

Filtering By List 
Some filtering conditions involve a fixed list of values for a field. The field you 
select in the Fields panel must be one that allows you to specify In List criteria. 

Selecting a field will generate a list of lookup values for that field on the In List tab. 
You can choose one or more of the values from the list. If the condition you want 
doesn't match an item in the list, you can tell RAMM Street Lights what not to 
look for - by ticking Exclude selected items. 

4 To Filter By List 

1 Select the Field you wish to work with. 

2 Click the In List tab. The available lookups will be listed. 
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NOTE: Certain fields will allow you can import In List values from a file by 
clicking the Options button on the In List tab. If importing is not 
allowed, the Load Options from File item on the menu will be dimmed 
(unavailable). 

3 Tick each value you want to match. You can match as many values as you like. 
In the example below we've chosen to look at the all assets on Bennett, 
Beresford and Birmingham streets. The Filtered Fields window will 
automatically load the relevant Road IDs. 

 

4 If you want to show all the details which do not match the values you selected 
from list, tick Exclude selected items. 

5 Click OK to return to the window you launched the filter from (in this case, 
Street Lights) and view the results of your filtering. 

 

Filtering By Range 
Some filtering conditions involve a range of values. For these, you'll use the By 
Range tab. The field you select in the Fields panel must be one that allows you to 
specify By Range criteria. 

4 To Filter By Range 

1 Select the field you wish to work with. 

2 Click the By Range tab. If the range you require involves a date, you can select a 
range quickly from the drop-down menu on the Date Range field, or specify the 
range as below.~a 

3 Select the relationship between the condition and the starting value of the 
range (Greater Than, or Greater Than or Equal To). 
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4 Type the value for the start of the range. To make the field blank, click the 
Clear button. 

5 Select the relationship between the condition and the end value of the range 
(Less Than, or Less Than or Equal To). 

6 Type the value for the end of the range. To make the field blank, click the Clear 
button. 

 

If you want to show all Lights last tested outside the range, tick Exclude items in 
range. In our example, ticking the box would find all Lights except those within 
the date range above. 

7 Click OK to return to the window you launched the filter from (in this case, 
Street Lights) and view the results of your filtering. 

 

Filtering By Value 
This filter option is for finding information by a straightforward one-to-one match 
with a single value. The field you select in the Fields panel must be one that allows 
you to specify By Value criteria. 

4 To Filter By Value 

1 Select the field you wish to work with. 

2 Select the By Value tab. 
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3 Select the relationship between the condition and the value. In the example 
below we've launched the filter from the Dispatch Entry window and wish to 
configure the filter to show Dispatch ID 8677. Equal To is the most common 
Field Value. 

 

There are other options available in the Field Value drop-down list: 

§ If you're looking for a word or phrase that's buried somewhere in a text 
field, select Partial Match at Beginning or Partial Match Anywhere. 

§ Select Is Null to find all details where the filter criteria field is empty. This is 
useful, for example, if you're cleaning up your database and you want to 
find only records with missing information in that field. 

§ Select Is not Null to find all details where the filter criteria field is not empty. 
For example, you might use this to find road asset records whose Notes 
field has something entered in it. 

4 Type the value (unless it's not needed). Click the Clear button to clear the filter 
criteria field. 

5 Click OK to return to the window you launched the filter from (in this case, 
Dispatch Entry) and view the results of your filtering. 

NOTE: If you're using Network Owner version of RAMM Street Lights, it's 
possible that more than one Dispatch will be returned as your 
permissions allow you to work with more than one contract 
simultaneously. A Dispatch ID is unique only within a contract. If 
you're using the Contractor version of RAMM Street Lights, you 
will only see Dispatches from the contracts currently open. 
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Filtering Poles (Example) 
In this example we'll define a complex filter to show us very specific data. 

We'll define a filter to show all ground planted Poles with an outreach greater than or 
equal to 2m and 70w HPS Lamps. 

4 To Set Up Your Filter 

1 From the Street Lights window, launch the filter (see "Filter Window" on page 
142). 

2 This is what you will see: 

 

3 Select Pole Mount in the Fields panel under Street Light - Pole > Identification. Select 
Ground Plant on the In list tab. 
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4 Scroll down to the Street Light - Bracket section on the Fields panel and select 
Outreach(m). Select a Field Value of Greater than or Equal To and enter 2 in the field 
below (this is the length of the outreach in metres). 

 

You'll see this criteria added to the Filtered Fields panel. 

5 Now scroll down to the Street Light - Light section on the Fields panel and open 
up the Lamp subsection to be able to select Lamp Make/Model. You'll now be able to 
go to the In List tab and open up the selections under High Pressure Sodium, and 
select 70. 

 

Once again, you'll see the new criteria added to the Filtered Fields panel. 

6 Click OK to apply your filter to the network and show you the results in the 
Street Lights window. 

TIP: If you're likely to use this filter more than once, we would suggest saving 
it (see Saving Filters below). 
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Saving Filters 
Saving your filters is very important. It safeguards the work you've done 
configuring the filter, and you can also easily load the filters and apply them to 
your network with a few mouse clicks. See Loading Saved Filters (on page 150) for 
more information. 

Saved filters can also be loaded, changed, and saved under a different name using 
the Save As menu option. 

Saved filters can also help with regular tasks - for example, you can run a filter on a 
monthly basis. Save the filter with a date the first time you run it. The next time, 
simply change the date and run it again. You can also save the filter and overwrite 
the existing filter, or save it under a different name. 

4 To Save a Filter 

1 Define the filter (see "Defining Filters" on page 143). 

2 From the filter window, choose File > Save As. The first time you save a filter 
you will be required to give it a name. The Save As filter dialog box appears. 

 

Type the name you want to use for the filter - make it something meaningful, 
so you'll know what it does when you're looking at a list of filters to load. 

NOTE: The Save option is for saving edits to an existing filter. 

3 Choose OK to save the filter. You're returned to the filter window. 
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Loading Saved Filters 
You'll probably find yourself working with the same filter settings more than once, 
so RAMM Street Lights makes it easy to load any filter you've previously saved 
(see "Saving Filters" on page 149). 

4 To Load a Saved Filter 

1 Launch the filter window (on page 142). 

2 Clear any currently active filters if necessary by selecting File > Clear 

3 Choose File > Load Filter > [Name of Saved Filter] from the menu. 

 

4 The selected filter's settings are displayed. You can now edit them and save 
them under a different name if you wish- see Saving Database Filters. 

5 Apply the filter's settings by clicking the OK button. 
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Clearing Filters 
When you're working with filters, it's important to clear the currently applied filter 
if you don't want the existing settings added to your settings. 

There are two places in RAMM Street Lights where you can clear filter settings - 
inside the function window you are using (the Dispatch Entry window or the 
Street Lights window) or inside the filter window itself. 

4 To Clear Filters from the Dispatch Entry or Street Lights Window 

§ Select Options > Clear Filter 

-OR- 

CTRL + L on your keyboard. 

4 To Clear Filter Settings in the Filter Window 

§ Select File > Clear from the menu. 

If the saved filter is one you won't need again it can also be permanently deleted 
(see below). 
 

Deleting Saved Filters 
Every now and then, you'll want to get rid of a database filter that you've saved (see 
"Saving Filters" on page 149). 

4 Deleting a Saved Filter 

1 Launch the filter window (on page 142). 
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2 Choose File > Delete Filter from the menu. The Delete Filter window appears. 

 

3 Select the filter you want to delete, then click the OK button. The filter is 
deleted immediately and the filter window reappears. 
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Patrols are crucial to keeping your Street Light network in good working order. 
This section describes setting up Patrols. You can then link each Dispatch directly 
to a Patrol. 

~a entire chapter 

IN  THIS  CHAPTER 
Maintaining Contract Patrols....................................................153 
Entering Patrol Details ..............................................................154 

 
 

Maintaining Contract Patrols 
Patrols are handled somewhat differently in RAMM Street Lights to earlier 
versions of SLIM, and are now governed by Staff Permissions (see "Security" on 
page 287). 

You'll begin by defining Contract Patrols in the relevant Maintenance window. 
From the main RAMM Street Lights window select Maintenance > Contract Patrols to set 
these up. 

 

Patrols 
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Once these are set up you link Patrol Events to the the Contract Patrols you 
defined earlier in the Patrols window, rather than set up Patrol Areas and then 
attach Contract Patrols to them. 

NOTE: Once a Contract Patrol has been linked to a Patrol Event and/or a 
Dispatch, the details cannot be altered.~a 

 

Entering Patrol Details 
Patrols, Patrol actions and Patrol crew members are linked to the contract, and are 
therefore governed by staff permissions (see "Security" on page 287). This window 
allows you to enter Patrol details, and link them to Contract Patrols (see 
"Maintaining Contract Patrols" on page 153).~a 

From the main RAMM Street Lights window, select Actions > Patrols. 

 

The information you see is filtered by default to Patrols within the last month. To 
change this select Options > Edit Filter (CTRL+F) or Clear Filter (CTRL+L) from the 
Patrols window menu. 

4 To Enter Patrol Details 

1 Select a Contract Patrol to link to the Patrol record you're setting up from 
those already defined- see Maintaining Contract Patrols (on page 153), or 
select Actions > Maintain Contract Patrol to do so. The Patrol ID will also come 
through. 
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2 Enter the other details. Patrol Status refers to the type of Patrol, whether 
Emergency or Routine. 

3 Patrol Action is an important field, as it decides whether the Patrol is Planned or 
Complete. 

4 The Call Type refers to the source of the information controlling the Patrol 
event, and should correspond to the Call Type on the Dispatch. 

5 Now set a Start Date and time, and end date and time. 

NOTE: Choosing the right frequency for the Patrols is crucial. Large areas 
can be patrolled once a month, but it may be advisable to patrol main 
roads weekly. Click the drop-down arrows  to bring up a calendar 
to select the date. Use arrow keys on your keyboard to select a start 
and end time. 

6 The Crew member field will allow you to select from crew members already 
entered as part of contract level staff permissions (see "Contract Details" on 
page 55). 

7 Notes is a free format field to enter any notes you may feel are relevant. 

Now that the Patrol has been entered, you can go to the Dispatch Entry window 
(on page 84) and enter the problems found by that Patrol in the Patrol Details 
section at the bottom of the Detail panel. 
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A Claim groups together Claim lines for the same contract within a fixed period. 
This section examines how you work with Claims in RAMM Street Lights. 

IN  THIS  CHAPTER 
Claims Window.........................................................................157 
Claim Life Cycle .......................................................................158 
Printing a Claim (Example) ......................................................159 
Claim Reports ...........................................................................161 
Payments from Claim Lines .....................................................163 
Dispatch Claim Approval..........................................................164 

 
 

Claims Window 
The Claim Maintenance window can be launched either from the main RAMM 
Street Lights window by clicking the Claims launch button indicated by the 
mouse arrow below: 

 

Claims 
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-OR- 

by select Actions > Contract Claims from the main RAMM Street Lights window. 

You can now enter or edit Claim headers. By default, only the Claims that are not 
completed are shown. If you wish to see all Claims, select View > Show All Claims. 

 

Entering a Claim header is a matter of simply selecting the appropriate contract, 
inserting an optional description and filling in the start and end dates for the 
Claim. You can also add notes. The Claim header is now ready to have Claim lines 
attached to it. 

NOTE: Claim lines can only be added when completing a Dispatch, or by 
selecting Actions > Claim Lines or CTRL+A on a completed Dispatch. See 
Claim Lines (on page 79). Approval of Claims can also be managed from 
the Dispatch Claim Approval window (see "Dispatch Claim Approval" 
on page 164). 

 

Claim Life Cycle 
A Claim has a three stage life cycle:  

§ Open. When the Claim is open, Claim lines can be linked to it. 

§ Prepare. This indicates that the Claim is currently being prepared for 
presentation, and therefore should not have any further Claims or Claim lines 
added to it.~a 
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§ Presented. This indicates that the Claim has been printed and presented for 
payment. 

§ Complete. The Claim has been accepted and no further action is required. 

By default, when a Claim is created it is Open. The options to move the Claim 
through the next steps are under Actions. 

Claim Actions 
§ Print Claim (CTRL+P). This prints a Claim, changes the status to Presented and inserts 

the presented date. Once a Claim has been presented, Claim lines cannot be 
altered. If changes are required, you will need to Unpresent the Claim (see 
below). 

§ Complete Claim (CTRL+O). This allows you to enter a payment in order to complete 
the current Claim. 

§ UnPresent Claim (CTRL+U). You should avoid using this option unless absolutely 
necessary. This will reverse the status of the Claim from Presented to Open. 
However, this means you also have to cancel or destroy all printed material 
relevant to the prior Claim. 

Selecting Claim Lines from the menu opens another window that gives you access to 
the individual lines grouped under the Claim. Claim lines can be updated and 
deleted from this window. You can also view the details of each Claim line by 
double-clicking it, or by selecting the Claim line and then selecting View > Show Detail 
from the menu. 
 

Printing a Claim (Example) 
The steps below show how to print (and present) a Claim. 

4 To Print a Claim 

1 Select the Claim in the List panel of the Claim Maintenance window. 

2 Select Actions > Print Claim 
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-OR- 

CTRL+P. 

 

3 You have a number of options: 

§ Change this Claim to Presented (selected by default) can be unticked if you just 
want to preview the Claim. 

§ Show details for non-standard Claims. 

When the Claimed Rate does not equal the Agreed Rate then these values 
can be highlighted on the Claim in red. They are also listed individually 
under each Claim item. Selecting this option prints the Dispatch ID and 
the Maintenance Notes from the Dispatch for these items on the Claim. 

NOTE: This changes the print layout of the Claim from portrait to 
landscape. You will also need a colour printer to print the 
highlighted values in red. 

§ Generate Claim Groups Report. 

§ Generate Claim Details Report. 

Make your selections and then click either Preview or Print. For more 
information on the Claim Groups Report and the Claim Details Report, see 
Claim Reports (on page 161). 

NOTE: Once the Claim is presented, this window will show only the last 3 
options as active (Change this Claim to Presented will be inactive). 

4 When you're done you'll be returned to the Claim Maintenance window. 
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Claim Reports 

Claim Groups Report 
The Claim Groups Report summarises Claims by Account Group. 

To generate this report in the Claim Maintenance window, select Actions > Print Claim 
(CTRL+P) and select the option to Generate Claim Group Report. 

NOTE: If you don't intend to change the status of the Claim to Presented, untick 
the option to Change this Claim to Presented. 
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Claim Details Report 
The Claim Details Report shows a detailed description of each Claim line and the 
Dispatch it refers to. 

This report can be generated either from the Claim Maintenance menu by 
selecting Actions > Claim Details Report 

-OR- 

from the Claim Maintenance Print dialog box (select Actions > Print Claim (CTRL+P) and 
tick the option Generate Claim Details Report). 
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Decision Cube 
Click  to bring up a Decision Cube report. By default the Claim lines will be 
grouped by contract item. 

To add more sort fields to your cube, simply drag a grid header  of your 
choice down to the existing grid header for Claim Year. 

See Decision Cube (on page 217) for more information. 

NOTE: These reports are Claim specific- they're relevant only to the Claim 
you're currently viewing. For an analysis of all the Claims relevant to 
your network, see Claim Analysis Report (on page 236). 

 

Payments from Claim Lines 
When creating a Claim line, if there is more than one payment header open, you're 
prompted to select one. 

 

If there is no payment header available, you're prompted to create one. 

 

If a payment header isn't available, you won't be able to add a Claim line. 

All lines entered for this Dispatch will be linked to the payment header selected or 
created. 
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Dispatch Claim Approval 
The Dispatch Claim Approval window facilitates the viewing, managing and 
processing of Claims (on page 157). From the main RAMM Street Lights window, 
select Actions > Dispatch Claim Approval to launch it. 

NOTE: You can use this facility to manage any Claim raised in RAMM Street 
Lights, in particular Automatic Claims (on page 63). In addition to 
approving or processing Claims, details can be added or corrected and 
the Claim status changed. 

 

By default the window is filtered to show only Claims that are Pending, indicated 
by the red dot  on the relevant Dispatch, Claim line and on the toolbar in the 
Dispatch Claim panel at the lower right. The Dispatch list on the left shows the 
Dispatches with pending Claims, and the Dispatch Detail panel at top right shows 
information relating to the location and persons responsible for the job. To mark 
the Claim as Approved, click the green dot  on the Dispatch Claim panel toolbar 
indicated by the mouse arrow.~a 
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This section shows you how configure RAMM Street Lights Options. 

By choosing Actions > Options from your RAMM Street Lights menu, you can set 
other options pertaining to Database, Electricity charges, Safety Testing and Enforcement. 

You can also configure how you will send and receive RAMM Street Lights data 
by Email (see "Email Options" on page 101) by selecting Actions > Email Options. 

NOTE: This section does not describe setting general programme preferences, 
which are accessed in the main RAMM Street Lights window from the 
Options > Preferences menu. See Setting Editing and Viewing Preferences 
(on page 31). 
 
Optional Groups are now described under Contract Groups (on page 58) 
for contract specific Groups, and Optional Grouping (on page 192) for 
contract non-specific Groups. 

IN  THIS  CHAPTER 
Database Options ......................................................................166 
Electricity Charges.....................................................................167 
Safety Testing ............................................................................168 
Tolerances .................................................................................169 
Enforcement ..............................................................................170 

 
 

RAMM Street Lights Options 
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Database Options 
The Database tab sets database related RAMM Street Lights options. 

 

§ Database Name. This appears on the second line of every report heading (see 
"Reporting" on page 215). This name can differ from the name entered in the 
Database Description column. By default, the name is carried across from the 
Network Owner's database, but if you're a Contractor you can alter this name 
as the information isn't transferred to the Network Owner. 

§ Guarantee Period. All new Poles entered will have the option to apply a guarantee 
date to the Pole. The guarantee period is for one year from the guarantee date. 
If during this period a Dispatch is raised against this Pole, the comment This 
Pole is still under guarantee is printed beneath the details of the relevant Pole. This 
indicates to the Contractor that any fault with this Pole is the responsibility of 
the entity that erected the Pole. For more information, see Printing Dispatches 
(on page 71). 

§ Rating. This option is for the purpose of rating Street Light assets as part of the 
Dispatch procedure. See Rating Categories (on page 187) for more 
information on entering rating categories. The results of the Contractor's 
rating of the assets should be entered onto the rating tab of the Street Lights 
window (on page 112). 

§ Circuit Information Required. This allows the user to enter additional information 
about the circuit and sequence number of the Pole within the circuit that may 
come in useful when doing a bulk replace of Lights (see "Bulk Replacement of 
Assets" on page 126). The lookup tables that become available when this 
option is ticked are located under Maintenance > Miscellaneous Definitions > Circuit 
Information. 
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§ Line Company. If this option is enabled, the Line Company name will be made 
available with the circuit information. 

§ Warranty Period. Tick the Warranty Period box if you want the warranty period to 
be taken into account when certain assets are replaced. The warranty period 
applies to Lamps, Gears and Lights. For more information, see Warranty (on 
page 174). 

§ Power Company. This option will enable the power company field on the Pole 
General tab in the Street Lights window (on page 112). 

§ Pole Link. This enables selection of a unique identifier for the Pole when 
entering Dispatches (see "Dispatch Entry" on page 68). Available options from 
the drop-down list: 

§ Power Board Number. 

§ Easting, Northing. 

§ System Pole ID. 

§ Map Pole ID. 

§ Not Applicable. 

§ Pole Number. 
 

Electricity Charges 
The Electricity Charges tab allows you to enter default value which can be used in the 
Electricity and Maintenance Cost Report (on page 233). 
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Enter the values in the respective fields. 
 

Safety Testing 
The Safety Testing tab gives access to the fields below. Currently six testing categories 
are entered as defaults, all of which can be changed. 

 

If this option is selected the testing is carried out as part of the Dispatch procedure, 
the testing categories appear at the base of the full Dispatch report: 

 

For more information on printing Dispatch reports, see Dispatch Printing Options 
(on page 97). 
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Tolerances 
The Tolerances tab allows you to set a tolerance level (in units) to reconcile either 
house numbers or map co-ordinates that do not match in the Dispatch Entry 
window (on page 84). 

 

According to the settings in the image above, RAMM Street Lights will show 10 
house numbers greater or lesser than the stated house number so that you have a 
better chance of identifying the correct Pole for the Dispatch. 

The tolerance setting for the map co-ordinate is particularly important, because 
you can't rely on the person taking the reading for the Pole standing in the same 
spot every time. The setting is expressed in metres. 
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Enforcement 
The Enforcement tab of the RAMM Street Lights Options window relates to the asset 
replacement process (see "Replacing Street Light Assets" on page 125). 

You can set whether to make replacement of these assets Optional or Mandatory from 
the drop-down list. Replacement of Gear can also be set to Not Required. 
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This section in RAMM Street Lights describes working with the items on the 
Maintenance menu of the main RAMM Street Lights window. 

This is essentially where you will set up the information for the various drop-
down lists in the various windows of RAMM Street Lights. This information is 
held in a number of tables. Most tables contain a Code and a Description, but 
some require additional information. Wherever possible, the software will fill in 
the default values for these tables when you enter a maintenance window. 

You must have the relevant security (on page 287) permissions to configure these 
settings. 

IN  THIS  CHAPTER 
Duplicating Entries ...................................................................172 
Merging Entries.........................................................................173 
Warranty ....................................................................................174 
Allowed Items............................................................................174 
Contract Details and Contract Item Activities..........................175 
Light Models .............................................................................176 
Gear Models ..............................................................................177 
Lamp Models.............................................................................178 
Pole Details................................................................................179 
Miscellaneous Definitions ........................................................180 
Rating Categories ......................................................................187 
Optional Grouping....................................................................192 
Costs ..........................................................................................194 
Event Codes ..............................................................................197 
Lux Survey.................................................................................197 
Default Values ...........................................................................200 
Organisation ..............................................................................201 

 
 

Maintenance 
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Duplicating Entries 
Most RAMM Street Lights Maintenance windows allow you to duplicate an 
entered item to save you time and trouble setting up assets. Simply select the item 
in the List panel (see "RAMM Street Lights Workspace" on page 43) and select Edit 
> Duplicate from the menu. 

4 To Duplicate an Entry 

1 Go to the relevant Maintenance window for the asset from the main RAMM 
Street Lights window. 

2 Select the item to be duplicated in the List panel. 

3 Select Edit > Duplicate on the menu 

-OR- 

Right-click anywhere other than inside a panel to bring up the same menu and 
select Edit > Duplicate. 

 

4 This will generate a copy of the item. 

 

5 You can now edit the item, changing its parameters and description. 

6 Save  each item, and close the window when you're done. 
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Merging Entries 
RAMM Street Lights Maintenance windows also have the facility of merging 
entries to avoid duplicating information unnecessarily. 

For example, you  may have entered a number of Lights on the Street Lights 
window, and given them different Models, but later find that the Models actually  
refer to the same Model of Light (for example H 50 and H50). 

You can merge the entries for these codes, so that analyses or reports based on this 
Model will accurately reflect the fact that all of these Lights are the same Model. 

4 To Merge Entries 

1 Go to the relevant Maintenance window for the asset from the main RAMM 
Street Lights window. 

2 Select the entry to be merged in the List panel. 

3 Select Edit > Merge from the menu 

 

-OR- 

Right-click anywhere other than inside a panel to bring up the same menu and 
select Edit > Merge. 

4 You will be asked to choose which row you wish to merge with the entry 
selected in 2 above. 
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Select the relevant row and click Merge Rows. 

5 Close the Maintenance window when you're done. 
 

Warranty 
Selected RAMM Street Lights Maintenance windows allow you to enter a 
warranty period in months. This field will be available from the Maintenance 
menus (Maintenance > Manufacturers > [Asset]) if you have enabled it in RAMM Street 
Lights Options (on page 165), and only for Lamps, Gear Assemblies and Lights. 

This facility is useful to check whether assets need replacement before the end of 
this period. The assets that are identified as such are shown in the Warranty 
Failure Report (on page 236). 

 

Click below the relevant column in the Detail panel of the window to enter the 
warranty period. 
 

Allowed Items 
Certain Maintenance windows in RAMM Street Lights have a tab to specify 
Allowed [Items]. 

§ Light Models (Maintenance > Manufacturers > Light Models menu) 

§ Lamp Models (Maintenance > Manufacturers > Lamp Models menu) 
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This way you can be sure that the combination (in this example, the Light and the 
Lamp) is logical. 

Select the main item in the List panel, and use the Detail panel to specify the 
combinations with the drop-down lists as below. 

 
 

Contract Details and Contract Item Activities 
These tasks are generally performed at the beginning of the contract. For more 
information, see Contract Details (on page 55) and Contract Item Activities (on 
page 60). 
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Light Models 
Select Maintenance > Manufacturers > Light Models to configure these details and make 
them available in the Street Lights window (see "Light" on page 121). 

 

The List panel shows the Light Make on the left, and within a Light Make you can 
enter a number of Models. 

4 To Enter Light Makes and Models 

1 Click the Add Record button  on the window toolbar to begin a new entry. 

2 Enter the Code and Light Make on the General tab. 

3 On the Models tab, click the  button on the Detail panel and enter different 
Models in the Light Model column. You can also enter a Warranty Period in 
months (see "Warranty" on page 174). 

4 You can also specify Allowed Lamps on the next tab (see "Allowed Items" on 
page 174). 

5 Save  each Model description. 

6 Close the window when you are done. 
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Gear Models 
Select Maintenance > Manufacturers > Gear Models to configure these details and make 
them available in the Street Lights window (see "Gear" on page 122). 

 

Within a Gear Make there can be a number of different Models.  The Make must 
be created first, and then the Models. 

The Gear Wattage field for each Model is required to calculate the electricity 
consumed across the network.  This is a mandatory field. A Wattage Analysis 
Report (on page 229) is available that uses the wattage figure to determine the 
electricity usage across the network by Area, Owner, Gear Make and Model. 

4 To Enter Gear Makes and Models 

1 Click  on the window toolbar to begin a new entry. 

2 Enter the Code and Gear Make. 

3 You can now click the  button in the Detail panel to enter more 
information for each Make. Enter Models in the Gear Model column, and 
Descriptions and/or Gear Wattage as required. 

4 Save  each Model description. You can also enter a Warranty Period in 
months (see "Warranty" on page 174). 

5 Close the window when you are done. 
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Lamp Models 
Select Maintenance > Manufacturers > Lamp Models to configure these details for the Street 
Lights window (see "Lamp" on page 123). 

 

A Lamp Make can encompass a number of different Models. You need to enter the 
Lamp Make first before you can add Models under it. 

For Models the Lamp Wattage field is required to calculate the electricity consumed 
across the network.  This is a mandatory field. This is a mandatory field. A Wattage 
Analysis Report (on page 229) is available that uses the wattage figure to determine 
the electricity usage across the network by Area, Owner, Lamp Make and Model. 

Entering a dollar value into the Maintenance field is optional. This enables you to 
estimate the cost of maintaining the Lights in the network. The Electricity and 
Maintenance Cost Report (on page 233) uses the Lamp Wattage and Maintenance 
Value fields to calculate an estimate of  Electricity and Maintenance charges for the 
previous month. 

4 To Enter Lamp Makes and Models 

1 Click the Add Record button  on the window toolbar to begin a new entry. 

2 Enter the Code and Lamp Make on the General tab. 

3 On the Models tab Detail panel, you can now click the  button and enter 
different Models in the Lamp Model column. You can also enter Description and/or 
a Warranty Period in months (see "Warranty" on page 174). 
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4 You can also specify Allowed Lights on the next tab (see "Allowed Items" on 
page 174). 

5 Save  each Model description.  

6 Close the window when you are done. 
 

Pole Details 
You can set up and maintain Pole related information from Maintenance menu. 

These details will then be available in Street Lights window on the Location (on 
page 115), Pole General (on page 116), and Pole Identifier (on page 119) tabs. 

Here is a guide to the different Pole maintenance categories. 

§ Pole Make and Model - select Maintenance > Manufacturers > Pole Manufacturers. 

§ Control Types - select Maintenance > Pole Definitions > Control Types. 

§ Construction Materials - select Maintenance > Pole Definitions > Construction Materials. 

§ Pole Attachment - select Maintenance > Pole Definitions > Pole Attachment. 

§ Pole Mount - select Maintenance > Pole Definitions > Pole Mount. 

§ Pole Purpose - select Maintenance > Pole Definitions > Pole Purpose. 

§ Pole Shapes - select Maintenance > Pole Definitions > Pole Shapes. 

For each Pole maintenance category, click the Add Record  button, enter a code 
and relevant description, and Save  each record you enter. 

~q MEN Point and Location, Tightened 

NOTE: To set up Pole Owners, see Street Light Owners (on page 180). 
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Miscellaneous Definitions 
Select Maintenance > Miscellaneous Definitions > [Lookup] to launch the maintenance window 
you require. 

4 To Maintain Miscellaneous Definitions 

Use the menu guide below to: 

1 Navigate to the maintenance category. 

2 Add new items with the Add Record button . 

3 Enter the relevant information. 

4 Make appropriate option selections. 

5 Save  each record. 
 

Street Light Owners 
Select Maintenance > Miscellaneous Definitions > Street Light Owners to maintain these details 
and make them available on a number of tabs (Summary, Pole General, Light) in the 
Street Lights window (on page 112). 

 

You can also set an Owner Type from the drop-down list indicated by the mouse 
arrow to cater for different ownership situations for the components of the Street 
Light. 
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Bracket Types 
Select Maintenance > Miscellaneous Definitions > Bracket Types to maintain these details and 
make them available in the Street Lights window (see "Bracket" on page 120). 

 

In addition to the Code and the Bracket type you can also specify the Length from Pole 
or the Vertical height. 

The Length from Pole is the length of the bracket as it extends outwards from the 
Pole, as in the examples below. 
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The Vertical Height refers to the Bracket's rise in height, from where it connects 
to the Pole, up to the Light. See the examples below. 

 

 
 

Coating Systems 
Select Maintenance > Miscellaneous Definitions > Coating Systems to maintain these details and 
make them available in the Street Lights window (see "Pole General" on page 116). 

 

This window allows you to select whether the coating is used on the Pole, the 
Bracket, the Light, or any combination of these three options. 
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Replacement Reasons 
When an asset is replaced in the Street Lights window (on page 112), a reason for 
the replacement needs to be given. 

 

First enter a code and a description for the reason in the normal way. Then decide 
which asset(s) you wish each reason to apply to, by ticking the relevant boxes 
marked Allowed for [Asset]. 

Tick the Warranty Reason box if the warranty period needs to be noted when this 
particular reason is given for replacing an asset. If you do, and replacements are 
being made while the warranty period is still in effect, you will be informed of this 
while doing the replacement. You can also report on all such cases by running the 
Warranty Failure Report (on page 236). 

NOTE: The warranty period (and therefore, Warranty Reason) only applies to 
Lamps, Gear and Lights. You can activate this in Database Options (on 
page 166). 
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Power Supply Points 
Three maintenance windows available from the Maintenance > Miscellaneous Definitions 
menu help keep track of Power Supply Point, Type and Case details. 

Select Maintenance > Miscellaneous Definitions > Power Supply [Point / Type / Case] as relevant to 
maintain these details and make them available on a number of tabs in the Street 
Lights window (on page 112). 

 

In situations where the supply point may be remote to the Pole it serves, you can 
launch a separate, Pole specific, Power Supply Points window (see "Power Supply 
Points" on page 117). Select Actions > Power Supply Points in the main RAMM Street 
Lights window or from the Power Supply Points section on the Street Lights 
window Location tab (see "Location" on page 115).~a 
 

Power Company 
Select Maintenance > Miscellaneous Definitions > Power Company to maintain these details and 
make them available in the Street Lights window (see "Pole General" on page 116). 

~e recapture #7138 

The Power Company is defined as the company that generates and supplies the 
power to the asset.  This is the same company that you pay for the power 
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consumption/usage based on the wattage of the network for each ICP (Installation 
Connection Point).  

The values in Fixed rate and Variable rate represent those negotiated between the 
Network Owner and the Power Company and are used in the Electricity and 
Maintenance Cost Report (on page 233). 

Night Hours represents the average hours of darkness in a year that needs to be 
considered when calculating power supply costs, and is set to a default of 4250. 
You may wish to alter this to more accurately reflect your area.  For example 
Network Owners in the far North and South of the country may experience less 
or more hours of darkness than the default setting.  This value is also used in the 
report mentioned above.  

Electricity Charge 
The electricity charge is calculated using the formula below. 

Electricity 
Charge 

= (no of Lights x fixed rate x days in period) +  
(((sum of (no of Lamps per Model x Wattage)) / 
1000) x (4250/365 x days in period) x variable rate) 

 
 

Circuit Information 
Select Maintenance > Miscellaneous Definitions > Circuit Information to maintain these details 
and make them available in the Street Lights window (see "Pole Identifier" on page 
119). They will be available only if Circuit Information Required is ticked in Database 
Options (on page 166). 

§ Bulk Change Groups 
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Bulk change groups need to be set up before they can be selected in the 
Circuit ID maintenance window below. Bulk change groups are for Network 
Owners that have regular replacement cycles for an entire circuit or area rather 
than dealing with individual faults as and when they occur. 

§ Line Company 

 

You can enter notes for the line company and select whether the company is 
Active or not. The Line Company is in charge of the lines, and supplies the 
power to the asset on behalf of the Supply Company. When a whole street is 
reported as “not going”, for example, this could be a Line Fault rather then 20 
Lights with blown Lamps. 

§ Circuit IDs 

 

The Circuit ID information is particularly important for Dispatch Entry. 
Specifying the Bulk Group, Group Sequence No. and Bulk Circuit is mandatory. 

 

Gear Ballast, Capacitor and Ignitor 
Select Maintenance > Miscellaneous Definitions > Gear [Ballast/Capacitor/Ignitor] to maintain these 
details and make them available in the Street Lights window (see "Gear" on page 
122). Each entry requires a name and a description. 
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Rating Categories 
Rating in RAMM Street Lights enables you to set up various rating categories, record 
the state of the asset as it is visited on a Dispatch basis, and apply them to Street 
Light assets. Once enabled, it can work in conjunction with RAMM Asset 
Valuation (see "Asset Valuation in RAMM Street Lights" on page 134) or with the 
Rating Reports (see "Rating Report" on page 232) available within RAMM Street 
Lights. 

Before you set up rating, you need to consider what you want to rate and what you 
are looking for.  For example you may want to rate the condition of the Light, and 
you would define 1 as Excellent but 5 as Very Poor (see below). Another good 
example would be a rating category specifically for the paint on the Pole. 1 could 
be defined as looks good. 5 would be paint is peeling and needs redoing. The system is 
designed with flexibility in mind. 

NOTE: The rating results go against the Pole, so remember that if you decide to 
rate the Light and there is more than one Light on the Pole the rating 
value entered is reflective of all the Lights on the Pole. 

Next, rating needs to be enabled in RAMM Street Lights Options. From the main 
RAMM Street Lights window select Actions > Options, and tick Rating on the  Database 
tab (see "Database Options" on page 166). 

You can now enter Rating Categories and related values. 

4 Entering Rating Categories, Defaults and Values 

TIP: While you're setting up rating categories, leave the Category in use option 
unticked. It's better to do that once everything is set up. Remember that 
each rating category has to be individually selected to enable it. 

1 Select Maintenance > Rating Categories to enter and maintain rating categories. 

2 Enter a description of the category in the Rating Category field. Save  each 
category. 
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3 On the Values tab, enter a Rating Value (for example E, G, P  or  1, 2, 3, 4, 5, or 
any rating scale of your choice) and corresponding Description. Each Rating 
Category can have as many rating values as you wish. 

 

4 You may now wish to set up default replacement rating values for the 
categories so that a rating value is automatically generated for a replaced item. 
This is done on the Defaults tab and is optional, but advisable (RAMM Street 
Lights will remind you if you attempt to close the screen without entering this 
information). 
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For example, if you are replacing a Light then you can reasonably expect the 
condition of the new asset to be Excellent. If you set it up as in the example 
above, the rating value will be automatically entered when any Light on your 
network is replaced, saving you the trouble of remembering to manually key it 
in. 

NOTE: If you wish to enter a default replacement rating value you need to 
first untick Not Applicable for the individual asset as above. You can 
then select a default replacement rating value from the rating values 
you have entered earlier, which will now be available from the drop-
down list. 
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Rating on Dispatches 
The rating categories you have entered will print at the bottom of the Dispatch 
(see "Printing Dispatches" on page 71), allowing the crewman handling that 
Dispatch to tick the relevant rating values. 
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Rating in the Street Lights window 
A Rating tab will also become available in the Street Lights detail window (see 
"Rating in RAMM Street Lights" on page 133) so that you can enter the rating 
information that comes back to you from the Dispatch form. 

 

This information is now available for the various Rating Analyses and reports you 
can generate - see the Rating Analysis Report (on page 230) and our example based 
on the criteria entered above. 
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Optional Grouping 
This window allows you to set up the contract non-specific groups that will become 
available in the Claims Lines Detail window (see "Claim Lines" on page 79) and 
the the Dispatch Entry window (on page 84). To maintain contract specific groups, 
see Contract Groups (on page 58). 

Optional Claim Group 
Select Maintenance > Optional Grouping > Claims from the main RAMM Street Lights 
window to configure this group. 

You would typically use this Claim Group for a wide range of Claims not confined 
to a single contract. 

You can change the name of the Group to something more meaningful by 
selecting Actions > Modify Group Name and entering a new name. RAMM Street Lights 
will show the modified name in the Maintenance menu. In the example below we 
have renamed the group to Account Group. 

 

Enter each Claim group Description. Tick the groups you want Active, Save  and 
close the window. 

The Claim groups you have entered will now be available in the Claim Lines 
Detail window (you may need to use the Detail window button on the Claim Lines 
window toolbar to make the detail window visible if it isn't). 
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Optional Dispatch Group 
As with the Claim Group above, this window allows you to set up the contract non-
specific Dispatch Group that will become available in the Dispatch Entry window. 

Select Maintenance > Optional Grouping > Dispatches from the main RAMM Street Lights 
window to configure this group. 

You would typically use this Dispatch Group for Dispatches not confined to a 
single contract. 

Select Actions > Modify Group Name to enter a new name. In the example below we have 
renamed Group 2 to Regular Dispatch Groups. 

 

Enter a name for each Dispatch Group in the Description field.each record. Select the 
groups you want to be Active, Save  and close the window when you are done. 
They will now become available in the Dispatch Entry window. 
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Costs 
The RAMM Street Lights Maintenance system allows you to set up Maintenance 
Cost groups, activities and faults that can later be linked with Claims and later 
exported to RAMM for analysis by the Network Owner. These groups are 
selected from drop-down lists and linked to individual Schedule Items (on page 
61). 

To set up the items in these cost groups and categories, select Maintenance > Costs > 
[Lookup] from the RAMM Street Lights main window. We've described the 
submenus for this menu below. 

Activity 
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Cost Group 

 

Failure 
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Fault 

 

4 To Enter Cost Items 

1 In the main RAMM Street Lights window, select Maintenance > Costs > [Lookup] as 
appropriate. 

2 Click  on the window toolbar to begin a new entry. 

3 Enter the information in the relevant fields or select them from the drop-
down lists. 

Some windows have Detail panels, in which you can click the  button to 
enter more details. 

4 Save  frequently while entering the data, and before you close the window. 

5 Close the window when you are done. 
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Event Codes 
Event codes are used for classifying events in emails sent from within RAMM 
Street Lights, between the Network Owner and the Contractor, and typically will 
be supplied by the Network Owner. You can view them in the Dispatch Entry 
window (see "Progress" on page 88). 

To maintain event codes, select Maintenance > Dispatch Definitions > Event Codes from the 
main RAMM Street Lights window menu. Enter a Code and Description for each of 
them, Save  and close the window when you are done. 
 

Lux Survey 
RAMM Street Lights now has the capability of storing Lux Survey data. 

This is essentially a measure of whether the level of illumination for a carriageway 
meets predefined Lighting Category criteria. 

The database supplied to you should include a number of default Lighting 
Categories for pedestrian areas. If not, you will need to set them up manually- see 
Lighting Categories (on page 198). You can set up new categories as well. 

Each carriageway section can be linked to a Lighting Category. You can also 
change Lighting Categories from the Carriageway window in RAMM Street 
Lights. See Carriageway (on page 199). 

Setting Up the Lux Survey Header 
If you don't have a Lux Survey supplied with your database, you will need to set up 
the header and import the Lux Survey data from Maintenance > Lux Survey > Survey 
Header. Once you've set up the survey header, the survey data can be imported 
using the File > Import option. 

Contact us (see "Contacting CJN Technologies Ltd" on page 23) for more 
information. 
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Lighting Categories 
The Lighting Category values are used with the latest Lux Survey values in 
determining whether the respective carriageway section meets the lighting 
standards of the category assigned to it. 

Each section of road should meet a certain standard of lighting. This standard is 
based on three criteria: 

§ Type of road (hierarchy). 

§ Level of pedestrian traffic. 

§ Industrial makeup of the area. 

 

Category Lux range - 
Minimum and Maximum 
average values 

Minimum 
spot Lux 

Pedestrian 1 7.0 to 20 2.00 

Pedestrian 2 3.5 to 7.0 0.70 

Pedestrian 3 1.75 to 3.0 0.30 

Pedestrian 4 0.85 to 1.4 1.40 

Pedestrian 5 0.5 to 0.7 0.07 

 

These values are reflected in the Lighting Categories. 

Select Maintenance > Lux Survey > Lighting Category to configure them. 

The values in the table above correspond to the Min Avg LUX and Max Avg LUX fields in 
the Lighting Category Maintenance screen below, and represent a range. The Min 
Spot LUX reading is an absolute value and not an average. 
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Once the Lighting Categories are configured, you can apply them to individual 
carriageway sections in the Maintenance > Carriageway window below. 
 

Carriageway 
This window shows basic carriageway details, and allows you to attach or change 
the Lighting Category of any carriageway. 

This information will then be compared with the data from the Lux Survey (on 
page 197). 

Select Maintenance > Carriageway from the main RAMM Street Lights window to view 
Lighting Category settings for each carriageway section, and adjust them if 
necessary. 

NOTE: The Carriageway window takes a minute or two to appear, as it loads 
every road in your database. Please be patient. 

 

Select a Lighting Category from the drop-down list in the Lighting Category field. 

You can then configure and generate the Lighting Category Performance Report 
(on page 228) to show lighting performance by carriageway. You can also use this 
report to find those carriageways that have not been assigned a Lighting Category. 

If your database is an installed version (on a standalone computer) any changes to 
this column in the carriageway table are sent back as part of the Data Transfer (on 
page 204) process.  You won't be able to maintain any other values in Carriageway 
as your database is not the master version. 
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Default Values 
This Maintenance window sets the defaults for a number of tables and related 
columns in RAMM Street Lights. Select Maintenance > Default Values to launch it. 

This is useful when completing the various fields in the Claim Line, Dispatch 
Entry, Patrol, Power Supply Point and Street Light asset windows. 

Below are the tables that are available. 

 

For example, you can choose to set the defaults for new Dispatches in a particular 
contract to have a Call Type of Routine Patrol. You would set up the values for the 
Dispatch Entry table and related Call Type column as follows. 

 

Save  and close the window when done.~a 
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Organisation 
All organisations in RAMM Street Lights are now set up in a single maintenance 
window. Select Maintenance > Organisation from the main RAMM Street Lights 
window to launch it. 

 

These organisations are then made available for drop-down lists in the fields of the 
various windows in which they are required- for example, when setting up Staff 
Permissions. 
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This section describes how to create, maintain and transfer databases. 

NOTE: The options below refer to databases that are being accessed from 
installed versions of RAMM Street Lights. Data Transfer is not 
applicable if you're using a live database on the RAMM Hosting service 
(on page 299), since your database is being maintained and backed up by 
CJN Technologies. 

IN  THIS  CHAPTER 
Data Transfer.............................................................................204 
Data Transfer for Councils .......................................................205 
Data Transfer for Consultants ..................................................207 
Data Transfer for Contractors...................................................209 
Contract Details - Load Dates...................................................212 

 
 

Working with Databases 
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Data Transfer 
Data Transfer in RAMM Street Lights is essential to synchronise the Network 
Owner / Council database and the Consultant /Contractor database so that they 
hold the same information. 

Select Actions > Data Transfer from the main RAMM Street Lights window to access 
these options. 

The Data Transfer screen is specific to the type of user. The options you see will 
depend on whether you are a Council, Contractor or a Consultant. 

Contractors and Consultants may share data with a Council (and vice versa) by 
transferring copies of the current database. 

Overview 
At the beginning of every contract, the Network Owner / Council has the 
responsibility of unloading the Street Light data into an .slm file for transferring 
either to the Consultant or to the Contractor. (If the Council is dealing with the 
Consultant, the Consultant has the responsibility of unloading the data once again 
for the Contractor). 

At the end of every contract, the organisation maintaining the Street Light data will 
always unload it into a .slm file to be sent back to the source. If this is a Contractor 
working with a Consultant, the Contractor's updated .slm file needs to be loaded 
into both the Consultant's database as well as the Council's so that all copies of the 
Street Light network are up to date. 

CAUTION: Only one organisation may maintain the data at any time; either the 
Network Owner, a Consultant or a Contractor, and only a single 
RAMM Street Lights maintenance contract may be awarded, rather 
than having two Contractors maintaining half the data each. While the 
RAMM Street Lights data is being maintained by a Consultant or 
Contractor, no changes should be made to the data stored at the 
Network Owner end. 

If the Network Owner maintains their own network and database, Data Transfer 
is not necessary. 
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Data Transfer for Councils 
Select Actions > Data Transfer from the main RAMM Street Lights window. 

NOTE: These Data Transfer options are for Network Owners / Councils only. 
Remember that only one organisation should maintain the Street Light 
data (either the Council or the Contractor or the Consultant), and this data 
should be transferred to all other copies of the database at regular 
intervals. 

 

4 To Unload Data to Consultant/Contractor 

This should be done at the beginning of every contract. 

NOTE: This option will be unavailable if a contract has already been unloaded 
and not completed. 

1 Select Unload data for new contract on the Consultant or Contractor tab as appropriate. 

2 Click the browse button , set the directory path and name of the file to be 
produced, and click OK. 

3 This will bring up the Unload dialog box. Here the contract to unload should be 
selected, and any notes to be sent to the Consultant/Contractor can be 
included. 

4 Clicking OK here begins the unload process. 

5 When the unload is complete, close the window. 

6 You can now send the .slm file to the Consultant or Contractor by email or 
disk. 
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4 To Load Data from Consultant/Contractor 

At regular intervals and at the end of every contract, the database must be loaded 
back into your copy. For the steps below, we assume you have received the .slm 
file containing the database changes from the Consultant/Contractor. 

1 Select Actions > Data Transfer from the main RAMM Street Lights window menu. 

2 Select Load data from Consultant on the Consultant tab or Load data from Contractor on the 
Contractor tab as appropriate. 

3 Click the browse button , set the directory path and name of the .slm file to 
load the data from, and click OK. 

4 After the file is uncompressed, the Load dialog box will be brought up 
displaying a description of the file to be loaded, the date it was unloaded, by 
whom, the contract ID, and any notes written by the person who unloaded it. 
If these details are correct then click OK to proceed with the load process, 
otherwise click Cancel. 

5 While the load is proceeding, if RAMM Street Lights detects that changes 
have occurred to any of the core tables since this contract was started, these 
will be displayed in a dialog box. You may choose Cancel to abort the load and 
investigate the changes further, or OK to continue loading and deal with 
problems later. 

6 When the load is complete, close the window. 

7 When you next start RAMM Street Lights, your database will reflect the 
loaded changes. 
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Data Transfer for Consultants 
Select Actions > Data Transfer from the main RAMM Street Lights window menu. 

NOTE: These Data Transfer options are for Consultants only. Remember that 
only one organisation should maintain the Street Light data (either the 
Council or the Contractor or the Consultant), and this data should be 
transferred to all other copies of the database at regular intervals. 

At the beginning of every contract, the Street Light data must be transferred from 
the Council and to the Contractor. At the end of the contract and at regular 
intervals, the Street Light data must be transferred back from the Contractor and to 
the Council. This will ensure that all three copies of the database are up to date. 

 

4 To Unload Data to Council or to Contractor 

1 Select the appropriate tab and action for the Data Transfer you wish to 
perform. 

2 Click the browse button , set the directory path and name of the file to be 
produced, and click OK. 

3 This will bring up the Unload dialog box. Here the contract to unload should be 
selected, and any notes to be sent to the Council or Contractor can be 
included. 

4 Clicking OK here begins the unload process. 

5 When the unload is complete, close the window. 

6 You can now send the .slm file to the Council or the Contractor by email or 
disk. 
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4 To Load Data from Council or from Contractor 

For the steps below, we assume you have received the .slm file containing the 
database changes from the Council or the Contractor. 

1 Select Actions > Data Transfer from the main RAMM Street Lights window menu. 

2 Select the appropriate tab and action for the Data Transfer you wish to 
perform. 

3 Click the browse button , set the directory path and name of the .slm file to 
load the data from, and click OK. 

4 After the file is uncompressed, the Load dialog box will be brought up 
displaying a description of the file to be loaded, the date it was unloaded, by 
whom, the contract ID, and any notes written by the person who unloaded it. 
If these details are correct click OK to proceed with the load process, otherwise 
click Cancel. 

5 While the load is proceeding, if RAMM Street Lights detects that changes 
have occurred to any of the core tables since this contract was started, these 
will be displayed in a dialog box. You may choose Cancel to abort the load and 
investigate the changes further, or OK to continue loading and deal with 
problems later. 

6 When the load is complete, close the window. 

When you next start RAMM Street Lights, your database will reflect the loaded 
changes. 
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Data Transfer for Contractors 
Select Actions > Data Transfer from the main RAMM Street Lights window menu. 

NOTE: These Data Transfer options are for Contractors only. Remember that 
only one organisation should maintain the Street Light data (either the 
Council or the Contractor or the Consultant), and this data should be 
transferred to all other copies of the database at regular intervals. 

 
 

Load Data from Council 
At the beginning of every contract, the Street Light network data must be loaded 
from the Council or the Consultant. 

4 To Load Data from Council (or from Consultant) 

For the steps below, we assume you have received the .slm file containing the 
database. If you haven't, see Installing RAMM Street Lights (on page 50). 

1 In the Data Transfer window select Load data from Council. Use this option for a 
.slm file received from the Consultant as well. 

2 Click the browse button , set the directory path and name of the .slm file to 
load the data from, and click OK. 

3 After the file is uncompressed, the Load dialog box will be brought up 
displaying a description of the file to be loaded, the date it was unloaded, by 
whom, the contract ID, and any notes written by the person who unloaded it. 
If these details are correct then click OK to proceed with the load process, 
otherwise click Cancel. 

4 While the load is proceeding, if RAMM Street Lights detects that changes 
have occurred to any of the core tables since this contract was started, these 
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will be displayed in a dialog box. You may choose Cancel to abort the load and 
investigate the changes further, or OK to continue loading and deal with 
problems later. 

5 When the load is complete, close the window. 

When you next start RAMM Street Lights, your database will reflect the loaded 
changes. 
 

Unload Changes for Council 
CAUTION: This option is exclusively for Contractors using Informix databases 

that support triggers and procedures. If you're using an MS Access 
database you should not use this option. 

As you work with your Informix database, its log files will be updated for the data 
that has been changed. These logs are used to unload only the data that has 
changed, and not the entire database. Once the unload is complete, the logs will be 
cleared. 

When the .slm file is sent to the Council, RAMM Street Lights checks the file to 
ensure that the previous file was loaded before loading the new changes. If it 
hasn't, RAMM Street Lights will generate an error message. 

NOTE: When using this option it's important that all files are loaded in the 
correct sequence, and RAMM Street Lights will compare dates and 
changes to ensure this. 

4 To Unload Changes for Council 

For the steps below, we assume you are using Informix and you have made some 
changes to your database that need to be synchronised with the Council database. 

1 In the Data Transfer window select Unload changes for Council. 

2 Click the browse button , set the directory path and name of the .slm file to 
create, and click OK. 

3 The Unload dialog box will open, identifying the Contract and other 
information to be unloaded. Click OK to proceed or Cancel to abort. 

4 When the unload is complete, close the window. 

5 You can now send the .slm file you have created to the Council by disk or 
email. 
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Unload All Data for Council 
This option unloads all data from the Street Light tables and all the information 
for the selected contract. Use this option if you're running RAMM Street Lights 
on a stand-alone computer. 

At the Council end, loading a file generated from this process will result in all 
Street Light data being deleted from the Council machine and the new data and 
lookups being loaded. If the Council is using Asset Valuation for the Street Light 
data, RAMM Street Lights will try to repopulate this information where the assets 
have not changed. 

NOTE: This option will be unavailable if a contract has already been unloaded 
and not completed. 

4 To Unload All Data for Council 

1 In the Data Transfer window select Unload all data for Council. 

2 Click the browse button , set the directory path and name of the file to be 
produced, and click OK. 

3 This will bring up the Unload dialog box. Here the contract to unload should be 
selected, and any notes to be sent to the Council can be included. 

4 Clicking OK here begins the unload process. 

5 When the unload is complete, close the window. 

6 You can now send the .slm file to the Council by email or disk. 
 

Unload Data for Council at End of Contract 
This option unloads all the data as described above, and performs the additional 
task of setting the contract status to Closed in the current database. Once this is 
done, the contract will no longer be available to you. 

The contract will be flagged as Closed at the Council end as well when the data is 
loaded into the Council database. 

4 To Unload Data for Council at End of Contract 

1 In the Data Transfer window select Unload all data for Council at End of Contract. 

2 Click the browse button , set the directory path and name of the file to be 
produced, and click OK. 
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3 This will bring up the Unload dialog box. Here the contract to unload should be 
selected, and any notes to be sent to the Council can be included. 

4 Clicking OK here begins the unload process. 

5 When the unload is complete, close the window. 

6 You can now send the .slm file to the Council by email or disk. 
 

Contract Details - Load Dates 
Load dates are shown in the Contract Details window (Maintenance > Contract Details). 
Any Data Transfer action will cause one of these three fields to be updated. 

§ Initial load. The date on which the initial unload from the Council was done. 

§ Last Update. The date of the most recent Data Transfer back to the Council. 

§ Final Load. The date on which all of the data was returned to the Council. 

Occasionally the dates get out of step, and we have set up options to help correct 
this. 

Council Options 
If you are a Network Owner / Council, the Actions menu gives you an option to 
clear the initial load date and allow you to Unload Data again, for the purpose of re-
sending it to the Consultant or Contractor. 
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You would only use this if for some reason the Consultant or Contractor had not 
received the data which you had sent previously, or could not load it successfully. 

CAUTION: This feature should never be used if the contract is already in use by 
the Consultant or Contractor. In such a case, a new contract should 
be started, unloaded and sent to the Consultant or Contractor, once 
the current contract has ended and been loaded back at the Network 
Owner's end. 

The option to clear the final load date is available to you if there is a need to reload 
the data sent from a Contractor or Consultant. This would be used only if there 
was a problem with the loaded data and you needed to load it again. 
     

Contractor Options 
The option to Set Initial Load date is only available to the Contractor. 

 

This would be needed in a case where the Contractor had loaded the data from the 
Council, but the initial load date had not been set. Unless the initial load date is 
set, the Contractor will not be allowed to unload his (changed) data for sending 
back to the Council. 

This may occur if the database has been created from a type of file other than a 
.slm - for example, a .cjx file. 
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RAMM Street Lights has the ability to generate a number of reports to help with 
your decision making. This section tells you about these reports. 

Some reports are presented in the CJN Decision Cube format (see "Decision 
Cube" on page 217), and some reports are generated directly from the RAMM 
Street Lights windows. 

You will generally always have the ability to preview the report before you print it, 
and have the option to save it in other formats (Microsoft Excel Spreadsheets, 
Quick Reports). 

IN  THIS  CHAPTER 
Viewing and Saving Previews and Reports ...............................215 
Decision Cube...........................................................................217 
Asset Management ....................................................................227 
Asset Replacement.....................................................................235 
Contract Management ..............................................................236 
Auditing.....................................................................................240 
Road Names ..............................................................................243 
Year To Date (YTD) Report .....................................................243 

 
 

Viewing and Saving Previews and Reports 
RAMM Street Lights facilitates the saving of previews as separate files in a number 
of different formats. 

This is useful for documentation, or if you need to transfer the report to another 
location. Once you've saved the file, you can send it anywhere by disk or email. 

4 To Save a Preview as a File 

1 In any preview window in RAMM Street Lights, click the Save button. 

Reporting 
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2 RAMM Street Lights will bring up a window that allows you to set the name 
and the location of the saved file. 

 

Click the drop-down arrow for the Save As Type field if you wish to choose  a 
different file type. 

 

Click Save to save your file at the chosen location. 

3 Click Close to exit the preview window when you are done. 

4 To View a Saved Preview File 

1 Click Reporting > Open Preview file from the main RAMM Street Lights window. 

-OR- 

If you're already in a preview window, click the Open button on the toolbar. 

2 You'll see an Open File window similar to the window above. Navigate to the 
location of your file and click Open to open it. 

3 Click Close to exit the preview window when you are done. 
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Decision Cube 
The Decision Cube is a powerful analysis tool for looking at your data in a 
number of ways. It can be launched from any toolbar that contains the Decision Cube 
button . 

 

It is essentially a context sensitive pivot table that will populate the cube with 
available data, and present you with a number of grid headers  that you can 
click and drag with your mouse to change the cube views. 

The grid header can be filtered to further refine the information they show and 
save the settings. 

The results of your analysis can be printed, or saved in the following formats: 

§ Microsoft Excel spreadsheet format. 

§ CJN Decision Cube format. 
 

Decision Cube Toolbar 
In addition to the standard RAMM Street Lights toolbar buttons, the Decision 
Cube has some unique controls. 

§  Percent view across rows. Use this button to display percentages horizontally 
instead of numeric values (see below). 
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§  Percent view across columns. This control displays percentages vertically. 

NOTE: If you have switched totals on, the totals of the cells in the direction 
opposite to that which you have selected should be ignored. For 
example, if you have selected Percent view across rows, the correct totals for 
those rows will show 100%. All other totals should be ignored. 

§  Numeric View. This is the default view, and will show absolute (numeric) 
values. 

§  Show Totals. This will add totals to both the horizontal and vertical series. 

§  Graph. Generates a graph of the Cube information. You can choose the 
design and colours of the graph as well. 

§  Graph selection. Will generate a graph for the current selection - you will need 
to select the cell/s you wish to view in the graph before using this tool. 

§  Filter. You can use this tool to refine your Cube view and save it so that it is 
applied each time you call up the relevant Cube. 

The View Menu of the Decision Cube window also has controls for showing you 
other data items. These controls will be specific to the cube you are viewing. 
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Sorting Grid Headers Horizontally or Vertically 
The advantage of the Decision Cube is that you can view your data in different 
ways. This is controlled by where you place the Header you want to sort by - 
either horizontally, or vertically. 

4 To Sort Grid Headers Horizontally 

Drag the Grid Header you require (for example, Replace Year) downwards and 
release it when you see a horizontal green line. 

 

The result of adding that particular grid header will be arranged in horizontal 
columns as follows: 
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If this is not the result you expected, you can simply drag the Replace Year grid 
header back to its original position. 
     

4 To Sort Grid Headers Vertically 

Drag the Replace Year grid header downwards and release it when you see a vertical 
green line. 

 

The cube will arrange the same results in vertical columns instead. 
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Decision Cube Filter 
A filter is available within the Decision Cube to refine the data returned by the 
Cube and ensure that your Cube isn't cluttered with unnecessary information. 

Once you define your filter criteria, the settings are saved into the system so that 
the relevant Cube will always apply that criteria automatically. 

NOTE: When a filter is applied to a Decision Cube View, the window title bar 
will contain the word Filtered. To clear the filter, see below. 

4 Applying a Filter to a Cube View 

You have a choice of three alternative methods of applying a filter to a Cube View. 

1 Click the Filter button drop-down list  on the Decision Cube toolbar and 
click the relevant grid header you wish to define a filter for: 
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This will bring up a window where you can select and deselect filter fields for 
the chosen grid header as required. You can also use the Tick All  and Tick None 

 buttons: 

 

and click Apply to view the results of your actions 

-OR- 

2 Right-click any Grid Header , 

left-click the Filter... button that pops up: 
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Select or deselect the filter fields as required, and click Apply to view the results 
of your actions 

-OR- 

3 Click the drop-down arrow at the right hand edge of each grid header , 

select or deselect the filter fields as required from the list that pops up: 

 

and click anywhere else inside the Cube window to view the results of your 
actions. 

4 Returning a Cube View to its Original (Unfiltered) State 

§ Click View > Default Layout from the Decision Cube Menu bar. 
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Example - Analysing Lamp Replacements with the Decision 
Cube 

4 To Analyse Lamp Replacements with the Decision Cube 

1 Select Reporting > Asset Replacement > Lamps from the RAMM Street Lights main 
window. 

 

The cube currently shows Lamp Quantity by Replace Reason. For our example, we 
will add the Replace Year grid header to sort the Lamp replacements by Year and 
Reason. 

TIP: Select View from the menu bar to choose how the Cube values are 
reported. The defaults are Show Totals and Quantity. For this example, we 
wish to reflect the values in percentages, so add As Percent in Column, and 
the values will change to percentages. 

2 Since we don't need to analyse all Lamp replacements but just the ones in 
2002 and 2003, we can remove other years from our Cube view with the filter. 
You can do this three ways: 

§ Click the drop-down arrow  at the right hand edge of each grid header to 
bring up a list of filter fields (in this case, replacement years) 

§ Use the filter from either the Menu bar or 
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§ Use the right-click context menu to bring up the filter on the grid header. 
For more information, see Decision Cube Filter (on page 221). 

 

3 Now drag the Replace Year grid header down to the existing grid header, Replace 
Reason. This can be done two ways, and each way will display the same 
information horizontally or vertically (see "Sorting Grid Headers Horizontally 
or Vertically" on page 219). 

4 You have a number of options to record the results. 

§ You can save the cube as a Cube file or an Excel spreadsheet by using the Save 
As option on the File menu of the decision cube window. 

§ You can print the cube. 

§ You can generate a standard graph or chart from the data displayed. Click 
the Graph button  on the toolbar, or 

§ Select a specific number of cells and then click Graph Selection button  to 
build a chart or graph for just the selected cells. 
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For the graph below, we have placed the Replace Year grid header 
horizontally, and then generated pie graphs for the two years. 

NOTE: The default graph design is a 3D bar graph. You can change the type 
of graph, colour schemes and legend displays from the graph toolbar. 
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Asset Management 
The reports available from the Asset Management menu show you information 
relevant to the utilisation, location and performance of your assets. 
 

Pole, Bracket and Light Reports 
Select Reporting > Asset Management > [Pole Quantities / Bracket / Light]. 

 

These reports are all in decision cube format, and will show you the selected asset 
by asset owner / asset type and quantity by default. You can add other grid headers 
to add more details to the report. For more information on working with cubes, 
see Decision Cube (on page 217). 
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Lighting Category Performance Report 
Select Reporting > Asset Management > Lighting Category Performance to enter options for this 
report. 

 

Lighting Categories relate to the Lux Survey (on page 197). This report measures 
the effectiveness of the Lighting Categories linked to roads or carriageways. Make 
your selections on the dialog box above and click Preview or Print to generate the 
report. 
 

Light Spacing Report 
The Light Spacing Report is generated by selecting Reporting > Asset Management > Light 
Spacing Report. 
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This dialog box gives you some options on the report contents. 

You can choose to show all Poles within a selected Area and/or Sub-Area, and 
combine that with a minimum and maximum tolerance in metres. 

You can also select whether to include duplicate Poles. 

Make your selections and click Preview or Print to generate the report. 
 

Wattage Analysis Report 
Wattage Analysis - Reporting > Asset Management > Wattage Analysis  

 

This cube shows you a Wattage Analysis and Cost Report by Street Light owner. 
You can add other grid headers to add more details to the report. For more 
information on working with cubes, see Decision Cube (on page 217). 
 

Wattage Report 
Select Reporting > Asset Management > Wattage Report to generate a standard report on 
wattage for different Gear and Light configurations on your network. 
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This dialog box allows you to group Gear and Light wattage totals either by Make 
or by owner. 

Make your selections and click Preview or Print to generate the report. 
 

Rating Analysis Report 
The Rating Analysis report is generated by selecting Reporting > Asset Management > 
Rating Analysis. 

Click the button for the asset you wish to run the rating analysis for- Poles, Brackets 
or Lights.  

 

There may be delay while RAMM Street Lights builds the necessary tables - please 
be patient. 

It will then show you a decision cube for the asset. By default the cube will first 
show Quantity, but you can drag and drop in a grid header of your choice to 
generate the Rating Analysis you wish to see. 

For more information on working with cubes, see Decision Cube (on page 217). 
 

Rating Analysis Report (Example) 

4 How to Generate a Rating Analysis Report 

In this example, we look at a simple analysis of assets rated earlier. See Rating 
Categories (on page 187) for more information. 

1 Select Reporting > Asset Management > Rating Analysis to set up the cube. 

2 After the temporary tables are built, RAMM Street Lights will ask you to 
choose an asset (see above). Click Lights. 

3 The cube will initially show Quantity. Drag and drop the following Grid 
Headers into the cube respectively: 

§ Road Name 

§ Lantern 
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If you placed the headers to show the result in vertical columns, it should look 
like this: 

 

4 You can add more grid headers to your analysis, for example Light Make and Light 
Model. You may also need to use the scroll bar and resize the window to see the 
results as applied to a particular street. 
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5 You can now print the report or close the window to exit Rating Analysis. 
 

Rating Report 
Select Reporting > Asset Management > Rating Report to generate this report. 

 

You can set a number of options for this report- a date range for rated assets, or 
whether the report shows old ratings or unrated assets. 

 You can also Filter the assets (see "Filters" on page 139) and include replaced Poles 
in the report. 

Make your selections and click Preview or Print to generate the report. 
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Electricity and Maintenance Cost Report 
Selecting Reporting > Electricity Maintenance generates a report of Electricity and 
Maintenance charges for the previous month. 

The costs are based on the Maintenance Charge per Lamp Model, a fixed daily 
electricity charge and a variable electricity charge per KWh (kilowatt hour).  

 

If you have ticked Power Company in Database Options (on page 166), and set up at 
least one Power Company (on page 184), you can select to apply the charges 
which have been entered for that power company to the report by choosing the 
relevant power company name from the drop-down list below the Use Power Company 
Values tick option. 

Alternatively, you can deselect the Use Power Company Values option, and use the 
default values (if any), which were entered as Electricity Charges (on page 167). 
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You can also untick each of the default values in the Check for Default Value section 
of the window, and type in your own values in the corresponding entry boxes on 
the right. 

 

Click Close when you are done. 
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Latest Pole Numbers 
When installing new assets in RAMM Street Lights you sometimes require the 
next available Pole number. 

This report generates a list of all Pole numbers in your database, from which 
you're able to elicit the latest. 

Select Reporting > Asset Management > Latest Pole Number Report from the main RAMM 
Street Lights window to generate this report. 

 
 

Asset Replacement 
Select Reporting > Asset Replacement to generate a number of decision cube reports 
pertaining to asset replacement. 

The steps to generate the various cube reports for Poles, Brackets, Lights, Gear and 
Lamps are the same. 

Since we have looked at generating a Lamp Replacements decision cube report 
earlier, see Example - Analysing Lamp Replacements with the Decision Cube (on 
page 224). 
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Warranty Failure Report 
The Warranty Failure Report enables you to compare expected against actual asset 
performance. 

Select Reporting > Asset Replacement > Warranty Failure Report. 

 

Select a date range and whether you would like a Full Report and/or Summary. 

Click Preview or Print to generate the report. 
 

Contract Management 
The Reporting > Contract Management menu generates a number of reports that deal with 
the Contract, Claims and Dispatches. 
 

Claim Analysis Report 
The Claim Analysis Report is a general report that analyses all Claims relevant to 
your network. 

For specific reports about individual Claims, see Claim Reports (on page 161). 
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Select Reporting > Claim Analysis Report to bring up a decision cube that summarises 
Claims on all contract items by Claim Year. 

 

The Claim Amount is displayed by default, but you can add more columns from 
the View menu. 

 

For more information on working with cubes, see Decision Cube (on page 217). 
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Dispatch Summary Report 
The Dispatch Summary Report gives a summary of the Dispatches for the entered 
period. Dispatches are grouped on entry type and status. This report is contract 
dependent. 

Select Reporting > Contract Management > Dispatch Summary from the main RAMM Street 
Lights window menu to generate the Dispatch Summary Report. 

You'll first need to choose a contract and a date range: 

 

Click Preview or Print to view the report, or Close to return to the previous window. 
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Dispatch Detail Report 
See Print Dispatches window (see "Dispatch Printing Options" on page 97). 
 

Dispatch Analysis Report 
This report generates an analysis of Dispatches by Call Status and Call Type by 
default. 

Select Reporting > Contract Management > Dispatch Analysis. 

 

Unlike the decision cube in the Dispatch Entry window, which analyses only the 
Dispatches in the list, this report covers all Call Status categories and Call Types 
for the active contract. 

Since the report is in decision cube format, you can add grid headers for a more 
extensive report. 

For more information on working with cubes, see Decision Cube (on page 217). 
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Dispatch Progress Report 
The Dispatch Progress Report will print a progress report for a specific Dispatch. 

Select Reporting > Contract Management > Dispatch Progress. 

RAMM Street Lights will ask you to select a Dispatch to query. 

 

Select the contract and enter the Dispatch number. 

Click Preview or Print to view the report, or Close to return to the previous window. 
 

Auditing 
RAMM Street Lights has the ability to generate a number of audit reports. 
 

Asset Audit Report 
This report shows all changes to assets in the network within a specified period. 

Select Reporting > Auditing > Asset Audit Report to configure and generate the report. 
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The default report type setting is Summary Report. Selecting Detailed Report activates the 
other query options- assets to Include, Action taken in relation to those assets and the 
order in which the results will be displayed (Order results by). 

Click Preview or Print to view the report, or Close to return to the previous window. 
 

Multiple Claims Per Dispatch Report 
Select Reporting > Auditing > Multiple Claims per Dispatch to identify Dispatches within a 
given period linked to multiple Claims. 

 

Select the relevant contract, specify a date range and a minimum Claim number 
and set the order of the results in the report. 

Click Preview or Print to view the report, or Close to return to the previous window. 
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Table Statistics Report 
This report highlights table size changes over a period of time. 

If the table statistics are out of date, RAMM Street Lights will prompt you to 
upgrade the table statistics before generating the report. When the upgrade is 
finished, choose the relevant report options from the dialog box. 

 

Click Preview or Print to view the report, or Close to return to the previous window. 
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Road Names 
This option simply generates a list of all the road names in your database. 

Select Reporting > Road Names from the main RAMM Street Lights window. 
 

Year To Date (YTD) Report 
This report summarises the state of the contract over the current year. 

Select Maintenance > Contract Details from the main RAMM Street Lights window, and 
in the Contract Details screen select Reports > YTD Report from the menu to generate 
it. 

 

Usage over the agreed budget is highlighted in red. 

The Not Yet Claimed column shows work completed but not yet passed to the 
Network Owner for payment. 

This report can be printed or saved in a number of different formats - see Viewing 
and Saving Previews and Reports (on page 215). 
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This section describes the RAMM Mapping function. 

NOTE: To use Mapping you need to purchase the appropriate licences - for 
more information, contact us (see "Contacting CJN Technologies Ltd" 
on page 23). 

IN  THIS  CHAPTER 
Mapping - Overview .................................................................246 
Setting Up and Loading the Map..............................................247 
Map Window.............................................................................248 
Map Window Toolbar...............................................................249 
Adding Assets to the Map..........................................................252 
Changing Map Layer Settings While Adding Items to the Map255 
Working with Mapping .............................................................257 
Changing the Map's Appearance...............................................265 
Map Options Window...............................................................272 
Printing the Map .......................................................................281 
Updating RAMM from the Map, and the Map from RAMM.282 

 
 

Mapping 
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Mapping - Overview 
Mapping is a powerful tool for visualising your data. It facilitates viewing and 
selecting your data in the context of roads, boundaries, geographical features, 
places and properties. 

You can use map tools bring up information on a selected area, measure distances, 
and display the RAMM displacement and offset of a given point. 

Map Details are Synchronised 
The Map window is synchronised with other windows. When you select a feature 
in the map which has a corresponding record in an open Grid or Detail window, 
that record's details will automatically be shown. 

RAMM Applications Using Mapping 
RAMM Mapping is currently available for RAMM, RAMM Street Lights, Signs 
and RAMM Traffic Signals. 
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Setting Up and Loading the Map 
If you're using the RAMM Hosting service, Mapping will be available as soon as 
you log in. If you're using an installed copy of the software the map data will be 
sent to you on CDROM. 

If you're not sure how to install Mapping, contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

4 To Set Up Mapping 

1 Launch Mapping by clicking the Show map  button on the toolbar. If you 
haven't used Mapping before, you'll be asked to select a map. 

 

2 Select your map. 

TIP: Select Automatically show map if you wish Mapping to automatically load 
the map whenever you enter the relevant window. For more 
information, see Saving Layouts and Loading Maps (on page 273). 

3 Click OK to load the map. 

NOTE: You may see a message that the Map Index needs to be recalculated. 
Let this process finish before you start working with Mapping. 
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Map Window 
This is the Map window. Initially you will see only the toolbar and the main Map 
window. 

 

While you're working with the map, the Status Bar at the bottom shows you the 
current scale of the map, location information and a numerical zoom level. 
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Map Window Toolbar 
Here's a "quick reference" briefly describing the toolbar controls. 

Some functions on the toolbar are accompanied by drop-down lists. You can click 
the drop-down arrow  on the right of the respective toolbar button to select 
another tool. The tool will remain selected until you change to another. 

At any stage, click the Help button  or press F1 on your keyboard for context 
sensitive help. 

NOTE: Most controls described below can also be accessed by right-clicking in 
the Map window and then using the pop-up menu to select the function 
you require. In the RAMM main window, Map is also a menu item from 
which you can access all the controls described below. 
 
In RAMM Street Lights, Signs and Traffic Signals, the Map window 
toolbar has an additional button  to quickly reveal the application 
window you launched Mapping from. You can also use ALT+S to 
quickly switch between the Map window and the application window. 

 

Selection Tools 
See Selecting Items on the Map (on page 257). 

 

§  Select. Select one map feature. 

NOTE: All selection tools below will automatically enable Multi-select mode. 

§  Rectangle. Select all road features within a rectangle. 

§  Radius. Select all road features within a radius. 

§  Polygon. Select all road features within a polygon. 

§  Region. Click to select all features within the selected region. 
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Query and Annotation Tools 
See Getting Information from the Map (on page 258). 

 

§  Query Point. Display details of all map items near selected point. 

§  Pick Nearest. Pick the nearest road and display details- for example, RAMM 
Road ID, Displacements, X/Y Coordinates, Offset. 

§  Measure. Measure the distance between two points. 

§  Annotations. Click to add notes to the map. See Making Notes on the Map 
(on page 260). 

 

Zooming, Panning and Rotating Tools 
See Zooming, Panning and Rotating the Map (on page 261). 

§  In. Zoom into map. 

§  Out. Zoom out in the map. 

§  Pan. Pan around the map. 

§  Rotate Left. Rotate the map counterclockwise. 

§  Rotate Right. Rotate the map clockwise. 
 

Map View Configuration Tools 
See Defining and Loading Map Views (on page 262) for a detailed description of 
these tools. To use them, you should already have selected a feature or features on 
the map (see "Selecting Items on the Map" on page 257). 

§  Go to a view. Go to a specified centre point and zoom level. 

§  Go to a road. This button brings up a dialog to help you go directly to a road 
and displacement. 

§  Zoom to selected features. To zoom to any map item/s you have already selected. 
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§  Center on selected features. You'll use this option if you'd like to position the 
item/s you have selected in the centre of the screen. This will not change the 
zoom level. 

§  Show selected features. This is similar to the control above, but is useful when 
you just want to bring things into view and not necessarily centre them in 
your Map window. This view also does not change the zoom level. 

 

Automatic Map View Configuration Tools 
See Automatically Showing Selected Map Items (on page 265). 

 

§  Auto Zoom. Automatically zoom to selection. 

§  Auto Show. Automatically bring current selection into view. 

§  Auto Center. Automatically centre on selection. 
 

Printing and Copying Tools 
§  Print. Brings up the Print Map Options window (see "Printing the Map" on 

page 281). 

§  Copy the Current Map Area to the Clipboard. Copies the currently visible map area to 
the Windows clipboard so that you can paste or save it as a bitmap image. 

 

Map Layer Panel Tools 
Click the Map Layer button  to open the Map Layer panel (on page 266). This has 
the same effect as using the panel sizer (see "Using Collapsible Panels" on page 
29). It displays a legend and a number of controls for Map Layers on a separate 
toolbar. 

§  Import Layer (see "Exporting and Importing Map Layers" on page 269). 

§  Export Layer. 

§  Delete a Layer. 

§  Move Layer Up. 

§  Move Layer Down. 



 

2 5 2  R A M M  S t r e e t  L i g h t s  
 

§  Layer Settings. 
 

Map Options and Tools 
The Map Options window is where you'll go to set the current layout you're 
using, select a map to use with your database or run processes like map validation 
or indexing. Click the Map Options button  on the Map window toolbar to launch 
the window, and select the option you require in the Selection Panel on the left. For 
more information, see Map Options window (on page 272). 
 

Map Title Tool 
§  Click this button to show or hide the title of the map. 

 
 

Adding Assets to the Map 
Once you've loaded a map (see "Setting Up and Loading the Map" on page 247), 
you can add your assets to it. You can also configure Mapping to do this 
automatically. 

4 How to Add Assets to the Map 

1 In RAMM Street Lights, Signs or RAMM Traffic Signals, select Actions > Add to Map 
or click the Add to Map  button on the main window toolbar of the application 
that you are using 

-OR- 

in RAMM, select Actions > Add to Map from either the Grid window or Detail 
window menu. 

NOTE: You can choose Map Poles, Brackets and Lights or Map Poles only. The first 
option will take a minute or two to process, since it involves more 
detail. When the assets are added, the map will show the icon for the 
Pole, with a pop-up description of all Bracket(s) and Light(s) 
attached to the Pole on mouse-over. The second option is faster, and 
on mouse-over will show details for the Pole only.~a 
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2 Choose either Add all items to add all items currently listed in the List panel, or 
Add selected items only if you've selected specific items in the list to load. 

 

NOTE: You can also change the layer name if you wish. Mapping will load 
the name of the asset you are adding to the map by default - in the 
example above, since we are adding Street Lights, it is SLIM. If you 
select a layer name that already exists, you can choose to Clear existing 
items on the layer before loading the current data. 
 
If you wish to change the settings for the layer, such as the icons or 
labels used to represent the Street Lights, see Changing Map Layer 
Settings (on page 270). 

3 Click OK to begin loading the items to the map or Cancel to abort the process. 
You'll see a progress window while this happens. If you're adding many assets, 
this can take some time. 
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4 Mapping will now add the assets to the map and show them to you. If you 
have configured Mapping to automatically zoom to the selected assets (see 
"Automatically Showing Selected Map Items" on page 265), what you select in 
the relevant Grid or Detail window will be synchronised with the Map 
window. 

 

If you click the Show/Hide Map Layer Panel button on the toolbar, you'll also see that 
the legend now shows the layer you just added in the list. See Map Layer 
Panel (on page 266). 

TIP: When adding assets with length to the map, it can sometimes be 
difficult to see them- especially if they are clustered together and use 
the default polygon style. You can change layer settings (see 
"Changing Map Layer Settings" on page 270) for these assets to be 
added as lines, and if necessary add markers to each line ending to 
emphasise the length. 
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Changing Map Layer Settings While Adding Items to the Map 
You can also change Map Layer options while adding items to the map. 

For the procedure below, you will need to have started the process of Adding 
Items to the Map (see "Adding Assets to the Map" on page 252). 

4 To Change the Map Layer Settings While Adding to Map 

1 In the Add to Map dialog box, click the [...] button next to the Settings field. 

 

In the example above, we've defined a filter to bring up all Carriageway 
Surface records on a selected road, so the default layer name comes up as 
Carriageway Surface. 

2 This will take you into the Map settings window. 

 

You can now edit the style objects for the layer. See Changing Map Layer 
settings (on page 270) for more information on the Appearance tab controls and 
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what they do. If the asset you're adding to the map has both area and length, as 
above, you'll see number of style options. Other assets may show you just two 
styles - for example, line and item. Items that are not ticked will be disabled. 

3 You can also select which fields will display on the map labels for the layer you 
are adding. 

 

The fields correspond to the asset. 

4 You can also set some other options on the Other tab. 
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5 To save your settings for future use, click the Save button  at the top of the 
Map Settings window and choose a filename and location for the map settings 
file (.msf). 

6 To apply the settings, click the OK button. You'll return to the Add to Map 
dialog, and you can proceed to add your assets to the map. 

 

Working with Mapping 
This section describes common mapping tasks. 

NOTE: Most controls described below can also be accessed by right-clicking in 
the Map window and then using the pop-up menu to select the function 
you require. 

 

Selecting Items on the Map 
Before you can view an item on the map you need to select it. The selection tools 
allow you to select features and assets in a number of ways. 

If you don't see the item you wish to select, you may need to adjust the Zoom 
level (see "Zooming, Panning and Rotating the Map" on page 261). 

If you can see it but not select it, you may need to check its selection status in the 
Map Layer Panel. See Map Layer Panel (on page 266). 

In RAMM, the selection tools are synchronised with any RAMM windows you 
may have open. If you prefer to select your assets in the Grid or Detail window 
you're working in and have the map show them automatically, see Automatically 
Showing Items on the Map (see "Automatically Showing Selected Map Items" on 
page 265). 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 
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§  Select (select one map feature). Click this control and then click on the Map 
item to select it. Use CTRL + click to add to your selection (to select multiple 
items - the mouse will show a + next to the arrow) and SHIFT + click to 
subtract from your selection (to deselect from multiple selections - the mouse 
will show a - next to the arrow). 

NOTE: All selection tools below will automatically enable Multi-select mode. 

§  Rectangle (select all road features within a rectangle). With this tool selected 
you can click and drag your mouse to select all items within a rectangular area. 

§  Radius (select all road features within a radius). Click and drag to define a 
circular area, and select all items within it. 

§  Polygon (select all road features within a polygon). To select an irregular area. 
Single clicks will extend the selection area. Double-click to end drawing the 
area and select all items within it. 

§  Region. You can click on a large map item and use this tool to select all items 
within that area. This is particularly useful, for example, if you've loaded iwi 
boundaries and wish to find all roads within them. Selecting the iwi region 
will automatically select all roads within it. 

 

Getting Information from the Map 
The query controls on the Map window toolbar help you get information from 
your map that isn't immediately visible. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 
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§  Query Point (display details of all features near selected point). Select this 
control and click anywhere to bring up a window with the details of all road 
features near the selected point. If you click exactly between two item, 
Mapping will bring up information for both. 

 

§  Pick Nearest (pick the nearest road and display details). Select this control and 
click anywhere to bring up details about the nearest road. 

 

§  Measure (measure the distance between two points). After selecting this 
control, click and drag your mouse to draw a line between two points 
anywhere on the map, and get an instant readout of the distance in metres. 
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TIP: While clicking and dragging, your status bar at the bottom right of 
your Map window will run a continuous "live" readout of the 
distance. 

 

Making Notes on the Map 
This useful tool allows you to add notes to your map. 

4 To Add Annotations to the Map 

1 From the Query Tools drop-down menu 

 

click the  Annotations tool to bring up a dialog box with instructions. 

 

2 Either: 

§ Click anywhere to add an annotation on a point on the map, or 

§ Click (where you want to place the note) and drag (to the point you wish 
to describe) to add an annotation with an arrow callout. 
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3 Type your note into the box that appears. The square below your note shows 
you which type of annotation you've selected. 

 

4 Click OK to add your note into the Annotations layer and to the map. You can 
add as many notes as you wish. 

You can also export the annotation layer (see "Exporting and Importing Map 
Layers" on page 269). 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 
 

Zooming, Panning and Rotating the Map 
Use these controls to move around the map area. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 

§  In (zoom into map). Zoom in to enlarge the view, centering the map on 
your mouse cursor. Note that your mouse cursor changes to indicate the tool 
you've selected. To temporarily reverse the zoom direction and zoom out, 
hold down the CTRL button as you click. 
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§  Out (zoom out in the map). Reduce the view by zooming out, centering the 
map on your mouse cursor. To temporarily reverse the zoom direction and 
zoom in, hold down the CTRL button. 

§  Pan (pan around the map). With this tool active, click on any area of the 
map and drag while holding the mouse button down to move the entire map. 

§  Rotate Left (rotate the map counterclockwise). 

§  Rotate Right (rotate the map clockwise). 

CAUTION: Be careful when rotating the map, as you cannot see compass 
points. If you want to return the map rotation to 0 (North = UP), 
use the Go to a view control (see "Defining and Loading Map Views" 
on page 262). 

 

Defining and Loading Map Views 
The Go to a View button  on the Map window toolbar launches a window to define 
specific map views that you can save and load later. The Goto and Close buttons work 
with the settings immediately above them, which set co-ordinates, zoom and rotation. 
You can either enter number values directly into these fields, or go to a view on 
the Map window using the zoom and selection tools and then save the view here 
with a name of your choice. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 

4 How to Define and Load Map Views 

1 Click the Go to a view button . 
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The dialog show you the Current view displayed on your map as well as any 
other views you may have defined earlier. 

2 You can now configure and define the view you require. 

You can enter X and Y co-ordinates, a Zoom level, or a Rotation number in 
degrees. Click Goto to go to the specified view. 

Once you're satisfied with the view you've generated, you can save the view 
with a name of your choice. 

3 Click the Save button  if the view has not been saved before, or the Save As  
button if you wish to save an existing view under another name. 

 

Mapping will duplicate the view as Copy of Current. You can now give the view a 
unique name of your choice. 

You can rename any view you have defined by right-clicking the view and 
choosing the Rename option, or pressing F2 on the keyboard. 

 

4 Press Enter on your keyboard or click anywhere inside the view name window 
to save the view. 
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5 Click Goto button to load the selected view, or Close to return to the Map 
window. 

4 Go to a Road 

This control helps you go directly to a road and specified displacement. 

1 Click the Go to a road button  on the Map window toolbar. 

2 In the Road field, either: 

Choose the road you wish to view from the drop-down list 

-OR- 

Type the road name 

-OR- 

Type the Road ID. 

 

You can also specify a displacement along the road. 

3 Click Goto or press Enter on your keyboard, and Mapping will automatically 
zoom to your choice. 
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Automatically Showing Selected Map Items 
These controls will automatically synchronise what the map shows to what you 
select in any other Grid or Detail window, with the desired zoom, centering or 
selection option you choose. 

The buttons in this list will remain selected (button down) until you deselect them 
(button up) or select another automatic Show Selected control. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 

 

§  Auto Zoom (automatically zoom to selection). 

§  Auto Show (automatically bring current selection into view). 

§  Auto Centre (automatically centre on selection). 
 

Changing the Map's Appearance 
The features on your map, and the symbols, colours, lines and shapes representing 
them are designed to present the information to you in a clear and logical way. 

If you need to change these properties, however, you can do so at two levels. 

§ To control which features are included in the map, and what you can do with 
them, set their status in the Map Layer Panel (on page 266). 

§ For more control over appearance, including defining colours, symbols and 
shapes, you can change Map Layer settings (see "Changing Map Layer 
Settings" on page 270). 

Each type of road asset - like Roads or Places - is added to the map as a separate 
layer. When you add the Street Lights to the map, it will have its own layer. You 
can change the appearance of each layer separately. Its appearance settings are also 
retained when you save the map (see "Saving Layouts and Loading Maps" on page 
273). 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 
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Map Layer Panel 
The map that you see in the Map window is actually made up of a number of map 
layers, each stacked on top of the other. The layers may sometimes block other 
layers (and map items) from view, particularly if you have customised the 
appearance of a given layer. You can always change the order of a given layer (see 
below). 

The expanded map layer panel image below shows how the layers are structured. 
Land, logically, is right at the bottom, and everything else is stacked upwards from 
it to build a clear and representative picture of the relevant area. 

Click the panel sizer control at the left edge of the Map window 

 

to see the layers and how they are arranged, as in the image below. 

The Map Layer panel control is more than a simple description of the map layers - 
it enables you to show or hide them, make them selectable, and show labels. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 

NOTE: If you change the filtering options in the Grid or Detail window 
containing the items you are viewing on the map, those records will not 
be automatically shown when you select the corresponding map item. 
You'll need to add those new records to the map. 
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4 To Work with Map Layers 

1 Click the Show Map Layer panel button  on the Map window toolbar to bring up 
the Map Layer panel. 

 

We've expanded the view to display System layers in the image above- usually 
you will see only the default layers Highways and Roads, and any layers you may 
have just added (SLIM above). 

The key next to the map item (Highways, Roads and SLIM above) indicates 
how they are currently displayed on the map- what icons, lines and colours 
they are using. To configure these settings, see Changing Map Layer Settings 
(on page 270). 

2 Set the options for each layer. 

§  Make the layer Visible. 

§  Show Labels on the respective layer. 
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NOTE: Earlier versions of the Mapping software included a Selectable option. 
This is now configured manually by changing map layer settings (on 
page 270). 

When you select an option for a layer it is highlighted in blue. In the example 
above, all layers except Places are Visible. Labels are switched on for Annotations, 
SLIM, Highways, Roads, Address, Cities, Towns, Suburbs and Localities. 

TIP: Don't switch labels on for more than a layer or two at a time. The 
labels on higher layers can obscure details of the lower layers. 

3 Close the window by collapsing the panel or clicking the Map Layer panel 
button . Your changes are applied to the map automatically as soon as you 
make them. 

4 To Make Map Layers Visible By Changing Their Order 

§ If you can't see the labels for a particular map feature when you look at the 
map, other features on a higher layer may be obscuring them. To move the 
affected layer higher up the stack and make it visible, use the Move Layer Up  
and Move Layer Down  buttons. 

4 To Delete a Map Layer 

§ To delete a Map Layer, select the layer and click the Delete Layer  button. 

CAUTION: Be careful when deleting layers, as you will not be able to restore 
them unless you've exported them beforehand (see "Exporting 
and Importing Map Layers" on page 269). You cannot delete 
System layers. 
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Exporting and Importing Map Layers 
Mapping lets you export or import map layers in the MapInfo .tab format. You can 
also export them as plain text files. 

TIP: If a particular layer of your map takes a while to set up, and you know 
that the data in that layer won't change often, you can export that layer 
and then re-import it when you need it. Importing a layer is faster than 
generating the layer again. 

4 To Export Map Layers 

1 Open the Map Layer panel (on page 266). 

2 Select the layer you wish to export. 

3 Click the Export Layer button . 

4 Define a location and filename for your layer .tab file. 

5 Click Save to save the file and return to the Map window. 

4 To Import the Map Layer 

1 Open the Map Layer panel (on page 266). 

2 Click the Import Layer button . 

3 Browse to and select the .tab file to import. 

 

4 Click the Open button to import. The layer is added to the Map window, and 
you'll see it when you next open the Map Layer panel (on page 266). 
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Changing Map Layer Settings 
You can change Map Layer settings in two places. 

§ You'll most often want to change Map Layer settings after the details have been 
added, in the Map Options panel. This is described below. 

§ You can also change Map Layer settings at the point of adding items to the 
map (see "Changing Map Layer Settings While Adding Items to the Map" on 
page 255). You can choose how those details are shown on the map, before 
they're added to it. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 249). 

Map Layer Settings Window 
To bring up this window, open the Map Layer panel (on page 266) and click the 
Map Layer settings button . 

 

This window allows you to set the global options for the layer such as the Zoom 
Range for the layer objects or labels, whether the layer objects will have arrows to 
Show Direction, whether they will Show Nodes at their start and end points, and whether 
they will Show Centroids (markers in the centre of objects with an area). The 
availability of objects sometimes depends on the type of layer you have selected. 

You also have some layer label specific options. The Maximum Labels setting, and 
options to Allow Overlapped Text, Allow Duplicated Text and Label Partial Objects  are to help 
reduce label clutter in your Map window. You can also choose whether the Label 
Lines will be simple or show arrows, the label Orientation in relation to the object, 
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whether the label will be displayed Parallel to the object and how far away from the 
object it will be (Offset). 

Map Style Objects 
It's useful to have some idea of the different objects you can customise before you 
start changing their settings. The four types of style objects you can customise are 
listed below, together with the settings you can edit. 

Tick Override Style if you wish to change the style of the layer - the style button next 
to it will not be active until you do so. 

CAUTION: You can configure individual settings for each of the following 
categories for each layer. That gives you very wide range of options for 
customising the map, so please exercise caution and change only the 
style objects you absolutely need to. 

§  Symbol. Click this button to bring up a separate dialog box to change the 
style of the symbols that are displayed on the respective map layer. 

 

§  Line. Click this button for style settings relating to lines on the respective 
layer. 
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§  Region. This control will give you access to style settings relating to object 
regions on the layer. 

 

§  Label. This button brings up a dialog box to set Label style 
options. 

 
 

Map Options Window 
Click the Map Options button  on the Map window toolbar (on page 249) to access 
a number of options related to saving and loading map layouts, and validating map 
data. 

The selection panel on the left hand side of the window allows you to select the 
tool you require. 
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Saving Layouts and Loading Maps 
The Maps section of the Map Options window contains controls to save map 
layouts and load maps. The map layout you're currently using will be selected, and 
any other layouts you have saved will be available in the list. 

The original layout will always have (Original) after the file name. For your 
security, this file cannot be deleted. 

Mapping saves a map layout as MapInfo GeoSet file with a .gst file extension. It 
will retain all layout, view and layer settings. 

Once you've saved a map layout, you can configure Mapping to load it instead of 
the default map. 
 

Saving, Deleting and Loading Map Layouts 
When you've made changes to a map layout, you'll most likely want to save it. For 
example, you may have added new layers to the layout (see "Adding Assets to the 
Map" on page 252), changed the zoom levels (see "Defining and Loading Map 
Views" on page 262), or customised styles (see "Changing the Map's Appearance" 
on page 265). 

CAUTION: We'd strongly recommend saving your changes under a new name 
instead of overwriting the default map layout, as you will not be able 
to restore the original layout without reloading the original .gst file. 
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4 To Save the Map Layout 

1 When you're satisfied with your changes, click the Map Options button  on the 
Map window toolbar to load the Map Options window (on page 272). 

 

2 In the selection panel at the left, ensure that Change Current Map Layout is selected as 
above. 

3 Click the Save As button  to save the current layout under a new name 

-OR- 

Select the .gst layout file already in the window (the default layout you are 
using at the moment) and click the Save button  if you wish to overwrite the 
existing layout file. 

4 In the browse window that pops up, choose a name and location for the .gst 
file. This will be the location of your current .gst files by default. 

5 Click Save to return to the Map Options window above. You can now select 
the layout  and load it (see below). 

4 Deleting a Map Layout 

§ You can delete any saved layout with the Delete button . For your security, 
Original layouts cannot be deleted. 

4 Loading a Map Layout 

1 To load a saved map layout (above), or the Original layout supplied with the 
map, select the layout you want to use. 
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2 Tick this option to load this layout automatically every time you launch the 
Map window: 

 

As indicated, the layout will be specific to the database you're currently using. 

3 Click Close to close the window and cancel all changes, Apply to apply your 
settings to the Map window right away, or OK to apply your settings and close 
the Map Options window. 

 

Loading an Alternative Map 
You can reload your original map layout or an alternative layout from your default 
map layout folder. 

NOTE: You will need to ensure that you have the relevant .gst map layout file in 
the appropriate folder of your RAMM application (usually 
C:\PROGRAM FILES\CJN TECHNOLOGIES\MAPS) 

4 To Load An Alternative Map, Or No Map 

1 Click the Map Options button  to load the Map Options window (on page 
272). 

2 From the selection panel on the left, select Choose Map. 
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This window will show you a list of the maps you can load. Make your 
selection. If you want to stop using a map, scroll up the list and select No Map. 

3 Click Close to close the window and cancel all changes, Apply to apply your 
settings to the Map window right away, or OK to apply your settings and close 
the Map Options window. 

 

Running the Map Validation Report 
When you're working with mapping, it's a good idea to run the map validation 
report: 

§ The first time you use the mapping module. 

-AND- 

§ Each time you receive updated mapping data as part of an upgrade. 

The map validation report compares the details about each mapped item stored in 
the road network database with the details in the mapping database. This alerts you 
to any discrepancies, which can then be sorted out (see "Compensating for Map 
Data Discrepancies" on page 279). 

4 To Run the Validation Report 

1 Open the Map Options window by clicking the Map Options button  on the 
Map window toolbar (on page 249). 

2 Click Tools on the left-hand selection panel. 

 

3 Click the Validation Report button. 
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4 A progress window appears as Mapping extracts map data for comparison with 
the RAMM application you're running. 

 

5 The Map Audit window appears. 

 

6 Mapping will now compare the map data with the RAMM Road data. Select 
the appropriate types of fault to check for: 

§ Length Discrepancies. Identifies roads whose length in RAMM is different than 
the length in the map data. Ignores any discrepancies that are within the 
Allowed Length Tolerance specified on the right side of the window. 

§ Missing RAMM Roads. Lists road centrelines in the map data which have a 
RAMM Road ID that does not exist in the RAMM data. 

§ Missing Map Roads. Lists Road IDs from the RAMM data whose 
corresponding road centreline does not exist in the map data. 

§ Road Name Discrepancies. Lists RAMM roads and map roads with same 
RAMM Road ID but different names. Ignores differences like "Ave" and 
"Avenue". 

§ Sequence ID Errors. Lists internal errors in the map data where the same 
sequence number has been used for more than one road. Mapping will 
not work properly with such data, and you must inform the map data 
supplier (usually Critchlow Associates) of the problem. 

§ Identify Possible Matches. Attempts to match RAMM roads with map roads that 
haven't been assigned a RAMM Road ID. 
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7 Select the difference between lengths in the map data and RAMM data 
Mapping should tolerate in the Allowed Length Tolerance section. 

8 In Output Options, select whether to group the report by the Fault type or by the 
Road Name, and whether or not to include Map References. You can also choose to 
export the report results as a Comma-separated file for later use. 

9 Preview or Print the report. Mapping may take a while to generate this report - 
please be patient. It will look like this: 

 

10 Go through the discrepancies noted in the report, writing your notes on the 
printed report as you go. This is one situation where there's no substitute for 
hard copy. 

11 Please send the annotated report to your map supplier, so they can make any 
necessary changes to the map data they supply. If your map supplier is 
Critchlow Associates, their postal address is PO Box 4103, Wellington. Aim to 
send your comments before the December-February period each year, when 
the maps are usually updated. The updated map data will accompany the 
RAMM and RAMM Street Lights software upgrades released in March/April. 
These upgrades are automatically loaded for you if you're using the RAMM 
Hosting Service. 
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Compensating for Map Data Discrepancies 
Discrepancies can sometimes occur between the information in the mapping file 
and in your database. This can be for a number of reasons- apart from survey 
inaccuracies, it can also happen as a result of not taking into account geographical 
features like hills as in the image below. 

 

NOTE: Whenever you get updated mapping data as part of an upgrade, we 
recommend you identify any discrepancies between the map data and 
road data by running the Map Validation Report (on page 276). 

Every database is provided with a Map Index. You can Generate the Map Index to 
have Mapping compare the map with the RAMM data and adjust the data 
accordingly. In fact, when you load a map for the first time Mapping will 
automatically prompt you to generate the Index. 
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4 Generating the Map Index 

If you need to manually generate the Index, you can do so from the Map Options 
window. 

1 Click the Map Options button  and select Tools from the left-hand selection 
panel. 

 

2 Click the Generate Map Index button. This may take a while - please be patient. 
You'll see a progress bar as this happens. 

 

3 Click OK to return to the Map window. 
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Printing the Map 
To bring up print options for the map, click the Print button  on the Map 
window toolbar (on page 249). 

 

You can choose the position of the legend and whether Scale and Details will be 
shown. The map licence will always be shown. 

If you're printing the legend you can also select which layers to show, so that you 
don't clutter your print with unnecessary information. 
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Two Scale options give you control over the labels and detail visible on the screen. 
Scale to Page will print the map exactly as it is on the screen. Scale to Page - Detail will add 
more labels if there is room for them on the page being printed. The other options 
are specific to the scale selected. 

 

You can also print the map over multiple pages. Simple select the layout you 
require, and the panel on the right will show you how it will look. You can also 
select the option to Print the Legend and Details on every page if you wish. 

 

Close the window when you are done. 
 

Updating RAMM from the Map, and the Map from RAMM 
You can update RAMM Road IDs, Displacements and Offsets from the Map for 
greater consistency between the Map data and the RAMM data. You can update 
the following: 

§ RAMM Road ID 

§ Side 
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§ Displacement 

§ Offset 

You can also do the reverse, and update Map Coordinates from RAMM. 

The Update RAMM from Map option is available from selected RAMM Grid and Detail 
window menus. Select Actions > Update RAMM from Map, and then select either Map 
Coordinates or RAMM Displacement as required. 

CAUTION: Updating the RAMM Displacement is a fairly complex operation and has the 
potential to alter crucial RAMM data. If you're not absolutely sure that 
you need to use these options, please contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

In RAMM Street Lights, RAMM Traffic Signals and Signs, this process can be also 
automated by selecting Options > Map Automatic Update Options and making the necessary 
selections in the window below. 

 

4 To Update Map Coordinates from RAMM 

1 From the relevant RAMM Grid or Detail window menu, the RAMM Street 
Lights window, RAMM Traffic Signals window or the Signs window, select 
Actions > Update RAMM from Map, and then select Map Coordinates 

-OR- 

To update Map coordinates automatically in the RAMM Street Lights 
window, RAM Traffic Signals window or the Signs window, select Options > Map 
Auto Update Options > Update Eastings and Northings when you change the Road ID or Displacement 
(see image above) and click Options. 
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2 You can now select whether or not to override existing co-ordinates. 

 

3 Click OK to return to the previous window. 

4 To Update RAMM from the Map 

1 From the relevant RAMM Grid or Detail window menu, the RAMM Street 
Lights window, RAMM Traffic Signals window or the Signs window, select 
Actions > Update RAMM from Map, and then select RAMM Displacement 

-OR- 

If you wish to update RAMM information automatically in the RAMM Street 
Lights window, RAMM Traffic Signals window or the Signs window, select 
Options > Map Auto Update Options > Update Road ID & Displacement when you change the Eastings & 
Northings (see image above) and click Options. 

 

2 Make your selections, and click OK to return to the previous window. 
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This section describes running the Status Check in RAMM Street Lights. 

IN  THIS  CHAPTER 
Status Check..............................................................................285 

 
 

Status Check 
From the menu Actions > Status Check, you can perform a number of database specific 
status checks. 

§ Reload query tables 

§ Reload triggers and procedures 

§ Update database statistics 

§ Clear processing triggers 

Status Check in RAMM Street 
Lights 
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If  more then a month has expired since Update database statistics was last run or if 
any of the other status checks need to be done, they will be indicated with a blue 
icon as below:  

 

Click Begin Processing to start the status check process and update your data. While 
processing, the current process running will be indicated by a yellow arrow. 

RAMM Street Lights will automatically exit the window. 
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This section deals with setting staff security permission levels for different types of 
users in RAMM Street Lights. 

IN  THIS  CHAPTER 
Staff Security Permissions.........................................................288 
Custom Database Permissions..................................................290 
Contract Specific Staff Permissions ..........................................295 

 
 

Security 
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Staff Security Permissions 
Staff permissions in RAMM Street Lights govern the levels of access (View Only, 
Full Control, Custom) and what actions can be performed within the application (for 
example, replace assets or generate Claims). 

There are two types of staff permissions in RAMM Street Lights: the general 
database permissions that you set in RAMM Manager from the Maintenance > Staff menu, 
and the contract specific permissions you set in the RAMM Street Lights Contract 
Details window (see "Contract Specific Staff Permissions" on page 295). 

4 Setting General Database Permissions 

1 Select Maintenance > Staff in RAMM Manager to maintain these permissions. 
Every database needs at least one user. If no users have been entered, you'll be 
asked to do so. 
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2 You will see a dialog box to select or add a user. 

 

The All Users option is not recommended unless you definitely want to give all 
users of the database equal permissions. Select a user from the list, or Add New 
User, enter a name and click OK. 

     

3 A new staff security record with the current date will be created, and you can 
proceed with setting up the new user. 
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4 Select the permission record with the current date in the list panel on the left, 
as indicated by the mouse arrow, to set the level of access you require. 

 

For most users, Full Control should be adequate. If you choose to customise the 
permissions, see Custom Database Permissions (on page 290). 

CAUTION: Be careful when altering your own permissions. If you make a 
mistake it is possible to lock yourself out of your database, or parts 
of it. Please contact us (see "Contacting CJN Technologies Ltd" 
on page 23) if you need help with this area. 

5 Save  and close the window. 
     

Custom Database Permissions 
To customise database permissions for staff, click Custom in the button bar at the 
top of the Detail panel of the Staff Permissions window in RAMM Manager. 

The icons on the button bar of the Detail panel are a good way to keep track of the 
custom permissions you set up, as they are reflected in the tree structure of the 
permissions list as well. 
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Select the custom permission categories as appropriate in the left pane. If they 
aren't immediately visible, click the  and expand the options. We've described 
some of the most important categories below. 

Edit the permissions as required, using the category list on the left to select and set 
permission options. Save  and close the window when done. 

CAUTION: Be careful when altering your own permissions. If you make a mistake 
it is possible to lock yourself out of your database, or parts of it. Please 
contact us (see "Contacting CJN Technologies Ltd" on page 23) if you 
need help with this area. 

For permissions that are contract specific (for example Dispatches, Claims and 
Patrols), see Contract Specific Staff Permissions (on page 295). 
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General Category 
Following the installation of a new software build, you may need to perform a Data 
base Upgrade. When this option is unchecked, a message is displayed and access to 
the database is denied until the upgrade has been done, so when customising 
database permissions you will need to ensure that at least one user has permission 
to do so. 

The option No access allowed in the Parameter section enables the administrator to 
exclude users from accessing the current database. Access to the Parameter table 
enables the user to define database wide options, including the ability to 
reconfigure the name of the database which appears in report headings (see 
"Database Options" on page 166). 
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Staff Category 
When customising database permissions it's important to ensure that at least one 
user is given permission to maintain the Staff list, as this is key to adding other 
users. 

 
 

Contract Category 
When customising database permissions, you need to ensure that at least one user 
has permission to add contracts and update lookups. 
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NOTE: The permissions in this category govern adding a Contract and updating 
Lookups for the Contract. They are distinct from Contract Specific Staff 
Permissions (on page 295), which control what happens within the 
contract. Similarly, the Contractor permission button on the button bar is a 
quick control to give the selected user access to the database in 
Maintenance Contractor applications only, and does not control adding 
contracts or setting permissions within the contract.~a 

 

SLIM (Street Lights) Category 
The SLIM (Street Lights) category contains most of the options to maintain asset data 
and control importing of files. 

 

Data transfer function permissions are found in the SLIM Transfer category. 

~e,i SLIM > RAMM Street Lights, document after change, may need to be shifted to 
Contract Specific Staff Permissions. 
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Contract Specific Staff Permissions 
Contract specific staff permissions are set up in the Contract Details window (see 
"Contract Details" on page 55). 

NOTE: Unlike in the general database permissions window in RAMM Manager, 
the contract specific staff permissions window title bar will have the 
contract description on it, and the button to set up new users reads Add 
User to Contract instead of Add New User. 

4 Setting Up Contract Specific Permissions 

1 Launch the contract specific permissions window by clicking the Staff Permissions 
 button on the toolbar. 

 

2 Click Add User to Contract. 

3 Select a user from the list that pops up or select Add New User, enter a new name, 
and click OK. 
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4 A new contract specific staff security record will be created, and you can 
proceed to set up the permissions for that user. 

 

The image above shows the options available within the Contract category. As 
with general database permissions in RAMM Manager, you can either enable 
No Access, View Only access, Full Control or Custom access. If you choose Custom, each of 
the options in the permission list can be ticked or unticked to customise access 
to those parts of the contract. 

5 Use the category list on the left to select and set permission options for the 
various categories. 

CAUTION: Be careful when altering your own permissions. If you make a 
mistake it is possible to lock yourself out of parts of your 
Contract. Please contact us (see "Contacting CJN Technologies 
Ltd" on page 23) if you need help. 

6 Save  and close the window. 
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Building an initial inventory of Street Lights is necessary when you have no Street 
Light data at all and you need to collect this information from scratch. 

This can be done for an entire network, but more commonly when surveying 
Street Light assets in a new subdivision. 

4 To Build a Street Light Inventory 

1 Draw up specifications. All organisations involved (Network Owner, Contractor, or 
Consultant) must agree on consistency in respect of terminology, descriptions 
etc for all Street Light assets. For example, referring to a Lamp as a Gough GL 
500 in one place and a GL500 in another place will cause unnecessary 
problems with the database. If only one person is involved in collecting the 
information this is less of a problem, but if a team is involved there must be a 
specific method to how it's done. 

2 Collect the information. Below is a list of all the information you can collect about 
each asset. 

§ Components. Information about the components of each asset (for example, 
information about the Light must also include information on the Gear 
and the Lamp). 

§ GPS co-ordinates. 

§ Location. Information about the location of the asset, such as the road name. 

§ Powerboard numbers. Powerboard numbers, if available, are useful to locate 
assets. 

§ House numbers. House numbers are also important to locate assets. 

§ Feature. Any other useful information about the asset location, for instance 
house w. brown picket fence - dog bites or pole believed to be live. 

§ Photographs. Photographs are useful to illustrate the above. 

§ Rating information. If rating information is supplied with the assets it 
should be entered into RAMM Street Lights. 

Building a Street Light Inventory 
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3 Record the information. The Street Light asset information you collect can be in any 
format - for example, you can collect your information in an Excel spreadsheet 
on a handheld or laptop computer and CJN Technologies can import it into 
RAMM Street Lights. Please contact us (see "Contacting CJN Technologies 
Ltd" on page 23) to inquire about the costs involved. Alternatively, you can key 
the asset information into RAMM Street Lights yourself. 

4 Set up the contract. Once your Street Light asset data is in RAMM Street Lights, 
you are ready to begin setting up a contract and managing your network. For 
more information, see Setting Up a Contract (on page 55). 

NOTE: The Road ID, Location and Side can be generated from the Easting and 
Northing Values. 

 



 

  

Access (MS Access, Microsoft Access) 
A Microsoft application included with the RAMM Street Lights software to help 
you load and work with the *.slm database file if you are not running RAMM 
Street Lights on the RAMM Hosting Service (see below). 
 

Bracket 
The Bracket is the item that attaches the Light to the Pole. Various Bracket Types 
can also be defined. 
 

Call Types 
A description of the source of a call which has been made in response to a fault 
(e.g. Public Call, Council, Routine Patrol). 
 

Carriageway 
A term for a continuous section of road between displacements (see below). 
RAMM sometimes identifies assets in relation to carriageway sections. 
 

Circuit Information 
This refers to Line Companies, Bulk Change Groups and Lighting Circuits. A 
Bulk Change Group is the grouping together of circuits for regular maintenance of 
the assets. 
 

RAMM Hosting Service 
The RAMM Hosting Service allows you to host your database and the software on 
one of our fast servers at CJN. You simply use your standard internet browser to 
run the software and work with your data, so you don't need any specialised 
software. It's also more secure, since your data is on our servers and not your local 
machine. 
 

Claim Groups 
Optional codes for use with Claims that refer to specific groups. 
 

Glossary 
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Claim Header 
A Claim header groups together Claim lines for the same contract within a fixed 
period. Claim headers must exist for Claim lines to be entered during the 
Dispatch completion process. 
 

Claim Lines 
Every Dispatch needs to be linked to a Claim line, and RAMM Street Lights will 
automatically prompt you to do so on completion of every Dispatch. Claim lines 
need to be set up under a Claim header. 
 

Coating Systems 
The Code and Description of the Coating Systems used for each Pole, Bracket and 
Light. 
 

Contract Item Activities 
Types of activities that can be carried out under a contract. These items need to be 
defined at the beginning of a new contract if they have not been pre-defined and 
included in a Data Transfer (see below). 
 

Data Transfer 
The transfer of data relating to a specific database and contract that takes place 
between Council and Consultant/Contractor at regular intervals, and especially at 
the beginning and end of each contract. The purpose of the transfer is to 
synchronise the Council's and Contractor's copies of the database so that they 
correspond. 
 

Dispatch 
A job of work raised in response to a fault. 
 

Dispatch Groups 
Optional analysis codes for use with Dispatches. 
 

Displacement 
A reference to a point on a road, used to define sections such as carriageways (see 
above) and expressed in metres. 
 

Event Codes 
A code for classifying events in emails sent from within RAMM Street Lights, 
between Network Owner and Contractor, to give more information about a job. 
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Fault 
A description of a regularly occurring fault or problem (for example, flickering lamp, 
light out). Faults can also be arranged in Fault Categories. 
 

Filters 
Filters help you sort information by specific criteria so that you see only what you 
need. You can also save your filter to use them again. 
 

Gear 
The group of components that ignite, control and regulate the operation of the 
Lamp (see below). 
 

Gear Ballast 
A type of transformer that varies the voltage through the Lamp (see below). 
 

Gear Capacitor 
Evens out the flow of current and provides protection from "noise" produced by 
the Gear on the network. 
 

Gear Ignitor 
Provides an increased voltage across the Lamp (see below) to get it started, and 
then switches itself off. 
 

Lamp 
The bulb, filament or tube that generates illumination from the Light. 
 

Light 
The entire object that would generally be termed a Street Light. The Light 
includes the Gear and the Lamp (see above). 
 

Line Company 
The Line Company is the owner of the line assets. 
 

Location 
The details that help to locate a Street Light within a database- the side of the road 
it is on, what landmarks are nearby, external factors (for example, "dog in brown 
house next to crossing bites"). 
 

Manufacturer 
A short code for the manufacturer's name or the models supplied by each 
manufacturer (refers to Poles, Lights, Gears and Lamps). 
 



 

3 0 2  R A M M  S t r e e t  L i g h t s  
 

Pole 
The Pole that the Street Light is attached to. 
 

Pole Link 
This option enables you to locate a Pole by a unique means of identification-  for 
example a System Pole ID, Power Board number. These options can be set from 
the main RAMM Street Lights menu by selecting Actions > Options and choosing an 
identifier from the Pole Link drop-down list on the Database tab. 
 

Pole and Light Owners 
The owners of the the Pole and the Lamp (or of both) of the respective Street 
Light. 
 

Pole Definitions 
Definitions specific to a Pole, for example Control Types, Construction Materials, Pole Shapes, 
Pole Purpose. 
 

Power Company 
Details about the power company that supplies power to the Street Lights. 
 

Power Supply Points 
Street Light power supply points (for example Overhead or Underground). 
 

Rating Categories 
User definable ratings for Street Light assets that can be categorised and activated 
for individual assets.  
 

Replacement Reasons 
The reasons given for the replacement of an asset. Replacement reasons can be set 
up and allocated to specific assets. 
 

Road (Road Name) 
In RAMM Street Lights this specifically refers to a road in the context of a location 
of a Street Light. 
 

Update Asset 
When entering Contract Details, selecting Update Asset will allow automatic updating 
of the Street Light data when completing a Dispatch. 
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Asset Management Reports • 227 
Asset Replacement Reports • 235 
Auditing Reports • 240 
Claim Analysis Report • 236 
Contract Management Reports • 236 
Dispatch Analysis Report • 239 
Dispatch Detail Report • 239 
Dispatch Progress Report • 240 
Dispatch Summary Report • 238 
Electricity and Maintenance Cost Report • 233 
Latest Pole Numbers Report • 235 
Light Spacing Report • 228 
Lighting Category Performance Report • 228 
Multiple Claims Per Dispatch Report • 241 
Pole, Bracket and Light Report • 227 
Rating Analysis Report • 230 
Rating Report • 232 
Road Names Report • 243 
Street Lights Report • 135 
Table Statistics Report • 242 
viewing and saving • 215 
Warranty Failure Report • 236 
Wattage Analysis Report • 229 
Wattage Report • 229 
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Year To Date (YTD) Report • 243 

S 
Schedule Items •  See Contract: Schedule Items, setting up 

Security • 287 
Contract Level Permissions • 295 
setting Custom Permissions, Contract Category • 293 
setting Custom Staff Permissions • 290 
setting up Staff Permissions • 288 

Setting up RAMM Street Lights • 48 

Status Check • 285 

Street Light Report •  See Report: Street Lights Report 

Street Lights • 111, 112 
Bracket tab • 120 
Component Diagram • 36 
Gear tab • 122 
Lamp tab • 123 
Light tab • 121 
Location Diagram • 34 
Location tab • 115 
Map Auto Update Options •  See Map: Auto Update options 
Pole General tab • 116 
Pole Identifier tab • 119 
Replacing Assets •  See Replacing Assets 
Street Lights window • 112 
Summary tab • 114 
viewing and filtering • 113 

T 
Tasks 

daily tasks • 67 
other regular tasks • 81 

Toolbar Buttons • 45 

U 
Understanding SLIM • 33, 34 

Updating Assets • 55, 124 

users currently logged on to database, viewing • 43 
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W 
What is RAMM Street Lights? • 33 

Workspace, RAMM Street Lights • 43 
 


