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When you contact us for help, we'll need to know what version of the RAMM 
Traffic Signals software you are using. 

TIP: Problems are sometimes fixed simply by upgrading your software to a 
later Build. To find out which problems are fixed in later Builds than the 
one you're using, see our website Upgrades page 
(http://www.cjntech.co.nz/upgrades.htm). If you have any questions 
about upgrading, feel free to contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

4 To Find the Software Build Number 

Go to the menu at the top of the main Traffic Signals window, then choose Help > 
About. A small window shows details about the software. You'll find the Build 
Number at the top- in the example below it is 92.0128. 

~i change to 2005 

 

Finding Which Software Version 
You are Using 
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C H A P T E R  1  

This guide is specifically intended to help you use and understand the functions of 
the RAMM Traffic Signals software from CJN Technologies. We've structured it 
to progress from basic tasks like getting to know RAMM Traffic Signals concepts 
and setting up to more complex tasks like Maintenance and Mapping, and has 
been written from the point of view of the RAMM Traffic Signals Contractor (see 
"About RAMM Traffic Signals" on page 35). 

Since RAMM Traffic Signals is both an independent, standalone application as 
well as part of the RAMM (Road Assessment and Maintenance Management) 
suite of applications, you may also need to refer the Using RAMM Guide. If you're 
not sure whether you're reading the right guide, see RAMM Guides (on page 21). 

This section tells you how to get the most out of using the rest of the document- if 
you're familiar with RAMM Traffic Signals you can use the links to go directly to 
the section you need. If you're new to it, we recommend that you read the entire 
guide. 

Understanding RAMM Traffic Signals 
Understanding RAMM Traffic Signals (on page 35) is an overview of what the 
software is, what it does, and other basic concepts like the placement of Traffic 
Signal assets in an intersection and Traffic Signal components. 

Getting Started with RAMM Traffic Signals 
Getting Started with RAMM Traffic Signals (on page 41) describes how to 
generate Intersections, build a Traffic Signals Inventory if necessary, configure the 
software and get to know the RAMM Traffic Signals workspace. We've included 
extensive descriptions of RAMM Traffic Signals Toolbar buttons (on page 51). If 
you need help setting up RAMM Traffic Signals including setting up contracts 
(see "Setting Up Contract Item Activities" on page 68), this is where you should 
look. 

RAMM Traffic Signals Tasks 
RAMM Traffic Signals Tasks (on page 75) covers most of the common tasks you 
will perform. Use this section if you're in a hurry and you want a quick start to 
working with the software. This is where you'll read about entering dispatches, 
printing them for your maintenance crew and completing them. We also have 

About This Guide 
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brief descriptions of other regular tasks such as patrols and claims. All the topics in 
this section are dealt with in more detail in separate sections - use the links in the 
descriptions below to go directly to them. 

Filters 
Though Filters are not exclusive to RAMM Traffic Signals, using filters is crucial 
to be able to see the information you want quickly instead of having to sort 
through unnecessary information. This section describes using Filters (on page 
97). 

Dispatches 
This section examines the dispatch entry process in detail and describes each tab of 
the Dispatch Entry window (on page 108). It also includes a section on Automatic 
Dispatches (dispatches received by email) and related options (see "Automatic 
Dispatches" on page 123). 

Traffic Signals 
This is where you'll find a detailed description of the Traffic Signals window (on 
page 134), with individual descriptions of each tab. We also look at the distinction 
between Updating and Replacing Traffic Signal assets (see "Replacing Traffic 
Signal Assets - ts" on page 150). 

Maintenance 
Use the Maintenance sections of this guide to work through setting up and 
configuring Patrols (on page 153), Claims (on page 159), Maintenance Crew 
Payments and all other Maintenance screens. You can refer to RAMM Traffic 
Signals Options (see "RAMM Traffic Signals Options" on page 169) for global 
options governing what you see in RAMM Traffic Signals, like screens for Rating, 
Electricity Charges and Optional Groups, and to set options for Tolerances. 

Reporting 
This is where we describe how to analyse your data and generate reports (on page 
201). They are either in QuickReport format or the Decision Cube format (see 
"Decision Cube" on page 203). Both are powerful tools for viewing and analysing 
your street light data and generating printed or soft-copy reports or charts and/or 
exporting to popular spreadsheet formats like Excel. 

Mapping 
Mapping (on page 227) is stand-alone function that can be linked to RAMM or 
RAMM Traffic Signals, and requires a separate licence - for more information, 
please contact us (see "Contacting CJN Technologies Ltd" on page 23). Mapping is 
a key element of Traffic Signals because it allows you to visualise your Traffic 
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Signals assets and linked Intersections on a map. You also have access to a number 
of mapping query tools. 

Administrative tasks 
Status Check (on page 269) and Security (on page 271) functions have their own 
sections in the guide. The Status Check function is to ensure that all the processes 
and tables in RAMM Traffic Signals are up to date, and Security sets different 
access levels for various users of the software. 
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This section describes the many ways you can get help when you have problems or 
questions about using our software. 

IN  THIS  CHAPTER 
Finding the Answers You Need Quickly....................................18 
What You Should Already Know ................................................19 
Conventions We Have Used.......................................................19 
Help Yourself ..............................................................................20 
Help from Other Users ..............................................................21 
Help from CJN Technologies ....................................................21 
RAMM Guides............................................................................21 
RAMM Database Details ............................................................22 
Comments and Suggestions........................................................23 

 
 

Getting Help 
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Finding the Answers You Need Quickly 

To Find Out How to Use Help 
For descriptions of the different types of help we have, formatting conventions 
and contact information - that's right here in the section you're reading now. 

To Find Out How to Work with a Particular Function 
Go directly to the section about that particular function - refer to the Contents. 

Answers Elsewhere 
If the task is not listed in the Contents, you may find it in another of the RAMM 
Guides. Check our list of RAMM Guides (on page 21) to make sure you've got the 
right one. 

To Find Out what a Particular Term Means 
Read the Glossary at the end of this Guide. 

To Find where a Particular Term Appears in this Guide 
Read the Index at the end of this Guide. 

Talk to Us 
Feel free to contact us (see "Contacting CJN Technologies Ltd" on page 23) 
directly. 
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What You Should Already Know 

The Microsoft Windows Environment 
Before you read this guide, you need to be comfortable working with the 
Windows environment and its applications. We assume you already know how to 
use standard Microsoft Windows applications. For more information about using 
Windows applications, please refer to the Windows user documentation - 
including the online Help which you can open by clicking on a blank part of your 
Windows desktop, then pressing the F1 key at the top of your keyboard. 

Security and Passwords 
Safeguarding passwords and security information is important. It's best never to 
write down a password, but if you must, keep it under lock and key. 

Data Backup 
Back up your data regularly. At the very least, you should back up your database in 
a location other than the computer you usually work on. Ideally, your entire 
computer's hard disk will be mirrored in another location such as a server or a 
network drive. Another cost-effective and secure backup solution is to use the 
RAMM Hosting Service. For more information, see our website 
(http://www.cjntech.co.nz). 
 

Conventions We Have Used 
This document uses certain ways of formatting text to identify special information.  

Formatting Convention Type of Information 
 (printed document) or 

Brown heading (online/web) 
Step-by-step procedures. Follow these instructions 
to complete a specific task. 

Bold Items you must select, such as buttons, menu 
options or items in a list. Menu options are 
separated by the > symbol. For example: View > 
Refresh. 

KEYS Keys on the keyboard. For example: SHIFT or 
CTRL. 

KEY+KEY Key combinations where you must hold down one 
key while you press another. For example: 
CTRL+P, or ALT+F4.  
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[Implied] Field Name Part of a field name not actually shown on the 
screen. 

> Menu Path > [Variable] A menu option that can have several values - usually 
Asset Types. 

Throughout this guide, when we refer to RAMM or a related application like 
RAMM Asset Valuation, RAMM Assessment, SLIM, Signs, or RAMM Traffic Signals 
we mean the Windows versions of our software. 
 

Help Yourself 
You can help yourself with integrated help, your printed help guide, or with web help. 

Many people like to be able to find their own answers. It's often quicker than other 
ways, and it's usually more satisfying. If you can't find the answer quickly, don't 
hesitate to ask us for help directly (see "Contacting CJN Technologies Ltd" on 
page 23). 

Using Integrated Help 
Press F1 on your keyboard in any window to access context sensitive help 

-OR- 

Click on the Help menu at the top of the window you're in and choose a relevant 
topic 

-OR- 

If you choose any of the Help > CJN Website options, your browser will be activated 
and take you to a page on our website (see Using Web Help below). 

Using the Printed Help Guide 
Printed help is useful especially when you don't have access to a computer. 

Using Web Help 
Our website (http://www.cjntech.co.nz) has number of resources that you'll find 
useful. Our Support page (http://www.cjntech.co.nz/support/index.htm) has links 
to documentation, reference, training and troubleshooting pages. If you're using an 
installed version of the application you can also download the latest version of the 
software from our website Upgrades page 
(http://www.cjntech.co.nz/upgrades.htm). 
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Help from Other Users 

Contacting Other Users 
When you have a problem or question about different ways of doing something, or 
you'd like to share ideas with those who have hands-on experience, you can ask 
other users. We'll be happy to put you in touch with them - just contact us (see 
"Contacting CJN Technologies Ltd" on page 23). 

CJN Forum 
You can also ask questions and participate in ongoing discussions in the CJN 
Forum (http://forums.cjntech.co.nz). 
 

Help from CJN Technologies 
We pride ourselves on our friendly, responsive support. If you need a helping 
hand, feel free to contact us (see "Contacting CJN Technologies Ltd" on page 23). 
 

RAMM Guides 
We publish a number of guides. Here's a brief overview of them and what they 
cover. 

With every major release of RAMM, we publish a brief description of what's new 
in the release: 

§ What's New in RAMM. 

Main functions and basic tasks in RAMM are described in: 

§ Using RAMM. 

Advanced functions in RAMM are in a separate guide: 

§ Working with RAMM, including: 

§ RAMM Network Manager. 

§ Transaction Logging. 

§ Surfaces. 
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§ RAMM SQL. 

§ Bridges. 

§ Maintenance Activity. 

§ Pavement Structure. 

§ Pavement Strength. 

§ RAMM Security. 

We have some other specific RAMM guides: 

§ Managing RAMM. 

§ Street Light Inventory Management (SLIM). 

§ RAMM Asset Valuation. 

§ RAMM Assessment. 

§ RAMM Forward Work Planning. 

§ RAMM Traffic Signals. 

We have two reference guides for advanced database details: 

§ Working with Treatment Lengths. 

§ RAMM Database Reference. 
 

RAMM Database Details 
Occasionally you'll need to know where specific details are stored in the RAMM 
database for more complex tasks. There are a number of ways to find out which 
tables and columns contain the information you need: 

§ Read the separate RAMM Database Reference guide. 

§ For the most up-to-date listing of the details you require, go to the RAMM 
Manager main menu and choose Reports > Database Structure. Choose the tables 
you wish to view and then Preview or Print them. 

§ For a general overview, read Understanding RAMM Toolbar Controls in the Using 
RAMM Guide. 

§ Ask workmates and associates who have used RAMM for longer. 

§ Contact CJN (see "Contacting CJN Technologies Ltd" on page 23). 
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Comments and Suggestions 
If you have any feedback about this document or about the software itself, please 
contact us (see below). We welcome your observations and suggestions, as they 
help us to improve what we offer you. 
 

Contacting CJN Technologies Ltd 
Web 
www.cjntech.co.nz 

Email 
support@cjntech.co.nz 

Phone 
+ 64 9 415 4790 

0800 CJNTECH (256 8324) within New Zealand only 

Fax 
+ 64 9 415 4791 

Post 
PO Box 302-278 
North Harbour 
Auckland 1330 
New Zealand 

Address 
12 Piermark Drive 
North Harbour 
Auckland 1311 
New Zealand 

For a location map, please see our website 
(http://www.cjntech.co.nz/AboutCJN/getting_to_cjn.htm). 
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When you're using RAMM, some of your actions will be common to more than 
one task or window. This section describes those common actions. 

IN  THIS  CHAPTER 
Synchronising Information Shown in Other Windows.............25 
Moving to the Next or Previous Record ....................................26 
Adding a New Record.................................................................27 
Cancelling Changes.....................................................................27 
Saving Your Changes ..................................................................28 
Updating a Record ......................................................................29 
Deleting a Record........................................................................29 
Using Collapsible Panels ............................................................30 
Resetting 'Don't Show This Again' Warning Dialogs .................31 
Setting Editing and Viewing Preferences....................................32 

 
 

Synchronising Information Shown in Other Windows 
When you select a different road or carriageway section in the Road Selection 
panel, or a Detail window or a Grid window, all other open windows are usually 
immediately updated so that they also show the information for the same road/s or 
section/s. 

If Windows Are Not Automatically Synchronised 
This automatic synchronisation is turned off if you have: 

§ Changed the layout of a window - for example, changing the order or 
grouping of columns in a Grid window. 

-OR- 

§ Selected multiple roads by name in the Road Selection panel. 

Common Actions 
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If the information in a window has not been synchronised, the whole window 
turns grey (dimmed). 

4 To Manually Synchronise Information in Windows 

You can easily tell RAMM to update the information shown in all windows to 
keep them synchronised, whenever you like. Activate the relevant window or 
panel by clicking it, and then: 

§ Press the F5 key at the top of your keyboard, then wait a few moments for the 
window to show the results. 

-OR- 

§ Click the Refresh button  on the window toolbar. 
 

Moving to the Next or Previous Record 
When you're working with details in a Detail window, you can only see one record 
at a time. You can easily move to the next and previous record. If you have made 
changes to the current record, you will be prompted to save them before the next 
record is shown. 

4 To Show the Next Record's Details 

§ From the toolbar at the top of the Detail window, click the Next button . 

-OR- 

§ From the menu at the top of the Detail window, choose View > Next. 

-OR- 

§ Press ALT + N. 

4 To Show the Previous Record's Details 

§ From the toolbar at the top of the Detail window, click the Previous button . 

-OR- 

§ From the menu at the top of the Detail window, choose View > Previous. 

-OR- 

§ Press ALT + P. 
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Adding a New Record 
When you want to add a new item to a window, you usually have to tell RAMM to 
create a new record (unless Auto Insert mode is switched on). 

4 To Add a New Record 

To add a blank new record, ready for you to add details: 

§ From the standard toolbar, click the Add Record button . 

-OR- 

§ From the menu, choose Edit > Add. 
 

Cancelling Changes 
When you have made changes that you do not want to keep, and you have not 
already saved them (see "Saving Your Changes" on page 28), you can tell RAMM 
to cancel the changes. 

4 To Cancel Changes 

To cancel changes, without closing the window you're working in: 

§ From the standard toolbar, click the Cancel button . 

-OR- 

§ From the menu, choose Edit > Cancel. 

-OR- 

§ Press ESC on the keyboard. 

To avoid saving changes, you can also close the window and click the No button 
when you are prompted to save changes.  
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Saving Your Changes 
When you make changes in a window you have to save those changes to the 
RAMM database. Until you do this, changes you have made to that record usually 
exist only on the screen and may be lost when you close that window (or if 
RAMM fails for whatever reason, while you are working). Read more about how 
the information shown on your screen relates to the database. 

4 To Save Changes 

To save changes you have made to the details in a window, either: 

§ From the toolbar, click the  button. 

-OR- 

§ From the menu, choose Edit > Save. 

-OR- 

§ Press CTRL + S. 

To Avoid Saving Changes 
To avoid saving your changes, either: 

§ Cancel them if you want to keep working in that window. 

-OR- 

§ Close the window and click on the No button when you are prompted to save 
changes. 

Using Auto Insert Mode 
Auto Insert mode is especially useful when you are entering many records at once. 
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Updating a Record 
Some Detail and Grid windows in RAMM open as read-only by default (for 
example, most asset windows that open inside the RAMM main window). If you 
have the correct permissions, you can edit or update the data in these windows. 

4 To Update a Record 

To edit or update a record in any Detail or Grid window: 

§ From the window toolbar, click the Update button . 

-OR- 

§ From the menu, choose Edit > Update. 

Save your changes  when you are done. 
 

Deleting a Record 
If you have the correct permissions, you can delete records in RAMM Detail and 
Grid windows. Some windows (for example, the SLIM windows launched from 
RAMM) do not allow deleting. 

4 To Delete a Record 

§ From the window toolbar, click the Delete button . 

-OR- 

§ From the menu, choose Edit > Delete. 
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Using Collapsible Panels 
Some windows in RAMM have collapsible panels, so you can get certain features 
out of the way when you're not using them. The most obvious examples are the 
Grid Layout panel and the Road Selection panel, which you'll often collapse to free 
up space to show more road assets. 

4 To Expand or Collapse a Panel 

Go to the panel you want to expand or collapse. Point to the panel sizer, the blue 
marked area on the dividing bar between the panel and the rest of the window 
with tiny triangles: 

 

Sometimes (in Grid windows and reports) the bar will be horizontal: 

 

The triangles show you the direction the panel will move in when you expand or 
collapse it. 

Click the sizer to expand or collapse the panel. 

TIP: To expand or collapse the Grid Layout panel, you can also go to the 
menu at the top of the Grid window and choose View > Show Layout. 

 



 

 C h a p t e r  3   –   C o m m o n  A c t i o n s  3 1   

Resetting 'Don't Show This Again' Warning Dialogs 
Several message windows in RAMM give you the option of not being shown again 
- usually in the same day or until the next upgrade is installed. You can easily reset 
this option to show all warning dialogs again, if you change your mind. 

4 To Reset 'Don't Show This Again' Warning Dialogs 

1 From the window menu, choose Options > Reset All Warning Dialogs. The Reset All 
Warning Dialogs window appears. 

 

2 Click OK to apply the change. From now on, warning dialogs which were 
hidden will be shown again whenever they are appropriate. 
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Setting Editing and Viewing Preferences 
There are some options you can set that control how RAMM works when you're 
viewing and editing data. The default settings should be adequate for most 
purposes, but this is where you change them if you need to. The settings apply 
only to you, and to the specific RAMM program you're working with - for 
instance, RAMM Traffic Signals but not SLIM. 

To open the Options window, go to the menu at the top of the main window and 
choose Options > Preferences. 

Editing Options 
You can tell RAMM how to behave when you're editing data, specify what 
happens when the Enter or Tab keys are pressed, and whether or not to use Auto 
Insert mode for all editable windows. You can instead specify Auto Insert for one 
window at a time, as you use them. 
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The Replacement Reminder option will activate a reminder on the Replace Asset 
dialog (see "Replacing Traffic Signal Assets - ts" on page 150) prompting you to 
replace all attached assets in addition to the asset itself. 

 

Viewing Options 
When you're editing or entering data, all fields where you must enter a value can 
be highlighted in a different colour. You can set that colour here. 

 

Make your changes and click Save to return to the RAMM main window. 
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This section covers the basic concepts of RAMM Traffic Signals. 

IN  THIS  CHAPTER 
About RAMM Traffic Signals.....................................................35 
Background Information.............................................................36 
How Does RAMM Traffic Signals Work? .................................36 
Traffic Signals - Concepts...........................................................36 
Traffic Signals - Components.....................................................39 

 
 

About RAMM Traffic Signals 
The RAMM Traffic Signals software has different levels of functionality 
depending on whether you are using it as a Client or a Contractor. 

If you're a Contractor, RAMM Traffic Signals gives you full control over building a 
Traffic Signals inventory and maintaining those Traffic Signal assets, including the ability 
add, delete or replace assets. If you're using the software as a Client, you cannot 
maintain assets. 

It's also a register of calls and information about asset faults and the dispatches that 
relate to those faults. 

Once the faults have been seen to, the contractor can also generate claims for the 
work that has been done. 

RAMM Traffic Signals can also generate reports that will analyse the traffic signal 
network in a number of different ways and help with the maintenance. 
 

Understanding RAMM Traffic 
Signals 
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Background Information 
Contracts to install and maintain Traffic Signals are awarded by Councils on a 
regular basis. 

RAMM Traffic Signals enables the transfer of traffic signal asset data between 
contractors while maintaining a history of asset replacement. It also ensures 
privacy between contractors. 

RAMM Traffic Signals helps to locate traffic signal assets and look into the history 
of a particular asset's performance, thereby giving Councils and their contractors a 
more accurate picture of the traffic signal network and its estimated value. 
 

How Does RAMM Traffic Signals Work? 
RAMM Traffic Signals is an extension of the RAMM (Road Assessment and 
Maintenance Management) software. RAMM is used by Councils to help them 
maintain their roading network and record other network assets. 

RAMM Traffic Signals uses the RAMM Roadnames and Carriageway core tables. 
These tables are maintained by the Council's roading engineers and reflect the 
current road network. For more information on RAMM, see the Using RAMM 
guide. 
 

Traffic Signals - Concepts 
The Traffic Signal information in RAMM is linked to specific terms and concepts. 
Here are some of the most important: 

§ Road. A road in RAMM Traffic Signals is the unique name given to a length of 
the network, for example Queen Street or Tamaki Drive. 

§ Carriageway. A road can be divided into logical sections in a number of ways- 
for example, where an intersection with another road occurs, the start of a 
bridge, or where an extra lane starts. These divisions are called Carriageway 
sections. The start and end of a carriageway section is measured in metres 
from the start of the road. To assist in visually locating these boundaries, start 
and end names can also be used. 
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§ Primary / Secondary / Tertiary Lantern. The lanterns for the traffic signals are 
assigned a priority level according to their visibility to the motorist. 

§ Intersection. Traffic Signals are always located at an intersection- therefore in 
RAMM the intersection is the primary point of reference for the traffic 
signals. In some cases a pedestrian crossing with signals some distance away 
from the main intersection may need to be defined as a separate intersection, 
even though it may share a controller with the main intersection. You can read 
more about working with Intersections (on page 42). 
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§ Pole Numbering. RAMM follows the convention that traffic signal poles are 
numbered clockwise, starting from the Controller unit. 
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NOTE: If the Traffic Signal data is available in the database, it has already been 
collected and needs updating only. If you haven't been supplied with the 
data, you will need to build a Traffic Signals inventory (see "Building a 
Traffic Signals Inventory" on page 44). 

 

Traffic Signals - Components 
A traffic signal has eight basic components. 

§ Lantern. This is the most visible component of the traffic signal system. A 
Lantern may have a type assigned in terms of priority (primary, secondary or 
tertiary), a body type, a lamp type, or a display type (for example left turn, 
right turn, pedestrian). 

§ Controller. This is perhaps the most important component, though it is not 
usually visible to the motorist. The Controller is the "nerve centre" of the 
intersection signal system, and may in fact control more than one intersection. 
A Controller also has a number of sub-components: 

§ Logic Rack.  

§ Detector Card.  

§ Software (for such purposes as Vehicle Preemption).  

§ Communication Device (for example, a dialup modem, multidrop / 
multiplexor) 

§ Target Boards.  

§ Poles.  

§ Pole Attachments (for example, cameras).  

§ Pedestrian Call Boxes / Pedestrian Detectors.  

§ Loops (also known as Detector Loops).  
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§ Cabling.  

 

NOTE: Visors are not recorded separately, since the visor type may be deduced 
from the lantern type. 
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This section tells you how to begin working with RAMM Traffic Signals. 

IN  THIS  CHAPTER 
Working with Intersections.........................................................42 
Building a Traffic Signals Inventory ...........................................44 
Launching RAMM Traffic Signals .............................................45 
RAMM Traffic Signals Workspace .............................................49 
RAMM Traffic Signals Toolbar Buttons....................................51 
Setting Up RAMM Traffic Signals .............................................55 
Setting Up A Contract ................................................................65 
Opening The Contract................................................................71 
Setting Up Call Types.................................................................71 
Setting Up Fault Categories........................................................72 

 
 

Getting Started with RAMM Traffic 
Signals 
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Working with Intersections 
Before you begin working with the actual Traffic Signal assets, you should ensure 
that the Intersections they will be attached to have been generated and marked as 
controlled. Intersections are crucial to locating Traffic Signals. 

Before you begin generating Intersections and setting their status you should also 
check that Intersection Behaviour and Types have been set up - see Maintenance - 
Intersection Behaviour and Types (see "Maintaining Intersection Behaviour and 
Type" on page 182). 

Generate Intersections Using the Map 
Using Mapping (on page 227) to generate your intersection data is quick and 
efficient. 

This is done in RAMM Manager. Select Projects > Intersection > Generate Intersections Using 
the Map. 

RAMM Manager will bring up a dialog warning you that the Map Index may need 
to be recalculated. RAMM will then search the database for intersections and list 
them in the Intersections Grid window. 

There are some occasions on which an intersection will not be generated - such as 
when a road on the map cannot be matched to a road in the database. An exact 
intersection location can be determined when the intersecting roads start or end 
where a carriageway starts or ends. 

NOTE: If the intersection occurs within a carriageway instead of at its beginning 
or end, RAMM Mapping will find it difficult to determine the location 
accurately from the map. In these cases an intersection record will still be 
generated, but it will not have a location. RAMM will calculate the location 
from the data available, and put this into the Notes field as Approximate 
Location ....m. When you have the opportunity, the correct location 
should be entered. 

Two reports are also available in from the same menu in RAMM Manager to help 
manage and verify your intersections. Go to RAMM Manager > Projects and make your 
selection: 

§ Identify Roads without Intersections 

§ Identify Intersections with Invalid Locations. 
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Maintaining Intersections 
To maintain the intersections you've loaded into RAMM, launch the relevant Grid 
window by clicking the Intersections button  on the main RAMM window 
toolbar -OR- click the Intersection button on the toolbar of the main RAMM 
Traffic Signals window. These two Grid windows are different but perform 
essentially the same function. We show the main Intersection Detail window 
below. 

Click the Update button  to edit or change the details. 

 

You can set up intersection types as above. Intersections can occur on a single road, 
to indicate a Pedestrian Crossing or the Traffic Signals at a Fire Station. 

NOTE: You can launch the Traffic Signals window from the Intersection Grid 
and Detail windows as indicated by the mouse arrow above. 

Identifying Controlled Intersections 
Identifying an Intersection as a Controlled Intersection is done manually. In the 
Controlled field of the Intersection Detail window, ensure that Yes is selected. 

NOTE: For more information on maintaining Intersection Locations and 
Navigation Restrictions, see the Using RAMM guide. 

Save  your settings once you're done. 
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Building a Traffic Signals Inventory 
Building an initial inventory of Traffic Signals is necessary when you have no 
Traffic Signal data at all and you need to collect this information from scratch. If 
you already have a Traffic Signals inventory, you can go on to the next step (see 
"Launching RAMM Traffic Signals" on page 45). 

This can be done for an entire network, but more commonly when surveying 
traffic signal assets in a new subdivision. 

4 How To Build a Traffic Signals Inventory 

1 Draw up specifications. It's good to agree on consistency in respect of 
terminology, descriptions etc for all traffic signal assets. For example, referring 
to a Detector Card as AWA MT24B in one place and MT24B in another place 
will cause unnecessary problems with the database. If only one person is 
involved in collecting the information this is less of a problem, but if a team is 
involved there must be a specific method to how it's done. 

2 Collect the information. Below is a checklist of the data you should collect. 

§ Components. Information about the components of each asset (for example, 
information about the light must also include information on the gear and 
the lamp). 

§ GPS co-ordinates. 

§ Location. Information about the location of the asset. The most important 
is the Intersection, but details such as the Road name are also useful. 

§ Feature. Any other useful information about the asset location, for instance 
pole believed to be live. 

§ Photographs. Photographs are useful to illustrate the above, and can be 
attached as multimedia objects in the Traffic Signals window. 

§ Assessment information. If Assessment information is supplied with the 
assets it should be entered into RAMM Traffic Signals. 

3 Record the information. The Traffic Signal asset information you collect can be 
in any format - for example, you can collect your information in an Excel 
spreadsheet on a handheld or laptop computer and CJN Technologies can 
import it into RAMM Traffic Signals. Please contact us (see "Contacting CJN 
Technologies Ltd" on page 23) to inquire about the costs involved. 
Alternatively, you can key the asset information into RAMM Traffic Signals 
yourself. 
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4 Set up the contract. Once your Traffic Signal asset data is in RAMM Traffic 
Signals, you are ready to begin setting up a contract and managing your 
network. For more information, see Setting Up A Contract (on page 65). 

5 Enter the Traffic Signals inventory items. The quickest and easiest way to do this 
from scratch is to use the Traffic Signals Insert Wizard (on page 89). 

NOTE: The Road ID, Location and Side can be generated from the Easting and 
Northing Values.~q is this still true 

 

Launching RAMM Traffic Signals 
There are two main methods of launching the RAMM Traffic Signals application, 
described in detail below. If you need help with setting up RAMM Traffic Signals 
on your computer, see Setting Up RAMM Traffic Signals (on page 55). 

You can also launch RAMM Traffic Signals from inside RAMM main window, 
from the Intersection Grid and Detail window toolbars. 

Launching Installed Versions of Traffic Signals 
On computers running Windows 95 and later, use your Start menu to launch 
RAMM Traffic Signals from the relevant program group. RAMM Traffic Signals 
may be in its own program group or in the RAMM program group, depending on 
how it has been installed. 
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You will next connect to your database. If your database has not been set up for 
you, see Setting Up RAMM Traffic Signals (on page 55). 

RAMM Traffic Signals will show you the database login screen: 

 

The database name should be visible in the Database field - if you have more than 
one database installed click the  to select the one you want from the drop-down 
menu. 

Enter your User Name and Password and click OK, and you will connect to the 
RAMM Traffic Signals main window. 
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Launching RAMM Traffic Signals Via Hosting 
Use a standard web browser (for example Internet Explorer) to connect to our 
website (http://www.cjntech.co.nz). 

Click on the links to RAMM Hosting and Login Here. Enter your Hosting Username and 
Password in the window below and click Login. This will have been supplied to you 
by CJN Technologies earlier. Contact us (see "Contacting CJN Technologies Ltd" 
on page 23) if you can't remember them. 

If you haven't installed the Citrix ICA client you will need to do so first - see 
Setting Up RAMM Traffic Signals On The CJN Hosting Service (on page 56). 
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You will then see a number of icons to launch programs. Launch RAMM Traffic 
Signals from the icon below by choosing either the Full Screen or Seamless 
(windowed) option. 

    

On the Hosting service RAMM Traffic Signals is usually configured to connect 
automatically to your database. 
 



 

 C h a p t e r  5   –   G e t t i n g  S t a r t e d  w i t h  R A M M  T r a f f i c  S i g n a l s  4 9   

RAMM Traffic Signals Workspace 
Here are some of the terms we use for different areas of the RAMM Traffic 
Signals workspace. We describe the RAMM Traffic Signals buttons and controls in 
more detail in RAMM Traffic Signals Toolbar buttons (on page 51). 

Pop-up help 
All buttons and fields in RAMM Traffic Signals have pop-up help. Just hover your 
mouse over a control, button or field and a little pop-up will describe what that 
control or field is supposed to do. 

RAMM Traffic Signals Main Window 
This is the main window you see after starting RAMM Traffic Signals and 
connecting to your database. 

The database you're connected to is always shown in the title bar of the window at 
the top. 

The RAMM Traffic Signals main window has four buttons on its toolbar to 
launch its main function windows- they're described in the section on the Main 
Window Toolbar (on page 52) below. 

 

You can also launch these windows from the Actions menu. Whether you begin 
working with the menu bar or click on any menu link under Home in the main 
section of the window, the result is the same- a sub-menu will open up, and your 
current location in the menu structure will be indicated next to Home. 

RAMM Traffic Signals Working Windows 
The working windows are broadly divided into two areas, the List panel and the 
Detail panel. The Detail panel is itself sometimes divided into an upper and lower 
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section, depending on which function of RAMM Traffic Signals you're currently 
using. 

 

You'll select either dispatches, traffic signals or claims in the List panel on the left. 
In some cases you can view further details of the item in the List panel by clicking 
the + to expand the tree. 

The Detail panel is where you view and enter details for the items you have 
selected in the List panel in corresponding fields. Often the Detail panel will have 
more than one tab, as above, and you can activate each tab by clicking on the tab 
header to reveal the fields you need. You can either type directly in the field or make 
a selection from a drop-down list. These selections are set up beforehand in 
Maintenance (on page 175). 

Some fields are highlighted in a colour to indicate that they are mandatory. 

Note the component selection header at the top of the Detail panel. This is simply a 
visual confirmation of what you have selected in the List panel for your 
convenience. 

The toolbar at the top is where you will find buttons to quickly perform important 
actions- the buttons you see will change according to the window you are 
currently in. These actions can also be selected from the menu bar. If a control for 
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an action is unavailable, it is "dimmed" as above. See RAMM Traffic Signals 
Toolbar buttons (on page 51). 

Using Collapsible Panels 
Some windows in RAMM Traffic Signals have collapsible panels, so you can get 
certain features out of the way when you're not using them. Most Maintenance 
windows have them. 

To expand or collapse these panels, you use the Panel Sizer, the blue marked area 
on the dividing bar between the panel and the rest of the screen with tiny triangles: 

 

Sometimes (in Grid windows and reports) the bar will be horizontal: 

 

The triangles show you the direction the panel will move in when you expand or 
collapse it. 

Click the sizer to expand or collapse the panel. 

TIP: You can also go to the menu at the top of the respective window and 
choose View > Show Layout. 

 

RAMM Traffic Signals Toolbar Buttons 
Every RAMM Traffic Signals window has a toolbar at the top that contains 
buttons for quick access to RAMM Traffic Signals functions. We've described 
them all here for you as a toolbar "quick reference". 

The exact buttons you see on each RAMM Traffic Signals window toolbar vary 
according to the task at hand. If you'd like to know more about a control, hover 
your mouse over any button in RAMM Traffic Signals and a pop-up description 
will appear. This description will also give you the HOTKEY combination for that 
respective action. If disabled, use the ALT key to make them visible. 
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Main Window Toolbar 
These buttons launch the main functions of RAMM Traffic Signals. 

§  Dispatch Entry. For viewing, entering, managing and printing dispatches 
relating to Traffic Signal problems and setting relevant options. 

§  Intersections. To enter and manage intersection information.  

§  Traffic Signals. To view and manage traffic signal units, including poles and 
other components. Replacements and asset updates are also carried out here. 

§  Contract Claims. When dispatch and asset replacement or updating work is 
concluded, claims for the work done are generated and managed here. 

 

Common Toolbar Controls 
§  Add Record. Adds a new record relevant to the window you're in. 

§  Delete Item. Deletes the selected item. 

§  Save Item. Save the current window. 

§  List View. This toggle reveals or hides the List panel (see "RAMM Traffic 
Signals Workspace" on page 49). 

§  Detail View. This toggle reveals or hides the Detail panel. 

§  Previous Item. In a window with a number of records, clicking this button will 
take you to the previous record. 

§  Next Item. In a window with a number of records, clicking this button will 
take you to the next record. 

§  Undo action. Undo the last action you performed. 

§  Filter. This control is to perform actions in the Filter window (see "Filters" on 
page 97). The Traffic Signals and Dispatch Entry windows are filtered by 
default, so if you don't see anything when you open them you may need to 
adjust the filter. 

§  Decision Cube. You can generate analyses of RAMM Traffic Signals 
information in various ways with the Decision Cube (on page 203). 

§  Multimedia. This button is to load multimedia objects into your database- for 
example, digital camera images of traffic signal assets. 

§  Help. Click this button to access context sensitive help from any screen 
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-OR- 

Press F1 on your keyboard. 
 

Dispatch Entry Toolbar Controls 
§  Dispatch Update. When you are in the Dispatch Entry window, if 

this button shows Refresh Dispatches instead of No Dispatch Updates as above, you have 
new dispatches via email from your client. Click the button to refresh the 
Dispatch list in the List panel. 

For a full description of the controls and menus that apply to the dispatch 
management process, see Dispatch Entry (on page 76). 
 

Traffic Signals Toolbar Controls 
§  Add Traffic Signal Item. This button is used for adding new traffic signal 

components to the network quickly. The drop-down list will change 
according to the item currently selected in the List panel as below. 

§ If Controller is currently selected, the following options become available: 

 

 

§ If Detector Card is selected, the following options become available: 

 

§ If Pole is selected, the following options become available: 

 

§ If Target Board is selected, the following options become available: 
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NOTE: If any other component is selected, no further options are available 
beyond the individual component itself. 

§  Replace. Replace an asset. 

For a full description of the controls and menus that apply to the traffic signal 
management process, see Traffic Signals (on page 133). 
 

Status Check Controls 
§  Tick All. Select all the options available for the Status Check. 

§  Tick None. Clear all selections. 

§  Required only. Select options based on the availability of data. 

For more information, see Status Check (on page 269). 
 

Patrols Window Controls 
§  Show Patrol Area. This control is available only in Patrols (on page 153). It shows 

the area that the patrol is responsible for. 
 

Preview Toolbar Controls (for Reports) 
§  Zoom To Fit. Fits the entire page to the preview window. 

§  Zoom To 100%. Actual size. 

§  Fit Width. Fits the width of the page only to the preview window. 

§  Zoom in. Enlarge the text by zooming in each time you click the button. 

§  Zoom out. Reduce the text by zooming out each time you click the button. 

§  Go To First Page. Displays the first page of the preview. 

§  Go To Previous Page. Displays the previous page. 

§  Go To Next Page. Displays the next page. 

§  Go To Last Page. Displays the last page. 

§  Print Report. Brings up the Print dialogue for your default printer to enable 
you to print the report. 
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§  Open Report. Brings up the Open File dialogue to enable you to select a 
previously saved report file and open it. 

§  Save Report. Brings up the Save File dialogue box to enable you to select a 
location and Save As Type and save the report as a file. 

For more information, see Viewing and Saving Previews and Reports (on page 
202). 
 

Setting Up RAMM Traffic Signals 
This section is aimed at the RAMM Traffic Signals Contractor. If you're a RAMM 
Traffic Signals Council client and have purchased RAMM Traffic Signals, then 
this will be made available as part of the RAMM install. The RAMM Traffic 
Signals tables are incorporated in your existing RAMM database, and once the 
software is loaded you'll be able to access them. 

As the new contractor you need to start by setting up your database and your 
contract details. 

If you'd like a quick guide to those actions you need to do most often, such as 
entering dispatches, completing them, updating the network and claiming for 
work done, see Daily Tasks (on page 75). 

Once the work is done, you can generate and keep track of claims for the work. 

Two Ways Of Setting Up RAMM Traffic Signals 
There are two methods of setting up RAMM Traffic Signals- you either install it 
on your computer from a CDROM, or contact us to set up RAMM Traffic Signals 
on the CJN Hosting Service. 

These depend on whether you have been supplied with traffic signal data or not, 
and whether you are using the CJN Hosting Service or an installed version on 
RAMM Traffic Signals. 

NOTE: If you do not have traffic signal data, you will need to go out into the 
field, record information about the traffic signal assets and build the 
inventory (see "Building a Traffic Signals Inventory" on page 44). 
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Setting Up RAMM Traffic Signals On The CJN Hosting Service 
This section deals with setting up RAMM Traffic Signals on the CJN Hosting 
service. If you're not using the CJN Hosting Service, go the next step (see "Setting 
Up RAMM Traffic Signals On Your Local Computer" on page 57). 

To use RAMM Traffic Signals on the CJN Hosting Service, all you need is a 
connection to the Internet and a standard web browser like Internet Explorer. For 
more information on Hosting- click on the link to RAMM Hosting on our website 
(http://www.cjntech.co.nz). 

Before You Log In To The Hosting Service 
§ You need a login Username and Password. The process of setting up the 

Hosting Service generally includes setting up permissions and access levels to 
RAMM Traffic Signals databases, so you should already have your username 
and password by this time. If you need help with this contact your 
administrator or contact us (see "Contacting CJN Technologies Ltd" on page 
23). 

§ You also need to install the Citrix ICA Client. This is a small programme that 
facilitates the connection to RAMM Traffic Signals. If it's not already installed, 
RAMM Traffic Signals will prompt you to download and install it. Our 
Hosting page on the website has a link for this purpose. 

You're now ready to start working with RAMM Traffic Signals (see "Launching 
RAMM Traffic Signals" on page 45). 
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Setting Up RAMM Traffic Signals On Your Local Computer 
This section describes how to install RAMM on your computer, and RAMM 
Traffic Signals with it. 

We assume that you already have your database. If you do not, contact us (see 
"Contacting CJN Technologies Ltd" on page 23). 

NOTE: These options do not apply to the RAMM Hosting Service. 

Installing RAMM 
To install the RAMM software just place the CDROM in the drive. Most 
computers will generally automatically run the CDROM and begin the RAMM 
installation. If this does not happen, use My Computer to open a window for your 
CDROM drive, which will then show the contents of the CDROM disc. Open 
the RAMM_ALL_SETUP folder, and double-click the RAMM_ALL_SETUP.exe file. 

4 How To Install RAMM 

1 The setup process begins with this screen. 

 

Click Next to proceed. 

2 You will now see the License Agreement. Read the license, select the I accept the 
agreement option, and click Next. 

3 You can now choose the installation folder. By default the software will be 
installed in the directory 
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C:\PROGRAM FILES\CJN TECHNOLOGIES\RAMM 

You can click Browse to change this if you wish, and click Next to proceed. 

4 The next screen allows you to customise your installation, and select or 
deselect RAMM applications as you wish. 

 

Click Next when you're done. 

5 Setup will now give you an option to configure and change the options for 
your Windows Start Menu. Click Next when you're done. 

6 In the Select Additional Tasks screen, you can choose not to set up desktop icons. 
Click Next when you're done. 

7 Setup now shows you a final Ready To Install screen as a checklist of the 
installation components. At this point you can select Back and change your 
selections, or click Install to proceed. 
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While the installation proceeds, you will see a progress bar: 

 

8 You will see this screen when Setup is finished. 

 

Click Finish to return to Windows. You're now ready to connect to your 
database and, if necessary, upgrade it. 

NOTE: The directory location is up to you, but please ensure it is placed on 
a drive that is regularly backed up. 

9 When you click OK RAMM Traffic Signals will go through the process of 
loading all the tables and setting up the database. You'll see a series of progress 
windows. Please be patient, this step of the process takes some time. 

10 When the database setup is finished, click OK. RAMM Traffic Signals is now 
up and running. 
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Setting Up Your RAMM Database 
You will generally need to load a RAMM database only if you have never done so 
before. In rare circumstances you may also need to reload your RAMM database 
after a system or machine crash, or configure additional databases to connect to. 

You should have the database file already, either on your computer or in a location 
accessible through your office network. 

NOTE: These options do not apply to the RAMM Hosting Service. 

4 How To Load the RAMM Database 

1 Start up the RAMM software. 

2 Select Database > Maintain List. If you do not have any databases loaded, the 
window will open empty. Click Add to set up a database profile, or Update if 
you're changing the details of a profile. 

3 Select the type of database you have. Contact us (see "Contacting CJN 
Technologies Ltd" on page 23) if you're not sure. 

 

4 Enter the Description of the database. This is what you will see as the database 
name when you connect to it. 

5 Enter the Host Name. This is the name of the computer where your database is 
located. 

6 Enter the Directory where your database is located. 

This varies depending on the sort of Database Type you have chosen. If you've 
selected Informix SE (Unix), it will be a location such as  /usr/roads, and the 
Browse button will be unavailable. If you've selected Informix Dynamic Server 
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(Unix or Windows NT) or Informix Personal Edition (Windows 95 or NT), Host 
and Directory settings are immaterial. If your choice was Informix SE (Windows 
95) you can set a directory path of your choice. The default path is: 

C:\Program Files\CJN Technologies\RAMM\Database 

NOTE: The directory location is up to you, but please ensure it is placed on 
a drive that is regularly backed up. 

7 The Database Name must be the name of the database file supplied to you. 

8 When the database definition setup is finished, you should see something 
similar to this: 

 

9 Click OK to return to the list window, and the database you just set up should 
now appear in the list. 

 

The database is now ready for you to connect to it. See Logging In below for 
more information. 
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Logging In 
Like most applications, the first thing you have to do when you're using RAMM is 
log in. RAMM will verify your login name and password, and may present you 
with other options before it starts. 

If you're using the RAMM Hosting service, RAMM already knows who you are 
from your hosting login, so you won't need to login again. 

Sometimes the entire process of logging in may take only a few seconds, and other 
times it may take quite a few minutes. This depends on how up-to-date your 
database is, the speed of your network and/or Internet connections, and how 
powerful your computer is. 

4 To Log In 

1 Start RAMM Traffic Signals. 

§ If you're using the RAMM Hosting service, you'll start the program from 
your Hosting Applications page on the CJN Technologies website 
(http://www.cjntech.co.nz). Go directly to Step 3. 

§ If you're using a copy of RAMM installed on your computer, start the 
program from your Windows Start menu or Desktop shortcut. 

The Login window appears. 

 

2 You'll see the last database you used in the Database field. You can also select 
another database: 

Select it from the drop-down list  

-OR- 

Click the Cancel button, then when the RAMM main window appears, choose 
Database from the menu, then choose a different database from the list. If you 
don't see the database in the list, you may need to click Maintain List and set up a 
new database. 

3 Type the User Name and Password for the database and click the OK button. 
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4 If RAMM detects that the information stored in your database is not up to 
date, you'll be prompted to run processes to update it, but only if you have the 
correct security permissions. If you do not have permissions, you'll need to ask 
your System Administrator to run the update, and you can jump directly to 
Step 7 now. 

 

§ Click the Cancel button to work with the existing information, knowing 
that it may not be up to date. 

§ Click the OK button to perform the processing first. This may take some 
time, depending on the size of your database and how out of date it is. A 
confirmation window lists all the items that need processing. 

5 To prevent this prompt window from appearing if you login again today, click 
the Don't show this dialog... tickbox so it's ticked, then choose either of the options 
described above. 

6 You may be asked to set options for display of Treatment Length details.  

7 If RAMM detects that the structure of your database is out of date, you'll be 
prompted to upgrade it if you have the correct security permissions. This 
process may take some time, depending on the size of your database and how 
out of date it is. 
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TIP: We strongly recommend that you make a backup of your database 
before upgrading. Click the Backup button to do this. 

 

NOTE: If you do not have permissions, you'll need to ask your System 
Administrator to run the upgrade. 

Click the Upgrade button to begin the database upgrade. 

8 RAMM will ask you to confirm that you wish to upgrade the database. Click 
Yes to start the upgrade process. You'll see progress indicators while the process 
runs. 

WARNING: If you stop the process by clicking the Abort button, your database 
will be unusable without repair by CJN, so we strongly 
recommend that you do not do this. 

 



 

 C h a p t e r  5   –   G e t t i n g  S t a r t e d  w i t h  R A M M  T r a f f i c  S i g n a l s  6 5   

9 If the copy of the RAMM program you're using has recently been upgraded to 
a later version, you can read the changes included in that version. 

 

§ To read the changes, click the Yes button. Your browser shows a page 
describing the changes. 

§ To continue without reading the changes, click the No button. 

§ To prevent this prompt window from appearing again when you login - 
until the next time the RAMM program is upgraded - click the Don't show 
again... tickbox so it's ticked, then choose either of the options described 
above. 

10 The RAMM main window appears. 
 

Setting Up A Contract 
If you've successfully set up RAMM Traffic Signals and connected to your 
database you're now ready to set up your Contract Details, Contract Item 
Activities and Schedule Items. If you haven't, see Setting Up RAMM Traffic 
Signals (on page 55). 

This is a very important step, as it will establish a number of settings for other 
areas of RAMM Traffic Signals. 

You can always return here to make changes, but entering the details as accurately 
and comprehensively as you can at the beginning of the contract is crucial. 

Doing so will help you perform your contract duties efficiently and quickly. 
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Setting Up Contract Details 
From the main RAMM Traffic Signals window, click Maintenance > Contract Details to 
view and work with your contract details. 

If Your Contract Is Already Loaded 
If your contract was loaded when you installed RAMM, you will see the contract 
details when you open this window. If you see a contract already loaded in the 
Contract field, go straight on to setting up Contract Item Activities (on page 68). 
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Adding A New Contract 
If you need to set up a contract from scratch, however, the fields above will be 
blank. To add a contract, click the Add Record button  on the toolbar of your 
window 

-OR- 

Simply start typing in a blank field. 

4 How To Enter Contract Details 

You'll notice that while you are doing the initial input of contract details, the 
words Setting Up are visible on the window next to the Contract ID field. You'll 
now enter contract details and set up Contract Item Activities (see "Setting Up 
Contract Item Activities" on page 68). When that's done, to make the contract 
available you'll need to open the contract (see "Opening The Contract" on page 
71). 

NOTE: All coloured fields are mandatory (you must enter the information). 

1 Enter the Contract name and a unique (user defined) ID number. This may be 
supplied to you by the client. 

2 Enter the start and end dates of the contract in the From and To fields. 

3 Enter the names of the organisations involved in the Parties section and the 
individual Contact for each organisation. 

4 The PMR Payment and Update Asset Information options should not be changed unless 
you are specifically instructed to do so. PMR represents Piecemeal Rate - for 
more information on PMR payments, see Crew Payments (on page 165). For 
more information on updating assets, see Updating Assets (on page 149). 

5 You can record any general comments relating to the contract on the Notes tab. 

6 Enter the names of crew members if necessary on the Crew tab. These can be 
referred to later when claiming for work done. See Crew (on page 167) for 
more information. 

7 Save  the contract details into RAMM Traffic Signals. 

For more information on the Reports menu, see Reports (on page 201). 
 



 

6 8  R A M M  T r a f f i c  S i g n a l s  
 

Setting Up Contract Item Activities 
These are the activity categories for the schedule items you will be entering. 

TIP: For example, within the contract there may be a number of different 
items for replacing lanterns. The breakdown of these items will reflect 
the differing costs for each wattage and type. If you set up "Replacing 
Lanterns" as a Contract Item Activity this enables you to enter all related 
schedule items under the one activity. This allows grouping later on the 
overall cost to replace lamps. 

It's advisable to set these up first before setting up schedule items. 

Close the Contract Details window and select Maintenance > Contract Item Activities from 
the main RAMM Traffic Signals menu. 

 

4 How To Enter Contract Item Activities 

1 Enter the activity categories you need by clicking the Add Record button . 

2 Enter a Code, an Activity name, and descriptive Notes in the respective fields. 

3 Save  the entry. 

4 Repeat steps 1 through 3 as needed. 

5 Close the window when you are done. 
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These activities will become available to you from a drop-down list when you're 
entering the schedule items. 

For more information, see Maintaining Contract Item Activities (on page 179). 
 

Setting Up Schedule Items 
If you've finished entering the general contract details and the contract item 
activities, you're now ready to enter Schedule Items. 

Select Maintenance > Contract Details from the main RAMM Traffic Signals window and 
click the Schedule Items button on the menu. 
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NOTE: The schedule items reflected in this window must reflect the schedule 
items on your contract. You'll need a copy of the contract before you 
proceed any further. 

4 How To Enter Schedule Items 

1 Click the Add Record button  on the toolbar of your window to begin entering 
schedule items. 

2 Item Number. The numbering system you use here should reflect the system in 
the contract itself. This column allows both alphabetical and numeric 
characters, so by using either a space ( ) or a zero (0) before the number, you 
can ensure that your schedule items are sorted correctly. 

TIP: To get items 1 through 11 to appear in the correct order, enter item 
1 with either a space (  1) or a zero (01) before it. Item 2 should be 
entered the same way (   2 or 02) - and so on. 

3 Item Description. When entering schedule items, it's important to enter a 
meaningful description to make working with schedule items easy and 
efficient not just in this window but in RAMM Traffic Signals generally. 

TIP: A long description like Replacement of Gough GL 500 50w Lantern is likely to 
have you searching through a long list of schedule items to get to the 
one you want. Entering the same item as 50w GGL 500 L will make 
things much easier for you. Especially when it comes to replacing 
assets in the Traffic Signals window, simply start typing 50w ..... and 
RAMM Traffic Signals will jump to the 50w items, refining the list 
as you keep typing the description. 

4 Activity. Choose the appropriate contract item activity for the schedule item. If 
you don't have any activities in the drop-down list they need to be set up 
beforehand, from the Maintenance > Contract Item Activities menu (see "Setting Up 
Contract Item Activities" on page 68). 

5 Rate. The rate is optional but the unit indication is mandatory. The rate 
entered here will be used as the default rate when claiming for this item. 

6 Totals. This section requires you to enter an amount as an Allocation for the 
specified schedule item that covers replacement as well as overheads. This can 
be an Agreed amount or an Indicative number only. You can also enter the Hardware 
Cost for comparison if you wish. The Item Count is an estimation of how often 
within the contract you expect to claim for that schedule item. The PMR Rate 
field will be active only if you have ticked PMR Payment (see "Piecemeal Rate" on 
page 166) while setting up contract details. 
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7 Notes. This space is for any notes you wish to attach to a specific schedule item. 

8 Save  each item. Repeat the steps above until all items are entered. 

9 Close this window to return to the Contract Details window, which you can 
also close if you are done. 

 

Opening The Contract 
When you've finished entering Contract Details, Contract Item Activities and 
Schedule Items, you're ready to open the contract and begin work on it. 

If not, see Setting Up a Contract (on page 65). 

In the Contract Details window, click Actions > Open Contract. Depending on the 
permissions that have been set up for you in the Security section, you're now able 
to enter dispatches, carry out replacements, and generate claims on this contract. 
For more information on permissions see Security (on page 271). 
 

Setting Up Call Types 
Call Types describe the source of a fault report - for example a consultant, staff, 
patrol, or a member of the public. Call Types are required on the Dispatch Entry 
window (on page 108), where you will select them from a drop-down list. 

In the main RAMM Traffic Signals window, select Maintenance > Dispatch > Call Types to 
begin setting them up. 
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4 How To Set Up Call Types 

1 Click Add Record  

-OR- 

CTRL+N on your keyboard. 

2 Give your call type a Code and a Description. 

3 Select either Caller, Patrol or Other to define the category for this call type. Your 
selection will be reflected at the bottom of the Detail panel of the Dispatch 
Entry window, and will govern how you record details about how the fault 
was reported. 

4 Save  each entry, and repeat the process for each item. 

5 Close the window to exit when you are done. 
 

Setting Up Fault Categories 
Fault Categories describe the actual faults. Like Call Types, Fault Categories are 
required when you're working in the Dispatch Entry window. 

In the main RAMM Traffic Signals window, select Maintenance > Dispatch Definitions > 
Fault Categories to begin setting them up. 

 

4 How To Set Up Fault Categories 

1 Click Add Record  
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-OR- 

CTRL+N on your keyboard. 

2 Enter a Code and a Fault description. 

3 Save  each entry, and repeat the process for each item. 

4 Close the window to exit when you are done. 

NOTE: Categorising call types and faults into groups allow the client to collect 
statistics on how the faults are reported. For example, if Routine Patrols 
find the greater percentage of faults, it's proof that they are a worthwhile 
expense. 

 





 

  

C H A P T E R  6  

This section outlines the common tasks involved in maintaining your traffic signal 
network. 

IN  THIS  CHAPTER 
Daily Tasks ..................................................................................75 
Other Regular Tasks ...................................................................88 
Traffic Signals Insert Wizard.......................................................89 
Concluding the Contract ............................................................94 

 
 

Daily Tasks 
You're now ready to get started with the regular tasks involved in working with 
RAMM Traffic Signals. 

We've categorised them as follows: 

§ Daily tasks (in this section). 

§ Other regular tasks (on page 88). 

NOTE: The exact frequency of these tasks is up to you, and naturally dependent 
on the stipulations of your contract. Our recommendations are a guide 
only. 

For more information on setting up a new contract, see Setting Up A Contract (on 
page 65). 
 

RAMM Traffic Signals Tasks 
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Dispatch Entry 
Dispatch handling is a key area of RAMM Traffic Signals. 

This is where you'll record all the faults that are found or reported on your traffic 
signal network as a dispatch. 

These dispatches can then be printed and passed on to the maintenance crews. 

Entering as much detail as possible is an important aid to locating the faulty asset. 

This section of the RAMM Traffic Signals guide gives you a quick introduction to 
entering a new dispatch. For more detailed instructions, see Dispatches (on page 
107). 

TIP: For more information on RAMM Traffic Signals windows and controls, 
see RAMM Traffic Signals Workspace (on page 49). 

4 How To Enter A Dispatch 

1 From the main RAMM Traffic Signals window, click the Dispatch Entry window 
launch button  
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-OR- 

Select Actions > Dispatch Entry. 

 

NOTE: When you open the Dispatch Entry window, RAMM Traffic Signals 
filters the dispatches you see to display only current or outstanding 
dispatches. See Filters (on page 97). These include dispatches that 
may have been emailed from your Council, which will be 
highlighted in the List panel. For more information see Email 
Options (on page 124). Completed dispatches are still in the system, 
just not visible. 

2 Click the Add Record button  
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-OR- 

CTRL+N on your keyboard. 

RAMM Traffic Signals now adds a new dispatch to the List panel with a Call 
Status of Entered and records the date and time in the Entered field on the 
Detail panel. 

3 Select a Contract by clicking on the  in the Contract field. If you don't see a 
contract, you need to close this window and set it up (see "Setting Up A 
Contract" on page 65). If the List panel already has dispatches, the contract and 
other details will default to those of the last highlighted dispatch. 

NOTE: Coloured fields are mandatory. 

4 Select the Call Type from the drop down list, and enter corresponding Details in 
the panel below the Location section. If you do not have a list of Call Types, 
you need to set them up (see "Setting Up Call Types" on page 71). 

5 Select the Fault. This can either be a Standard fault you can select from the 
drop-down list, or you can select Other and enter your own. If you have no 
faults in your drop-down list, you need to set them up (see "Setting Up Fault 
Categories" on page 72). 

6 Priority. The default is 5 Days. If you select a priority level in hours, the dispatch 
will be marked with red or orange icons according to the priority level, and 
this will be indicated on the printed dispatch (see "Printing Dispatches" on 
page 79). 

7 Location. The location information should be entered as accurately as possible. 
Select the Feature Side (the side that the asset is located on). You can also leave 
this as the default, Not Applicable. 

NOTE: All other fields in the Location section (Address, Feature, Notes) are 
optional, but remember that the more information you include, the 
easier it will be for your crew to find and fix the fault. The 
information you enter here also depends on how you identify 
features on your traffic signal network. For example, if you prefer to 
identify Traffic Signals by Pole ID, you can configure this section to 
show Likely Pole ID instead. For more information on the other 
fields in the Detail window and on the other tabs, see Dispatches (on 
page 107). It's advisable that you enter at least a possible house 
number or Pole ID - if you don't enter any location information at 
all, your dispatch won't show any poles. 

8 Save  the dispatch into RAMM Traffic Signals. 
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9 Once you've entered the dispatches, you need to print them (see "Printing 
Dispatches" on page 79). 

TIP: To show the Intersection in the list select Options > Show Intersection In 
List. 

 

Printing Dispatches 
Once you've entered your dispatches into RAMM Traffic Signals, you need to 
print them out for your crew so that they can find and fix the faults. 

This section gives you basic instructions on printing a dispatch for your 
maintenance crew. For more advanced printing options related to dispatches, see 
Dispatch - Printing Options (on page 120). 

TIP: For more information on RAMM Traffic Signals windows and controls, 
see RAMM Traffic Signals Workspace (on page 49). 

4 How To Print Dispatches 

1 In the Dispatch Entry window, select Actions > Print Dispatches 

-OR- 

CTRL+P on your keyboard. 

TIP: If you want to print a specific dispatch, in the Dispatch Entry 
window, select the dispatch you want to print in the List panel and 
select Actions > Print Selected Dispatch from the menu 
-OR- 
CTRL + B on your keyboard. 
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2 By default this window is set up to print only the newly Entered dispatches. 
Once the Entered dispatches have been printed they will show as Dispatched in 
the List Panel of the Dispatch Screen. The dispatches will also be updated 
with the date and time the print dispatch process was run. 
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3 Report Selection. What you see on your report is governed by the selections in 
this section. With Full Report selected, you will see a single dispatch per page. 
The number of pages will correspond with the number of dispatches Entered. 

 

NOTE: With Full Report selected, the report will show a number of poles in the 
vicinity of the location details entered. If there is a direct match 
between the location entered and the RAMM Traffic Signals data 
Most Likely will be printed alongside the pole.~q most likely - is this 
true 
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The Summary selection lists the same dispatches but with just the dispatch 
information. 

 

Once you've made your selection, click Preview to see what the report will look 
like or Print to print it directly. Click Close when you are done. Either or both 
types of reports can be printed at the same time. 

4 When you return to the Dispatch Entry window, you'll see the dispatches that 
had a status of Entered have now changed to Dispatched, and the date and time of 
dispatch are also present. 

For the other printing options available on this window, see Dispatch - Printing 
Options (on page 120). 
 

Completing Dispatches 
A dispatch is completed when the required maintenance is done and the asset is 
working. If your crew have seen to the problem, you need to complete the 
dispatch in RAMM Traffic Signals, update the asset/s repaired or replaced, and 
link the work done to a Claim Line. 

4 How To Complete A Dispatch 

1 Open the Dispatch Entry window (on page 108) and select the dispatch you 
wish to complete. 
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2 Select Actions > Complete Dispatch from the menu 

-OR- 

Use the key combination CTRL + O. 

3 RAMM Traffic Signals asks you to confirm your action. Click OK to proceed. 
RAMM Traffic Signals may also warn you if the dispatch is still flagged as 
Entered. Dispatches do not have to be printed before they are completed. 

4 The Call Status in the List Panel will change to Complete and you'll be taken to 
the Maintenance Notes tab to add notes. These maintenance notes will show on the 
Dispatch Summary Report for completed dispatches- see Dispatch Summary 
Report (on page 221). 

 

NOTE: The Completed date of the dispatch will default to the current date, 
but should be changed to reflect the actual date of completion. Click 
the drop-down arrow  on the Completed field to bring up a Date 
Picker to do this. It's important to have the correct Completed date 
as this date is used to calculate response times. 
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5 Click the save button  to complete the dispatch and proceed to the Traffic 
Signals window to update the assets that have been repaired or replaced as part 
of this dispatch. 

 

Replace Asset 
You now need to update the asset register to reflect the actual repairs made by the 
crew. 

The Traffic Signals window will be opened and a filter applied, using the road and 
house number information from the completed dispatch. See Filters (on page 97) 
for more information. 

NOTE: The Update Asset option on the Contract Details window must be 
ticked to enable you to replace an asset as part of the dispatch completion 
process. See Updating Assets (on page 149). 

4 How To Replace The Asset 

1 Select the pole that the work was carried out on in the List panel. You need to 
be absolutely sure to select the correct pole, or you'll replace the wrong asset. 
This is where details like the pole number and pole ID will be crucial. For 
more information see Options - Database (on page 170). 

2 Click the tab for the asset you wish to replace. 

3 Click the Replace Asset  button on the toolbar. 

4 Choose a replacement reason from the drop-down list and click OK. 
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If you don't have Replacement Reasons to choose from, you can click the  
button to set them up. 

The date will default to the Completed date, but you can choose another from 
the date picker if required. 

For more information, see Maintaining Replacement Reasons (on page 186). 

5 Choose the replacement make and model from the relevant list on the asset 
tab. 

 

If you don't have makes and models to choose from, see Maintenance (on page 
175). 

6 Save  the replaced asset. The Date, Dispatch and Reason fields in the 
Replaced row will be updated. 

7 Repeat steps 3 through 6 as needed. 

8 Close the window. When you have finished replacing the assets RAMM 
Traffic Signals will automatically take you to Claims to claim for the repairs 
that were carried out in order to get the asset working. See Claims (on page 
159). 

Your replacement has now been recorded in history, and will be available for the 
relevant reports and analyses. See Replacing Traffic Signal Assets (see "Replacing 
Traffic Signal Assets - ts" on page 150) for more information. 
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Claim Lines 
RAMM Traffic Signals takes you into the Claims module as part of the dispatch 
completion process. If you choose not to continue, you can always manually enter 
the claims window by selecting Actions > Claim Lines from the Dispatch Entry window 
menu. 

Claim Lines represent each part of the work done to repair the asset and are 
created based on the list of schedule items set up for the contract. This is 
equivalent to the amount the Council will be charged for the work. Claim lines 
are grouped together under a claim header. Each claim header reflects a claim 
period, for example monthly, or fortnightly. See Claims (on page 159). 

Claim lines can only be created for completed dispatches. As many claim lines as 
required can be entered during this process. Each claim line is linked to a 
scheduled item in the contract. 

By default, the Claim Lines window shows you only the Detail panel. If you wish 
to view multiple claims, click the List panel button  on the toolbar- see RAMM 
Traffic Signals Toolbar Buttons (on page 51). 
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A claim line must be linked to a claim header so that the amount can be presented 
to the Council. By default the new claim line will be added to the currently open 
header. 

If there is no claim open, you will be prompted to create a claim. 

 

On the other hand, if there is more than one claim open, you will be prompted to 
select a claim. 

 

In both cases, all lines being entered for this dispatch will be linked to this claim. 
For more information, see Claims.  

4 How To Enter A Claim Line 

1 Item. Select the Schedule Item that corresponds to the fault that has been fixed. 
This is the reference for the claim line. By default, the Quantity, Units and 
Rate/Unit are carried across from the item definition. The Claim Amount = 
Quantity x Rate. If one of these values is altered, the other values will be 
updated. 

NOTE: To view all dispatches with more than a specific number of claims 
per dispatch, see Auditing (on page 216). 

2 The Crew name is optional, unless the Piecemeal Rate (see 7. below) applies to 
the contract. Select a crew name from the list. Crew members are entered on 
the Contract Details window while setting up contract details (see "Setting Up 
Contract Item Activities" on page 68). 

3 Where there is some problem about a specific claim, the claim line can be 
flagged Held from Payment on the Claim tab, and the claim line will not appear in a 
claim. The claim line can be reinstated at a later date and then presented for 
payment. 
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4 Claim group codes can be selected on the Claim tab. These will be available to 
you if you have set Claim Groups 1 and 2 to Optional or Required in RAMM 
Traffic Signals Options (on page 169). 

5 You can also enter Notes if necessary. 

6 Dispatch Details. This tab shows details from the dispatch, which are useful when 
viewing the claim line from the Claims window (see "Claims" on page 159). 

7 Payment tab (PMR only). This tab will be available only if the PMR Payment option 
has been activated when setting up the contract (see "Setting Up A Contract" 
on page 65). It shows details of the PMR rate. The contractor may choose to 
mark this claim line for non-payment at this time by selecting Do not Pay on the 
Payment tab. See Crew Payments (on page 165) for a full description of the 
application of the Piecemeal Rate. 

8 Save  each item. You can continue to enter claim lines, and close the 
window when you're finished. 

NOTE: You can enter as many claim lines as you need - in this window 
you're in auto-insert mode, so you can keep adding claim lines. 

When all lines have been entered, close this window. You will be returned to the 
Dispatch Entry window, and you will see that the dispatch call status in the List 
panel will now show as Complete. 

This dispatch is now complete, and you can move on to the next one. 
 

Other Regular Tasks 
There are other tasks in RAMM Traffic Signals that you need to perform at 
regular intervals in addition to daily tasks (on page 75). These can be weekly, 
monthly, quarterly, or at predefined intervals. 

Below are some regular RAMM Traffic Signals tasks and an indication of how 
often they are performed. 

§ Patrols (on page 153). Your patrols are your "eyes and ears" on the street, and you 
need to ensure that patrols are being conducted regularly and efficiently. If 
they are, the dispatches you enter will mainly originate from patrols rather 
than from other sources (the public, staff etc). The frequency of patrols will be 
stated in the contract. 

§ Claims (on page 159). Claims need to be presented to your client regularly to 
ensure that the work flows smoothly and that you make and receive payments 
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on time. Presenting and completing claims are covered in a separate section, 
and are generally done every month. 

 

Traffic Signals Insert Wizard 
This page is a quick guide to inserting Traffic Signals for an Intersection. It will 
guide you through the steps entering the necessary inventory items for the Traffic 
Signals, and in the right order. 

4 Inserting Traffic Signals 

1 Open the Traffic Signals window (on page 134). 

2 Select the Intersection you want to enter Traffic Signals for. You may need to 
use the filter (see "Filter Window" on page 98) to sort your intersections and 
get the one you want. 
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3 Click the Add Record button and select Controller to begin. This will launch the 
Traffic Signals Insert Wizard. 
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The wizard has a number of grids for entering asset details, and each grid 
works in the same way. You can use the standard RAMM Grid layout controls 
to customise the columns that are displayed in each grid, so that you don't see 
columns that you aren't interested in. 

NOTE: Viewing the Grid window behind the wizard as above is a good idea, 
so that you'll see the inventory items as you add them to the 
Intersection. 
 
You can use the Tab key to move quickly from one field to another. 
This also works within grids to jump between columns. 
 
You can use the Insert key and the CTRL + Delete key combination 
to insert and delete records easily within each grid. 
 
When entering inventory items in fields and grid columns, you can 
type the Code for an item to quickly jump to it in the drop-down list. 
 
When entering a number of similar items at once, you can use the 
Duplicate button  to quickly create a new record from the one you're 
working with. Remember to check that all of the details are correct 
for the new item. 

Enter the details for the Controller and the Detector Card(s). 

Click Next to continue. 

4 You can now set up the Poles for the intersection. 
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The Auto-Number button , when enabled, will automatically number the poles 
you add in ascending order. When you've entered all the necessary poles, click 
Next to continue. 

5 You'll now be asked to enter details for each pole, on separate windows, in the 
order you entered them in 3. above. 

 

To attach a Lantern to a Target Board, select the Lantern and choose the 
Target Board to which it is attached in the Target Board column. You may 
find it easiest to enter all your Target Boards first, and then all your Lanterns. 

NOTE: Remember that the Lanterns listed are all Lanterns attached to the 
Controller, rather than Lanterns for the selected Target Board. 
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When you're done, click Next to continue. 

6 You'll see a second screen for Pole 1, to continue entering more inventory 
items. 

 

Enter the details and click Next to continue. 

7 The wizard will now cycle through 4. and 5. above for each pole, to enable 
you to enter the necessary details. 



 

9 4  R A M M  T r a f f i c  S i g n a l s  
 

8 If you entered any Detector Cards in 2. above, the wizard will now ask you to 
enter details for them, including any attached Loops. 

 

The Wizard will repeat this step for each Detector Card in the Controller. 
Click Next to continue. If there are no more Detector Cards to enter, the Next 
button will be dimmed and the Finish button will be active. 

9 Click Finish to return to the Traffic Signals Maintenance window. 

10 Save  your settings. 
 

Concluding the Contract 
At the end of your contract, once all dispatches have been concluded and payments 
collected, the contract is closed. 

This should be done even if you know that the next contract will also be awarded 
to you. 

4 To Close the Contract 

1 Select Maintenance > Contract Details > Actions > Close Contract from the main RAMM 
Traffic Signals window to close the contract. 
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2 A confirmation dialog will ask whether you wish to close the contract. After 
this has been done, no new dispatches or claims can be entered, and no data 
transfers can be done. Click OK. 

3 The contract will now be closed, and marked as such in all relevant screens. 
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This section describes working with filters. 

Filters help you find the data you're looking for quickly. You'll use a database filter 
to narrow down the amount of information that is retrieved from the database and 
sent from the server to your computer. You're only sending the information you 
need across your network, which increases speed and reduces network traffic. This 
is especially important if you're using the CJN Hosting service. 

IN  THIS  CHAPTER 
Filter Window .............................................................................98 
Defining Filters ...........................................................................99 
Saving Filters .............................................................................103 
Loading Saved Filters ................................................................103 
Clearing Filters ..........................................................................104 
Deleting Saved Filters ...............................................................104 

 
 

Filters 
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Filter Window 
To launch the filter, click the  button on the toolbar of the Dispatch Entry or 
Traffic Signals window 

-OR- 

Selecting Options > Edit Filter from the menu 

-OR- 

Use the key combination CTRL+F. 

The screen below is what you see when launching filtering from the Dispatch 
Entry window (on page 108). 
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Defining Filters 
Defining a database filter is simply a matter of selecting the appropriate Field for 
the information you wish to see, defining criteria for filtering in the middle panel, 
ensuring that the Filtered Fields panel reflects the correct criteria you've defined. 

 

The example above shows only a single tab containing criteria for filtering by In 
List. Depending on which Field you select, you may also choose By Value, and By 
Range. 

NOTE: The filter fields are sorted in Logical Order by default. You can change 
this to Alphabetic Order by selecting Options > Alphabetic Order from the filter 
window menu. 

 

Filtering By List 
Some filtering conditions involve a fixed list of values for a field. The field you 
select in the Fields panel must be one that allows you to specify In List criteria. 

Selecting a field will generate a list of lookup values for that field on the In List tab. 
You can choose one or more of the values from the list. If the condition you want 
doesn't match an item in the list, you can tell RAMM Traffic Signals what not to 
look for - by ticking Exclude selected items. 

4 To Filter By List 

1 Select the Field you wish to work with. 

2 Click the In List tab. The available lookups will be listed. 
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3 Tick each value you want to match. You can match as many values as you like. 
In the example below we've chosen to look at the Traffic Signals on three 
specific intersections on Aaronville Way Aarts Avenue. The Filtered Fields 
window will automatically load the relevant Road IDs. 

 

4 If you want to show all the details which do not match the values you selected 
from list, tick Exclude selected items. 

5 Click OK to return to the window you launched the filter from (in this case, 
Traffic Signals) and view the results of your filtering. 

 

Filtering By Range 
Some filtering conditions involve a range of values. For these, you'll use the By 
Range tab. The field you select in the Fields panel must be one that allows you to 
specify By Range criteria. 

4 To Filter By Range 

1 Select the field you wish to work with. 

2 Click the By Range tab. 

3 Select the relationship between the condition and the starting value of the 
range (Greater Than, or Greater Than or Equal To). 

4 Type the value for the start of the range. To make the field blank, click the 
Clear button. 

5 Select the relationship between the condition and the end value of the range 
(Less Than, or Less Than or Equal To). 
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6 Type the value for the end of the range. To make the field blank, click the Clear 
button. 

 

This example would filter to show all lanterns replaced within a given range. If 
you want to show all lanterns replaced outside the range, tick Exclude items in range. 

7 Click OK to return to the window you launched the filter from and view the 
results of your filtering. 

 

Filtering By Value 
This filter option is for finding information by a straightforward one-to-one match 
with a single value. The field you select in the Fields panel must be one that allows 
you to specify By Value criteria. 

4 To Filter By Value 

1 Select the field you wish to work with. 

2 Select the By Value tab. 



 

1 0 2  R A M M  T r a f f i c  S i g n a l s  
 

3 Select the relationship between the condition and the value. In the example 
below we've configured the filter to show Intersection ID 3939. Equal To is the 
most common Field Value. 

 

There are other options available in the Field Value drop-down list: 

§ If you're looking for a word or phrase that's buried somewhere in a text 
field, select Partial Match at Beginning or Partial Match Anywhere. 

§ Select Is Null to find all details where the filter criteria field is empty. This is 
useful, for example, if you're cleaning up your database and you want to 
find only records with missing information in that field. 

§ Select Is not Null to find all details where the filter criteria field is not empty. 
For example, you might use this to find road detail records whose Notes 
field has something entered in it. 

4 Type the value (unless it's not needed). Click the Clear button to clear the filter 
criteria field. 

5 Click OK to return to the window you launched the filter from and view the 
results of your filtering. 
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Saving Filters 
Saving your filters is very important. It safeguards the work you've done 
configuring the filter, and you can also easily load the filters and apply them to 
your network with a few mouse clicks. See Loading Saved Filters (on page 103) for 
more information. 

Saved filters can also be loaded, changed, and saved under a different name using 
the Save As menu option. 

4 To Save a Filter 

1 Define the filter (see "Defining Filters" on page 99). 

2 From the filter window, choose File > Save As. The first time you save a filter 
you will be required to give it a name. The Save As filter dialog box appears. 

 

Type the name you want to use for the filter - make it something meaningful, 
so you'll know what it does when you're looking at a list of filters to load. 

NOTE: The Save option is for saving edits to an existing filter. 

3 Choose OK to save the filter. You're returned to the filter window. 
 

Loading Saved Filters 
You'll probably find yourself working with the same filter settings more than once, 
so RAMM Traffic Signals makes it easy to load any filter you've previously saved 
(see "Saving Filters" on page 103). 

4 To Load a Saved Filter 

1 Launch the filter window (on page 98). 

2 Clear any currently active filters if necessary by selecting File > Clear. 

3 Choose File > Load Filter > [Saved Filter] from the menu. 
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4 The selected filter's settings are displayed. You can now edit them and save 
them under a different name if you wish. 

5 Apply the filter's settings by clicking the OK button. 
 

Clearing Filters 
When you're working with filters, it's important to clear the currently applied filter 
if you don't want the existing settings added to your settings. 

There are two places in RAMM Traffic Signals where you can clear filter settings - 
inside the function window you are using (the Dispatch Entry window or the 
Traffic Signals window) or inside the filter window itself. 

4 To Clear Filters from the Dispatch Entry or Traffic Signals 
Window 

§ Select Options > Clear Filter 

-OR- 

CTRL + L on your keyboard. 

4 To Clear Filter Settings in the Filter Window 

§ Select File > Clear from the menu. 

If the saved filter is one you won't need again it can also be permanently deleted 
(see below). 
 

Deleting Saved Filters 
Every now and then, you'll want to get rid of a database filter that you've saved (see 
"Saving Filters" on page 103). 

4 Deleting a Saved Filter 

1 Launch the filter window (on page 98). 

2 Choose File > Delete Filter from the menu. The Delete Filter window appears. 
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3 Select the filter you want to delete, then click the OK button. The filter is 
deleted immediately and the filter window reappears. 
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This section describes actions related to dispatches. 

A dispatch is created for each call taken or problem raised with regard to a fault on 
the traffic signal network. Each dispatch is entered under a contract name and 
allocated a unique system generated number. Details of the person reporting the 
problem, the date and time of the call, and a description of the problem are all 
logged. 

IN  THIS  CHAPTER 
Dispatch Entry Window............................................................108 
Dispatch - General Tab.............................................................110 
Dispatch - Maintenance Tab.....................................................111 
Dispatch - Progress Tab............................................................112 
Dispatch - Audit Info Tab.........................................................114 
Dispatch - Actions .....................................................................114 
Dispatch - Options....................................................................118 
Dispatch - Printing Options .....................................................120 
Automatic Dispatches................................................................123 

 
 

Dispatches 
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Dispatch Entry Window 
You can access the Dispatch Entry window directly from the RAMM Traffic Signals 
main window toolbar by clicking the Dispatch Entry window button  

-OR- 

Select Actions > Dispatch Entry. 

 

When the Dispatch Entry window is open, if you are at the beginning of a contract 
and haven't entered any dispatches, you won't see any dispatch information. For an 
introduction to entering new dispatches, see Dispatch Entry (on page 76). 

By default it shows you only the dispatches with a Call Status of Entered, Dispatched 
or Loaded Data, though you can use the Filter button  to change what you see 
here. See Filters (on page 97) for more information. 

§ Contract. Since every dispatch is linked to a contract, that's what you see at the 
upper right hand of the Detail panel. If you have more than one contract active 
you'll be able to select a different contract to associate the dispatch with from 
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the Contract drop-down list. For more information, go to Setting Up a Contract 
(on page 65). 

§ Dispatch ID. The Dispatch ID is generated by RAMM Traffic Signals, and is the 
unique identifier of a job within a contract once it has been entered into 
RAMM Traffic Signals. 

§ External ID. This field allows you to enter a reference to another system - for 
example, the system of origin. Some councils have their own fault logging 
systems, dealing with problems not necessarily confined to Traffic Signals. 
References to these faults can be any combination of numbers or letters- for 
example, 267025.A106. You can then use the Filter to search for an External 
ID or ID range, return to this dispatch, view what work was done and how 
much was claimed on it. 

The external ID will be automatically entered if received via email. 

§ Type. This field is related to the Panel 4 - Caller Details field below, and refers to the 
person who reported the problem- for example a Routine Patrol, a member of 
the Public, or Other. See Setting Up Call Types (on page 71) for more 
information. 

§ Fault. This can be selected from a Standard list, or by clicking Other, a unique 
fault entry can be made. See Setting Up Fault Categories (on page 72) for 
more information. 

NOTE: All coloured fields are mandatory. 
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Dispatch - General Tab 
This section describes the panels on the General tab. Except for the Location Panel 
all other panels are optional. They will be visible depending on the RAMM Traffic 
Signals Options you've selected (see "RAMM Traffic Signals Options" on page 
169) and the Call type. 

 

§ Panel 1 - Intersection. You can enter details about the Intersection in this field. A 
Road name and Intersection can be selected from the list. Feature relates to an 
obvious landmark in the vicinity, and you can also specify a Feature Side. Use 
Notes for any extra comments as above. All of this information is printed on the 
Dispatch Form (see "Dispatch - Printing Options" on page 120). 

§ Panel 2 - Dispatch Groups. This panel will be available to you if you have set 
Dispatch Groups 1 and 2 to Optional or Required when configuring RAMM 
Traffic Signals Options (on page 169). To configure the drop-down lists, see 
Maintaining Dispatch Groups (on page 191). 

§ Panel 3 - [Caller Type] Details. This panel corresponds to and expands on the call type 
which has been selected in the Dispatch Entry Window (on page 108). For 
example, if Patrols is selected as the call type, this panel will contain further 
options to enter patrol details, and you will be able to select a patrol from the 
list available. Alternatively, the call type may be classified as Caller or Other, in 
which case this panel will be labelled Caller Details or Other Details. If so, 
enter details about the caller or company representative responsible for the 
call. A caller might call back, and if the contact name(s) are entered correctly 
then this information can be filtered on. See Setting Up Call Types (on page 
71) for more information. 
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TIP: Be consistent with the use of upper and lower case when entering 
names. 

 

Dispatch - Maintenance Tab 
The Maintenance tab of the Dispatch Entry window allows you to enter notes related 
to completing a dispatch. 

 

These notes can then be included on the Dispatch Summary Report (on page 
221). 
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Dispatch - Progress Tab 
Progress details about a job are displayed on the Progress tab of the Dispatch Entry 
window. In the example below we've also shown you the full window to 
demonstrate how the List panel indicates the presence of progress records. 

 

They consist of an optional user-defined Event Code, Event ID, and Council 
Code (which is available if this dispatch was sent from a Council/Call Centre). 
The message itself is the only field which is mandatory. 

There are two ways in which progress records can be created. Both apply only to 
Contractors. 

1 A progress record may be created during the automatic creation of a dispatch 
from data included in the email from the Council or their Call Centre - see 
Automatic Dispatches (on page 123). 
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The existence and status of the record will be indicated by an icon in the List 
panel. 

§  Unread progress record 

§  Read progress record 

§  Unread emergency progress record 

§  Read emergency progress record 

If the priority level on the Dispatch is changed, the icon will change to reflect 
this (for example, the highlighted dispatch for Aarts Avenue in the example 
above). 

2 You may enter progress records yourself on this tab by clicking the New button 
at the bottom right of the tab. These records may be for your own information 
(as a 'progress note'), or for sending progress messages back to the Council (if 
the messages are for dispatches that were originally created automatically from 
emails). 

If you wish to send progress information, you must click the Send Email box 
after entering the message (see below). This way the Council can be informed 
that the problem has been passed on to the electricity supplier or that you're 
waiting for repair / replacement parts. 

 

~q check whether send email option is still available 
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Dispatch - Audit Info Tab 
The Audit Info tab of the Dispatch Entry window Detail panel will be shown only if 
you have enabled sending and receiving by email. 

 

The information you see is generated from automatic emails, and enabled by the 
following selections on the Email tab in Email Options window: 

 

See Email Options (on page 124). 

Any or either of these options can be selected. 

In each case, the relevant date (of entry, dispatch and/or completion) will be 
shown on the Audit Info tab. 
 

Dispatch - Actions 
Select Actions from the Dispatch Entry window menu to access a number of 
dispatch related tasks. 

Actions for dispatches that have a Call Status of Entered or Dispatched: 

§ Complete dispatch (see "Completing Dispatches" on page 82). You'll use this 
option to complete the dispatch and enter a claim line when all required 
maintenance work has been done. 
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§ Transfer Dispatch (on page 116). This option is used if more than one call is logged 
for the same fault. 

§ No Further Action (on page 117). Occasionally, you may wish to select this option 
to manually close a dispatch if no further action on it is required. 

Claims and Traffic signal related actions: 

§ Claim Lines (see "Claims" on page 159). This option enables you to manually 
enter a Claim Line if there are existing claim lines for the dispatch- these will 
be shown when this window opens. 

NOTE: Claim Lines that have appeared on a claim cannot be pre-dated or 
closed. 

§ Traffic Signals (on page 133). This option takes you into the Traffic Signals 
window. It applies a filter to the dispatch data, using the house number and 
roadnames from the currently selected dispatch, and generates a list for all the 
assets in the vicinity. This option is available for all dispatches except those 
with a status of Loaded Data. 

The actions are available only to contractors, and relate to automatic dispatches (on 
page 123). 

§ Email. 

§ Email Options (on page 124). You can set up the various options for emailing 
dispatches here. 

§ Load Dispatches / Events. 

§ Dispatch Auto Process. 

§ Enter Loaded Dispatch. 

Other actions on this menu are reporting and analysis related. 

§ Dispatch Analysis. This brings up the Decision Cube (on page 203) where 
standard groupings (for example Call Type, Fault) are available for obtaining 
performance statistics. An overview dispatch analysis is also available by 
selecting Reporting > Contract Management > Dispatch Analysis from the main RAMM 
Traffic Signals window. 

§ Printing Dispatches (see "Dispatch - Printing Options" on page 120). 

~q last option is Duplicate External ID Report - does this need to be 
documented? 
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Transfer Dispatch 
When two calls are received about the same fault, this option allows the calls to be 
linked so that only one dispatch printout is produced. 

It's important that all calls are logged in the database - it takes the same time to 
handle a call even if it is about a known problem.  This option is designed to allow 
for this and avoid confusing dispatch crews with duplicate dispatch forms. 

CAUTION: Don't transfer a dispatch that already has work recorded against it. 
Always transfer a blank dispatch to the main dispatch. Also, completed 
dispatches should not be transferred - link the new dispatch to the 
completed one. 

4 How To Transfer A Dispatch 

1 In the Dispatch Entry window (on page 108), select the dispatch you wish to 
transfer. 

2 Select Actions > Transfer Dispatch to bring up a list of all dispatches. 

 

NOTE: If the list is too large, you can limit it to 30 days by selecting Options >  
Limit Transfer List (30 days) from the Dispatch Entry window menu. 

3 You can now select the dispatch to transfer to (the dispatch that duplicates the 
one you've currently selected in the Dispatch Entry window List panel). Click 
OK. 
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4 RAMM Traffic Signals will show you a confirmation screen identifying the 
two respective dispatch numbers. Click OK to continue. 

5 The dispatch that was transferred will now show as Transferred in the List 
panel. (If you do not see it, you need to select Options > Clear Filter to clear the 
default filter and view all dispatches). When viewing the dispatch that has been 
transferred, you can view the other dispatch by clicking the Transferred To button 
in the upper right of the Detail panel. 

 
 

No Further Action 
Occasionally situations arise where even though a problem has been reported and 
a dispatch entered, no further action is required. 

In the Dispatch Entry window, select Actions > No Further Action. 

The user is prompted to confirm this selection:  

 

The call will remain logged in the system, but as no work was carried out and no 
claims were made, no action was taken. The status will be shown as No Action 
Required, and the Completed date will be set to the current date. 
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Change Contract 
You can change the contract for a particular dispatch if necessary. This is only 
applicable if there is more than one open contract in the database. 

The dispatch will be given a new dispatch ID. 

4 How To Change The Contract 

1 Select the dispatch. 

2 Select Actions > Change Contract from the Dispatch Entry window menu. 

 

3 Choose the contract to switch to from the drop-down list. 

4 RAMM Traffic Signals will ask for confirmation for this action, and return 
you to the Dispatch Entry window once it is completed. 

 

Dispatch - Options 
Select Options on the Dispatch Entry window menu for a number of options for 
sorting and viewing dispatches. The Dispatch Entry window is filtered by default - 
see Filters (on page 97) for more information and advanced options for filters. 

§ Show Unread Progress. Selecting this option includes dispatches which have unread 
progress records, in addition to the filtered items, in the List panel. See 
Dispatch - Progress tab (on page 112) for more information. 

§ Show Contract No. In List. This allows you to see the contract number alongside the 
dispatch number in the List panel. This is useful if the dispatches in the list 
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belong to more than one contract. It's shown in the List panel in the format 
Contract ID/Dispatch ID. 

§ Show Intersection In List. This option, if selected, will show the Intersection and 
Road name in the List panel. 

§ Limit Transfer List (30 days). This option is to limit the list of dispatches shown when 
choosing to transfer a dispatch. Selecting it will restrict the list to those that 
were entered within the last 30 days. 

§ Limit Patrol List (3 months). This option limits the list of patrols available on the 
Detail panel when Patrol has been selected as the call type. It shows only those 
patrols that were begun within the last three months. 

These options allow you to personalise the way RAMM Traffic Signals works for 
you. When you leave the dispatch window, your current settings are saved so they 
can be reapplied when you next open the Dispatch Entry window. This saves you 
having to set up everything again. 
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Dispatch - Printing Options 
This section discusses the various options on the Print Dispatches window. For a 
quick introduction to printing dispatches for your maintenance crew, see Printing 
Dispatches (on page 79). 

 

§ New. Prints all those dispatches which have been entered into the system, and 
have a status of Entered. If the Update printed/exported dispatch status to 'Dispatched' 
option is ticked (default), the call status of these dispatches, once printed, will 
show as Dispatched. The dispatch forms can now be handed to the crew so that 
the repairs can be done. 

§ Completed. Prints those dispatches with a status of Completed between the dates 
selected. By default RAMM Traffic Signals will show a date range for a 
complete month. 
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You can also further specify a response time (in days) taken to complete a 
dispatch, or all completed but unclaimed dispatches. 

 

§ Outstanding. Prints those dispatches that have previously been printed but have 
not been completed. This option also brings up a date range, as above. 

Outstanding dispatches will be printed with the word COPY on them to 
indicate that they have been printed more than once. 

§ All. Prints all dispatches for the chosen contract within an entered period (date 
range shows as above). 

§ List. Prints those dispatches that are shown on the left hand display panel as a 
result of the chosen filter. 

§ Selected. Prints only the current dispatch. While in the Display Entry window 
CTRL + B has the same result. 

§ Claims. Prints those dispatches associated with a specific claim number. Claim 
lines can only be printed for a completed dispatches. Selecting this option 
brings up a drop-down list from which you can select a Claim Header. 

 

§ Loaded Data. Prints those dispatches which have been created automatically from 
emails, and still have a status of Loaded Data. A date range is available for this 
options also. 

NOTE: When entering a date range, ensure that the start date is prior to the end 
date. 

Report Formats 
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Two report formats are available : 

§ Full Report - one dispatch per page, giving asset specifications, giving poles 
located up to 5 house numbers away on either side of the entered location. 

§ Summary - multiple dispatches per page, giving a brief description only. Further 
options here include the printing of Claim Lines and any Notes pertaining to 
the dispatch. 

Either or both may be selected, depending on which initial selections have been 
made. 

Order By 

 

This box allows you to select the printing order according to the options listed. 
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Automatic Dispatches 

Receiving Emails and Converting them into Dispatches 
RAMM Traffic Signals can interface directly with a service call centre, and 
dispatch information can be sent via e-mail between the two systems in a 
predetermined format. This section covers the process of setting up RAMM 
Traffic Signals for this purpose, and the options available (see "Email Layout 
Types" on page 127). 

Once the e-mail has been successfully received and converted a dispatch is created. 
It is then added to the list of dispatches in the Dispatch Entry window list panel 
with the status Loaded Data (see "Receiving Loaded Dispatches" on page 130) to 
distinguish it from manually entered dispatches. 

Error Correction 
In the event of incorrect or incomplete data being sent in the e-mail, you can set 
up defaults to override these errors. In the case of more serious errors, however, 
the email data will not be converted. You'll be able to save and / or print out the 
email containing the errors and process them manually. 

Flexibility of Operation 
You have a certain amount of flexibility with regard to how the system is used. For 
example, once the basic options have been set up, it can be set to be completely 
automatic (you don't need to initiate email connections or be involved in 
converting the data if it is valid). Alternatively, you may prefer to view the dispatch 
after the initial processing has been done to edit or add data before the dispatch is 
added to the database. You can also choose if and when the email connection is 
established to retrieve the emails. 

Creating Dispatches From Other Sources 
A further option enables you to read a file into the RAMM Traffic Signals system 
even if it may have come from another source (for example from a Patrol), as long 
as it matches one of the specified email layout types. 

Dispatch Related Events 
You can enter information about the progress of a job in the relevant window on 
the dispatch, and have this automatically emailed to the Council. Communications 
of this nature are named events, and can have unique IDs. See Dispatch - Progress 
tab (on page 112). The Council can also send additional information about the job 
to you via events- you'll be notified on the Dispatch Entry window that there are 
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new events to view. Events cannot change the status of a dispatch (for example, re-
open a completed dispatch). All events are stored in the progress table. 
 

Email Options 
This section describes how to set up RAMM Traffic Signals to receive emails, and 
what defaults apply to the dispatches generated from those emails. 

 

4 How to Send and Receive Files via Email 

1 From the main RAMM Traffic Signals window, select Actions > Email Options 

-OR- 

In the Dispatch Entry window, select Actions > Email Options. 

2 Set the layout Type. The Standard layout is the default. The RFS layout was 
designed specifically to meet the needs of Waitakere City Council. For details 
of how the emails should report the information, see Email Layout Types below. 

3 Tick Receive files via EMAIL to activate this facility. If you don't tick this option, you 
will only be able to load dispatches and progress records from text files which 
have been saved on your computer. See Automatic Dispatches (on page 123) 
for a full description of both of these options. 

4 In the Description field, enter a descriptive name for the EMail Options 
record, followed by an optional three character code identifying the contractor 
who will be using this facility. 

5 Select the Contract that the emails will be linked with from the drop-down list. 

6 When the emails are processed into dispatches, there are some fields that are 
required information. The fields in the panels below the Contract panel are to 
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set the defaults for this information, and under which conditions they will 
apply. 

You can select the Call Type and Fault. Ticking If Blank will enter the information 
only if the corresponding field in the email is blank, and ticking If In Error will 
enter the information only if the corresponding field in the email is incorrect. 

If the relevant Required switches have been set on the Optional Groups tab of 
the RAMM Traffic Signals Options window (see "Options - Optional 
Groups" on page 171), the panels below will also be activated, and you have 
the same options for information and condition settings on these panels too. 

7 Connection Settings. The Email tab contains the settings for the type of connection 
you have to email and the Internet, and allow you to enter information such as 
passwords, mail server addresses etc. You may need to talk to your Network 
Administrator (if you're using a Local Area Network or LAN) or your Internet 
Service Provider (if you're using a stand-alone computer that you connect to 
the Internet for email and web services using a modem). You can also contact 
us (see "Contacting CJN Technologies Ltd" on page 23) if you need help on 
these settings. 

 

Here's a brief description of the sections you see on the Email tab in the image 
above: 

The Connection section is where you choose how you connect to the Internet. 

§ Use Local Area Network (LAN). Select this option if your computer is on an office 
network. 

§ Use Dialup Networking (DUN). Select this option if you use a modem to connect to 
email and the Internet via an Internet Service Provider (ISP). You should 
already have a connection available for selection from the drop-down list - 
if not, you will need to get the relevant information below from your ISP 
and set it up by clicking the Add Dialup Networking Connection  button. 
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The following sections contain settings that you need if you selected Use 
Dialup Networking (DUN). 

§ Receive (POP3) and Send (SMTP) Server settings. Typically they are 
pop3.yourisp.net.nz and smtp.yourisp.net.nz - sometimes both receive and 
send servers have the same address, such as mail.yourisp.net.nz. 

§ Port. It's very rarely that the port settings change from 110 to receive and 25 
to send - don't change these unless specifically instructed. 

§ User. You will definitely need a username to receive email - in rare cases 
you also require a username to send email. Enter the username/s here, and 
remember they are usually case sensitive. 

§ Password. Enter your password - it should also be case sensitive. 

§ Receive Address. This is your email address for receiving email dispatches 
from the Council. 

§ Send Address. This is optional, and is simply an alternative email address for 
replies to the automatic emails you send (see below). The Send to field is 
very important - here you'll enter the email address at the Council that the 
automatic emails (see below) will go to. 

§ The option to Send using UU Encoding is a specific email format. Don't select 
this unless specifically instructed. 

The panel at the bottom chooses which functions in RAMM Traffic Signals 
will Send an automatic Email when they are selected. You should consult the 
Council on when they would like to receive automatic emails from your 
system. 
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Email Layout Types 
This topic describes the fields needed for the Standard and RFS layout types to be 
able to receive emailed dispatches. 

You can use any pipe ( | ) delimited text file. 

Standard Layout 
Most Councils use the standard layout for email dispatches. The fields you can 
include are listed below- the only mandatory fields are Road Name and Notes. 

Field Remarks / Instructions 
Contract ID  

Call Type  

Fault Type  

External ID  

Priority  

House No.  

Road Name Mandatory Field 

Caller first name  

Caller surname  

Caller phone no.  

Feature side  

Feature description  

Likely Pole ID  

Dispatch Group 1  

Dispatch Group 2  

Notes Mandatory Field 
     



 

1 2 8  R A M M  T r a f f i c  S i g n a l s  
 

RFS Layout 
The RFS layout is much more detailed. It is currently used only by the Waitakere 
Council, and has the ability to interface directly with their Call Centre. Fields are 
as below: 

Field Remarks / Instructions 
Rfs Number Prefixed number with "RFS " 

Transmitted Date and Time, format- dd/mm/yyyy 99:99 

RFS Type For example- L01 

Rfs Type Description  

RFS Received Date and Time, format- dd/mm/yyyy 99:99 

Action required by Officer Code 

Action required by Officer Name 

Priority Normal or Emergency only 

Property code  

Property Owner's 
name 

 

Property address1 For example- House number 

Property address2 For example- Street name 

Property address3 For example- Suburb 

Property address4 For example- City 

Complainant code  

Complainant's first 
name 

 

Complainant's 
surname 

 

Complainants 
address1 

For example- House number 

Complainants 
address2 

For example- Street name 
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Complainants 
address3 

For example- Suburb 

Complainants 
address4 

For example- City 

Complainants ph nos: 
pvt 

 

Complainants ph nos: 
bus 

 

Complainants ph nos: 
mobile 

 

Enquiry details RFS details, 1 - 80 Char 

Enquiry details RFS details, 1 - 80 Char 

Enquiry details RFS details, 1 - 80 Char 

Response by Date and Time, format- dd/mm/yyyy 99:99 

Completion by Date and Time, format- dd/mm/yyyy 99:99 

Latest event number  

Latest event code  For example- RP, CC 

Latest event 
description: line 1 

Max 80 Characters 

Latest event 
description: line 2 

Max 80 Characters 

Latest event 
description: line 3 

Max 80 Characters 

Latest event 
description: line 4 

Max 80 Characters 

Latest event 
description: line 5 

Max 80 Characters 

Latest event 
description: line 6 

Max 80 Characters 

Latest event 
description: line 7 

Max 80 Characters 
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Latest event 
description: line 8 

Max 80 Characters 

Handling Officer 
Code 

For example- CC7 

 
 

Receiving Loaded Dispatches 
This section describes the process of receiving emailed dispatches in the RAMM 
Traffic Signals Dispatch Entry window. 

NOTE: For information on setting up and activating the receiving of emailed 
dispatches see Email Options (on page 124). For information on the 
formats you should use to create dispatches from emails, see Email 
Layout types (on page 127). 

The frequency of the emails and options for automatic sending and receiving can 
be configured in the Dispatch Entry window from the Actions > Email menu. 

§ Auto Send/Receive. In the image above this is currently inactive - clicking on this 
option will show a tick next to the option to indicate its status. When this is 
ticked, sending and receiving email will occur automatically at preselected 
intervals. 

§ Change Interval. The interval for automatic sending and receiving is originally set 
at 10 minutes, but can be changed. 

§ Send/Receive now. The email check can also be initiated manually as required by 
selecting Send/Receive Now. This option is available only if Auto Send/Receive is 
turned off. 
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§ View Import Errors. If the format of the email is incorrect or data corruption occurs 
for any reason, the resulting errors can be viewed here. If any errors are found 
in the incoming data, an error message will explain that errors have been 
found. You can correct the errors using the correction screen. 

 

Once they are corrected, the emails will be reprocessed. 

NOTE: If errors are found in incoming data, a dispatch will not be created 
for this data until it has been corrected and successfully input. 

When the email check is finished and new dispatches have been received, the 
Dispatch Update button  on the Dispatch Entry window toolbar 
will alert the user by showing the caption Refresh Dispatches in red. When this 
button is pressed, the window will be updated to show the new dispatches which 
have been received. See RAMM Traffic Signals Toolbar Buttons (on page 51) for 
more information. 
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Confirming the Intersection on Loaded Dispatches 
When an email or text file has been successfully received and processed, a dispatch 
will be produced and will appear in the Dispatch Entry window List panel. 

This type of dispatch is entered into RAMM Traffic Signals with a status of Loaded 
Data, to distinguish it from a manually entered dispatch. 

When RAMM Traffic Signals receives a Loaded Dispatch it will attempt to identify 
the Intersection from the emailed description. Where it is successful, this 
information will show in the dispatch. 

If the Intersection field is blank, however, this means that it could not be 
determined. This could be because the intersection was spelt wrong, is not yet in 
the database, or that there were too many intersections to choose from. 

At this point, therefore, it's important that you select the correct intersection from 
the list manually and save the dispatch. This will give the maintenance crew a 
more precise location, and also help to identify the job more accurately within 
RAMM. 
 

Changing Call Status On Loaded Dispatches 
Once you've viewed the data entered into RAMM Traffic Signals via the automatic 
process, and you're satisfied that everything is correct, you should change the 
status of the dispatch from Loaded Data to Entered. 

To do this select the dispatch in the List panel in the Dispatch Entry window, and 
then select Actions > Enter Loaded Dispatch from the menu 

-OR- 

CTRL+E on your keyboard. 

You can also configure RAMM Traffic Signals to do this automatically by selecting 
Actions > Dispatch Auto Process, in which case all automatic dispatches will be created 
with a status of Entered directly. 

 



 

  

C H A P T E R  9  

This section describes the Traffic Signals window and the many actions you can 
perform within it for Traffic Signal asset maintenance. 

IN  THIS  CHAPTER 
Traffic Signals Window.............................................................134 
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Traffic Signals - Lantern ...........................................................145 
Traffic Signals - Pedestrian Call Box ........................................146 
Traffic Signals - Attachment .....................................................147 
Traffic Signals - Cabling ...........................................................148 
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Asset Valuation in RAMM Traffic Signals................................151 

 
 

Traffic Signals 
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Traffic Signals Window 
On the main RAMM Traffic Signals window, click the Traffic Signals launch 
button . 

At this point no information has been asked for, so the window will open empty. 

NOTE: This section is intended to cover working with existing assets and 
maintaining them, though you can add and delete assets if required. If 
you want to set up Traffic Signals assets from scratch, the best way is to 
use the Traffic Signals Insert Wizard (on page 89). 
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You'll need to manually define a filter to bring up the intersections you need and 
begin working with Traffic Signals. 

NOTE: The same window will show different information if launched from the 
Dispatch Entry window Actions menu. When you do so, a filter relevant to 
the dispatch you're processing will be applied automatically- this is to 
help you locate the assets described in your dispatch and work with 
them. 

Click the Filter  button on the toolbar, define and apply your filter. See Filters 
(on page 97) for more information. 

Traffic Signals Window Detail Panel Tabs 
Once you've done so, the Traffic Signals window will show you the individual 
Traffic Signals and attached assets in the List panel on the left in a tree hierarchy. 
The details for the selected asset on the various tabs of the Detail panel. 

For an idea of how these assets are related to each other in a 'real-world' 
intersection situation, see Traffic Signals - Components (on page 39). 

Maintaining Traffic Signal Asset Details 
To add or edit the selection available from the various drop-down lists, read the 
Maintenance section (see "Maintenance" on page 175). 

NOTE: For more information on the Condition and Assessment tabs available for each 
asset in the Detail panel, see Condition and Assessment in RAMM 
Traffic Signals (on page 197). 
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Traffic Signals Window Controls 
The View menu contains a number of options to find the asset you want as quickly 
as possible. Auto Expand is a key function - it will automatically expand the assets in 
the List panel. Auto Collapse is similar - as you select a different asset, it will 
automatically collapse the previously expanded items. 

Each tab contains information about the assets at the current location.  You can 
navigate through the assets either by using the List panel to the left or the Next Record 

 and Previous Record  buttons on the toolbar (see "RAMM Traffic Signals 
Toolbar Buttons" on page 51). 
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Traffic Signals - Intersection 
Selecting the intersection in the List panel of the Traffic Signals window brings up 
its details in the Detail panel on the right. 

 

Select the tab you require to view the intersection details as required. Unlike the 
other items in the tree view, most details for an intersection in this window are 
view-only. 

§ General. This tab is essentially a summary of the information on the other tabs, 
and an indication of the status of the intersection - you would need to 
maintain this information on other tabs or in a different part of RAMM 
Traffic Signals. For example, the Controlled field shows its control status. If you 
need to change the intersection's control status you need to do so from the 
Intersections window (see "Working with Intersections" on page 42). 

§ Location. This tab shows the Road details. 

§ Miscellaneous. This tab has Map Coordinate and Data Collection details. 

§ Multimedia. This tab shows attached multimedia files such as images, videos and 
data files. 

~q pl recommend names etc to populate in blank fields as necessary, here and in 
topics below 
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Traffic Signals - Controller 
The Controller is the base unit for a Traffic Signal, and all the other assets are 
attached to it. The tree view in the List panel shows how the assets are attached, 
and their various dependencies. See Traffic Signal - Components (see "Traffic 
Signals - Components" on page 39) for more information. 

You'll notice that the Replace Asset button  is activated as soon as an asset is 
selected in the List panel. As assets are replaced, history is generated. By default, 
this history is not shown- you can select Options > Show Replaced Items if you'd like the 
history to be visible. 

Select Controller in the Traffic Signals window List panel to bring up its details. 

 

Select the tab you require to view and maintain the controller details as required. 

§ Location. For basic location information: Road ID, Location, Side, Offset, and 
Map Coordinates. 

§ General. A summary of asset owner, identification and device specification 
information, including power supply information and ICP Numbers (see 
"Maintaining Power Supply and Installation Information" on page 187). 
Preemption status is a required field. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Logic Rack 
The Logic Rack is the "brain" of the the Traffic Signal. 

 

Select the tab you require to view and maintain the Logic Rack details as required. 

§ General. A summary of asset owner, identification and device specification 
information. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Communications Device 
This device can be a modem, multiplexor or another type of communication 
device to remotely link the Traffic Signal with the central control unit. 

 

Select the tab you require to view and maintain the Communications Device 
details as required. 

§ General. A summary of asset owner, identification and device specification 
information. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Detector Card 
The Detector Card works with the Loop to alert the Logic Rack to the presence of 
a vehicle. 

 

Select the tab you require to view and maintain the Detector Card details as 
required. 

§ General. A summary of asset owner, identification and device specification 
information. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Loop 
The Loop senses the presence of a vehicle. Since it is installed into the road 
surface, location details are important. A Detector can have more than one Loop, 
so numbering them is also required. 

 

Select the tab you require to view and maintain the Loop details as required. 

§ Location. For location information: Road ID, Location, Side, Offset, and Map 
Coordinates. Side and Loop number are required fields. 

§ General. A summary of asset owner, identification and device specification 
information. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Pole 
The Pole, in the context of the RAMM Traffic Signals software, is attached to 
Controller. A Controller can control more than one Pole. 

 

Select the tab you require to view and maintain the Pole details. 

§ Location. For location information: Road ID, Location, Side, Offset, and Map 
Coordinates. Side and Pole number are required fields. 

§ General. A summary of asset owner, identification and device specification 
information including the Pole Mount (see "Maintaining Pole Mounting and 
Type" on page 183). 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Target Board 
The Target Board is where the Lantern is mounted. 

 

Select the tab you require to view and maintain the Target Board details. 

§ General. A summary of asset owner, identification and device specification 
information. The only required field is the Aspect - this will correspond to the 
Lantern below. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Lantern 
The Lantern appears in the asset List panel as a Primary, Secondary, Tertiary 
Lantern, depending on its position in the Intersection. See Traffic Signals - 
Concepts (on page 36). 

 

Select the tab you require to view and maintain the Lantern details. 

§ General. A summary of asset owner, identification and device specification 
information. The only required field is the Aspect in the Construction section. 
You can also specify the Type and Wattage of each Lamp. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Pedestrian Call Box 
The Pedestrian Call box is attached to the Pole in the Traffic Signals window List 
panel. 

 

Select the tab you require to view and maintain the Lantern details. 

§ General. A summary of asset owner, identification and device specification 
information. The only required field is the Aspect in the Construction section. 
You can also specify the Type and Wattage of each Lamp. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Attachment 
The Traffic Signals system also records Attachments to the Mast Arm (see "Traffic 
Signals - Components" on page 39), for example a Speed Camera, Flag, Red Light 
Camera, or Variable Message Sign. 

 

Select the tab you require to view and maintain the Attachment details. 

§ General. A summary of asset owner, identification and construction information 
including the type of attachment (see "Maintaining Attachment Types" on 
page 185). 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Traffic Signals - Cabling 
This  window is to maintain Cabling and associated Ducting. 

 

Select the tab you require to view and maintain the Attachment details. 

§ General. In addition to the asset owner and identification information, this tab 
also has fields to enable you to specify cable length, cores and cable ends. The 
End 1 Component is a required field. 

§ Ducting. This tab holds information on the ducting and protection for each cable 
length. 

§ History. To record installation and replacement information such as the 
installation company name, dates and related contract / dispatch information. 
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Updating Assets 
The decision whether to update traffic signal assets is made at the point of setting 
up the contract (see "Setting Up A Contract" on page 65). 

 

In the Contract Details window (Maintenance > Contract Details from the main RAMM 
Traffic Signals menu) select the Update Asset option (see above) to enable the 
replacement of traffic signal assets. 

If this is unticked, when completing a dispatch (see "Completing Dispatches" on 
page 82) you'll go straight on to the claims window (see "Claim Lines" on page 86) 
without being prompted to replace assets. 

This auto-skip facility cuts down on keying time and would only be applicable if as 
a contractor you have won another contract which you are running on the database 
without updating asset data. 

For example, you may have a traffic signal maintenance contract and also a power 
company maintenance contract. On checking a reported fault, you may have also 
found and fixed a related wiring fault. Back at base, you would transfer the 
supposed traffic signal from the Council contract to the power company contract 
and complete the dispatch without updating the data. 
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Replacing Traffic Signal Assets - ts 

NOTE: Replacing an asset is quite different from simply changing its details to 
correct an error. Replacing an asset has an impact on claims and 
maintenance schedules, and should be done only when necessary. 

Traffic signal assets are replaced in the Traffic signals window (on page 134) by 
clicking the Replace Asset  button on the toolbar. 

NOTE: When replacing assets,  you need to be absolutely sure that you're 
replacing the correct asset in the database. This is where details like the 
pole number and pole ID will be crucial. For more information on 
configuring location information, see Options - Database (on page 170). 

Replacement History 
Rather than simply replacing one asset with another, replacing assets in RAMM 
Traffic Signals involves 2 simultaneous actions: archiving the old asset, and adding 
the new asset. 

When the asset is replaced, the replaced date defaults to the completed date on the 
relevant dispatch. This is primarily to create a replacement history over time- a 
record of how often different assets and asset types are replaced and why. When 
analysed (see "Reports" on page 201), this becomes a good indication of the failure 
of a particular asset, or an external factor such as a poorly positioned pole. 

For the same reason, it's also important to enter a reason for the replacement- for 
example vandalism, poor condition. These are set up in Maintaining Replacement 
Reasons (on page 186). 

Linked Replacements 
The replacement dialog box has a context sensitive option to replace linked assets. 
For example, if you've selected the pole to be replaced, you have the option to 
replace the bracket and the light as well since that's probably what you will need to 
do. 
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If you choose not to, the existing bracket, light, gear and lamp combination are 
transferred to the new pole. RAMM Traffic Signals will also warn you if the 
change will have an impact on multiple assets, as in the screen above. For a 
detailed description of the replacement procedure, see Replace Asset (on page 84). 
 

Asset Valuation in RAMM Traffic Signals 
Asset Valuation in RAMM Traffic Signals helps you compare the expected 
performance of a traffic signal asset with its actual performance. 

The Asset Valuation information is view-only, and available only in Client versions 
of RAMM Traffic Signals. For more information on Asset Valuation, see the Using 
RAMM and Asset Valuation guides. 
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Patrols are crucial to keeping your Traffic Signals network in good working order. 
This section describes setting up patrol areas and recording patrols. You can then 
link each dispatch directly to a patrol. 

IN  THIS  CHAPTER 
Maintaining Patrol Areas...........................................................153 
Entering Patrol Details ..............................................................155 

 
 

Maintaining Patrol Areas 
Select Maintenance > Patrol Areas from the main RAMM Traffic Signals menu or Actions 
> Patrols > Maintain Patrol Areas from the Patrol window to access this facility. 

 

Patrols 
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From this window you can define regularly patrolled areas. Once defined, an area 
can then be linked to specific patrols. 

A patrol area can be defined either by area/sub-area (on the Area Selection tab) or by 
road/carriageway section (on the Road Selection tab), or a combination of both. The 
icon key below indicates the selection status within each area, and whether sub-
areas are available for selection. 

Area Selection List Icons 
§  Sub areas are available (click to expand list). 

§  Areas are already expanded (click to collapse list). 

§  Area is not selected. 

§  Part of the area is selected. 

§  All of the area is selected. 

Road Selection List Icons 
§  Carriageway sections are available (click to expand list). 

§  Carriageway sections are already expanded (click to collapse). 

§  Carriageway/Road is not selected. 

§  Some carriageway sections within the road are selected. 

§  The entire road is selected. 

4 How To Define Patrol Areas 

1 Click Add Record  to begin defining a Patrol Area. You can define as many 
patrol areas as you wish. 

2 Link the Patrol Area to a Contract. 

3 Enter a name for the Patrol Area. For each grouping a unique Patrol Area 
name is required. It is by this Patrol Area name that an area is linked to an 
actual Patrol. 

4 Select the patrol area. For example, you can select a large region such as 
Howick, a sub-area of Howick, a road such as Aaronville Way, a carriageway within 
Aaronville Way or a combination of all four options. The Areas window at the 
bottom of the window lists the selected areas, sub-areas, roads and carriageway 
sections that are covered by the current patrol area. 

5 Save  your changes. 
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NOTE: The Patrol Areas should correspond with the patrol requirements of 
the contract. Once a patrol area has been linked to an actual Patrol, 
the details of the area cannot be altered. 

 

Entering Patrol Details 
Inspection areas and the timing of patrols are normally defined in the contract. 
This window allows you to enter patrol details, and link them to predefined areas. 

From the main RAMM Traffic Signals main window, select Actions > Patrols. 
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The information you see is filtered by default, restricting those patrols displayed to 
patrols within the last month. To change this select Options > Edit Filter (CTRL+F) or 
Clear Filter (CTRL+L) from the Patrols window menu. 

An Area must be selected from the Patrol Areas already defined (see Maintaining 
Patrol Areas (on page 153)) - alternatively areas can be defined directly from this 
window by selecting Actions > Maintain Patrol Areas. Once a Patrol Area has been 
selected, the  button is enabled. Clicking this button will bring up a full 
description of the area. 

NOTE: Choosing the right frequency for the patrols is crucial. Large areas can be 
patrolled once a month, but it may be advisable to patrol main roads 
weekly. Click the drop-down arrow  to bring up a calendar to select the 
date. Use arrow keys on your keyboard to select a start and end time. 

The name of the person who carried out the Patrol must also be entered. 

You can now go to the Dispatch Entry window (on page 108) and view the 
dispatches entered by this patrol. 
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A Claim groups together claim lines for the same contract within a fixed period. 
This section examines how you work with claims in RAMM Traffic Signals. 

IN  THIS  CHAPTER 
Contract Claims ........................................................................160 
Claim Life Cycle .......................................................................160 
Select Payment Header .............................................................161 
Printing a Claim ........................................................................162 

 
 

Claims 
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Contract Claims 
The Claim Maintenance window can be launched either from the main RAMM 
Traffic Signals window by clicking the Claims window button  on the toolbar 

-OR- 

by select Actions > Contract Claims from the main RAMM Traffic Signals window. 

 You can now enter or edit claim headers. By default, only the claims that are not 
completed are shown. If you wish to see all claims, select View > Show All Claims. 

 

Entering a claim header is a matter of simply selecting the appropriate contract, 
inserting an optional description and filling in the start and end dates for the claim. 
You can also add notes. The claim header is now ready to have claim lines attached 
to it. 

NOTE: Claim lines can only be added when completing a dispatch, or by 
selecting Actions > Claim Lines or CTRL+A on a completed dispatch. See 
Claim Lines (on page 86). 

 

Claim Life Cycle 
A claim has a three stage life cycle:  

§ Open. When the claim is open, claim lines can be linked to it. 
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§ Presented. This indicates that the claim has been printed and presented for 
payment. 

§ Complete. The claim has been accepted and no further action is required. 

By default, when a claim is created it is Open. The options to move the claim 
through the next steps are under Actions. 

Claim Actions 
§ Print Claim (CTRL+P). This prints a claim, changes the status to Presented and inserts 

the presented date. Once a claim has been presented, claim lines cannot be 
altered. If changes are required, you will need to Unpresent the claim (see 
below). 

§ Complete Claim (CTRL+O). This allows you to enter a payment in order to complete 
the current claim. 

§ Unpresent Claim (CTRL+U). You should avoid using this option unless absolutely 
necessary. This will reverse the status of the claim from Presented to Open. 
However, this means you also have to cancel or destroy all printed material 
relevant to the prior presentation of the claim. 

Selecting Claim Lines from the menu opens another window that gives you access to 
the individual lines grouped under the claim. Claim lines can be updated and 
deleted from this window. You can also view the details of each claim line by 
double-clicking it, or by selecting the claim line and then selecting View > Show Detail 
from the menu. 
 

Select Payment Header 
When creating a claim line, if there is more than one payment header open, you're 
prompted to select one. 
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If there is no payment header available, you're prompted to create one. 

 

If a payment header isn't available, you won't be able to add a claim line. 

All lines entered for this Dispatch will be linked to the payment header selected or 
created. 
 

Printing a Claim 
The steps below show how to print (and present) a claim. 

4 How To Print a Claim 

1 Select the claim in the List panel of the Claim Maintenance window. 

2 Select Actions > Print Claim 

-OR- 

CTRL+P. 

 

3 You have a number of options: 

§ Change this claim to Presented (selected by default) can be unticked if you just 
want to preview the claim. 

§ Show details for non-standard claims. 
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When the Claimed Rate does not equal the Agreed Rate then these values can 
be highlighted on the claim in red. They are also listed individually under 
each claim item. Selecting this option prints the Dispatch ID and the 
Maintenance Notes from the Dispatch for these items on the claim. 

NOTE: This changes the print layout of the claim from portrait to landscape. 
You will also need a colour printer to print the highlighted values in 
red. 

§ Claim Groups Report. 

§ Claim Details Report. 

For more information on these two selections see Claim Reports (on page 
210). 

NOTE: Once the claim is presented, this window will show only 3 options 
as active (Change this Claim to Presented will be inactive). 

4 Make your selections and then click either Preview or Print. 

5 When you're done you'll be returned to the Claim Maintenance window. 
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This section looks at maintenance crew payments. 

IN  THIS  CHAPTER 
Crew Payments .........................................................................165 
Piecemeal Rate...........................................................................166 
Crew ..........................................................................................167 

 
 

Crew Payments 
The use of Crew Payments is linked to the Piecemeal Rate (PMR) option in the 
Contract. This allows for individuals to be paid for work done. When a dispatch is 
being completed and Claim Lines are being entered, if the PMR option applies, a 
Crew member must be selected from the list. The Crew member is the one who 
will receive payment for the completed job. The Payment covers a period and will 
link together all the claim lines for that period. The Payment can be printed, 
updated and then all claim lines linked to the payment can be flagged as Paid. 

A Payment has three phases:  

§ Open: Claim lines can be linked to this Payment. 

§ Claimed: The Payment report and unload file have been generated and 
presented for payment.  

§ Altered: A change has been made and the report/unload file needs to be 
recreated. 

§ Paid: The figures have been accepted and payments made to the Crew 
members. 

Maintenance Crew Payments 
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By default when a payment is created it is Open. Under Actions are the options to 
move the Payment through the next steps. Claim produces a report and an unload 
file giving payment details, and inserts the presented date. Pay allows the user to 
enter the payment number to complete the current claim.  

Payment Lines gives access to the individual lines grouped under the header. These 
lines can be update and deleted only when the Claim is not completed. The 
Payment Lines can be expanded either by double clicking on the highlighted line 
or clicking Expand under the View menu option.  

On entry only the Payments that are not completed are shown. Located under View 
is Show All Payments Headers. Click this to display everything. The status of a payment, 
unless otherwise displayed on the window, is Open. 
 

Piecemeal Rate 
From the RAMM Traffic Signals main window, select Maintenance > Contract Details to 
manage Piecemeal Rate settings for Maintenance Crews. 

 

If you tick the PMR Payment option as above, the PMR tab will become available. Here 
you should specify which day the payments will be made, and at what intervals.  

Selecting this option also enables the PMR Rate option on the Schedule Items (see 
"Setting Up Schedule Items" on page 69) entry window. 
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Crew 
If you enable PMR Payment on the Maintenance > Contract Details window, you will also 
need to enter settings on the Crew tab and the PMR tab. 

 

The crew members you enter will become active by default. You will also need to 
define the Start Day and Period for the PMR. 

 

Save  each change. 
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This section shows you how configure RAMM Traffic Signals Options. 

By choosing Actions > Options from your RAMM Traffic Signals menu, you can set 
other options pertaining to Database, Electricity charges, Safety Testing and Optional Groups. 

You can also configure how you will send and receive RAMM Traffic Signals data 
by Email (see "Email Options" on page 124) by selecting Actions > Email Options. 

NOTE: This section does not describe setting general programme preferences, 
which are accessed in the main RAMM Traffic Signals window from the 
Options > Preferences menu. 

IN  THIS  CHAPTER 
Options - Database....................................................................170 
Options - Safety Testing ...........................................................171 
Options - Optional Groups.......................................................171 
Options - Tolerances.................................................................173 

 
 

RAMM Traffic Signals Options 
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Options - Database 
The Database tab sets database related RAMM Traffic Signals options. 

 

§ Database Name. This appears on the second line of every report heading (see 
"Reports" on page 201). This name can differ from the name entered in the 
Database Description column. By default, the name is carried across from the 
Council's database, but if you're a Contractor you can alter this name as the 
information isn't transferred back to the Council. 

§ Guarantee Period. All assets will have the option to apply a guarantee date. The 
guarantee period is for one year from the guarantee date. If during this period 
a dispatch is raised against the asset, the comment This [Asset] is still under guarantee 
is printed with the relevant details. For more information, see Printing 
Dispatches (on page 79). 

§ Assessments. This option is for the purpose of assessing traffic signal assets. See 
Condition and Assessment in RAMM Traffic Signals (on page 197) for more 
information. The results of the Assessments are reported on the Assessment 
Detail tab of each asset in the Traffic Signals window (on page 134). 

§ Installation Company. To enable the user to enter installation company details. You 
can set up this information in Maintenance (see "Maintaining Power Supply 
and Installation Information" on page 187). 

§ Line Company. If this option is enabled, the Line Company name will be made 
available with the circuit information. 

§ Warranty Period. Tick the Warranty Period box if you want the warranty period to 
be taken into account when certain assets are replaced. The warranty period 
applies to lamps, gears and lights. For more information, see Maintaining 
Warranty Period (on page 178). 
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§ Power Company. This option will enable the power company field on the Pole 
General tab in the Traffic Signals window (on page 134). 

 

Options - Safety Testing 
The Safety Testing tab gives access to 8 fields that can be configured to produce a 
safety testing checklist on the Dispatch as below. 

 

The testing categories appear at the base of the Dispatch Detail report: 

 

For more information, see Dispatch - Printing Options (on page 120). 
 

Options - Optional Groups 
Optional Groups are to customise, record or group information in a way that's pertinent 
to a specific needs of a Council. This tab controls the activation of these Optional 
Groups. They then become available on the Dispatch Entry window (see 
"Dispatch - General Tab" on page 110) and Claim Line Detail window (see "Claim 
Lines" on page 86). 

For example, the Council may require a breakdown of their schedule items in 
such a way that they know how much a Ward is costing them to maintain (Claim 
group) or they may wish to find out how many faults are been reported on 



 

1 7 2  R A M M  T r a f f i c  S i g n a l s  
 

weekends (Dispatch group).  These Optional Groups can be configured to reflect 
this information. 

The Dispatch groups show on the Dispatch Entry window, the Claim groups in 
the Claim detail window. 

NOTE: It's advisable to configure the groups from their relevant Maintenance 
screens before you choose related actions for them here. Dispatch Group 
1 and Claim Group 1 are contract specific, and you can associate each of 
them with a contract. Dispatch Group 2 and Claim Group 2, however, 
cannot be linked to contracts. See Maintaining Dispatch Groups (on 
page 191) and Maintaining Claim Groups (on page 190) for more 
information, and return to this window to configure status options for 
the groups. 

Select the status of each optional group: 

§ Optional. The group is available, but the field can be left blank. Use this status 
option if the group needs to be selected only for certain items. 

§ Required. The user must select a value before the entry can be saved. This status 
option is a good way of ensuring that data is entered in all cases. 

§ Not in use. This is the default value. If this status option is selected the group will 
not be visible, even if other details have been set up within it. 
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You may then select the appropriate values from the drop down lists which will be 
made available to you when entering Claim Lines and/or Dispatches (depending 
on which of the possible four options you have activated). 

These groups will also be available for generating reports and analyses with the 
Decision Cube (on page 203), which is available by clicking  from the Dispatch 
Entry window, or from the Claims window. 

NOTE: Optional Dispatch groups can also be set up for email entries.  If you 
have these groups flagged as Required then ensure that default entries are 
selected under Email Options (on page 124). 

 

Options - Tolerances 
The Tolerances tab allows you to set a tolerance level (in units) to reconcile map co-
ordinates that do not match in the Dispatch Entry window (on page 108). 

 

With this example RAMM Traffic Signals will show 10 map coordinates greater 
and lesser than the expected location for the asset. This is particularly important 
because you can't rely on the person taking a map coordinate reading for an asset 
standing in the same spot every time. The setting is expressed in metres. 
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This section in RAMM Traffic Signals describes working with the items on the 
Maintenance menu of the main RAMM Traffic Signals window. 

If you're setting up your Traffic Signal assets from scratch, we advise using the 
Traffic Signals Insert Wizard (on page 89) to ensure that the assets are set up in the 
right order. 

This is where you set up the information for the various drop-down lists in 
RAMM Traffic Signals windows. Most tables contain a Code and a Description, 
but some require additional information. Wherever possible, RAMM Traffic 
Signals will fill in the default values for these tables when you enter a maintenance 
window. 

You must have the relevant security (on page 271) permissions to configure these 
settings. 

The assets in the lists correspond to the inventory items of a typical Traffic Signals 
system. To view a diagram of how they are related to each other, see Traffic 
Signals - Components (on page 39). 

Maintenance 
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IN  THIS  CHAPTER 
Maintenance - Duplicating Entries .......................................... 176 
Maintenance - Merging Entries ............................................... 177 
Maintaining Warranty Period................................................... 178 
Maintaining Contract Details ................................................... 179 
Maintaining Contract Item Activities....................................... 179 
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Maintenance - Manufacturers .................................................. 181 
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Maintenance - Duplicating Entries 
Most RAMM Traffic Signals Maintenance windows allow you to duplicate an 
entered item to save you time and trouble setting up assets. Simply select the item 
in the List panel (see "RAMM Traffic Signals Workspace" on page 49) and select 
Edit > Duplicate from the menu. 

4 How To Duplicate An Entry 

1 Go to the relevant Maintenance window for the asset from the main RAMM 
Traffic Signals window. 

2 Select the item to be duplicated in the List panel. 

3 Select Edit > Duplicate on the menu 
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-OR- 

Right-click anywhere other than inside a panel to bring up the same menu and 
select Edit > Duplicate. 

 

4 This will generate a copy of the item, named Copy of [Item]: 

 

5 You can now edit the item, changing its parameters and description. 

6 Save  your work and close the window. 
 

Maintenance - Merging Entries 
RAMM Traffic Signals Maintenance windows also have the facility of merging 
entries to avoid duplicating information unnecessarily. 

For example, you may have entered a number of lanterns in Traffic Signals and 
given them different models, but later find that the models actually refer to the 
same model (for example H 50 and H50). 

You can merge the entries for these codes, so that analyses or reports based on this 
model will accurately reflect the fact that all of these lights are the same model. 

4 How To Merge Entries 

1 Go to the relevant Maintenance window for the asset from the main RAMM 
Traffic Signals window. 
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2 Select the entry to be merged (the one that will NOT remain after the merge) in 
the List panel. 

3 Select Edit > Merge from the menu 

 

-OR- 

Right-click anywhere other than inside a panel to bring up the same menu and 
select Edit > Merge. 

4 RAMM Traffic Signals will ask you which row you wish to merge to with the 
entry selected in 2 above (the row that WILL remain after the merge): 

 

Select the relevant row and click Merge Rows. 

5 Close the Maintenance window when you're done. 
 

Maintaining Warranty Period 
Selected RAMM Traffic Signals Maintenance windows allow you to enter a 
warranty period in months. This field will be available from the Maintenance 
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menus (Maintenance > Manufacturers > [Asset]) if you have enabled it on the RAMM 
Traffic Signals Options Database tab (see "Options - Database" on page 170). 

This facility is useful to check whether assets need replacement before the end of 
this period. The assets that are identified as such are shown in the Warranty 
Failure Report (on page 216). 

 

Click below the relevant column in the Detail panel of the window to enter the 
warranty period. 
 

Maintaining Contract Details 
Entering contract details is generally done at the beginning of the contract. For 
more information, see Setting Up Contract Details (on page 66). 
 

Maintaining Contract Item Activities 
Maintaining Contract Item Activities is generally performed at the beginning of a 
contract. See Setting Up Contract Item Activities (on page 68). 
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Maintaining Owner Types and Owners 
This maintenance window is to set up Owner Types and Owners for assets. 

It's advisable that you set up the Owner Types first.  

4 To Set Up Owner Types 

1 From the main RAMM Traffic Signals window, select Maintenance > Owner > Type. 

2 Click  on the window toolbar to begin a new entry or select the entry you 
wish to edit. 

3 Enter the code for the Owner Type (mandatory field - for example, LA) and a 
Description (Local Authority). 

4 Save  your settings. These will then be available when setting up Owners 
below. 

4 To Set Up Owners 

1 From the main RAMM Traffic Signals window, select Maintenance > Owner > 
Owners. 

2 Click  on the window toolbar to begin a new entry or select the entry you 
wish to edit. 

3 Enter the code for the Asset Owner (mandatory field). 

4 Description and Type selection is optional. 

5 Save  your settings. 
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Maintenance - Manufacturers 
This menu allows you to set up the bulk of the Make and Model information for 
Traffic Signal assets. 

From the main RAMM Traffic Signals window, select Maintenance > Manufacturers > 
[Asset] to open a maintenance window where you can enter Make and Model 
information for these assets. 
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4 To Enter Manufacturer Make and Model for Assets 

1 Click  on the window toolbar to begin a new entry. 

 

2 Enter a code for the Make, and the complete name in the Name field. 

3 Enter Detail items as required by clicking the  button in the Detail panel of 
the window. Model and Name are required fields. 

4 Enter a Warranty Period in months and Notes if required. You can enter Notes for 
the Make as well as the Model. 

5 Save  and close the window when you are done. 
 

Maintaining Intersection Behaviour and Type 
This Maintenance window is to set Intersection Behaviour and Type that will be 
reflected in the Intersections window (see "Working with Intersections" on page 
42). 

4 To Set Up Intersection Behaviour 

1 From the main RAMM Traffic Signals window, select Maintenance > Intersection > 
Behaviour. 
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2 Click  on the window toolbar to begin a new entry or select the entry you 
wish to edit. 

3 Enter the code for the Behaviour and the Description (typically, whether the 
Intersection is Controlled or Uncontrolled). Both fields are mandatory. 

4 Save  your settings to make them available in the Intersections window. 

4 To Set Up Intersection Types 

1 From the main RAMM Traffic Signals window, select Maintenance > Intersection > 
Type. 

2 Click  on the window toolbar to begin a new entry or select the entry you 
wish to edit. 

3 Enter the code for the Intersection Type and the Description (typically, 4-way Junction, 
Pedestrian Crossing, T-Junction, Y-Junction). Both fields are mandatory. 

NOTE: If you have Intersections generated by RAMM, you will see a 
RAMM Generated type in the List by default. Since there will be 
Intersections attached to this type, you cannot delete it. 

4 Save  your settings to make them available in the Intersections window. 
 

Maintaining Pole Mounting and Type 
This maintenance window is to set up Pole Mounting and Type for selection in the 
Traffic Signals window (see "Traffic Signals - Pole" on page 143). 

4 To Set Up Pole Mounting and Type 

1 From the main RAMM Traffic Signals window,  select Maintenance > Pole > 
[Mounting/Type]. 

2 Click  on the window toolbar to begin a new entry or select the entry you 
wish to edit. 

3 Save  your settings to make them available  
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Maintaining Lantern Details 
A number of maintenance windows for Lanterns are available from this menu to 
set up Lantern details for selection in the Traffic Signals window (see "Traffic 
Signals - Lantern" on page 145). 

Lantern Display Type 
The Lantern Display Type represents its function - whether a Left Turn, Pedestrian, 
Right Turn, Through, Through and Left Turn or Through and Right Turn. 

Lantern Lamp Type 
The Lamp is the light source inside the Lantern. Typical Lamp types are 
Incandescent, Quartz Halogen or LED (Light Emitting Diode). 

Lantern Material 
The Lantern Material maintenance window details lantern construction materials. 
These are typically Metal or Plastic. 

Lantern Type 
The Lantern Type refers to its priority within the Intersection layout (Primary, 
Secondary or Tertiary). 

4 To Maintain Lantern Details 

1 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. 

2 Enter the code for the Type or Material and the Description. These are mandatory 
fields. 

3 If the window allows entry of Details, you can now enter them by clicking the 
 button in the Detail panel of the window. These may include a Wattage 

figure for each model, or a Warranty Period in months (see "Maintaining 
Warranty Period" on page 178). The Lantern Type maintenance window 
requires you to specify a Position. 

You can also enter detailed Notes. 

4 Save  and close the window when you are done. 
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Maintaining Miscellaneous Definitions 
RAMM Traffic Signals has a number of miscellaneous Maintenance categories 
(select Maintenance > Miscellaneous from the main RAMM Traffic Signals window). 
 

Maintaining Attachment Types 
This maintenance window sets up Attachment Types for selection in the Traffic 
Signals window (see "Traffic Signals - Attachment" on page 147). 

4 Maintaining Attachment Types 

1 From the main RAMM Traffic Signals window select Maintenance > Miscellaneous 
> Attachment Type. 

 

2 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. 

3 Enter the code for the Type, and the Description. These are mandatory fields. 

4 You can also enter detailed Notes if required. 

5 Save  and close the window when you are done. 
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Maintaining Replacement Reasons 
When an asset is replaced in the Traffic Signals window (on page 134), a reason for 
the replacement needs to be given. 

4 Maintaining Replacement Reasons 

1 From the main RAMM Traffic Signals window select Maintenance > Miscellaneous 
> Attachment Type. 

 

2 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. 

3 Enter the code for the Reason, and the Description. These are mandatory fields. 

4 Decide which asset(s) you wish each reason to apply to, by ticking the relevant 
boxes in the Applicable to section. 

5 Tick the Warranty Reason box if the warranty period needs to be noted when 
this particular reason is given for replacing an asset. If you do, and 
replacements are being made while the warranty period is still in effect, you 
will be informed of this while doing the replacement. You can also report on 
all such cases by running the Warranty Failure Report (on page 216). 

6 Save  and close the window when you are done. 
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Maintaining Power Supply and Installation Information 
Use these maintenance windows to configure ICP (Installation Connection Point) 
Numbers, Power Supply Company, Line Company and Power Supply Company details 
for selection in the Traffic Signals window (on page 134).  

ICP (Installation Connection Point) Numbers 
From the main RAMM Traffic Signals window select Maintenance > Miscellaneous > ICP 
Numbers to enter this information. ICP numbers are available for Controllers (see 
"Traffic Signals - Controller" on page 138). 

Installation Company 
The Installation Company information is maintained by selecting Maintenance > 
Miscellaneous > Installation Company. Once you've entered this information, you also need 
to ensure that Installation Company is selected on the RAMM Traffic Signal Options - 
Database (on page 170) tab to make the field available on the History tabs of the 
various assets in the Traffic Signals window. 

Line Company 
Select Maintenance > Miscellaneous > Line Company to maintain this information. 

Selecting whether the company is Active or not is mandatory. The Line Company is 
in charge of the lines, and supplies the power to the asset on behalf of the Power 
Supply Company (below). When a whole street is reported as “not going”, for 
example, this could be the responsibility of the Line Company rather then 20 
intersections with blown lanterns. 

You need to ensure that Line Company is selected on the RAMM Traffic Signals 
Options - Database (on page 170) tab to make the field available in the General tab 
for the Controller (see "Traffic Signals - Controller" on page 138). 

Power Supply Company 
Select Maintenance > Miscellaneous > Supply Company to configure this information. 
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The Supply Company is defined as the company that generates and supplies the 
power to the asset.  This is the same company that you pay for the power 
consumption/usage based on the wattage of the network for each ICP (see above). 

Selecting whether the company Status (whether Active or not) is mandatory. 

Electricity Charge 
The electricity charge is calculated using the formula below. 

Electricity Charge = (no of lanterns x fixed charge x days in period) +  
(((sum of (no of lamps per model x wattage)) / 1000) x 
(4250/365 x days in period) x variable charge) 

~q electricity charge - is this needed, is this necessary 

4 Maintaining Power Supply and Installation Information 

1 From the main RAMM Traffic Signals window, select the maintenance 
window you require from those described above in the Maintenance > Miscellaneous 
menu. 

2 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. 

3 Enter or change the required details. Mandatory fields are indicated by a 
colour. 

4 You can also enter detailed Notes if required. 

5 Some windows require you to set Status field. 

6 Save  and close the window when you are done. 
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Maintaining Asset Material and Type 
A number of maintenance windows available from the RAMM Traffic Signals 
Maintenance menu allow you to set up Material and Type fields to make them 
available for the respective assets in the Traffic Signals window (on page 134). 

Target Board Material and Type 
Select Maintenance > Target Board > [Material/Type] to open this maintenance window. 
Target Board Materials are typically Fibreglass, Metal or Plastic. The Type refers to 
the Aspect of the Target Board (3, 4, 5, or 6-Aspect). You can then select them for 
the relevant fields available for Target Board details (see "Traffic Signals - Target 
Board" on page 144). 

Cabling Material and Type 
Select Maintenance > Cabling > [Ducting/End Box Material/Type] to open this maintenance 
window. You'll set up information for Cable Ducting and End Boxes rather than for 
the cable itself. You can then select these entries for the relevant fields available for 
Cabling details (see "Traffic Signals - Cabling" on page 148). 

Loop Material and Type 
Select Maintenance > Loop > [Material/Type] to open this maintenance window and enter 
the relevant information. You can then select these entries for the relevant fields 
available for Loop details (see "Traffic Signals - Loop" on page 142). 

Pedestrian Call Box Type 
Select Maintenance > Pedestrian Call Box > Type to open this maintenance window and 
enter the relevant information. These Types are typically Audio / Tactile, Smart Ped, 
Standard, Tactile Only or X-flo. You can then select these entries for the relevant 
fields available for Pedestrian Call Box details (see "Traffic Signals - Pedestrian 
Call Box" on page 146). 

4 Maintaining Asset Material and Type 

1 Open the maintenance window for the asset Material or Type from the 
Maintenance menu as above. 

2 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. 

3 Enter the details. Mandatory fields are indicated by a colour. 

4 You can also enter detailed Notes if required. 
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5 Save  and close the window when you are done. 
 

Maintaining Claim Groups 
You can set up two Claim Groups that will become available in the RAMM Traffic 
Signals Options window on the Optional Groups tab - see Options - Optional 
Groups (on page 171). They will then become available for the Claims Lines 
Detail window (see "Claim Lines" on page 86). 

Claim Group 1 

NOTE: Claim Group 1 is contract specific. 

You would typically use this Claim Group for Claims that you specifically want to 
link to a contract. 

Select Maintenance > Claim Groups > [Group 1] from the main RAMM Traffic Signals 
window to configure this group. 

You can change the name of the Group to something more meaningful if you 
wish. Once you have done so, RAMM Traffic Signals will show the modified 
name in the Maintenance menu. In the example below we have renamed Group 1 
to Work Type. 
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If more than one contract is open, you can select your preference from the 
Contract drop-down list. Enter your Claim Group descriptions, and link each 
group to a contract from the Contract ID drop-down list.     

Claim Group 2 

NOTE: Claim Group 2 cannot be linked to a contract. 

You would typically use this Claim Group for a wide range of Claims not confined 
to a single contract. 

Select Maintenance > Claim Groups > [Group 2] from the main RAMM Traffic Signals 
window to configure this group. 

As with Group 1, you can change the name of the Group. RAMM Traffic Signals 
will show the modified name in the Maintenance menu. 

4 Maintaining Claim Groups 

1 From the main RAMM Traffic Signals window select Maintenance > Claim Groups > 
[Group Name]. 

2 If you wish to change the name of the group, select Actions > Modify Group Name 
and enter a new name. 

3 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. The Group ID will be assigned 
automatically. 

4 Enter the Description and select the Contract ID. These are mandatory fields. 

5 Make the Group Active by ticking it. 

6 Save  and close the window when you are done. 

The Claim Groups you have entered will now be available in Options - Optional 
Groups and for Claim Lines. 
 

Maintaining Dispatch Groups 
Two Dispatch Groups can also be set up for use with Dispatches. As with the 
Claim Groups, Group 1 is contract specific and Group 2 is not, and both groups 
can be renamed. Once set up, they will become available in the RAMM Traffic 
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Signals Options - Optional Groups (on page 171) window and the Dispatch Entry 
window (on page 108). 

Dispatch Group 1 

NOTE: Dispatch Group 1 is contract specific. 

You would use this group for dispatches that you would want to specifically link to 
a contract. 

You can change the name of the Group to something more meaningful if you wish 
- we've renamed Group 1 Method in the example below. 

 

Dispatch Group 2 

NOTE: Dispatch Group 2 cannot be linked to a contract. 

You would use this group for regular, non contract specific dispatch groups - for 
example, Dispatcher Names. 

4 Maintaining Dispatch Groups 

1 From the main RAMM Traffic Signals window select Maintenance > Dispatch > 
Dispatch Groups > [Group Name]. 

2 If you wish to change the name of the group, select Actions > Modify Group Name 
and enter a new name. 

3 Click  on the window toolbar to begin a new entry, or select an existing 
entry from the List panel on the left. The Group ID will be assigned 
automatically. 
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4 Enter the Description and (for Group 1) select the Contract ID. These are mandatory 
fields. 

5 Make the Group Active by ticking it. 

6 Save  and close the window when you are done. 

The Claim Groups you have entered will now be available in Options - Optional 
Groups and for Dispatches. 
 

Maintaining Costs 
The RAMM Traffic Signals Maintenance system allows you to set up 
Maintenance Cost groups, activities and faults that can later be linked with claims 
and later exported to RAMM for analysis by the Council. These groups are 
selected from drop-down lists and linked to individual Schedule Items (see 
"Setting Up Schedule Items" on page 69). 

To set up the items in these cost groups and categories, select Maintenance > Costs > 
[Lookup] from the RAMM Traffic Signals main window. 

Activity 
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Cost Group 

 

Failure 
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Fault 

 

4 To Enter Cost Items 

1 In the main RAMM Traffic Signals window, select Maintenance > Costs > [Lookup] 
as appropriate. 

2 Click  on the window toolbar to begin a new entry. 

3 Enter the information in the relevant fields or select them from the drop-
down lists. 

Some windows have Detail panels, in which you can click the  button to 
enter more details. 

4 Save  and close the window when you are done. 
 

Maintaining Call Types 
This is generally done while setting up a Contract (on page 65). See Setting Up 
Call Types (on page 71). 
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Maintaining Event Codes 
An Event Code is a code for classifying events in emails sent from within RAMM 
Traffic Signals, or between Council and Contractor, to give more information 
about a job. 

4 To Maintain Event Codes 

1 In the main RAMM Traffic Signals window, select Maintenance > Dispatch > Event 
Codes. 

 

2 Click  on the window toolbar to begin a new entry or select the item in the 
List that you wish to maintain. 

3 Enter the Event Code and the Description. 

4 Save  and close the window when you are done. 
 

Maintaining Fault Categories 
This is generally done while setting up a Contract (on page 65). See Setting Up 
Fault Categories (on page 72). 
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Condition and Assessment in RAMM Traffic Signals 
Assessment in RAMM Traffic Signals enables you to record the state of the asset as 
it is visited on a dispatch basis, and apply them to Traffic Signal assets. 

You need to have the appropriate security permissions (see "Security" on page 271) 
to work with Assessment in RAMM Traffic Signals. 

NOTE: Assessment is fairly complex subject that is covered in more detail in the 
separate RAMM Assessment guide. 

Before you set up Assessment for RAMM Traffic Signals, you need to consider 
what you want to assess and what results you expect. 

For example you may want to assess the condition of the lantern, and you would 
define 1 as Excellent but 5 as Very Poor (see below). Another good example would 
be an assessment category specifically for the paint on the pole. 1 could be defined 
as looks good. 5 would be paint is peeling and needs redoing. The system is designed 
with flexibility in mind. 

Performing Assessment in RAMM Traffic Signals 
Performing Assessment is a complex process that involves preparing Inspectors, 
Groups, Items and Responses, building Worksheet Templates, performing 
Assessment according to a Schedule, entering the Assessment Results into 
RAMM, determining Condition, Risk and Weighting, and looking at the results in 
reports or in the RAMM Traffic Signals window. 

All these actions are streamlined with the help of a Navigator that's available from 
the Assessment menu of the main RAMM Traffic Signals window. 

Read the RAMM Assessment guide for detailed help on using the Navigator and 
working your way through the Assessment process. 

Traffic Signals Window Assessment and Condition Tabs 
Once you've successfully performed your Assessment rounds, the results will be 
reflected in the Traffic Signals window. 

§ The full Assessment Results are shown by date in the List panel of the Traffic 
Signals window. 
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§ Condition and Risk Weights are shown on the Assessment tabs of the relevant 
asset Details. 
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§ You can also manually update Condition on the Condition tab of each asset in the 
Traffic Signals window, though this is not recommended unless you're sure of 
what you're doing - it's always a better idea to update Condition through the 
standard Assessment process. 

 

This tab allows you to enter Condition, Risk Likelihood / Consequence if necessary. You 
can also enter Asset Life and Guarantee details, and a name and date with 
regard to Data Collection for audit purposes. 
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RAMM Traffic Signals has the ability to generate a number of reports to help with 
your decision making. This section tells you about these reports. 

Some reports are presented in the CJN Decision Cube format, and some reports 
are generated directly from the RAMM Traffic Signals windows. 

You will generally always have the ability to preview the report before you print it, 
and have the option to save it in other formats (Microsoft Excel Spreadsheets, 
Quick Reports). 

IN  THIS  CHAPTER 
Viewing And Saving Previews and Reports ..............................202 
Decision Cube...........................................................................203 
Claim Reports ...........................................................................210 
Asset Management Reports.......................................................214 
Asset Replacement Reports .......................................................215 
Warranty Failure Report............................................................216 
Auditing.....................................................................................216 
Contract Management ..............................................................219 
Road Names ..............................................................................224 
Faults by Intersection Report....................................................224 
Faults by Job Report..................................................................225 
Controlled Intersections Detail Report ....................................226 

 
 

Reports 
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Viewing And Saving Previews and Reports 
The reports and previews generated from RAMM Traffic Signals can be saved as 
separate files in a number of different formats. 

This is useful for documentation, or if you need to transfer the report to another 
location. Once you've saved the file, you can send it anywhere by disk or email. 

4 How To Save a Preview As a File 

1 In any preview window in RAMM Traffic Signals, click the Save button. 

2 RAMM Traffic Signals will bring up a window that allows you to set the 
name and the location of the saved file. 

 

Click the drop-down arrow for the Save As Type field if you wish to choose  a 
different file type. 

 

Click Save to save your file at the chosen location. 

3 Click Close to exit the preview window when you are done. 
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4 How to View a Saved Preview File 

1 Click Reporting > Open Preview file from the main RAMM Traffic Signals window. 

-OR- 

If you're already in a preview window, click the Open button on the toolbar. 

2 You'll see an Open File window similar to the window above. Navigate to the 
location of your file and click Open. 

3 Click Close to exit the preview window when you are done. 
 

Decision Cube 
The Decision Cube is a powerful analysis tool for looking at your data in a 
number of ways. It can be launched from any toolbar that contains the Decision Cube 
button . 
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It is essentially a context sensitive pivot table that will populate the cube with 
available data, and present you with a number of grid headers  that you can 
click and drag with your mouse to change the cube views. 

The grid header can be filtered to further refine the information they show and 
save the settings. 

The results of your analysis can be printed, or saved in the following formats: 

§ Microsoft Excel spreadsheet format. 

§ CJN Decision Cube format. 
 

Decision Cube Toolbar 
In addition to the standard RAMM Traffic Signals toolbar buttons, the Decision 
Cube has some unique controls. 

§  Percent view across rows. Use this button to display percentages horizontally 
instead of numeric values (see below). 

§  Percent view across columns. This control displays percentages vertically. 

NOTE: If you have switched totals on, the totals of the cells in the direction 
opposite to that which you have selected should be ignored. For 
example, if you have selected Percent view across rows, the correct totals for 
those rows will show 100%. All other totals should be ignored. 

§  Numeric View. This is the default view, and will show absolute (numeric) 
values. 

§  Show Totals. This will add totals to both the horizontal and vertical series. 

§  Graph. Generates a graph of the Cube information. You can choose the 
design and colours of the graph as well. 

§  Graph selection. Will generate a graph for the current selection - you will need 
to select the cell/s you wish to view in the graph before using this tool. 

§  Filter. You can use this tool to refine your Cube view and save it so that it is 
applied each time you call up the relevant Cube. 

The View Menu of the Decision Cube window also has controls for showing you 
other data items. These controls will be specific to the cube you are viewing. 
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Sorting Grid Headers Horizontally or Vertically 
The advantage of the Decision Cube is that you can view your data in different 
ways. This is controlled by where you place the Header you want to sort by - 
either horizontally, or vertically. 

4 To Sort Grid Headers Horizontally 

Drag the Grid Header you require (for example, Replace Year) downwards and 
release it when you see a horizontal green line. 

 

The result of adding that particular grid header will be arranged in horizontal 
columns as follows: 
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If this is not the result you expected, you can simply drag the Replace Year grid 
header back to its original position. 
     

4 To Sort Grid Headers Vertically 

Drag the Replace Year grid header downwards and release it when you see a vertical 
green line. 

 

The cube will arrange the same results in vertical columns instead. 
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Decision Cube Filter 
A filter is available within the Decision Cube to refine the data returned by the 
Cube and ensure that your Cube isn't cluttered with unnecessary information. 

Once you define your filter criteria, the settings are saved into the system so that 
the relevant Cube will always apply that criteria automatically. 

NOTE: When a filter is applied to a Decision Cube View, the window title bar 
will contain the word Filtered. To clear the filter, see below. 

4 Applying a Filter to a Cube View 

You have a choice of three alternative methods of applying a filter to a Cube View. 

1 Click the Filter button drop-down list  on the Decision Cube toolbar and 
click the relevant grid header you wish to define a filter for: 
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This will bring up a window where you can select and deselect filter fields for 
the chosen grid header as required. You can also use the Tick All  and Tick None 

 buttons: 

 

and click Apply to view the results of your actions 

-OR- 

2 Right-click any Grid Header , 

left-click the Filter... button that pops up: 
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Select or deselect the filter fields as required, and click Apply to view the results 
of your actions 

-OR- 

3 Click the drop-down arrow at the right hand edge of each grid header , 

select or deselect the filter fields as required from the list that pops up: 

 

and click anywhere else inside the Cube window to view the results of your 
actions. 

4 Returning a Cube View to its Original (Unfiltered) State 

§ Click View > Default Layout from the Decision Cube Menu bar. 
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Claim Reports 
A number of reports are specific to the Claim Maintenance window (see "Claims" 
on page 159), and are described in more detail below. 

Click  on the toolbar to bring up a Decision Cube report. By default the claim 
lines will be grouped by Contract Item and Claim Year. To add more sort fields to 
your Cube, simply drag a grid header  of your choice down to the existing 
grid header for Claim Year. See Decision Cube (on page 203) for more 
information. 

These reports are claim specific- they're relevant only to the claim you're currently 
viewing. For an analysis of all the claims relevant to your network, see Claim 
Analysis Report (on page 220). 
 

Claim Group Report 
This report summarises claim activity by the various Groups that have been 
defined, and first generates a Detail report and then a summary of the claims 
under the two Claim Groups. 

4 To Generate the Claim Group Report 

1 Select a claim in the Claims window (see "Claims" on page 159). 

2 Then select Actions > Print Claim (CTRL+P) and select the option to Generate Claim Group 
Report. 

NOTE: If you don't intend to change the status of the claim to Presented, 
untick the option to Change this claim to Presented. 

3 RAMM Traffic Signals will first generate a Claim Report for the selected 
claim. You can print or export it. Click Close when you are done. ~q why does 
this report generate first 
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4 The software will now generate the Claim Group Report. 

 

5 You can print or export the report, and click Close when you are done. 
 

Claim Details Report 
The Claim Details Report shows a detailed description of each claim line and the 
dispatch(es) it refers to. 

4 To Generate the Claim Details Report 

1 This report can be generated either from the Claims (on page 159) window 
menu by selecting Actions > Claim Details Report 
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-OR- 

from the Print dialog box (select Actions > Print Claim (CTRL+P) and tick the option 
Generate Claim Details Report). 

2 Choosing the second option to above will first generate a Detail report for the 
specific claim. Preview and Print the report if necessary and then click Close to 
generate the Claim Details Report categorised by Dispatch as below. ~q why 
the difference in procedure 

 

3 Preview or Print the report and click Close when you are done. 
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Claim Summary Report 
This report generates a summary for the selected Claim in the standard RAMM 
Grid format for the purposes of exporting it. 

4 To Generate the Claim Summary Report 

1 In the Claims (on page 159) window, select Actions > Claim Summary. 

2 RAMM displays a dialog with the Description of the selected claim. Click 
Preview to continue. 

3 You'll now see a standard RAMM Grid window with a summary of the 
selected Claim. Use the Grid toolbar to export or print the claim as required. 

4 Close the window when you are done. 
 

Claim Group Details Report 
This option allows you to select a specific group from the two you have and 
generate a detailed description of the claims attached to that group. 

4 To Generate the Claim Group Details Report 

1 In the Claims (on page 159) window, select Actions > Claim Group Details Report. 
You'll first be shown a dialog that gives you the option to choose the Group. 
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2 Make your selection and click Preview or Print to view the report. 

 

3 When you're done, click Close. 
 

Asset Management Reports 
The reports available from the Asset Management menu show you information 
relevant to the utilisation, location and performance of your assets. 

Select Reporting > Asset Management > [Asset]. 
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These reports are all in decision cube format, and will show you the selected asset 
by asset owner / asset type and quantity by default. You can add other grid headers 
to add more details to the report. For more information on working with cubes, 
see Decision Cube (on page 203). 

 
 

Asset Replacement Reports 
Select Reporting > Asset Replacement > [Asset] to generate a number of Decision Cube 
reports pertaining to asset replacement. For more information on working with 
cubes, see Decision Cube (on page 203). 
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Warranty Failure Report 
The Warranty Failure Report enables you to compare expected against actual asset 
performance. 

Select Reporting > Asset Replacement > Warranty Failure Report. 

 

Select a date range and whether you would like a Full Report and/or Summary. 

Click Preview or Print to generate the report. 
 

Auditing 
RAMM Traffic Signals has the ability to generate a number of audit reports. 
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Asset Audit Report 
This report shows all changes to assets in the network within a specified period. 

Select Reporting > Auditing > Asset Audit Report to configure and generate the report. 

 

The default report type setting is Summary Report. Selecting Detailed Report activates the 
other query options- assets to Include, Action taken in relation to those assets and the 
order in which the results will be displayed (Order results by). 

Click Preview or Print to view the report, or Close to return to the previous window. 
 

Multiple Claims Per Dispatch Report 
Select Reporting > Auditing > Multiple claims per dispatch to identify dispatches within a given 
period linked to multiple claims. 
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Select the relevant contract, specify a date range and a minimum claim number 
and set the order of the results in the report. 

Click Preview or Print to view the report, or Close to return to the previous window. 
 

Table Statistics Report 
This report highlights table size changes over a period of time. 

If the table statistics are out of date, RAMM Traffic Signals will prompt you to 
upgrade the table statistics before generating the report. When the upgrade is 
finished, choose the relevant report options from the dialog box. 
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Click Preview or Print to view the report, or Close to return to the previous window. 

 
 

Contract Management 
The Reporting > Contract Management menu generates a number of reports that deal with 
the contract, claims and dispatches. 
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Claim Analysis Report 
The Claim Analysis Report is a general report that analyses all claims relevant to 
your network. 

For specific reports about individual claims, see Claim Reports (on page 210). 

Select Reporting > Claim Analysis Report to bring up a decision cube that summarises 
claims on all contract items by Claim Year. 

 

The Claim Amount is displayed by default, but you can add more columns from 
the View menu. 

 

For more information on working with cubes, see Decision Cube (on page 203). 
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Dispatch Summary Report 
The dispatch summary reports gives a summary of the dispatches for the entered 
period. Dispatches are grouped on entry type and status. This report is contract 
dependent. 

Select Reporting > Contract Management > Dispatch Summary from the main RAMM Traffic 
Signals window menu to generate the Dispatch Summary Report. 

You'll first need to choose a contract and a date range: 

 

Click Preview or Print to view the report, or Close to return to the previous window. 
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Dispatch Detail Report 
See Dispatch - Printing Options (on page 120). 
 

Dispatch Analysis Report 
This report generates an analysis of dispatches by Call Status and Call Type by 
default. 

Select Reporting > Contract Management > Dispatch Analysis. 

 

Unlike the Decision Cube in the Dispatch Entry window, which analyses only the 
dispatches in the list, this report covers all Call Status categories and Call Types for 
the active contract. 

Since the report is in Decision Cube format, you can add grid headers for a more 
extensive report. 

For more information on working with cubes, see Decision Cube (on page 203). 
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Dispatch Progress Report 
The Dispatch Progress Report will print a progress report for a specific dispatch. 

Select Reporting > Contract Management > Dispatch Progress. 

RAMM Traffic Signals will ask you to select a dispatch to query. 

 

Select the contract and enter the dispatch number. 

Click Preview or Print to view the report, or Close to return to the previous window. 
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Road Names 
This option simply generates a list of all the road names in your database. 

Select Reporting > Road Names from the main RAMM Traffic Signals window. 
 

Faults by Intersection Report 
This report shows you faults categorised by intersection. 

From the main RAMM Traffic Signals window, select Reporting > Faults By Intersection 
to launch it. 

 

Make your selections in the Options panel and click the Refresh/Generate button. 

You can print or export the report from the Grid toolbar. 
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Faults by Job Report 
This report shows you faults categorised by jobs as a result of being raised from 
Dispatches. 

From the main RAMM Traffic Signals window, select Reporting > Faults By Job to 
launch it. 

 

Make your selections in the Options panel and click the Refresh/Generate button. 

You can print or export the report from the Grid toolbar. 
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Controlled Intersections Detail Report 
This report simply shows you a detailed inventory of your Traffic Signal assets on 
the currently displayed Intersections in the Traffic Signals window, with options 
to preview and print it. 

In the Traffic Signals window (on page 134), select Actions > Controlled Intersections Detail 
Report from the menu. 

Click Preview or Print, or Close to return to the Traffic Signals window. 
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This section describes the RAMM Mapping function. 
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2 2 8  R A M M  T r a f f i c  S i g n a l s  
 

Mapping - Overview 
Mapping is a powerful tool for visualising your data. It facilitates viewing and 
selecting your data in the context of roads, boundaries, geographical features, 
places and properties. 

You can use map tools bring up information on a selected area, measure distances, 
and display the RAMM displacement and offset of a given point. 

Map Details are Synchronised 
The Map window is synchronised with other windows. When you select a feature 
in the map which has a corresponding record in an open Grid or Detail window, 
that record's details will automatically be shown. 

RAMM Applications Using Mapping 
RAMM Mapping is currently available for RAMM, SLIM (Street Light Inventory 
Management) Signs and RAMM Traffic Signals. 
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Setting Up and Loading the Map 
To use Mapping you need to purchase the appropriate licences - for more 
information, contact us (see "Contacting CJN Technologies Ltd" on page 23). 

If you're using the RAMM Hosting service, Mapping will be available as soon as 
you log in. If you're using an installed copy of the software the map data will be 
sent to you on CDROM. 

If you're not sure how to install Mapping, contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

4 To Set Up Mapping 

1 Launch Mapping by clicking the Show map  button on the toolbar. If you 
haven't used Mapping before, you'll be asked to select a map. 

 

2 Select your map. 

TIP: Select Automatically show map if you wish Mapping to automatically load 
the map whenever you enter the relevant window. For more 
information, see Saving Layouts and Loading Maps (on page 255). 

3 Click OK to load the map. 

NOTE: You may see a message that the Map Index needs to be recalculated. 
Let this process finish before you start working with Mapping. 
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Map Window 
This is the Map window. Initially you will see only the toolbar and the main Map 
window. 

 

While you're working with the map, the Status Bar at the bottom shows you the 
current scale of the map, location information and a numerical zoom level. 
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Map Window Toolbar 
Here's a "quick reference" briefly describing the toolbar controls. 

Some functions on the toolbar are accompanied by drop-down lists. You can click 
the drop-down arrow  on the right of the respective toolbar button to select 
another tool. The tool will remain selected until you change to another. 

At any stage, click the Help button  or press F1 on your keyboard for context 
sensitive help. 

NOTE: Most controls described below can also be accessed by right-clicking in 
the Map window and then using the pop-up menu to select the function 
you require. In the RAMM main window, Map is also a menu item from 
which you can access all the controls described below. 
 
In SLIM, Signs and Traffic Signals, the Map window toolbar has an 
additional button  to quickly reveal the application window you 
launched Mapping from. You can also use ALT+S to quickly switch 
between the Map window and the application window. 

 

Selection Tools 
See Selecting Items on the Map (on page 239). 

 

§  Select. Select one map feature. 

NOTE: All selection tools below will automatically enable Multi-select mode. 

§  Rectangle. Select all road features within a rectangle. 

§  Radius. Select all road features within a radius. 

§  Polygon. Select all road features within a polygon. 

§  Region. Click to select all features within the selected region. 
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Query and Annotation Tools 
See Getting Information from the Map (on page 240). 

 

§  Query Point. Display details of all map items near selected point. 

§  Pick Nearest. Pick the nearest road and display details- for example, RAMM 
Road ID, Displacements, X/Y Coordinates, Offset. 

§  Measure. Measure the distance between two points. 

§  Annotations. Click to add notes to the map. See Making Notes on the Map 
(on page 242). 

 

Zooming, Panning and Rotating Tools 
See Zooming, Panning and Rotating the Map (on page 243). 

§  In. Zoom into map. 

§  Out. Zoom out in the map. 

§  Pan. Pan around the map. 

§  Rotate Left. Rotate the map counterclockwise. 

§  Rotate Right. Rotate the map clockwise. 
 

Map View Configuration Tools 
See Defining and Loading Map Views (on page 244) for a detailed description of 
these tools. To use them, you should already have selected a feature or features on 
the map (see "Selecting Items on the Map" on page 239). 

§  Go to a view. Go to a specified centre point and zoom level. 

§  Go to a road. This button brings up a dialog to help you go directly to a road 
and displacement. 

§  Zoom to selected features. To zoom to any map item/s you have already selected. 
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§  Center on selected features. You'll use this option if you'd like to position the 
item/s you have selected in the centre of the screen. This will not change the 
zoom level. 

§  Show selected features. This is similar to the control above, but is useful when 
you just want to bring things into view and not necessarily centre them in 
your Map window. This view also does not change the zoom level. 

 

Automatic Map View Configuration Tools 
See Automatically Showing Selected Map Items (on page 247). 

 

§  Auto Zoom. Automatically zoom to selection. 

§  Auto Show. Automatically bring current selection into view. 

§  Auto Center. Automatically centre on selection. 
 

Printing and Copying Tools 
§  Print. Brings up the Print Map Options window (see "Printing the Map" on 

page 263). 

§  Copy the Current Map Area to the Clipboard. Copies the currently visible map area to 
the Windows clipboard so that you can paste or save it as a bitmap image. 

 

Map Layer Panel Tools 
Click the Map Layer button  to open the Map Layer panel (on page 248). This has 
the same effect as using the panel sizer (see "Using Collapsible Panels" on page 
30). It displays a legend and a number of controls for Map Layers on a separate 
toolbar. 

§  Import Layer (see "Exporting and Importing Map Layers" on page 251). 

§  Export Layer. 

§  Delete a Layer. 

§  Move Layer Up. 

§  Move Layer Down. 
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§  Layer Settings. 
 

Map Options and Tools 
The Map Options window is where you'll go to set the current layout you're 
using, select a map to use with your database or run processes like map validation 
or indexing. Click the Map Options button  on the Map window toolbar to launch 
the window, and select the option you require in the Selection Panel on the left. For 
more information, see Map Options window (on page 254). 
 

Map Title Tool 
§  Click this button to show or hide the title of the map. 

 
 

Adding Assets to the Map 
Once you've loaded a map (see "Setting Up and Loading the Map" on page 229), 
you can add your assets to it. You can also configure Mapping to do this 
automatically. 

4 How to Add Assets to the Map 

1 In SLIM, Signs or RAMM Traffic Signals, click the Add to Map  button on the 
main window toolbar of the application that you are using 
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-OR- 

in RAMM, select Actions > Add to Map from either the Grid window or Detail 
window menu. 

2 Choose either Add all items to add all items currently listed in the List panel, or 
Add selected items only if you've selected specific items in the list to load. 

 

NOTE: You can also change the layer name if you wish. Mapping will load 
the name of the asset you are adding to the map by default - in the 
example above, since we are adding street lights, it is SLIM. If you 
select a layer name that already exists, you can choose to Clear existing 
items on the layer before loading the current data. 
 
If you wish to change the settings for the layer, such as the icons or 
labels used to represent the street lights, see Changing Map Layer 
Settings (on page 252). 

3 Click OK to begin loading the items to the map or Cancel to abort the process. 
You'll see a progress window while this happens. If you're adding many assets, 
this can take some time. 
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4 Mapping will now add the assets to the map and show them to you. If you 
have configured Mapping to automatically zoom to the selected assets (see 
"Automatically Showing Selected Map Items" on page 247), what you select in 
the relevant Grid or Detail window will be synchronised with the Map 
window. 

 

If you click the Show/Hide Map Layer Panel button on the toolbar, you'll also see that 
the legend now shows the layer you just added in the list. See Map Layer 
Panel (on page 248). 

TIP: When adding assets with length to the map, it can sometimes be 
difficult to see them- especially if they are clustered together and use 
the default polygon style. You can change layer settings (see 
"Changing Map Layer Settings" on page 252) for these assets to be 
added as lines, and if necessary add markers to each line ending to 
emphasise the length. 
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Changing Map Layer Settings While Adding Items to the Map 
You can also change Map Layer options while adding items to the map. 

For the procedure below, you will need to have started the process of Adding 
Items to the Map (see "Adding Assets to the Map" on page 234). 

4 To Change the Map Layer Settings While Adding to Map 

1 In the Add to Map dialog box, click the [...] button next to the Settings field. 

 

In the example above, we've defined a filter to bring up all Carriageway 
Surface records on a selected road, so the default layer name comes up as 
Carriageway Surface. 

2 This will take you into the Map settings window. 

 

You can now edit the style objects for the layer. See Changing Map Layer 
settings (on page 252) for more information on the Appearance tab controls and 
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what they do. If the asset you're adding to the map has both area and length, as 
above, you'll see number of style options. Other assets may show you just two 
styles - for example, line and item. Items that are not ticked will be disabled. 

3 You can also select which fields will display on the map labels for the layer you 
are adding. 

 

The fields correspond to the asset. 

4 You can also set some other options on the Other tab. 
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5 To save your settings for future use, click the Save button  at the top of the 
Map Settings window and choose a filename and location for the map settings 
file (.msf). 

6 To apply the settings, click the OK button. You'll return to the Add to Map 
dialog, and you can proceed to add your assets to the map. 

 

Working with Mapping 
This section describes common mapping tasks. 

NOTE: Most controls described below can also be accessed by right-clicking in 
the Map window and then using the pop-up menu to select the function 
you require. 

 

Selecting Items on the Map 
Before you can view an item on the map you need to select it. The selection tools 
allow you to select features and assets in a number of ways. 

If you don't see the item you wish to select, you may need to adjust the Zoom 
level (see "Zooming, Panning and Rotating the Map" on page 243). 

If you can see it but not select it, you may need to check its selection status in the 
Map Layer Panel. See Map Layer Panel (on page 248). 

In RAMM, the selection tools are synchronised with any RAMM windows you 
may have open. If you prefer to select your assets in the Grid or Detail window 
you're working in and have the map show them automatically, see Automatically 
Showing Items on the Map (see "Automatically Showing Selected Map Items" on 
page 247). 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 
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§  Select (select one map feature). Click this control and then click on the Map 
item to select it. Use CTRL + click to add to your selection (to select multiple 
items - the mouse will show a + next to the arrow) and SHIFT + click to 
subtract from your selection (to deselect from multiple selections - the mouse 
will show a - next to the arrow). 

NOTE: All selection tools below will automatically enable Multi-select mode. 

§  Rectangle (select all road features within a rectangle). With this tool selected 
you can click and drag your mouse to select all items within a rectangular area. 

§  Radius (select all road features within a radius). Click and drag to define a 
circular area, and select all items within it. 

§  Polygon (select all road features within a polygon). To select an irregular area. 
Single clicks will extend the selection area. Double-click to end drawing the 
area and select all items within it. 

§  Region. You can click on a large map item and use this tool to select all items 
within that area. This is particularly useful, for example, if you've loaded iwi 
boundaries and wish to find all roads within them. Selecting the iwi region 
will automatically select all roads within it. 

 

Getting Information from the Map 
The query controls on the Map window toolbar help you get information from 
your map that isn't immediately visible. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 
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§  Query Point (display details of all features near selected point). Select this 
control and click anywhere to bring up a window with the details of all road 
features near the selected point. If you click exactly between two item, 
Mapping will bring up information for both. 

 

§  Pick Nearest (pick the nearest road and display details). Select this control and 
click anywhere to bring up details about the nearest road. 

 

§  Measure (measure the distance between two points). After selecting this 
control, click and drag your mouse to draw a line between two points 
anywhere on the map, and get an instant readout of the distance in metres. 
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TIP: While clicking and dragging, your status bar at the bottom right of 
your Map window will run a continuous "live" readout of the 
distance. 

 

Making Notes on the Map 
This useful tool allows you to add notes to your map. 

4 To Add Annotations to the Map 

1 From the Query Tools drop-down menu 

 

click the  Annotations tool to bring up a dialog box with instructions. 

 

2 Either: 

§ Click anywhere to add an annotation on a point on the map, or 

§ Click (where you want to place the note) and drag (to the point you wish 
to describe) to add an annotation with an arrow callout. 
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3 Type your note into the box that appears. The square below your note shows 
you which type of annotation you've selected. 

 

4 Click OK to add your note into the Annotations layer and to the map. You can 
add as many notes as you wish. 

You can also export the annotation layer (see "Exporting and Importing Map 
Layers" on page 251). 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 
 

Zooming, Panning and Rotating the Map 
Use these controls to move around the map area. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 

§  In (zoom into map). Zoom in to enlarge the view, centering the map on 
your mouse cursor. Note that your mouse cursor changes to indicate the tool 
you've selected. To temporarily reverse the zoom direction and zoom out, 
hold down the CTRL button as you click. 
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§  Out (zoom out in the map). Reduce the view by zooming out, centering the 
map on your mouse cursor. To temporarily reverse the zoom direction and 
zoom in, hold down the CTRL button. 

§  Pan (pan around the map). With this tool active, click on any area of the 
map and drag while holding the mouse button down to move the entire map. 

§  Rotate Left (rotate the map counterclockwise). 

§  Rotate Right (rotate the map clockwise). 

CAUTION: Be careful when rotating the map, as you cannot see compass 
points. If you want to return the map rotation to 0 (North = UP), 
use the Go to a view control (see "Defining and Loading Map Views" 
on page 244). 

 

Defining and Loading Map Views 
The Go to a View button  on the Map window toolbar launches a window to define 
specific map views that you can save and load later. The Goto and Close buttons work 
with the settings immediately above them, which set co-ordinates, zoom and rotation. 
You can either enter number values directly into these fields, or go to a view on 
the Map window using the zoom and selection tools and then save the view here 
with a name of your choice. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 

4 How to Define and Load Map Views 

1 Click the Go to a view button . 
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The dialog show you the Current view displayed on your map as well as any 
other views you may have defined earlier. 

2 You can now configure and define the view you require. 

You can enter X and Y co-ordinates, a Zoom level, or a Rotation number in 
degrees. Click Goto to go to the specified view. 

Once you're satisfied with the view you've generated, you can save the view 
with a name of your choice. 

3 Click the Save button  if the view has not been saved before, or the Save As  
button if you wish to save an existing view under another name. 

 

Mapping will duplicate the view as Copy of Current. You can now give the view a 
unique name of your choice. 

You can rename any view you have defined by right-clicking the view and 
choosing the Rename option, or pressing F2 on the keyboard. 

 

4 Press Enter on your keyboard or click anywhere inside the view name window 
to save the view. 
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5 Click Goto button to load the selected view, or Close to return to the Map 
window. 

4 Go to a Road 

This control helps you go directly to a road and specified displacement. 

1 Click the Go to a road button  on the Map window toolbar. 

2 In the Road field, either: 

Choose the road you wish to view from the drop-down list 

-OR- 

Type the road name 

-OR- 

Type the Road ID. 

 

You can also specify a displacement along the road. 

3 Click Goto or press Enter on your keyboard, and Mapping will automatically 
zoom to your choice. 
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Automatically Showing Selected Map Items 
These controls will automatically synchronise what the map shows to what you 
select in any other Grid or Detail window, with the desired zoom, centering or 
selection option you choose. 

The buttons in this list will remain selected (button down) until you deselect them 
(button up) or select another automatic Show Selected control. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 

 

§  Auto Zoom (automatically zoom to selection). 

§  Auto Show (automatically bring current selection into view). 

§  Auto Centre (automatically centre on selection). 
 

Changing the Map's Appearance 
The features on your map, and the symbols, colours, lines and shapes representing 
them are designed to present the information to you in a clear and logical way. 

If you need to change these properties, however, you can do so at two levels. 

§ To control which features are included in the map, and what you can do with 
them, set their status in the Map Layer Panel (on page 248). 

§ For more control over appearance, including defining colours, symbols and 
shapes, you can change Map Layer settings (see "Changing Map Layer 
Settings" on page 252). 

Each type of road asset - like Roads or Places - is added to the map as a separate 
layer. When you add the street lights to the map, it will have its own layer. You can 
change the appearance of each layer separately. Its appearance settings are also 
retained when you save the map (see "Saving Layouts and Loading Maps" on page 
255). 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 
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Map Layer Panel 
The map that you see in the Map window is actually made up of a number of map 
layers, each stacked on top of the other. The layers may sometimes block other 
layers (and map items) from view, particularly if you have customised the 
appearance of a given layer. You can always change the order of a given layer (see 
below). 

The expanded map layer panel image below shows how the layers are structured. 
Land, logically, is right at the bottom, and everything else is stacked upwards from 
it to build a clear and representative picture of the relevant area. 

Click the panel sizer control at the left edge of the Map window 

 

to see the layers and how they are arranged, as in the image below. 

The Map Layer panel control is more than a simple description of the map layers - 
it enables you to show or hide them, make them selectable, and show labels. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 

NOTE: If you change the filtering options in the Grid or Detail window 
containing the items you are viewing on the map, those records will not 
be automatically shown when you select the corresponding map item. 
You'll need to add those new records to the map. 
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4 To Work with Map Layers 

1 Click the Show Map Layer panel button  on the Map window toolbar to bring up 
the Map Layer panel. 

 

We've expanded the view to display System layers in the image above- usually 
you will see only the default layers Highways and Roads, and any layers you may 
have just added (SLIM above). 

The key next to the map item (Highways, Roads and SLIM above) indicates 
how they are currently displayed on the map- what icons, lines and colours 
they are using. To configure these settings, see Changing Map Layer Settings 
(on page 252). 

2 Set the options for each layer. 

§  Make the layer Visible. 

§  Show Labels on the respective layer. 
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NOTE: Earlier versions of the Mapping software included a Selectable option. 
This is now configured manually by changing map layer settings (on 
page 252). 

When you select an option for a layer it is highlighted in blue. In the example 
above, all layers except Places are Visible. Labels are switched on for Annotations, 
SLIM, Highways, Roads, Address, Cities, Towns, Suburbs and Localities. 

TIP: Don't switch labels on for more than a layer or two at a time. The 
labels on higher layers can obscure details of the lower layers. 

3 Close the window by collapsing the panel or clicking the Map Layer panel 
button . Your changes are applied to the map automatically as soon as you 
make them. 

4 To Make Map Layers Visible By Changing Their Order 

§ If you can't see the labels for a particular map feature when you look at the 
map, other features on a higher layer may be obscuring them. To move the 
affected layer higher up the stack and make it visible, use the Move Layer Up  
and Move Layer Down  buttons. 

4 To Delete a Map Layer 

§ To delete a Map Layer, select the layer and click the Delete Layer  button. 

CAUTION: Be careful when deleting layers, as you will not be able to restore 
them unless you've exported them beforehand (see "Exporting 
and Importing Map Layers" on page 251). You cannot delete 
System layers. 
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Exporting and Importing Map Layers 
Mapping lets you export or import map layers in the MapInfo .tab format. You can 
also export them as plain text files. 

TIP: If a particular layer of your map takes a while to set up, and you know 
that the data in that layer won't change often, you can export that layer 
and then re-import it when you need it. Importing a layer is faster than 
generating the layer again. 

4 To Export Map Layers 

1 Open the Map Layer panel (on page 248). 

2 Select the layer you wish to export. 

3 Click the Export Layer button . 

4 Define a location and filename for your layer .tab file. 

5 Click Save to save the file and return to the Map window. 

4 To Import the Map Layer 

1 Open the Map Layer panel (on page 248). 

2 Click the Import Layer button . 

3 Browse to and select the .tab file to import. 

 

4 Click the Open button to import. The layer is added to the Map window, and 
you'll see it when you next open the Map Layer panel (on page 248). 
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Changing Map Layer Settings 
You can change Map Layer settings in two places. 

§ You'll most often want to change Map Layer settings after the details have been 
added, in the Map Options panel. This is described below. 

§ You can also change Map Layer settings at the point of adding items to the 
map (see "Changing Map Layer Settings While Adding Items to the Map" on 
page 237). You can choose how those details are shown on the map, before 
they're added to it. 

For a quick reference to the Map window controls, see Map Window Toolbar (on 
page 231). 

Map Layer Settings Window 
To bring up this window, open the Map Layer panel (on page 248) and click the 
Map Layer settings button . 

 

This window allows you to set the global options for the layer such as the Zoom 
Range for the layer objects or labels, whether the layer objects will have arrows to 
Show Direction, whether they will Show Nodes at their start and end points, and whether 
they will Show Centroids (markers in the centre of objects with an area). The 
availability of objects sometimes depends on the type of layer you have selected. 

You also have some layer label specific options. The Maximum Labels setting, and 
options to Allow Overlapped Text, Allow Duplicated Text and Label Partial Objects  are to help 
reduce label clutter in your Map window. You can also choose whether the Label 
Lines will be simple or show arrows, the label Orientation in relation to the object, 



 

 C h a p t e r  1 6   –   M a p p i n g  2 5 3   

whether the label will be displayed Parallel to the object and how far away from the 
object it will be (Offset). 

Map Style Objects 
It's useful to have some idea of the different objects you can customise before you 
start changing their settings. The four types of style objects you can customise are 
listed below, together with the settings you can edit. 

Tick Override Style if you wish to change the style of the layer - the style button next 
to it will not be active until you do so. 

CAUTION: You can configure individual settings for each of the following 
categories for each layer. That gives you very wide range of options for 
customising the map, so please exercise caution and change only the 
style objects you absolutely need to. 

§  Symbol. Click this button to bring up a separate dialog box to change the 
style of the symbols that are displayed on the respective map layer. 

 

§  Line. Click this button for style settings relating to lines on the respective 
layer. 
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§  Region. This control will give you access to style settings relating to object 
regions on the layer. 

 

§  Label. This button brings up a dialog box to set Label style 
options. 

 
 

Map Options Window 
Click the Map Options button  on the Map window toolbar (on page 231) to access 
a number of options related to saving and loading map layouts, and validating map 
data. 

The selection panel on the left hand side of the window allows you to select the 
tool you require. 
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Saving Layouts and Loading Maps 
The Maps section of the Map Options window contains controls to save map 
layouts and load maps. The map layout you're currently using will be selected, and 
any other layouts you have saved will be available in the list. 

The original layout will always have (Original) after the file name. For your 
security, this file cannot be deleted. 

Mapping saves a map layout as MapInfo GeoSet file with a .gst file extension. It 
will retain all layout, view and layer settings. 

Once you've saved a map layout, you can configure Mapping to load it instead of 
the default map. 
 

Saving, Deleting and Loading Map Layouts 
When you've made changes to a map layout, you'll most likely want to save it. For 
example, you may have added new layers to the layout (see "Adding Assets to the 
Map" on page 234), changed the zoom levels (see "Defining and Loading Map 
Views" on page 244), or customised styles (see "Changing the Map's Appearance" 
on page 247). 

CAUTION: We'd strongly recommend saving your changes under a new name 
instead of overwriting the default map layout, as you will not be able 
to restore the original layout without reloading the original .gst file. 
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4 To Save the Map Layout 

1 When you're satisfied with your changes, click the Map Options button  on the 
Map window toolbar to load the Map Options window (on page 254). 

 

2 In the selection panel at the left, ensure that Change Current Map Layout is selected as 
above. 

3 Click the Save As button  to save the current layout under a new name 

-OR- 

Select the .gst layout file already in the window (the default layout you are 
using at the moment) and click the Save button  if you wish to overwrite the 
existing layout file. 

4 In the browse window that pops up, choose a name and location for the .gst 
file. This will be the location of your current .gst files by default. 

5 Click Save to return to the Map Options window above. You can now select 
the layout  and load it (see below). 

4 Deleting a Map Layout 

§ You can delete any saved layout with the Delete button . For your security, 
Original layouts cannot be deleted. 

4 Loading a Map Layout 

1 To load a saved map layout (above), or the Original layout supplied with the 
map, select the layout you want to use. 
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2 Tick this option to load this layout automatically every time you launch the 
Map window: 

 

As indicated, the layout will be specific to the database you're currently using. 

3 Click Close to close the window and cancel all changes, Apply to apply your 
settings to the Map window right away, or OK to apply your settings and close 
the Map Options window. 

 

Loading an Alternative Map 
You can reload your original map layout or an alternative layout from your default 
map layout folder. 

NOTE: You will need to ensure that you have the relevant .gst map layout file in 
the appropriate folder of your RAMM application (usually 
C:\PROGRAM FILES\CJN TECHNOLOGIES\MAPS) 

4 To Load An Alternative Map, Or No Map 

1 Click the Map Options button  to load the Map Options window (on page 
254). 

2 From the selection panel on the left, select Choose Map. 
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This window will show you a list of the maps you can load. Make your 
selection. If you want to stop using a map, scroll up the list and select No Map. 

3 Click Close to close the window and cancel all changes, Apply to apply your 
settings to the Map window right away, or OK to apply your settings and close 
the Map Options window. 

 

Running the Map Validation Report 
When you're working with mapping, it's a good idea to run the map validation 
report: 

§ The first time you use the mapping module. 

-AND- 

§ Each time you receive updated mapping data as part of an upgrade. 

The map validation report compares the details about each mapped item stored in 
the road network database with the details in the mapping database. This alerts you 
to any discrepancies, which can then be sorted out (see "Compensating for Map 
Data Discrepancies" on page 261). 

4 To Run the Validation Report 

1 Open the Map Options window by clicking the Map Options button  on the 
Map window toolbar (on page 231). 

2 Click Tools on the left-hand selection panel. 

 

3 Click the Validation Report button. 
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4 A progress window appears as Mapping extracts map data for comparison with 
the RAMM application you're running. 

 

5 The Map Audit window appears. 

 

6 Mapping will now compare the map data with the RAMM Road data. Select 
the appropriate types of fault to check for: 

§ Length Discrepancies. Identifies roads whose length in RAMM is different than 
the length in the map data. Ignores any discrepancies that are within the 
Allowed Length Tolerance specified on the right side of the window. 

§ Missing RAMM Roads. Lists road centrelines in the map data which have a 
RAMM Road ID that does not exist in the RAMM data. 

§ Missing Map Roads. Lists Road IDs from the RAMM data whose 
corresponding road centreline does not exist in the map data. 

§ Road Name Discrepancies. Lists RAMM roads and map roads with same 
RAMM Road ID but different names. Ignores differences like "Ave" and 
"Avenue". 

§ Sequence ID Errors. Lists internal errors in the map data where the same 
sequence number has been used for more than one road. Mapping will 
not work properly with such data, and you must inform the map data 
supplier (usually Critchlow Associates) of the problem. 

§ Identify Possible Matches. Attempts to match RAMM roads with map roads that 
haven't been assigned a RAMM Road ID. 
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7 Select the difference between lengths in the map data and RAMM data 
Mapping should tolerate in the Allowed Length Tolerance section. 

8 In Output Options, select whether to group the report by the Fault type or by the 
Road Name, and whether or not to include Map References. You can also choose to 
export the report results as a Comma-separated file for later use. 

9 Preview or Print the report. Mapping may take a while to generate this report - 
please be patient. It will look like this: 

 

10 Go through the discrepancies noted in the report, writing your notes on the 
printed report as you go. This is one situation where there's no substitute for 
hard copy. 

11 Please send the annotated report to your map supplier, so they can make any 
necessary changes to the map data they supply. If your map supplier is 
Critchlow Associates, their postal address is PO Box 4103, Wellington. Aim to 
send your comments before the December-February period each year, when 
the maps are usually updated. The updated map data will accompany the 
RAMM and SLIM software upgrades released in March/April. These upgrades 
are automatically loaded for you if you're using the RAMM Hosting Service. 
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Compensating for Map Data Discrepancies 
Discrepancies can sometimes occur between the information in the mapping file 
and in your database. This can be for a number of reasons- apart from survey 
inaccuracies, it can also happen as a result of not taking into account geographical 
features like hills as in the image below. 

 

NOTE: Whenever you get updated mapping data as part of an upgrade, we 
recommend you identify any discrepancies between the map data and 
road data by running the Map Validation Report (on page 258). 

Every database is provided with a Map Index. You can Generate the Map Index to 
have Mapping compare the map with the RAMM data and adjust the data 
accordingly. In fact, when you load a map for the first time Mapping will 
automatically prompt you to generate the Index. 
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4 Generating the Map Index 

If you need to manually generate the Index, you can do so from the Map Options 
window. 

1 Click the Map Options button  and select Tools from the left-hand selection 
panel. 

 

2 Click the Generate Map Index button. This may take a while - please be patient. 
You'll see a progress bar as this happens. 

 

3 Click OK to return to the Map window. 
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Printing the Map 
To bring up print options for the map, click the Print button  on the Map 
window toolbar (on page 231). 

 

You can choose the position of the legend and whether Scale and Details will be 
shown. The map licence will always be shown. 

If you're printing the legend you can also select which layers to show, so that you 
don't clutter your print with unnecessary information. 
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Two Scale options give you control over the labels and detail visible on the screen. 
Scale to Page will print the map exactly as it is on the screen. Scale to Page - Detail will add 
more labels if there is room for them on the page being printed. The other options 
are specific to the scale selected. 

 

You can also print the map over multiple pages. Simple select the layout you 
require, and the panel on the right will show you how it will look. You can also 
select the option to Print the Legend and Details on every page if you wish. 

 

Close the window when you are done. 
 



 

 C h a p t e r  1 6   –   M a p p i n g  2 6 5   

Updating RAMM from the Map, and the Map from RAMM 
~q Nigel this section does not seem to be valid for SLIM and Traffic Signals now, 
please advise 

You can update RAMM Road IDs, Displacements and Offsets from the Map for 
greater consistency between the Map data and the RAMM data. You can update 
the following: 

§ RAMM Road ID 

§ Side 

§ Displacement 

§ Offset 

You can also do the reverse, and update Map Coordinates from RAMM. 

The Update RAMM from Map option is available from selected RAMM Grid and Detail 
window menus. Select Actions > Update RAMM from Map, and then select either Map 
Coordinates or RAMM Displacement as required. 

CAUTION: Updating the RAMM Displacement is a fairly complex operation and has the 
potential to alter crucial RAMM data. If you're not absolutely sure that 
you need to use these options, please contact us (see "Contacting CJN 
Technologies Ltd" on page 23). 

In SLIM, RAMM Traffic Signals and Signs, this process can be also automated by 
selecting Options > Map Automatic Update Options and making the necessary selections in 
the window below. 
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4 To Update Map Coordinates from RAMM 

1 From the relevant RAMM Grid or Detail window menu, the SLIM Street 
Lights window, RAMM Traffic Signals window or the Signs window, select 
Actions > Update RAMM from Map, and then select Map Coordinates 

-OR- 

To update Map coordinates automatically in the SLIM Street Lights window, 
RAM Traffic Signals window or the Signs window, select Options > Map Auto 
Update Options > Update Eastings and Northings when you change the Road ID or Displacement (see 
image above) and click Options. 

     

2 You can now select whether or not to override existing co-ordinates. 

 

3 Click OK to return to the previous window. 

4 To Update RAMM from the Map 

1 From the relevant RAMM Grid or Detail window menu, the SLIM Street 
Lights window, RAMM Traffic Signals window or the Signs window, select 
Actions > Update RAMM from Map, and then select RAMM Displacement 
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-OR- 

If you wish to update RAMM information automatically in the SLIM Street 
Lights window, RAMM Traffic Signals window or the Signs window, select 
Options > Map Auto Update Options > Update Road ID & Displacement when you change the Eastings & 
Northings (see image above) and click Options. 

 

2 Make your selections, and click OK to return to the previous window. 
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From the menu Actions > Status Check, you can perform a number of database specific 
status checks. 

§ Reload query tables 

§ Reload triggers and procedures 

§ Update database statistics 

§ Clear processing triggers 

If  more then a month has expired since Update database statistics was last run or if 
any of the other status checks need to be done, they will be indicated with a blue 
icon as below:  

 

Click Begin Processing to start the status check process and update your data. While 
processing, the process currently running will be indicated by a yellow arrow. 

RAMM Traffic Signals will automatically exit the window. 

 

Status Check 
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This section deals with setting security levels for different types of users in 
RAMM Traffic Signals. 

IN  THIS  CHAPTER 
Setting Staff Security Permissions ............................................271 
Security - General .....................................................................273 
Security - Maintenance and Assessment...................................275 
Security - Contractor ................................................................277 

 
 

Setting Staff Security Permissions 
The Maintenance > Staff Security menu in RAMM Traffic Signals defines the levels of 
access each user has to a given database, and what tasks he or she can perform. 

If no users have been entered on this window, then all users can access all options 
and you will be warned of this. 

 

Security 
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When you click OK you will see that the staff security window is blank, so it's 
advisable to create a user. Click Add Record  on the toolbar to do this. 

Another warning informs you that you also need to set up a default user. 

 

A new staff security record with the current date will be created, and you can 
proceed with setting up the new user. 

 

Set the level of access you require for each user from the right hand panel of the 
Detail panel. If you choose to customise the permissions, see Security - General 
(on page 273). 
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Security - General 
If you choose to customise staff security permissions in RAMM Traffic Signals in 
the panel on the right hand side of the Staff Security Detail panel, the Custom 
Permissions tab is activated. Click this tab to define custom permissions. 

Select the custom permission categories as appropriate in the left pane of the Custom 
Permissions tab. 

Following the installation of a new software build, you may need to Upgrade this 
database. When this option is unchecked, a message is displayed and access to the 
database is denied until the upgrade has been done. 

The option No access allowed enables the administrator to exclude users from 
accessing the current database. 

Access to the Parameter table enables the user to define database wide options, 
including the ability to reconfigure the name of the database which appears in 
report headings. See RAMM Traffic Signals Options (on page 169) for more 
information about this. 

The topmost Permission Options category controls access and updating of the 
database. Choose the appropriate Parameter. 

 



 

2 7 4  R A M M  T r a f f i c  S i g n a l s  
 

When setting up this window, it's important that you ensure at least one user is 
given permission to maintain the Staff list. 

Access these settings by clicking the  and expanding the options under General. 

 

The above settings are individually selectable only when the option indicated 
(selected in blue above) in the right hand pane of the Custom Permissions tab is 
clicked. 
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Security - Maintenance and Assessment 
Select Intersections or Traffic Signals to set maintenance options in the Maintenance 
category. 

The choices refer to the updating of Intersections and Traffic Signal assets, and the 
list of Custom Permissions on the right panel is the same for both Intersections 
and Traffic Signals. 
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Select the required options by ticking them in the Custom Permissions list. 

Select Assessment to set options in the Assessments category and to enable the RAMM 
Assessment system in RAMM Traffic Signals. For a more detailed explanation of 
the RAMM Assessment system, read the RAMM Assessment guide. 

 

Select the required options by ticking them in the Custom Permissions list. 
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Security - Contractor 
The Custom Permissions tab also has contractor-specific options. 
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To change the default Maintenance Options, select them from the drop-down lists as 
indicated above. 

Contracts. This allows the maintaining of the Contract and Contract Items tables. 
This access is required for setting up a Contract. As all Contractor transactions are 
linked to a contract, changing this permission will impact on a number of related 
tables. 

Dispatches. This option relates to the entering, printing and completing of 
dispatches. 

Patrols. Patrols are performed at regular intervals. Those staff members who will be 
entering patrols or maintaining the patrol area definitions need to have permission 
in these areas. 

Claims. Claim lines are produced when completing a Dispatch, and Claim Lines are 
linked to a Claim header. This option gives access to the Claim headers, on which 
claims for work done, are based. 

Piecemeal Rate. The Piecemeal Rate system is optional. This enables contractors to 
subcontract out the maintenance of the assets. 

 



 

  

Asset Type 
An asset type is a category of the assets that make up your network - like Traffic 
Signals. 
 

Call Types 
A description of the source of a call which has been made in response to a fault 
(e.g. Public Call, Council, Routine patrol). 
 

Carriageway 
A term for a continuous section of road between displacements (see below). 
RAMM sometimes identifies assets in relation to carriageway sections. 
 

Circuit Information 
This refers to line companies, bulk change groups and lighting circuits. A bulk 
change group is the grouping together of circuits for regular maintenance of the 
assets. 
 

CJN Hosting Service 
The CJN Hosting Service allows you to host your database and the software on 
one of our fast servers at CJN. You simply use your standard internet browser to 
run the software and work with your data, so you don't need any specialised 
software. It's also more secure, since your data is on our servers and not your local 
machine. 
 

Claim Groups 
Optional codes for use with Claims that refer to specific groups. 
 

Claim Header 
A claim header groups together claim lines for the same contract within a fixed 
period. Claim headers must exist for claim lines to be entered during the dispatch 
completion process. 
 

Glossary 
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Claim Lines 
Every dispatch needs to be linked to a claim line, and RAMM Traffic Signals will 
automatically prompt you to do so on completion of every dispatch. Claim lines 
need to be set up under a claim header. 
 

Contract Item Activities 
Types of activities that can be carried out under a contract. These items need to be 
defined at the beginning of a new contract if they have not been pre-defined and 
included in a Data Transfer (see below). 
 

Database 
A computerised container for large amounts of information - in RAMM’s case, 
about a particular roading network. You may use more than one RAMM database, 
particularly if you work with more than one Road Controlling Authority. 
 

Detail Window 
Type of window used for working with road asset details one at a time, particularly 
when you're editing and viewing them. 
 

Dispatch 
A job of work raised in response to a fault. 
 

Dispatch Groups 
Optional analysis codes for use with Dispatches. 
 

Displacement 
A reference to a point on a road, used to define sections such as carriageways (see 
above) and expressed in metres. 
 

Event Codes 
A code for classifying events in emails sent from within RAMM Traffic Signals, or 
between Council and Contractor, to give more information about a job. 
 

Fault 
A description of a regularly occurring fault or problem (for example, lantern out, 
vehicle accident). Faults can also be assigned to fault categories. Fault reports are 
also available in RAMM Traffic Signals. 
 

Filters 
Filters help you sort information by specific criteria so that you see only what you 
need. You can also save your filter to use them again. 
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Grid Window 
Type of window used for working with road assets, usually for more than one road 
at a time. A Grid window is basically a visual report writer - you get everything 
looking the way you want by adjusting the Grid layout, then work with road assets, 
export or print the displayed details. 
 

Line Company 
The line company is the owner of the line assets. 
 

Location 
The details that help to locate a traffic signal unit- the side of the road it is on, 
what landmarks are nearby, external factors (for example, "dog in brown house 
next to crossing bites"). 
 

LTNZ 
Land Transport New Zealand, formerly Transfund New Zealand. 
 

Manufacturer 
A short code for the manufacturer's name or the models supplied by each 
manufacturer. 
 

Network 
The network is the entire collection of roads managed by a particular Road 
Controlling Authority. Each RAMM database usually contains all the information 
for a particular network. 
 

ICP 
Installation Connection Point. See Maintaining Power Supply and Installation 
Information (on page 187). 
 

Null 
Blank, having no value. 
 

Pole and Light Owners 
The owners of the respective traffic signal asset. 
 

Piecemeal Rate (PMR) 
An option used when entering contract details to enable allocation of different 
rates directly to individual crew members. The PMR is contract specific and links 
claim lines with payments. 
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Pole 
The pole that the traffic signal is attached to. 
 

Pole Definitions 
Definitions specific to a pole, for example Mounting and Type. 
 

Power Company 
Details about the power company that supplies power to the traffic signals. 
 

RAMM 
Road Assessment and Maintenance Management - the software suite that includes 
RAMM Traffic Signals. 
 

RCA 
Road Controlling Authority. The organisation responsible for managing a 
particular network of roading assets. 
 

Record 
A record holds all the details about a particular item, like a Lantern. Think of it like 
your medical record that holds all the details about your health, or your school 
record that holds academic details. 
 

Replacement Reasons 
The reasons given for the replacement of an asset. Replacement reasons can be set 
up and allocated to specific assets. 
 

Road (Road Name) 
In RAMM Traffic Signals this specifically refers to a road in the context of a 
location of a traffic signal. 
 

Table 
Container in the RAMM database that holds all the records about an aspect of the 
road network - its Intersections, for example. Each table holds all the information 
about only one aspect of the network. 
 

TFNZ 
Transfund New Zealand. Transfund is now known as Land Transport New 
Zealand. 
 

TNZ 
Transit New Zealand. 
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Update Asset 
When entering contract details, selecting Update Asset will allow automatic updating 
of the traffic signal asset data when completing a dispatch. 
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Getting Help • 17 

Getting Started with RAMM Traffic Signals • 41 

I 
ICP (Installation Connection Point) • 187 

Insert Wizard •  See Traffic Signals: Insert Wizard 

Intersections • 42 
Intersections 

controlled, identifying • 42 
generating, from a Map • 42 
identifying roads without • 42 
identifying, with invalid locations • 42 
maintaining • 42 
working with • 42 

L 
Launching RAMM Traffic Signals • 45 

Logging in to RAMM Traffic Signals • 62 

M 
Maintenance • 175 

Maintenance 
Asset Material and Type • 189 
Attachment Types • 185 
Call Types • 71 
Claim Groups • 190 
Contract Details •  See Contract: Contract Details 
Contract Item Activities •  See Contract: Contract Item Activities 
Cost • 193 
Dispatch Groups • 191 
duplicating entries • 176 
Event Codes • 196 
Fault Categories • 72 
Intersection Behaviour • 182 
Lantern Details • 184 
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Manufacturer Make and Model • 181 
merging entries • 177 
Miscellaneous Definitions • 185 
Owner Types and Owners • 180 
Pole Mounting and Type • 183 
Power Supply and Installation Information • 187 
Replacement Reasons • 186 
Schedule Items •  See Contract: Schedule Items 
Warranty Period • 178 

Maintenance Crew Payments • 66, 165 
Maintenance Crew Payments 

Crew Details • 167 
Crew Payments • 165 
Piecemeal Rate • 166 

Map • 227 
Map 

adding assets to • 234 
adding layers to • 234 
Audit Report • 258 
automatically load • 255 
changing the map's appearance • 247 
changing to a different map • 257 
compensating for data discrepancies • 261 
exporting and importing layers • 251 
Layer Options • 247 
Layer Panel • 248 
length discrepancy • 258 
loading • 229, 255 
missing roads • 258 
no map • 257 
sequence ID error • 258 
suppliers • 258 
synchronising with selected items • 247 
Validation Report • 258 

Merging entries •  See Maintenance: merging entries 

O 
Options • 169 

Options 
Database • 170 
Optional Groups • 171 
Safety Testing • 171 
Tolerances • 173 

Other Regular Tasks • 88 
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P 
Patrol • 153 

Patrol 
Areas, defining • 153 
Details, entering • 155 

Piecemeal Rate •  See Maintenance Crew Payments: Piecemeal Rate 

R 
Replacement Reasons •  See Maintenance: Replacement Reasons 

Replacing Assets • 84, 150 

Report • 201 
Report 

Asset Audit Report • 217 
Asset Management Reports • 214 
Asset Replacement Reports • 215 
Claim Analysis Report • 220 
Claim Details Report • 211 
Claim Group Details Report • 213 
Claim Group Report • 210 
Claim Reports • 210 
Claim Summary Report • 213 
Controlled Intersections Detail Report • 226 
Dispatch Analysis Report • 222 
Dispatch Detail Report • 222 
Dispatch Progress Report • 223 
Dispatch Summary Report • 221 
Faults by Intersection Report • 224 
Faults By Job Report • 225 
Multiple Claims Per Dispatch Report • 217 
Road Names Report • 224 
Table Statistics Report • 218 
Viewing and Saving • 202 
Warranty Failure Report • 216 

S 
Security • 271 

Security 
Contractor • 277 
General • 273 
Maintenance and Assessment • 275 
setting permissions • 271 

Setting up RAMM Traffic Signals • 55 
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Setting up RAMM Traffic Signals 
on the CJN Hosting Service • 56 
on your local computer • 57 
Setting up your Database • 60 

Status Check in RAMM Traffic Signals • 269 

T 
Toolbar • 51 

Toolbar 
Common Controls • 52 
Dispatch Entry Window • 53 
Main Window • 51, 52 
Patrol Window • 54 
Report Preview • 54 
Status Check Controls • 54 
Traffic Signals Window • 53 

Traffic Signals • 133, 134 
Traffic Signals 

Attachment • 147 
Cabling • 148 
Communications Device • 140 
Controller • 138 
Detector Card • 141 
Insert Wizard • 89 
Intersection • 137 
Lantern (and Lamp) • 145 
Logic Rack • 139 
Loop • 142 
Pedestrian Call Box • 146 
Pole • 143 
Target Board • 144 
Traffic Signals Window • 134 

U 
Understanding RAMM Traffic Signals • 35 

Updating Assets • 149 

V 
Versions of RAMM Traffic Signals, Client or Contractor • 35 
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W 
Workspace • 49 
 


